Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-12-2020 13:22:45

Herve5
Adhérent(e)
Lieu : mi au Sud mi à Paris, France
Distrib. : Debian 5.10.19-1 (2021-03-02) bullseye sid testing
Noyau : Linux 5.10.0-4-amd64
(G)UI : xfce 4.16
Inscription : 02-03-2019

[horrible tentation ] installer jami sur Debian testing

Bonjour,
Etant en version testing (bullseye) je n'arrive pas à ré-installer Jami en téléchargent le .deb correspondant sur leur site*, car apparemment elle est trop récente et repose sur des paquets qui ne sont pas encore dispo sur testing.
Je dois préciser que je n'aime pas vraiment les machins pré-emballés genre appimage/flatpak, mais que j'aurais tenté quand même : malheureusement Jami ne publie officiellement que des snaps, et là vraiment renforcer la politique d'Ubuntu dont le logicel chez eux désinstalle apt ne me convient vraiment pas...
Bref : pas de Jami pour moi pour l'instant, en tout cas ça me semblait l'état des choses jusqu'à hier.

Mais, hier, voilà, j'ai commis le péché : juste pour voir, dans la même url de download, en bas, j'ai téléchargé la version ubuntu.
Et juste pour voir, come ça, j'ai tenté un apt-get install -s.
Surprise, la bête me répond en souriant qu'apparemment ça marche :

Les paquets supplémentaires suivants seront installés :
libnatpmp1 libyaml-cpp0.6
Paquets suggérés :
minissdpd natpmpc
Les NOUVEAUX paquets suivants seront installés :
jami-all libnatpmp1 libyaml-cpp0.6
0 mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst libnatpmp1 (20150609-7+b2 Debian:testing [amd64])
Inst libyaml-cpp0.6 (0.6.3-9 Debian:testing [amd64])
Inst jami-all (20201127.1.409973e~dfsg1-0 local-deb [amd64])
Conf libnatpmp1 (20150609-7+b2 Debian:testing [amd64])
Conf libyaml-cpp0.6 (0.6.3-9 Debian:testing [amd64])
Conf jami-all (20201127.1.409973e~dfsg1-0 local-deb [amd64])


Alors voilà, messieurs-dames, si jamais j'ose tenter ça, que va-t-il se passer?
Et si l'écran, snap, se referme en collant mes mains sur le clavier, m'enchaînant définitivement au millionnaire qui pilote Ubuntu, me sera-t-il possible de désinstaller en retirant simplement les trois nouveaux paquets prévus ci-dessus? Ou bien ma punition sera-t-elle définitive?
Ne riez pas : vous mesurez ici le très faible niveau de mes compétences ;-)

Merci!!

(*) https://jami.net/download-jami-linux/


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#2 06-12-2020 13:50:51

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [horrible tentation ] installer jami sur Debian testing

Alors voilà, messieurs-dames, si jamais j'ose tenter ça, que va-t-il se passer?


Ben tu va installer le logiciel que tu veux. Tu pourra toujours le désinstaller intégralement avec la commande.

apt --autoremove purge jami-all


Tout dépend de la confiance que tu mets dans le développeur du paquet en question; mais si tu utilises un logiciel, en général, tu pars du principe que tu lui fait confiance, qu'importe celui qui le met en paquet, c'est mon opinion : lance-toi wink

Au passage jami a été empaqueté chez debian aussi à ce que je vois

<otyugh> ,v jami
<judd> Package: jami on amd64 -- buster: 20190215.1.f152c98~ds1-1; sid: 20191214.1.07edb5e~ds1-1

Dernière modification par otyugh (06-12-2020 13:54:40)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 06-12-2020 14:06:49

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [horrible tentation ] installer jami sur Debian testing

Herve5 a écrit :

malheureusement Jami ne publie officiellement que des snaps, et là vraiment renforcer la politique d'Ubuntu dont le logicel chez eux désinstalle apt ne me convient vraiment pas...



Je ne sais pas où tu as lu cette énormité au sujet de snapd qui désinstallerait apt, mais c'est bien sûr totalement faux.

---

otyugh a écrit :

Au passage jami a été empaqueté chez debian aussi à ce que je vois

<otyugh> ,v jami
<judd> Package: jami on amd64 -- buster: 20190215.1.f152c98~ds1-1; sid: 20191214.1.07edb5e~ds1-1



Il est présent en stable et en Sid, mais pas en testing wink
Je rappellerais bien au passage que la majorité des personnes qui utilisent testing le font pour de mauvaises raisons, mais je commence à m'épuiser sur ce sujet…


Jouer sous Debian ? Facile !

Hors ligne

#4 06-12-2020 15:58:04

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [horrible tentation ] installer jami sur Debian testing

vv222 a écrit :

Je rappellerais bien au passage que la majorité des personnes qui utilisent testing le font pour de mauvaises raisons, mais je commence à m'épuiser sur ce sujet…


Faudrait presque faire une page wiki vers lequel rediriger les gens sous testing mrgreen.gif


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#5 06-12-2020 16:17:56

Herve5
Adhérent(e)
Lieu : mi au Sud mi à Paris, France
Distrib. : Debian 5.10.19-1 (2021-03-02) bullseye sid testing
Noyau : Linux 5.10.0-4-amd64
(G)UI : xfce 4.16
Inscription : 02-03-2019

Re : [horrible tentation ] installer jami sur Debian testing

vv222 a écrit :


Je ne sais pas où tu as lu cette énormité au sujet de snapd qui désinstallerait apt, mais c'est bien sûr totalement faux.


ici entre autres :
https://news.slashdot.org/story/20/06/0 … buntu-snap
C'est suffisamment critique pour que la distribution Mint le supprime (tout en restant -bêtement mais irrémédiablement- associée à Ubuntu...)

Bon, allez, je me lance. Si vous me voyez revenir ici dans une heure la queue basse c'est que j'aurai foiré quelque chose big_smile
(et en attendant je me demande pourquoi diable les gars de Jami n'ont pas juste recopié, fût-ce provisoirement, ce .deb-là côté Debian...)

[edit] ça a marché, MAIS par la suite j'ai vu un tas de problèmes avec la série de mises à jour de cet après-midi, même LibreOffice... donc j'ai enlevé et nettoyé...
Sinon : je suis sous testing sans doute après avoir mal réfléchi, mais parce que je basculerai spontanément et sans rien changer sur le prochain stable, alors que ma dernière catastrophe s'est produite lors d'un changement d'un stable au suivant (sous Ubuntu il est vrai)
Mais, je reste peu compétent, et vous remercie fort pour votre soutien ici!

Dernière modification par Herve5 (06-12-2020 20:36:48)


--
Hervé S.
deux machines de type Clevo (donc pas très solides) de 2017, l'une sous Debian 10, l'autre Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian Testing Xfce

Hors ligne

#6 06-12-2020 18:21:01

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [horrible tentation ] installer jami sur Debian testing

otyugh a écrit :

Faudrait presque faire une page wiki vers lequel rediriger les gens sous testing mrgreen.gif



Chiche : Debian testing ?


Jouer sous Debian ? Facile !

Hors ligne

Pied de page des forums