Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-12-2020 13:26:10

debi1
Membre
Distrib. : Debian 10 (Buster)
Noyau : Linux 4.19.0-13-amd64
(G)UI : gnome 3.30.2
Inscription : 01-05-2015

Temps de démarrage très (trop) long !

Bonjour,

Debian 10 (sur DD)
Linux debian 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64 GNU/Linux
Processeur : Intel® Core™ i7-4770 CPU @ 3.40GHz × 8
Carte graphique : NVIDIA Geforce GTX 660 1.5G GDDR5
Gnome : 3.30.2
> Dual boot avec Windows 8.1 (sur SSD)
----------------------------------------------------------

Bonjour,

Jusqu'à présent, le démarrage de Débien était correct, de 1m30 à 2m à partir du moment où GRUB s'affichait.
Il me faut maintenant attendre 3m jusqu'à la mire de connexion et ensuite 1m supplémentaire d'écran noir jusqu'à l'arrivée sur le bureau.

Je procède à des nettoyages réguliers avec BLEATCH et aussi via mon TERMINAL avec apt autoclean / apt clean / apt autoremove

Pour information, les 2 changements que j'ai fait sont :
- Installation de WINE et Q4WINE > que j'ai désinstallé après 2/3 jours de tests négatifs
- Banchement HDMI de mon écran directement sur la carte graphique, avant je le branchais sur la carte mère.
Au sujet de ce dernier point, lorsque je reviens à un branchement sur la carte mère mon écran reste noir, et ce nouveau branchement sur la carte graphique affiche quelques lignes de pixels de couleur lorsque l'écran est noir dans l'attente du boot.

Je ne comprends pas du tout cette longueur inhabituelle !?scratchhead.gif

Hors ligne

#2 29-12-2020 13:44:04

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Temps de démarrage très (trop) long !

Donne la sortie de ces commandes voir ?

dmesg --level=err,warn
systemd-analyze critical-chain



1m supplémentaire d'écran noir jusqu'à l'arrivée sur le bureau.


Ça c'est probablement spécifique à gnome - j'imagine.

Aussi une des choses à faire pour trouver le problème c'est de débrancher le maximum de truc de ton ordi. Une souris qui déconne peut faire déconner le démarrage en te faisant attendre genre 5 minute pour rien à chaque fois, ça s'est vu (cela dit ça devrait te faire pareil sous windows). ...Donc ça vaut le coup de sortir ce genre de facteur du tableau.


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 29-12-2020 14:02:02

debi1
Membre
Distrib. : Debian 10 (Buster)
Noyau : Linux 4.19.0-13-amd64
(G)UI : gnome 3.30.2
Inscription : 01-05-2015

Re : Temps de démarrage très (trop) long !

dmesg --level=err,warn
systemd-analyze critical-chain


[    0.000000] secureboot: Secure boot could not be determined (mode 0)
[    0.322703] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
[    0.322704] ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
[    0.328521] MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.
[    0.328521]  #5 #6 #7
[    0.336685] pmd_set_huge: Cannot satisfy [mem 0xf8000000-0xf8200000] with a huge-page mapping due to MTRR override.
[    1.256347] r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    1.266307] ACPI Warning: SystemIO range 0x0000000000001828-0x000000000000182F conflicts with OpRegion 0x0000000000001800-0x000000000000187F (\PMIO) (20180810/utaddress-213)
[    1.266314] ACPI Warning: SystemIO range 0x0000000000001C40-0x0000000000001C4F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20180810/utaddress-213)
[    1.266317] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20180810/utaddress-213)
[    1.266320] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20180810/utaddress-213)
[    1.266323] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20180810/utaddress-213)
[    1.266325] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20180810/utaddress-213)
[    1.266328] lpc_ich: Resource conflict(s) found affecting gpio_ich
[    1.647804] ata4.00: supports DRM functions and may not be fully accessible
[    1.648603] ata4.00: supports DRM functions and may not be fully accessible
[    1.650009] ata6.00: NCQ Send/Recv Log not supported
[    1.650551] ata6.00: NCQ Send/Recv Log not supported
[    8.559600] iwlwifi 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
[   16.843858] r8169 0000:03:00.0: firmware: failed to load rtl_nic/rtl8168g-2.fw (-2)
[   16.844080] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[   16.844291] r8169 0000:03:00.0: Direct firmware load for rtl_nic/rtl8168g-2.fw failed with error -2
[   16.844294] r8169 0000:03:00.0 enp3s0: unable to load firmware patch rtl_nic/rtl8168g-2.fw (-2)
[   38.372578] mei_me 0000:00:16.0: timer: init clients timeout hbm_state = 2.
[   38.372589] mei_me 0000:00:16.0: unexpected reset: dev_state = INIT_CLIENTS fw status = 1E000042 66002106 00000200 00004000 00000000 30000020
[   68.612559] mei_me 0000:00:16.0: timer: init clients timeout hbm_state = 2.
[   68.612572] mei_me 0000:00:16.0: unexpected reset: dev_state = INIT_CLIENTS fw status = 1E000042 66002106 00000200 00004000 00000000 30000020
[   98.852080] mei_me 0000:00:16.0: timer: init clients timeout hbm_state = 2.
[   98.852091] mei_me 0000:00:16.0: unexpected reset: dev_state = INIT_CLIENTS fw status = 1E000042 66002106 00000200 00004000 00000000 30000020
[   98.852093] mei_me 0000:00:16.0: reset: reached maximal consecutive resets: disabling the device
[  785.638690] kauditd_printk_skb: 10 callbacks suppressed
[  944.779242] kauditd_printk_skb: 13 callbacks suppressed
[ 3335.531025] kauditd_printk_skb: 9 callbacks suppressed
[ 6592.901981] kauditd_printk_skb: 9 callbacks suppressed
[ 9168.428856] kauditd_printk_skb: 17 callbacks suppressed
[ 9204.658721] kauditd_printk_skb: 11 callbacks suppressed
[ 9231.695799] kauditd_printk_skb: 42 callbacks suppressed
[ 9344.758974] kauditd_printk_skb: 23 callbacks suppressed
[ 9417.903774] kauditd_printk_skb: 4 callbacks suppressed
 



Quant aux tests d'allumage avec et sans mes péripériques, c'est déjà fait ... RAS de ce côté.

Dernière modification par debi1 (29-12-2020 14:02:49)

Hors ligne

#4 29-12-2020 14:13:34

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Temps de démarrage très (trop) long !

Tu n'a pas envoyé la sortie de systemd-analyze.

Apparemment y a un souci de firmware pour ta carte réseau ? Si c'est pas déjà installé :

apt install firmware-realtek



Pour mei_me ça ressemble beaucoup à un problème de firmware graphique, quelqu'un a un problème similaire ici sous MX (qui est une distro très proche de debian) : https://forum.mxlinux.org/viewtopic.php?t=43873
C'est en anglais par contre. ~


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#5 29-12-2020 14:37:20

debi1
Membre
Distrib. : Debian 10 (Buster)
Noyau : Linux 4.19.0-13-amd64
(G)UI : gnome 3.30.2
Inscription : 01-05-2015

Re : Temps de démarrage très (trop) long !

Le firmware Realtek n'était pas installé ... je branchais mon écran sur le port HDMI de la carte mère (e qui d'ailleurs ne fonctionne plus et je ne sais pas pourquoi !?)

Après installation voici les résultats

dmesg --level=err,warn


[    0.000000] secureboot: Secure boot could not be determined (mode 0)
[    0.322918] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
[    0.322918] ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
[    0.328734] MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.
[    0.328734]  #5 #6 #7
[    0.336903] pmd_set_huge: Cannot satisfy [mem 0xf8000000-0xf8200000] with a huge-page mapping due to MTRR override.
[    1.275486] ACPI Warning: SystemIO range 0x0000000000001828-0x000000000000182F conflicts with OpRegion 0x0000000000001800-0x000000000000187F (\PMIO) (20180810/utaddress-213)
[    1.275494] ACPI Warning: SystemIO range 0x0000000000001C40-0x0000000000001C4F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20180810/utaddress-213)
[    1.275497] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20180810/utaddress-213)
[    1.275500] ACPI Warning: SystemIO range 0x0000000000001C30-0x0000000000001C3F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20180810/utaddress-213)
[    1.275503] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001C3F (\GPRL) (20180810/utaddress-213)
[    1.275505] ACPI Warning: SystemIO range 0x0000000000001C00-0x0000000000001C2F conflicts with OpRegion 0x0000000000001C00-0x0000000000001FFF (\GPR) (20180810/utaddress-213)
[    1.275508] lpc_ich: Resource conflict(s) found affecting gpio_ich
[    1.283069] r8169 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    1.672239] ata4.00: supports DRM functions and may not be fully accessible
[    1.673004] ata4.00: supports DRM functions and may not be fully accessible
[    1.674299] ata6.00: NCQ Send/Recv Log not supported
[    1.674854] ata6.00: NCQ Send/Recv Log not supported
[    8.764591] iwlwifi 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
[   38.312749] mei_me 0000:00:16.0: timer: init clients timeout hbm_state = 2.
[   38.312760] mei_me 0000:00:16.0: unexpected reset: dev_state = INIT_CLIENTS fw status = 1E000042 60002106 00000200 00004000 00000000 30000020
[   68.552819] mei_me 0000:00:16.0: timer: init clients timeout hbm_state = 2.
[   68.552833] mei_me 0000:00:16.0: unexpected reset: dev_state = INIT_CLIENTS fw status = 1E000042 60002106 00000200 00004000 00000000 30000020
[   98.792102] mei_me 0000:00:16.0: timer: init clients timeout hbm_state = 2.
[   98.792116] mei_me 0000:00:16.0: unexpected reset: dev_state = INIT_CLIENTS fw status = 1E000042 60002106 00000200 00004000 00000000 30000020
[   98.792118] mei_me 0000:00:16.0: reset: reached maximal consecutive resets: disabling the device
 



systemd-analyze critical-chain


bThe time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @2min 2.579s
└─multi-user.target @2min 2.579s
  └─gwsetup.service @16.094s +79ms
    └─geneweb.service @15.837s +254ms
      └─network-online.target @15.834s
        └─NetworkManager-wait-online.service @9.923s +5.910s
          └─NetworkManager.service @7.339s +2.577s
            └─dbus.service @7.337s
              └─basic.target @7.232s
                └─sockets.target @7.232s
                  └─cups.socket @7.232s
                    └─sysinit.target @7.197s
                      └─systemd-timesyncd.service @6.972s +224ms
                        └─systemd-tmpfiles-setup.service @6.676s +294ms
                          └─local-fs.target @6.675s
                            └─media-MEDIAS.mount @3.355s +3.319s
                              └─dev-sda2.device @3.171s
 



je vais aller jeter un coup d'oeil au lien que tu as donné.

Hors ligne

#6 29-12-2020 15:19:44

debi1
Membre
Distrib. : Debian 10 (Buster)
Noyau : Linux 4.19.0-13-amd64
(G)UI : gnome 3.30.2
Inscription : 01-05-2015

Re : Temps de démarrage très (trop) long !

J'ai été régler ce problème de driver Nvidia via https://wiki.debian.org/fr/NvidiaGraphi … buster-450
...
J'ai fait plusieurs reboot et je suis toujours à des niveaux trop long, j'ai gagné 20s à 30s !

Hors ligne

#7 29-12-2020 16:43:38

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Temps de démarrage très (trop) long !

Sur un ordi modern sous linux, je m'attends à 10 à 30sec de démarrage.

Tu peux gagner une dizaine de secondes en n'attendant pas le réseau

systemctl disable NetworkManager-wait-online.service



Pour une autre perspective, tu peux aussi retourner

systemd-analyze blame

Dernière modification par otyugh (29-12-2020 16:44:51)


datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#8 29-12-2020 20:11:11

debi1
Membre
Distrib. : Debian 10 (Buster)
Noyau : Linux 4.19.0-13-amd64
(G)UI : gnome 3.30.2
Inscription : 01-05-2015

Re : Temps de démarrage très (trop) long !

Sur un ordi modern sous linux, je m'attends à 10 à 30sec de démarrage

> J'avais encore avant ce changement de branchement écran entre 45s et 60 s !

systemd-analyze blame

... voici les pemières lignes ...

2min 7.327s plymouth-quit-wait.service
          5.616s NetworkManager-wait-online.service
          4.522s udisks2.service
          4.311s ModemManager.service
          3.520s systemd-modules-load.service
          3.462s media-MEDIAS.mount
          3.381s media-MUSIQUE.mount
          2.840s dev-sdb1.device
          2.663s NetworkManager.service
          2.304s accounts-daemon.service
          2.186s media-DONNEES.mount
          1.917s networking.service
          1.839s lm-sensors.service
          1.839s wpa_supplicant.service
          1.838s systemd-logind.service
          1.834s rsyslog.service
          1.562s avahi-daemon.service
          1.562s bluetooth.service
          1.557s alsa-restore.service
          1.555s pppd-dns.service
          1.062s upower.service
          1.004s systemd-fsck@dev-disk-by\x2duuid-523e8922\x2dbf6a\x2d43c8\x2d9683\x2d730bf2bc26bf.service
           970ms colord.service
           868ms gdm.service
           753ms user@117.service
           722ms boot-efi.mount
           710ms lvm2-monitor.service
...etc....
 

Hors ligne

#9 29-12-2020 20:26:52

debi1
Membre
Distrib. : Debian 10 (Buster)
Noyau : Linux 4.19.0-13-amd64
(G)UI : gnome 3.30.2
Inscription : 01-05-2015

Re : Temps de démarrage très (trop) long !

Bon et bien un p'tit bilan en cette fin de journée après  3 nouveaux reboot de test > 3mn avant la mire de connexion + 1 mn ensuite
La situation est donc identique à ce matin old_geek.gif

Je suis preneur de toute nouvelle idée merci.gif

Hors ligne

#10 29-12-2020 22:24:56

phreg
Membre
Distrib. : MX Manjaro Ubuntu
Noyau : 4.9 à 5.10
(G)UI : Xfce
Inscription : 02-04-2011

Re : Temps de démarrage très (trop) long !

Bonjour,
NetworkManager-wait-online.service et  ModemManager.service ne servent à rien, à supprimer comme indiqué par Otyugh.
Que donnent

systemd-analyze critical-chain

et

systemd-analyze

Hors ligne

#11 30-12-2020 11:01:38

debi1
Membre
Distrib. : Debian 10 (Buster)
Noyau : Linux 4.19.0-13-amd64
(G)UI : gnome 3.30.2
Inscription : 01-05-2015

Re : Temps de démarrage très (trop) long !

Bonjour,

phreg a écrit :

NetworkManager-wait-online.service et  ModemManager.service ne servent à rien, à supprimer comme indiqué par Otyugh.


> J'avais déjà lorsqu'Otyugh l'a proposé effectué hier

systemctl disable NetworkManager-wait-online.service
 


... je réitère donc maintenant et fait comme tu le suggère un

systemctl disable ModemManager.service



phreg a écrit :

Que donnent

    systemd-analyze critical-chain

et

    systemd-analyze



systemd-analyze


Startup finished in 14.397s (firmware) + 7.144s (loader) + 5.110s (kernel) + 2min 38.383s (userspace) = 3min 5.036s
graphical.target reached after 2min 38.377s in userspace



et je joins à nouveau :

systemd-analyze critical-chain


The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.
graphical.target @2min 38.377s
└─multi-user.target @2min 38.377s
  └─gwsetup.service @11.162s +160ms
    └─geneweb.service @10.556s +603ms
      └─network-online.target @10.555s
        └─network.target @10.555s
          └─NetworkManager.service @7.681s +2.873s
            └─dbus.service @7.679s
              └─basic.target @7.673s
                └─sockets.target @7.673s
                  └─uuidd.socket @7.673s
                    └─sysinit.target @7.641s
                      └─systemd-timesyncd.service @7.356s +284ms
                        └─systemd-tmpfiles-setup.service @6.976s +379ms
                          └─local-fs.target @6.972s
                            └─run-user-117.mount @16.538s
                              └─swap.target @5.797s
                                └─dev-disk-by\x2duuid-eefdfefd\x2dd56e\x2d4a2e\x2d9a3a\x2d17e4d340268f.swap @5.692s +104ms
                                  └─dev-disk-by\x2duuid-eefdfefd\x2dd56e\x2d4a2e\x2d9a3a\x2d17e4d340268f.device @5.691s
 

Hors ligne

Pied de page des forums