Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-12-2020 18:35:56

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

[Résolu]revenir à une version précédente

Bonjour,
Je suis actuellement avec la version 4.19.0-13-686-pae (32 bit) pour cet OS (Debian10)
Je souhaiterais revenir à la version 4.19.0-12-686-pae
Est-ce possible ?
Merci pour vos réponses.

Dernière modification par gargamel79 (31-12-2020 11:58:35)

Hors ligne

#2 29-12-2020 19:00:55

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : [Résolu]revenir à une version précédente

Je vois pas de méthode simple, sinon d'installer manuellement les paquets d'avant s'ils sont encore dans le cache... X_X
Je vois pas non plus aucune "bonne" raison de faire une chose pareille, à dire vrai.

datalove-datalove-s1-2.png agendadulibre-lagendadulibre.png arzinfo-arzinfo.png

Hors ligne

#3 30-12-2020 13:10:11

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]revenir à une version précédente

J'ai trouvé ce site, c'est justement de wheezy dont j'avais besoin, à cause d'un certain g++ antique qui n'est plus installable avec la -13 mais encore avec l -12 !
https://blog.seboss666.info/2019/06/lar … s-zombies/
Pour l'heure, je réinstalle Buster i386 from cratch .... en espérant arriver sur une version antérieure du kernel tongue
J'espère que la mise à jour ne se fait pas automatiquement
Merci pour ta réponse. Et bonjour à la Bretagne que j'adore!!!

Dernière modification par gargamel79 (30-12-2020 13:16:58)

Hors ligne

#4 30-12-2020 13:22:35

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]revenir à une version précédente

gargamel79 a écrit :

Je suis actuellement avec la version 4.19.0-13-686-pae (32 bit) pour cet OS (Debian10)
Je souhaiterais revenir à la version 4.19.0-12-686-pae


Ce ne sont pas deux versions différentes d'un même paquet mais deux paquets différents.
Si le paquet que tu veux est toujours disponible dans les dépôts, rien ne t'empêche de l'installer avec les méthodes classiques.


Il vaut mieux montrer que raconter.

Hors ligne

#5 30-12-2020 17:17:54

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]revenir à une version précédente

Merci pour ta suggestion, j'ai maintenant sous /boot les 2 images -12 et -13.
Grub voit bien ces 2 images.
Mais je ne sais pas comment lancer proprement celle que je veux ?
Et éventuellement supprimer celle qui ne sert plus, car maintenant ma partition est pleine comme un œuf.

Dernière modification par gargamel79 (30-12-2020 17:21:11)

Hors ligne

#6 30-12-2020 18:10:43

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]revenir à une version précédente

gargamel79 a écrit :

Mais je ne sais pas comment lancer proprement celle que je veux ?


Que veux-tu dire par "proprement" ?
Il suffit d'entrer dans le sous-menu "options avancées" et de sélectionner le noyau désiré.
Pour que ce soit par défaut, il faut modifier /etc/default/grub pour mettre quelque chose comme

GRUB_DEFAULT="1>2"


Puis exécuter update-grub.

gargamel79 a écrit :

Et éventuellement supprimer celle qui ne sert plus


Il suffit de supprimer le paquet correspondant.


Il vaut mieux montrer que raconter.

Hors ligne

#7 30-12-2020 18:35:57

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]revenir à une version précédente

Encore merci pour ton aide raleur, mais je ne vois pas de quel sous menu il s'agit roll
J'avais bien pensé à supprimer les paquets indésirables, je n'ai pas osé tant que je ne démarre pas sur la bonne image.

Dernière modification par gargamel79 (30-12-2020 19:07:46)

Hors ligne

#8 30-12-2020 20:12:40

macisa
Adhérent(e)
Inscription : 25-01-2020

Re : [Résolu]revenir à une version précédente

Je vais pet être émettre une mauvaise thèse,

Est-ce que utiliser un live-cd ne sauverait pas l'affaire?


Sinon pour râleur c'est le lendemain de la veille smile:)

https://www.debian-fr.org/t/ordre-grub2 … lles/61510

Dernière modification par macisa (30-12-2020 20:15:14)

Hors ligne

#9 30-12-2020 21:41:11

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]revenir à une version précédente

gargamel79 a écrit :

je ne vois pas de quel sous menu il s'agit


Le menu de démarrage de GRUB qui s'affiche au démarrage et attend quelques secondes avant d'amorcer l'entrée sélectionnée par défaut.
Tu as bien écrit

gargamel79 a écrit :

Grub voit bien ces 2 images.


Alors de quoi d'autre pourrait-il s'agir ?

macisa a écrit :

Est-ce que utiliser un live-cd ne sauverait pas l'affaire?


Pour quoi faire ?

macisa a écrit :

Sinon pour râleur c'est le lendemain de la veille


Pardon ?


Il vaut mieux montrer que raconter.

Hors ligne

#10 30-12-2020 22:08:15

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]revenir à une version précédente

Je passe la commande


# grub-update


Je vois alors toutes les images disponibles ....
J'ai rallongé  la tempo. de démarrage à 10s mais je ne comprends toujours pas comment on accède à Grub pendant cette phase .
Il y a peut-être une touche à appuyer ?

Hors ligne

#11 30-12-2020 22:43:02

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]revenir à une version précédente

Tu ne vois pas le menu de GRUB s'afficher au démarrage de l'ordinateur, après les écrans du BIOS ?

Il vaut mieux montrer que raconter.

Hors ligne

#12 31-12-2020 10:08:18

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu]revenir à une version précédente

Hello
forcement si tu tape grub-update ça fonctionne moins bien et du coup tu as toujours ton ancien fichier ?
tu as pourtant un message d'erreur dans ton terminale qui dit que la commande n'existe pas

sinon la modification fonctionne bien
par contre je me demande si il faut pas supprimé le meta paquet linux-image-amd64 pour évité les nouvelles mise a jour du noyau , car sinon ta ligne dans le sous menu grub va changer de place forcement

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#13 31-12-2020 10:51:29

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]revenir à une version précédente

J'ai 3 OS sur cette station (Debian10 i386/686, Debian10 AMD64, Artix) , au démarrage, je vois bien toutes ces possibilités.
Mais seulement une possibilité pour Debian10 i386). Et je démarre sur 4.19.0-13.   

Croutons a écrit :

Hello
forcement si tu tape grub-update ça fonctionne moins bien et du coup tu as toujours ton ancien fichier ?
tu as pourtant un message d'erreur dans ton terminale qui dit que la commande n'existe pas

sinon la modification fonctionne bien
par contre je me demande si il faut pas supprimé le meta paquet linux-image-amd64 pour évité les nouvelles mise a jour du noyau , car sinon ta ligne dans le sous menu grub va changer de place forcement



Je n'ai pas vu de message d'erreur, à quel moment doit-il se produire ?
J'ai supprimé le méta paquet linux-image-686 (et non -amd64), sans résultat...
Est-ce que si je supprime tout ce qui concerne 4.19.0.13 suivi d'un grub-update cela ne va pas forcer la reconnaissance de 4.19.0-12 ?
Merci pour votre aide.

Dernière modification par gargamel79 (31-12-2020 10:51:57)

Hors ligne

#14 31-12-2020 11:21:24

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu]revenir à une version précédente

gargamel79 a écrit :

Je n'ai pas vu de message d'erreur, à quel moment doit-il se produire ?


grup-update
bash: grub-update : commande introuvable


erreur de frappe sans doute

les anciens noyau apparaissent dans le sous menu de grup option avancé (2éme ligne), tu valides et la tu as le choix de démarrer sur un autre noyau
c'est ça la modification message 6 de raleur

GRUB_DEFAULT="1>2"


grub se positionnera sur le menu avancé ligne 2 et lancera l'ancien noyau 4.12
(0 étant la premiere ligne)
puis

update-grub


et non pas grub-update

Dernière modification par Croutons (31-12-2020 11:22:02)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#15 31-12-2020 11:26:26

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu]revenir à une version précédente

Croutons a écrit :

forcement si tu tape grub-update ça fonctionne moins bien


Un peu de jugeote, c'est une erreur de frappe dans le forum (grub-update au lieu de update-grub). Si gargamel79 avait vraiment tapé cette commande dans le shell, cela aurait affiché une erreur et non la liste des noyaux et OS détectés.

gargamel79 a écrit :

J'ai 3 OS sur cette station (Debian10 i386/686, Debian10 AMD64, Artix) , au démarrage, je vois bien toutes ces possibilités.


Tu aurais pu le dire plus tôt. Auquel des trois appartient le GRUB qui s'affiche ? (en clair, lequel est en haut de la liste ?). Si ce n'est pas Debian i386, alors il faut aussi exécuter update-grub dans cet OS.

gargamel79 a écrit :

Mais seulement une possibilité pour Debian10 i386


Il n'y a pas de sous-menu "options avancées pour Debian" juste dessous, avec des entrées pour chaque noyau en mode normal et en mode rescue ?
On peut voir le contenu du fichier /boot/grub/grub.cfg ?

Dernière modification par raleur (31-12-2020 11:29:09)


Il vaut mieux montrer que raconter.

Hors ligne

#16 31-12-2020 11:29:18

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu]revenir à une version précédente

raleur a écrit :

On peut voir le contenu du fichier /boot/grub/grub.cfg ?


le résultat de la commande :

cat /boot/grub/grub.cfg



Force et vigueur... wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#17 31-12-2020 11:55:19

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]revenir à une version précédente

Effectivement, il m'arrive fréquemment de me croiser les yeux; c'est update-grub que j'avais entré ! sad
De guerre las j'ai supprimé, avec synaptic , tout ce qui concerne 4.9.0-13 . Et à Dieu va, après reboot uname -a me donne bien 4.9.0-12.
Mais un seul OS, celui du 32bits. un petit coup de

# update-grub


Et je retrouve mes 3 OS.
Je n'ai plus qu'à voir la cohérence des /etc/fstab (pour le swap) et le choix de l'OS de démarrage par défaut. cool
Excusez pour l'imprécision du  1e post, effectivement j'aurais pu préciser 3 OS sur la station..
Merci pour l'aide, je passe Résolu.

Hors ligne

Pied de page des forums