Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-01-2021 15:23:52

Libad
Membre
Distrib. : LM 20 Mate
Inscription : 09-01-2021

Encore un problème d'install' de DF10

J'ai bien vu que je n'étais pas le seul à galérer à l'install', mais je ne comprends vraiment rien aux explications données. Je me permets donc de créer un nouveau sujet dédié à mon problème en particulier.
Alors voilà. J'ai récupéré il y a très peu un Asus vivobook pour un prix intéressant. La bestiole n'a servi qu'un mois a une étudiante et date de mars. J'ai tout d'abord réinitialisé windows pour le laisser dans un coin (au cas où) et installé Linux Mint Ulyana xfce. Au bout de 2 jours, des problèmes au démarrage ont surgi, avec ça comme message avant l'écran noir

file-R1aed1ad39741873ce22410bd8ff236c1

ainsi que des bugs genre l'écran de gestion de l'affichage qui apparaît tout seul. Ceci dit, ça fonctionne en recovery mode

Je suis passé à la version mate et le problème a persisté, un peu différemment. Et le clic droit a disparu.
J'ai essayé cette méthode : https://forums.linuxmint.com/viewtopic. … MDBPhPhBp4
Mais le problème reste entier

Là je me dis autant retourner sur Debian (j'avais une xfce avant) et juste après le boot live, pour tester avant d'installer je tombe sur ça, avant l'écran noir :

file-R63346b9e509c5a93a980a3f2b6d5e56b


Voilà, c'est un peu vexant quand jon sait que le matos est quasi neuf et que rien ne devrait polluer l'osmose tant recherchée.
J'aimerais savoir si les problèmes sont liés (entre Mint et Debian) ? Si il y a un moyen pas trop complexe de le/les résoudre (ou si quelqu'un veut bien me tenir la main ^^') ?
Et si rien de tout ça, quelle distribution me conseilleriez vous pour un type qui veut juste un ordi qui fonctionne pour un usage lambda (web, photos, musique)

Voili voilou, merci de votre aide

Dernière modification par Libad (09-01-2021 15:35:08)


Pc : VivoBook-ASUSLaptop-X512DA | LinuxMint 20 Ulyana mate |5.4.0-59-generic x86_64 | Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
|Memory: 5.81 GiB | AMD Picasso

Hors ligne

#2 09-01-2021 16:22:15

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.10.16
(G)UI : KDE 5.21.0
Inscription : 11-03-2016

Re : Encore un problème d'install' de DF10

Bonjour smile

Libad a écrit :

Voilà, c'est un peu vexant quand on sait que le matos est quasi neuf et que rien ne devrait polluer l'osmose tant recherchée.
J'aimerais savoir si les problèmes sont liés (entre Mint et Debian) ? Si il y a un moyen pas trop complexe de le/les résoudre (ou si quelqu'un veut bien me tenir la main ^^') ?
Et si rien de tout ça, quelle distribution me conseilleriez vous pour un type qui veut juste un ordi qui fonctionne pour un usage lambda (web, photos, musique)


C'est tout à fait possible que DFlinux qui est une Debian stable ne soit pas un choix adapté si ton PC est très récent.
Ubuntu/LinuxMint proposent des noyaux plus récents (5.4 je crois) et des firmwares qui ont plus de chances de faire tourner ton matériel.

Attends l'avis de membres qui suivent ça de près mais, à moins de tester testing ou sid, je ne sais pas si buster avec un noyau et des firmwares des backports suffiront pour ton PC

Si Linuxmint s'est bien installé, il faudrait peut-être creuser pour savoir pourquoi le système a eu un problème quelques jours après

Hors ligne

#3 09-01-2021 16:38:32

Libad
Membre
Distrib. : LM 20 Mate
Inscription : 09-01-2021

Re : Encore un problème d'install' de DF10

Yo !
Merci de ta réponse. Avec du recul, je réalise que je ne suis pas à plaindre. Mint mate tourne quand même en recovery. J'ai juste le clic droit qui a disparu. Mais je me disais qu'avec tout en tout neuf ou presque, je pourrais avoir un système stable et performant. Je suis trop exigent ? Ma précédente instal' était lente mais n'avait aucun bug. Peut être prendre une version un peu plus ancienne ?
J'arrête pas de faire de la pub aux gens que je rencontre ou côtoie sur les bienfaits des distros alternatives, mais là ils doivent prendre peur à me voir galérer comme ça.
" à moins de tester testing ou sid, je ne sais pas si buster avec un noyau et des firmwares des backports suffiront pour ton PC" ça me fait le même effet que si je disais "choquer la drisse de cartahue du palan de fortune avant de l'affaler pour la carguer " à quelqu'un qui a jamais fait de bateau ^^

Pc : VivoBook-ASUSLaptop-X512DA | LinuxMint 20 Ulyana mate |5.4.0-59-generic x86_64 | Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
|Memory: 5.81 GiB | AMD Picasso

Hors ligne

#4 09-01-2021 17:50:21

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.10.16
(G)UI : KDE 5.21.0
Inscription : 11-03-2016

Re : Encore un problème d'install' de DF10

excuses moi, je pensais que tu étais un habitué de debian wink
Tu ne démarrais pas normalement avec linux mint après l'installation ? ça pourrait vouloir dire qu'il te faut un noyau encore plus récent et sans doute le firmware-amd libre qui va avec.
J'avais compris que c'était bon après l'installation et que le problème était survenu après, problème qui pouvait alors être causé par toi-même par exemple en installant un logiciel hors-dépôt par exemple mais si dès le départ ça n'allait pas alors il faut tester un noyau plus récent.

Edit : en relisant ton message, j'ai fait une recherche sur ton premier message d'erreur et trouvé ceci :
https://forums.linuxmint.com/viewtopic.php?t=323152

Hors ligne

#5 10-01-2021 12:20:06

Libad
Membre
Distrib. : LM 20 Mate
Inscription : 09-01-2021

Re : Encore un problème d'install' de DF10

Bon matin !
J'ai déjà essayé cette méthode, tout s'est bien déroulé mais le bug persiste. Ce problème est arrivé quasiment après l'installation. Je n'ai rien installé vu que je me suis très vite dit que j'allais essayer une autre distro. Mais j'ai l'impression qu'il est inhérent à l'ordi vu que sur les 3 essayées, aucune ne fonctionne nickel. Quand tu parles de noyau plus récent, comment faire ? J'ai téléchargé les iso au fur et à mesure de mes essais, je vois pas comment faire plus récent ?

Pc : VivoBook-ASUSLaptop-X512DA | LinuxMint 20 Ulyana mate |5.4.0-59-generic x86_64 | Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
|Memory: 5.81 GiB | AMD Picasso

Hors ligne

#6 10-01-2021 13:05:54

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.10.16
(G)UI : KDE 5.21.0
Inscription : 11-03-2016

Re : Encore un problème d'install' de DF10

Ça se fait avec le choix de ta distribution
Avec DFlinux ou Debian Buster tu as un noyau 4.19
Avec Ubuntu 20.4 LTS tu as un noyau 5.4
Ubuntu 20.10 a un noyau 5.18
Tu pourrais essayer cette dernière pour voir si c’est mieux avec ton PC.
Les backports sur Debian stable c’est un dépôt qui permet d’avoir des versions plus récentes pour certains paquets comme le noyau.
Tu pourrais essayer Debian testing ou Debian sid qui ont un noyau 5.10, mais si tu débutes , je ne sais pas si c’est une bonne idée

Hors ligne

#7 10-01-2021 14:55:09

Libad
Membre
Distrib. : LM 20 Mate
Inscription : 09-01-2021

Re : Encore un problème d'install' de DF10

Si je suis bien, mon problème viendrait du fait que mon ordi est un peu trop récent par rapport aux distributions essayées ? Potentiellement, avec le temps, les corrections et les mises à jour, le problème pourrait disparaître ?
Ceci dit, est-ce qu'il y a une marche à suivre pour régler ces problèmes maintenant ?
En dernier recours je garde l'option Ubuntu.
Merci de ton aide, j'espère que ça ne te gonfle pas ^^

Pc : VivoBook-ASUSLaptop-X512DA | LinuxMint 20 Ulyana mate |5.4.0-59-generic x86_64 | Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
|Memory: 5.81 GiB | AMD Picasso

Hors ligne

#8 10-01-2021 16:30:50

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.10.16
(G)UI : KDE 5.21.0
Inscription : 11-03-2016

Re : Encore un problème d'install' de DF10

C’est une possibilité.
Actuellement tu as quel système installé sur ce PC ? Il faudrait essayer un noyau plus récent sur ce système.
c’est toujours ce qui est dans ta signature ?
Pc : VivoBook-ASUSLaptop-X512DA | LinuxMint 20 Ulyana mate |5.4.0-59-generic x86_64 | Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
|Memory: 5.81 GiB | AMD Picasso

Je ne connais pas linuxmint, je vais chercher s’il propose des backports.
Édit : il y a moyen d’instalier un noyau plus récent https://9to5linux.com/how-to-install-li … linux-mint par contre ce fil indique qu’ils sont non signés et qu’il faut désactiver le secureboot ce qui m’etonne Debian propose des noyaux signés dans les backports.
Mint étant dérivé d’Ubuntu tu devrais pouvoir utiliser ça https://doc.ubuntu-fr.org/mainline

Hors ligne

#9 11-01-2021 11:43:56

Libad
Membre
Distrib. : LM 20 Mate
Inscription : 09-01-2021

Re : Encore un problème d'install' de DF10

Bon, j'ai découvert hier soir qu'une version 20.1 de Linux Mint était sorti. Je l'ai installé hier, nickel. Ce matin démarrage et même message qu'avec la version précédente (Cf 1e photo dans mon premier message). On m'a conseillé de basculé iommu en off dans le menu UEFI. Mais pas moyen de le trouver dans ledit menu. C'est possible en passant par le terminal ?
Merci pour les pistes, mais mainline est devenu payant apparemment.

Pc : VivoBook-ASUSLaptop-X512DA | LinuxMint 20 Ulyana mate |5.4.0-59-generic x86_64 | Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
|Memory: 5.81 GiB | AMD Picasso

Hors ligne

#10 11-01-2021 13:44:01

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.10.16
(G)UI : KDE 5.21.0
Inscription : 11-03-2016

Re : Encore un problème d'install' de DF10

Non mainline n’est pas payant, c’est ukuu qui est devenu payant

Je l'ai installé hier, nickel.


Tu as fait un redémarrage qui a fonctionné normalement hier soir et ce matin ça ne veut plus ? C’est bizarre, je crois qu’une telle situation me dépasse

Hors ligne

#11 11-01-2021 17:24:59

Libad
Membre
Distrib. : LM 20 Mate
Inscription : 09-01-2021

Re : Encore un problème d'install' de DF10

Après encore plus de recherches sur le sujet, il semble que je fais partie des rares qui ne sait pas se débarrasser du bug.
J'ai finalement opté pour rétrograder à une version antérieure, linuxmint 19.3 XFCE. Jusqu'ici, tout va bien.
C'est con, j'aurais bien voulu essayer Debian, peut être plus tard, en espérant que ça deviendra compatible sans galère
Anyway, merci de ton aide !

Pc : VivoBook-ASUSLaptop-X512DA | LinuxMint 20 Ulyana mate |5.4.0-59-generic x86_64 | Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
|Memory: 5.81 GiB | AMD Picasso

Hors ligne

#12 11-01-2021 20:13:04

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.10.16
(G)UI : KDE 5.21.0
Inscription : 11-03-2016

Re : Encore un problème d'install' de DF10

C'est peut-être un souci entre certaines versions du noyau 5 et ton AMD Ryzen, je n'en sais rien mais si tu as trouvé chaussure à ton pied c'est l'essentiel wink

Hors ligne

Pied de page des forums