Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-01-2021 15:50:13

madiwas
Membre
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Cinnamon
Inscription : 11-11-2020

dpkg-deb: erreur: coller subprocess was killed by signal

Bonjour,

Je voulais faire les mises à jour de mon Debian 10.7 qui tourne depuis déjà longtemps sur un MacBook (4.19.0-11-amd64 #1 SMP Debian 4.19.146-1 (2020-09-17) x86_64) mais mon système rencontre les erreurs suivantes :

apt --fix-broken install



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  nextcloud-desktop-l10n
Les NOUVEAUX paquets suivants seront installés :
  nextcloud-desktop-l10n
0 mis à jour, 1 nouvellement installés, 0 à enlever et 104 non mis à jour.
4 partiellement installés ou enlevés.
Il est nécessaire de prendre 411 ko dans les archives.
Après cette opération, 3973 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]
Réception de :1 http://ftp.fr.debian.org/debian buster/main amd64 nextcloud-desktop-l10n all 2.5.1-3+deb10u1 [411 kB]
411 ko réceptionnés en 1s (589 ko/s)            
(Lecture de la base de données... 206933 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../nextcloud-desktop-l10n_2.5.1-3+deb10u1_all.deb ...
Dépaquetage de nextcloud-desktop-l10n (2.5.1-3+deb10u1) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/nextcloud-desktop-l10n_2.5.1-3+deb10u1_all.deb (--unpack) :
 tentative de remplacement de « /usr/share/nextcloud/i18n/client_TW.qm », qui appartient aussi au paquet nextcloud-client-l10n 2.3.3-20180415.190957
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/nextcloud-desktop-l10n_2.5.1-3+deb10u1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 



Que pouvez-vous me conseiller ?

Merci,

Madiwas

Hors ligne

#2 28-01-2021 22:06:51

raleur
Membre
Inscription : 03-10-2014

Re : dpkg-deb: erreur: coller subprocess was killed by signal

Qu'est-ce que tu ne comprends pas dans le message d'erreur ?

nextcloud-desktop-l10n ne peut s'installer parce qu'un de ses fichiers est en conflit avec un fichier du paquet nextcloud-client-l10n. Je ne trouve pas le paquet nextcloud-client-l10n dans l'archive Debian buster. D'où vient-il ?

Dernière modification par raleur (28-01-2021 22:11:04)


Il vaut mieux montrer que raconter.

Hors ligne

#3 29-01-2021 09:34:38

madiwas
Membre
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-amd64
(G)UI : Cinnamon
Inscription : 11-11-2020

Re : dpkg-deb: erreur: coller subprocess was killed by signal

Ma demande d'assistance est de savoir ce que je dois faire pour résoudre ce phénomène qui m'empêche de faire les MAJ de Debian.
help.gif

Hors ligne

#4 29-01-2021 11:53:48

raleur
Membre
Inscription : 03-10-2014

Re : dpkg-deb: erreur: coller subprocess was killed by signal

Je ne peux pas répondre sans savoir d'où vient le paquet nextcloud-client-l10n qui est en conflit avec la mise à jour et pourquoi il est installé.
Je pourrais te suggérer de le désinstaller sans chercher à comprendre, mais c'est comme suggérer à quelqu'un qui a mal à la jambe de la couper : il n'aura plus mal à la jambe, certes, mais il n'aura plus de jambe non plus.

Il vaut mieux montrer que raconter.

Hors ligne

#5 29-01-2021 22:14:42

èfpé
Membre
Inscription : 10-07-2016

Re : dpkg-deb: erreur: coller subprocess was killed by signal

Bonsoir, en passant,

raleur a écrit :

Je ne trouve pas le paquet nextcloud-client-l10n dans l'archive Debian buster. D'où vient-il ?


Probablement de ce dépôt PPA (version 2.3.3-20180415.190957~artful1). Source : nextcloud.com.

Hors ligne

Pied de page des forums