Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-02-2021 16:34:37

Framboisier
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : cinnamon 3.8.8
Inscription : 22-01-2017

[Résolu] Comment désactiver le Dim Screen (demi-luminosité imposée à

Bonjour,

C'est rien de grave mais ce truc m'énerve régulièrement depuis 2 ans déjà, et j'ai jamais trouvé comment le virer ou le régler. Un coup de main serait vraiment le bienvenu.
En fonctionnement sur batterie, il m'impose une demi-luminosité après 90 secondes. Pas quand il est sur secteur.
Je suis sur Debian10 + Cinnamon3.8.8 (ordi Acer Aspire5).
Il me le faisait déjà avec Debian9 + Cinnamon 327 précédemment sur le même ordi.
Par contre il ne me le fait pas sur mon ancien ordinosaure (PackardBell) avec le même Debian9 + Cinnamon 327: donc ça ne semble pas être du ressort de cinnamon ???
Serait-ce alors un réglage dans le bios de mon Acer? Je ne crois pas car j'ai réveillé son w10 au fond du tiroir en dualboot et il ne me fait pas cette demi-lumière...
Le Screensaver de Cinnamon ne me laisse régler que l'économiseur d'écran qui fonctionne bien aux 10 minutes indiquées. Mais il ne me parle nulle part de dim screen.
J'ai lu en revanche quelque part que Gnome dispose d'un dim screen régulable... Y aurait-il interaction quelquepart?
Xscreensaver principal n'est pas installé, seulement certains de ses modules.

Quelqu'un voit-il où je devrais aller jeter un oeuil ? J'aimerais tant pouvoir rajouter un "0" derrière le 90...
Merci beaucoup d'avance.

Voici ce que donne xset q :

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
 

Dernière modification par Framboisier (10-02-2021 13:37:34)

Hors ligne

#2 10-02-2021 09:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Comment désactiver le Dim Screen (demi-luminosité imposée à

Bonjour,

Framboisier a écrit :

Quelqu'un voit-il où je devrais aller jeter un œil ?


En GUI, installer le paquet dconf-editor, démarrer l'Éditeur dconf, enfin rechercher le motif idle-dim :

1612956586.png

Et hop. En CLI cela se passe avec la commande gsettings. Il faut un petit peu lire le man mais ça va.

gsettings get org.cinnamon.settings-daemon.plugins.power idle-dim-time

90


gsettings set org.cinnamon.settings-daemon.plugins.power idle-dim-time 900


Alternative, passer la valeur de la clé idle-dim-battery de true à false désactivera le comportement...

Dernière modification par èfpé (10-02-2021 13:34:42)

Hors ligne

#3 10-02-2021 13:30:53

Framboisier
Membre
Distrib. : Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : cinnamon 3.8.8
Inscription : 22-01-2017

Re : [Résolu] Comment désactiver le Dim Screen (demi-luminosité imposée à

WWWWOOOOUUUUUAAAAAAWWWWWW ! ! ! ! ! !

C'est exactement ça !

Merci beaucoup èfpé de m'avoir fait découvrir dconf et gsettings !

Bonne journée à toi et à tous    smile

Hors ligne

Pied de page des forums