Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-02-2021 07:04:58

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour à tous,

En voulant mettre à jour  (apt update / apt upgrade) ma debian stable 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux à l'instant, j'ai apt qui se bloque lors du dépaquetage du paquet nvidia_legacy_check_418.181.07-1. Du coup, arrêt forcé. Il y avait pas mal de mise à jour car nouvelle version de debian en 10.8. D'autres paquets doivent encore être mis à jour dans la liste.

Parmi vous, d'autres personnes ont également eu ce souci ? Est-il possible de bloquer temporairement la mise à jour nvidia mais de continuer à mettre à jour le restant des paquets ?

Pouvez-vous me donner la commande pour que je vous affiche les derniers logs ?

Merci à vous !

MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#2 11-02-2021 14:52:08

raleur
Membre
Inscription : 03-10-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Antidentity a écrit :

apt qui se bloque lors du dépaquetage du paquet


C'est-à-dire ?


Il vaut mieux montrer que raconter.

Hors ligne

#3 13-02-2021 06:50:19

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Je me suis mal exprimé, je pense. Je voulais dire (sans doute avec les mauvais mots toujours) que l'upgrade se fige à la progression de 0% ou 1% sur la ligne "Préparation du dépaquetage de .../nvidia-legacy-check_418.181.07-1_amd64.deb". Et je crois que tout le système se fige car je ne sais pas revenir à ma session avec ctrl+alt+F1.

Il me reste d'autres paquets à mettre à jour mais le 1er que apt veut mettre à jour est ce nvidia-legacy-check qui me bloque tout pour le moment. Voici la liste des autres paquets encore à mettre à jour:

chromium-common/stable 88.0.4324.146-1~deb10u1 amd64 [pouvant être mis à jour depuis : 87.0.4280.141-0.1~deb10u1]
chromium-l10n/stable 88.0.4324.146-1~deb10u1 all [pouvant être mis à jour depuis : 87.0.4280.141-0.1~deb10u1]
chromium-sandbox/stable 88.0.4324.146-1~deb10u1 amd64 [pouvant être mis à jour depuis : 87.0.4280.141-0.1~deb10u1]
chromium/stable 88.0.4324.146-1~deb10u1 amd64 [pouvant être mis à jour depuis : 87.0.4280.141-0.1~deb10u1]
file/stable 1:5.35-4+deb10u2 amd64 [pouvant être mis à jour depuis : 1:5.35-4+deb10u1]
grub-common/stable 2.02+dfsg1-20+deb10u3 amd64 [pouvant être mis à jour depuis : 2.02+dfsg1-20+deb10u2]
grub-efi-amd64-bin/stable 2.02+dfsg1-20+deb10u3 amd64 [pouvant être mis à jour depuis : 2.02+dfsg1-20+deb10u2]
grub-efi-amd64-signed/stable 1+2.02+dfsg1+20+deb10u3 amd64 [pouvant être mis à jour depuis : 1+2.02+dfsg1+20+deb10u2]
grub-efi-amd64/stable 2.02+dfsg1-20+deb10u3 amd64 [pouvant être mis à jour depuis : 2.02+dfsg1-20+deb10u2]
grub2-common/stable 2.02+dfsg1-20+deb10u3 amd64 [pouvant être mis à jour depuis : 2.02+dfsg1-20+deb10u2]
iproute2/stable 4.20.0-2+deb10u1 amd64 [pouvant être mis à jour depuis : 4.20.0-2]
libcairo-gobject2/stable 1.16.0-4+deb10u1 amd64 [pouvant être mis à jour depuis : 1.16.0-4]
libcairo2/stable 1.16.0-4+deb10u1 amd64 [pouvant être mis à jour depuis : 1.16.0-4]
libmagic-mgc/stable 1:5.35-4+deb10u2 amd64 [pouvant être mis à jour depuis : 1:5.35-4+deb10u1]
libmagic1/stable 1:5.35-4+deb10u2 amd64 [pouvant être mis à jour depuis : 1:5.35-4+deb10u1]
libnvidia-cbl/stable 418.181.07-1 amd64 [pouvant être mis à jour depuis : 418.152.00-1]
libnvidia-fatbinaryloader/stable 418.181.07-1 amd64 [pouvant être mis à jour depuis : 418.152.00-1]
libnvidia-ptxjitcompiler1/stable 418.181.07-1 amd64 [pouvant être mis à jour depuis : 418.152.00-1]
libnvidia-rtcore/stable 418.181.07-1 amd64 [pouvant être mis à jour depuis : 418.152.00-1]
libpq5/stable 11.10-0+deb10u1 amd64 [pouvant être mis à jour depuis : 11.9-0+deb10u1]
libsnmp-base/stable 5.7.3+dfsg-5+deb10u2 all [pouvant être mis à jour depuis : 5.7.3+dfsg-5+deb10u1]
libsnmp30/stable 5.7.3+dfsg-5+deb10u2 amd64 [pouvant être mis à jour depuis : 5.7.3+dfsg-5+deb10u1]
libzstd1/stable 1.3.8+dfsg-3+deb10u1 amd64 [pouvant être mis à jour depuis : 1.3.8+dfsg-3]
nvidia-legacy-check/stable 418.181.07-1 amd64 [pouvant être mis à jour depuis : 418.152.00-1]
unzip/stable 6.0-23+deb10u2 amd64 [pouvant être mis à jour depuis : 6.0-23+deb10u1]



J'ai tenté un:

apt-mark hold nvidia-legacy-check


dans le but de vouloir bloquer temporairement sa mise à jour et permettant de mettre à jour le restant des paquets (espérant par la même occasion que la mise à jour des autres paquets libnvidia etc. débloquerait plus tard le souci, même si j'ai un gros doute...) et j'ai donc tenté un apt update et upgrade après le "hold" du paquet mais il m'indique ceci:

E: Impossible de trouver une source de téléchargement de la version "418.152.00-1" de "nvidia-legacy-check:amd64"



(J'ai remis en place le paquet avec apt-mark unhold nvidia-legacy-check.) Je n'ai aucune idée de ce que je pourrais faire d'autre.


MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#4 13-02-2021 11:05:19

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian bullseye (testing)
Noyau : Linux 5.10.0-5-amd64
(G)UI : LightDM et Xfce4.16
Inscription : 29-04-2015

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Dans quel type de terminal lances-tu la mise à jour (conole tty ou terminal x) ?

Sinon perso je supprimerai temporairement ke paquet nvidia-legacy-check. Toutefois attends la réponse de raleur avant de le faire.

Tousse antique Ovide !

Hors ligne

#5 14-02-2021 05:16:35

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour Philou92,

J'ai d'abord essayé plusieurs fois de faire la mise à jour au démarrage de l'ordi, sans lancer de session startx. Ensuite, j'ai également essayé en lançant ma session et de faire la mise à jour depuis la console tty. (je ne le fais jamais depuis le terminal quand il y a des paquets nvidia)

Je vais attendre la réponse de raleur (et je vais quand même regarder pour faire un backup avant de faire quoi que ce soit ^^)

MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#6 14-02-2021 10:28:05

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour

tu a une debian stretch (ta signature ) ? et un noyau des backports de stretch ?
il manque le type de ta carte graphique ?

il s'agit peut être d un driver incompatible avec ton matériel

ps: sur stable (buster) le driver nvidia a été mit a jour sans aucun souci pour moi
en général c'est pour corriger des bugs ou pour des raisons de sécurité

nota: il faut si possible les paquets image et headers des backports aussi (méta paquet )  et les dépendances
normalement le driver ne casse pas debian , juste au pire un écran noir au démarrage , il suffit de le purger et d' installer une bonne version .
si tu compte passer a buster (stable) faire la migration sans le driver nvidia et prendre un driver compatible (avec ta carte graphique ) avant de redémarrer la machine

donc bien vérifier que le driver qui est proposé en mise a jour est bien compatible avec ton matériel

=>  https://packages.debian.org/fr/stretch- … gacy-check

version 418.152.00-1~bpo9+1

la page du driver-nvidia  =>  https://packages.debian.org/fr/stretch- … dia-driver

Hors ligne

#7 14-02-2021 10:34:27

raleur
Membre
Inscription : 03-10-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Les derniers logs de dpkg sont dans /var/log/dpkg.log, dpkg.log.1, dpkg.log.2.gz (compressé)...
A quel point le système est-il bloqué ? Est-ce que Alt+Fx pour basculer vers les autres consoles fonctionne (si cela fonctionne en temps normal, j'ai cru comprendre que ce n'était pas toujours le cas avec me pilote nvidia) ? Est-ce que les "touches magiques" (Alt+Sys+REISUB) fonctionnent ?
Je ne connais rien aux pilotes nvidia.

Il vaut mieux montrer que raconter.

Hors ligne

#8 14-02-2021 10:54:20

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour raleur

normalement sans serveur graphique , bien purger le driver (mode normal ou dépannage )
il doit garder la main sur le système ( Ctrl+Alt+F2 par exemple )  ,  et stopper le  bureau avec


service lightdm status
 



pour le stopper


service lightdm stop
 



ps: remplacer "lightdm" par celui que tu utilise ( gdm3 ou autre )

bien purger le driver en console et installer le nouveau puis reboot
normalement on ne refait pas une installation de debian sur un problème de driver propriétaire nvidia

cela va lui permettre de faire la mise a jour des paquets autre que le driver aussi
le souci aussi c'est le mélange avec les backports , il vaut mieux utiliser le driver de la version de debian installé si possible (et pas les backports )

je trouve aussi une différence de version entre la sienne et celle du dépôt debian  =>  418.152.00-1~bpo9+1

il faut qu'il précise sa version de debian , si il utilise bien les backports et le type de carte graphique (je me suis basé sur sa signature )

Hors ligne

#9 14-02-2021 12:42:04

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

robert2a a écrit :

il faut qu'il précise sa version de debian


Il a indiqué dans son premier message :

Antidentity a écrit :

En voulant mettre à jour  (apt update / apt upgrade) ma debian stable 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux


En regardant les changements sur le paquet nvidia-legacy-check, il me semble qu'il y a eu une version 418.152.00-1 dans les dépôts de Buster

nvidia-graphics-drivers (418.152.00-1) buster; urgency=medium

  * New upstream Tesla release 418.152.00 (2020-06-24).
    * Fixed CVE-2020-5963, CVE-2020-5967.  (Closes: #963766)
      https://nvidia.custhelp.com/app/answers … /a_id/5031

  [ Andreas Beckmann ]
  * Use amd64 Tesla releases for buster.
  * Refresh patches.
  * Update lintian overrides.
  * Upload to buster.

Hors ligne

#10 14-02-2021 13:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour, en passant,

robert2a a écrit :

le type de ta carte graphique ?


Le GPU censé équiper le MSI GE 6QD Apache Pro est un GeForce GTX 960M (GM107) ; à confirmer :

lspci -nnk


Ce GPU serait pris en charge depuis la version 349.16, rien n'indique qu'il s'agit d'un souci de pilote.

@Antidentity : as-tu encore accès à ta session graphique ? As-tu vérifié l'espace disque disponible ?

Hors ligne

#11 14-02-2021 19:04:06

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

re,
sur pc de bureau  une GTX950 et buster stable
le type


01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 950] (rev a1)
 



la version du driver nvidia de buster


glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 2048 MB
    Total available memory: 2048 MB
    Currently available dedicated video memory: 1851 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 950/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 418.181.07
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 418.181.07
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 418.181.07
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 



donc version 418.181.07

moi je répond au titre


 upgrade bloqué par nvidia_legacy_check_418.181.07-1
 



donc aucun soucis avec du gm2xx et buster avec le driver nvidia
ps: comme dit plus haut le driver a été mit a jour sur stable il n' y a pas longtemps .

la série mobile a très peu de différence avec la série PC de bureau
et aucun soucis avec la version du driver , je fais tourner des GTX6xx et GTX7xx et GTX9xx en stable

comme le blocage vient du driver , le purger  , mettre a jour debian et le réinstaller , mais sur un portable ça sent mauvais cette histoire ( si 2 gpu par exemple  ).  roll
je vous laisse continuer pour la suite

remarque:
si le disque est plein , difficile de mettre a jour , a creuser  smile   , voir la remarque de  éfpé au dessus .

Dernière modification par robert2a (14-02-2021 19:08:55)

Hors ligne

#12 14-02-2021 20:57:21

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonsoir tout le monde,

Merci de vous pencher sur mon problème. Désolé, effectivement j'aurais dû donner plus de détail sur ma configuration. Il s'agit bien du pc portable MSI GE 6QD Apache Pro avec une GeForce GTX 960M et Debian buster stable.


root@Antidentity:~# tail -n 61 /var/log/dpkg.log



2021-02-03 18:58:54 status installed ca-certificates:all 20200601~deb10u2
2021-02-11 05:34:05 startup packages configure
2021-02-11 05:34:05 configure libnvidia-glvkspirv:amd64 418.181.07-1 <aucune>
2021-02-11 05:34:05 status unpacked libnvidia-glvkspirv:amd64 418.181.07-1
2021-02-11 05:34:05 status half-configured libnvidia-glvkspirv:amd64 418.181.07-1
2021-02-11 05:34:05 status installed libnvidia-glvkspirv:amd64 418.181.07-1
2021-02-11 05:34:05 configure libnvidia-eglcore:amd64 418.181.07-1 <aucune>
2021-02-11 05:34:05 status unpacked libnvidia-eglcore:amd64 418.181.07-1
2021-02-11 05:34:05 status half-configured libnvidia-eglcore:amd64 418.181.07-1
2021-02-11 05:34:05 status installed libnvidia-eglcore:amd64 418.181.07-1
2021-02-11 05:34:05 configure libgnutls-dane0:amd64 3.6.7-4+deb10u6 <aucune>
2021-02-11 05:34:05 status unpacked libgnutls-dane0:amd64 3.6.7-4+deb10u6
2021-02-11 05:34:05 status half-configured libgnutls-dane0:amd64 3.6.7-4+deb10u6
2021-02-11 05:34:05 status installed libgnutls-dane0:amd64 3.6.7-4+deb10u6
2021-02-11 05:34:05 configure systemd-sysv:amd64 241-7~deb10u6 <aucune>
2021-02-11 05:34:05 status unpacked systemd-sysv:amd64 241-7~deb10u6
2021-02-11 05:34:05 status half-configured systemd-sysv:amd64 241-7~deb10u6
2021-02-11 05:34:05 status installed systemd-sysv:amd64 241-7~deb10u6
2021-02-11 05:34:05 configure nvidia-nonglvnd-vulkan-common:amd64 418.181.07-1 <aucune>
2021-02-11 05:34:05 status unpacked nvidia-nonglvnd-vulkan-common:amd64 418.181.07-1
2021-02-11 05:34:05 status half-configured nvidia-nonglvnd-vulkan-common:amd64 418.181.07-1
2021-02-11 05:34:05 status installed nvidia-nonglvnd-vulkan-common:amd64 418.181.07-1
2021-02-11 05:34:05 configure libnss-systemd:amd64 241-7~deb10u6 <aucune>
2021-02-11 05:34:05 status unpacked libnss-systemd:amd64 241-7~deb10u6
2021-02-11 05:34:05 status half-configured libnss-systemd:amd64 241-7~deb10u6
2021-02-11 05:34:05 status installed libnss-systemd:amd64 241-7~deb10u6
2021-02-11 05:34:05 configure udev:amd64 241-7~deb10u6 <aucune>
2021-02-11 05:34:05 status unpacked udev:amd64 241-7~deb10u6
2021-02-11 05:34:05 status half-configured udev:amd64 241-7~deb10u6
2021-02-11 05:34:06 status installed udev:amd64 241-7~deb10u6
2021-02-11 05:34:06 status triggers-pending initramfs-tools:all 0.133+deb10u1
2021-02-11 05:34:06 configure libnvidia-glcore:amd64 418.181.07-1 <aucune>
2021-02-11 05:34:06 status unpacked libnvidia-glcore:amd64 418.181.07-1
2021-02-11 05:34:06 status half-configured libnvidia-glcore:amd64 418.181.07-1
2021-02-11 05:34:06 status installed libnvidia-glcore:amd64 418.181.07-1
2021-02-11 05:34:06 configure libpam-systemd:amd64 241-7~deb10u6 <aucune>
2021-02-11 05:34:06 status unpacked libpam-systemd:amd64 241-7~deb10u6
2021-02-11 05:34:06 status half-configured libpam-systemd:amd64 241-7~deb10u6
2021-02-11 05:34:06 status installed libpam-systemd:amd64 241-7~deb10u6
2021-02-11 05:34:06 trigproc mime-support:all 3.62 <aucune>
2021-02-11 05:34:06 status half-configured mime-support:all 3.62
2021-02-11 05:34:06 status installed mime-support:all 3.62
2021-02-11 05:34:06 trigproc libc-bin:amd64 2.28-10 <aucune>
2021-02-11 05:34:06 status half-configured libc-bin:amd64 2.28-10
2021-02-11 05:34:06 status installed libc-bin:amd64 2.28-10
2021-02-11 05:34:06 trigproc man-db:amd64 2.8.5-2 <aucune>
2021-02-11 05:34:06 status half-configured man-db:amd64 2.8.5-2
2021-02-11 05:34:07 status installed man-db:amd64 2.8.5-2
2021-02-11 05:34:07 trigproc dbus:amd64 1.12.20-0+deb10u1 <aucune>
2021-02-11 05:34:07 status half-configured dbus:amd64 1.12.20-0+deb10u1
2021-02-11 05:34:07 status installed dbus:amd64 1.12.20-0+deb10u1
2021-02-11 05:34:07 trigproc bamfdaemon:amd64 0.5.4-1 <aucune>
2021-02-11 05:34:07 status half-configured bamfdaemon:amd64 0.5.4-1
2021-02-11 05:34:07 status installed bamfdaemon:amd64 0.5.4-1
2021-02-11 05:34:07 trigproc desktop-file-utils:amd64 0.23-4 <aucune>
2021-02-11 05:34:07 status half-configured desktop-file-utils:amd64 0.23-4
2021-02-11 05:34:07 status installed desktop-file-utils:amd64 0.23-4
2021-02-11 05:34:07 trigproc initramfs-tools:all 0.133+deb10u1 <aucune>
2021-02-11 05:34:07 status half-configured initramfs-tools:all 0.133+deb10u1
2021-02-11 06:36:17 startup packages configure
 



raleur a écrit :

Est-ce que Alt+Fx pour basculer vers les autres consoles fonctionne ? Est-ce que les "touches magiques" (Alt+Sys+REISUB) fonctionnent ?


J'avais testé REISUB et malheureusement aucune réponse du système (pas d'arrêt/redémarrage). Je viens d'essayer Alt+Fx et aucun basculement ne se produit, tout est bloqué.


robert2a a écrit :

ps: remplacer "lightdm" par celui que tu utilise ( gdm3 ou autre )


Je lance ma session manuellement avec startx mais lightdm est bien actif (exited):

# service --status-all



 [ - ]  acpid
 [ - ]  alsa-utils
 [ - ]  anacron
 [ + ]  apparmor
 [ + ]  avahi-daemon
 [ + ]  bluetooth
 [ + ]  bumblebeed
 [ - ]  console-setup.sh
 [ + ]  cron
 [ + ]  cups
 [ + ]  cups-browsed
 [ + ]  dbus
 [ + ]  exim4
 [ - ]  hwclock.sh
 [ - ]  irqbalance
 [ - ]  keyboard-setup.sh
 [ + ]  kmod
 [ - ]  lightdm
 [ + ]  network-manager
 [ + ]  networking
 [ + ]  openvpn
 [ - ]  pcscd
 [ - ]  plymouth
 [ - ]  plymouth-log
 [ - ]  pppd-dns
 [ + ]  procps
 [ + ]  resolvconf
 [ + ]  rsyslog
 [ - ]  saned
 [ - ]  sudo
 [ + ]  udev
 [ - ]  x11-common
 



# service lightdm status



● lightdm.service - LSB: Light Display Manager
   Loaded: loaded (/etc/init.d/lightdm; generated)
   Active: active (exited) since Sun 2021-02-14 19:27:25 CET; 9min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 685 ExecStart=/etc/init.d/lightdm start (code=exited, status=0/SUCCESS)

fév 14 19:27:25 Antidentity systemd[1]: Starting LSB: Light Display Manager...
fév 14 19:27:25 Antidentity systemd[1]: Started LSB: Light Display Manager.
 




èfpé a écrit :

@Antidentity : as-tu encore accès à ta session graphique ? As-tu vérifié l'espace disque disponible ?


Oui, j'ai encore de l'espace disque disponible et accès à la session graphique

# df -h



Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
udev                12G       0   12G   0% /dev
tmpfs              2,4G    9,4M  2,4G   1% /run
/dev/nvme0n1p6      36G    5,7G   29G  17% /
tmpfs               12G    272M   12G   3% /dev/shm
tmpfs              5,0M    4,0K  5,0M   1% /run/lock
tmpfs               12G       0   12G   0% /sys/fs/cgroup
/dev/nvme0n1p2      96M     32M   65M  33% /boot/efi
/dev/nvme0n1p4     235G    181G   55G  77% /media/windows
/dev/sda1          466G    165G  302G  36% /media/hdd-data
/dev/nvme0n1p8     183G     20G  154G  12% /home
tmpfs              2,4G     20K  2,4G   1% /run/user/1000
 



Par contre, il y a un problème pour la commande lspci -nnk chez moi. Elle fait freezer complètement l'ordi que ce soit en user ou via su -. Obligé de forcer le redémarrage.



# apt-cache policy nvidia-legacy-check



nvidia-legacy-check:
  Installé : 418.152.00-1
  Candidat : 418.181.07-1
 Table de version :
     418.181.07-1 500
        500 https://deb.debian.org/debian buster/non-free amd64 Packages
 *** 418.152.00-1 100
        100 /var/lib/dpkg/status
 




/etc/apt$ tail sources.list



deb http://security.debian.org/debian-security buster/updates main contrib non-free
#deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb https://deb.debian.org/debian/ buster-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# backports
deb http://deb.debian.org/debian buster-backports main
 




J'ai réalisé mon backup. Je vais tenter d'arrêter lightdm et purger le paquet nvidia_legacy_check. Je reviens vers vous asap.

Dernière modification par Antidentity (14-02-2021 21:01:15)


MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#13 14-02-2021 21:17:14

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

J'ai stoppé le service lightdm
J'ai tenté de purger le paquet nvidia-legacy-check mais malheureusement il m'indique ceci:

dpkg: erreur de traitement du paquet nvidia-legacy-check (--remove):
Le paquet est dans un état incohérent: vous deviez le réinstaller avant d'essayer de le supprimer.
Des erreurs ont été rencontrées pendant l'exécution :
nvidia-legacy-check
E: Sub-process /usr/bin/dpkg returned an error code (1)


MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#14 15-02-2021 00:16:05

raleur
Membre
Inscription : 03-10-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Antidentity a écrit :

il y a un problème pour la commande lspci -nnk chez moi. Elle fait freezer complètement l'ordi que ce soit en user ou via su -. Obligé de forcer le redémarrage.


A mon avis tu devrais te pencher là-dessus en priorité. C'est peut-être la même cause et c'est le signe d'un problème matériel ou dans le noyau.


Il vaut mieux montrer que raconter.

Hors ligne

#15 15-02-2021 13:06:12

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour

tu dois fonctionner avec nouveau avec ce gpu
pour le driver quelques commandes

vider le cache


apt-get clean
 


supprimer nvidia


apt-get remove --purge nvidia*
 



apt-get remove --purge xserver-xorg-video-nvidia
 




apt-get autoremove --purge
 


pour "update" le faire avec un sources.list correct


apt update
 



donne nous le nombre de paquet en attente de mise a jour

teste tout cela et dit nous ce qui fonctionne ou pas

pour le sources.list c'est ceci pour buster


#buster10  http
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb http://deb.debian.org/debian/ buster main contrib non-free
 



le tien pour l'instant pas correct


deb http://security.debian.org/debian-security buster/updates main contrib non-free
#deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb https://deb.debian.org/debian/ buster-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# backports
#deb http://deb.debian.org/debian buster-backports main
 



il te manque une ligne (dépôt principal) et commenter les "backports"
les backports pourquoi ?

si par hasard ça fonctionne faire un upgrade et un reboot (mais bon pas gagner )  roll

par exemple si tout va bien


apt-get dist-upgrade
 



remarque:
pour fonctionner avec "nouveau" le firmware peut être utile


apt-get install firmware-misc-nonfree
 



ps: il peut être installé même si tu utilise le driver propriétaire

Dernière modification par robert2a (15-02-2021 13:22:57)

Hors ligne

#16 15-02-2021 20:04:42

èfpé
Membre
Inscription : 10-07-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Re-,

en #11, robert2a a écrit :

si 2 gpu par exemple


Oui c'est effectivement le cas (HD Graphics 530), et le post #12 montre le démon bumblebeed actif.

en #15, robert2a a écrit :

il te manque une ligne (dépôt principal)


Non probablement pas, par défaut la commande tail n'affiche que les 10 dernières lignes, cat plutôt.

Hors ligne

#17 16-02-2021 00:51:39

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Re
ça va être un peu plus compliquer .
démarrer seulement avec le gpu intel qui demande aussi le firmware-misc-nonfree je pense
la priorité purger bumblebee ,bumblebee-nvidia et le driver , blacklister nouveau , utiliser nouveau.modeset=0 dans grub
mettre a jour debian

je sais pas pourquoi l' upgrade a planter

donc commencer par le sources.list


cat /etc/apt/sources.list
 



et explique pourquoi tu utilise les backports ?
tu a des logiciels hors dépôt debian sur cette machine ?
quelque chose dans  "/etc/apt/sources.list.d/ "   ?

donne le retour de cette commande


apt policy firmware-misc-nonfree
 

Dernière modification par robert2a (16-02-2021 00:54:48)

Hors ligne

#18 16-02-2021 21:34:23

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonsoir,

Pour le sources.list, effectivement, j'aurais dû utiliser cat au lieu de tail

cat /etc/apt/sources.list


deb https://deb.debian.org/debian/ buster main non-free contrib
#deb-src http://deb.debian.org/debian/ buster main non-free contrib

deb http://security.debian.org/debian-security buster/updates main contrib non-free
#deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb https://deb.debian.org/debian/ buster-updates main contrib non-free
#deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# backports
deb http://deb.debian.org/debian buster-backports main
 



J'utilise les backports quasi uniquement que pour libreoffice.

apt-cache policy firmware-misc-nonfree



firmware-misc-nonfree:
  Installé : 20190114-2
  Candidat : 20190114-2
 Table de version :
 *** 20190114-2 500
        500 https://deb.debian.org/debian buster/non-free amd64 Packages
        100 /var/lib/dpkg/status
 



Pour la purge, en simulation, j'ai ceci:

apt -s purge bumblebee



Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  bbswitch-dkms dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions libgles1 libnvidia-cbl libnvidia-eglcore libnvidia-fatbinaryloader libnvidia-glcore libnvidia-glvkspirv libnvidia-ptxjitcompiler1 libnvidia-rtcore libxnvctrl0 linux-headers-4.19.0-12-amd64 linux-headers-4.19.0-12-common
  linux-image-4.19.0-12-amd64 nvidia-kernel-common nvidia-legacy-390xx-alternative nvidia-legacy-390xx-kernel-dkms nvidia-legacy-390xx-kernel-support nvidia-modprobe nvidia-support primus-libs socat sudo update-glx
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  nvidia-legacy-check
Les paquets suivants seront ENLEVÉS :
  bumblebee* bumblebee-nvidia* primus*
Les paquets suivants seront mis à jour :
  nvidia-legacy-check
1 mis à jour, 0 nouvellement installés, 3 à enlever et 24 non mis à jour.
1 partiellement installés ou enlevés.
Inst nvidia-legacy-check [418.152.00-1] (418.181.07-1 Debian:10.8/stable [amd64])
Purg primus [0~20150328-7]
Purg bumblebee-nvidia [3.2.1-20]
Purg bumblebee [3.2.1-20]
Conf nvidia-legacy-check (418.181.07-1 Debian:10.8/stable [amd64])
 



Et dans cette simulation, on voit ceci qui risque de poser problème:

Les paquets suivants seront mis à jour :
  nvidia-legacy-check



Avant la purge, est-ce que un:

apt clean


pourrait me retirer cette tentative de mettre à jour nvidia-legacy-check et ainsi permettre de faire la purge bumblebee ?


MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#19 17-02-2021 04:22:09

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour

bumblebee est une dépendance de bumblebee-nvidia

donc je testerai plutôt ceci


apt-get -s remove --purge bumblebee bumblebee-nvidia primus nvidia* xserver-xorg-video-nvidia
 



pour ceci tu peu tenter


Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  bbswitch-dkms dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions libgles1 libnvidia-cbl libnvidia-eglcore libnvidia-fatbinaryloader libnvidia-glcore libnvidia-glvkspirv libnvidia-ptxjitcompiler1 libnvidia-rtcore libxnvctrl0 linux-headers-4.19.0-12-amd64 linux-headers-4.19.0-12-common
  linux-image-4.19.0-12-amd64 nvidia-kernel-common nvidia-legacy-390xx-alternative nvidia-legacy-390xx-kernel-dkms nvidia-legacy-390xx-kernel-support nvidia-modprobe nvidia-support primus-libs socat sudo update-glx
Veuillez utiliser « apt autoremove » pour les supprimer.
 




apt-get -s autoremove --purge
 



tu peu utiliser aussi "aptitude" comme commande

par exemple


aptitude -s install nvidia-legacy-check
 


il va te proposer des solutions

aussi ceci


aptitude -s reinstall nvidia-legacy-check
Les paquets suivants seront RÉINSTALLÉS :              
  nvidia-legacy-check
Les paquets suivants seront ENLEVÉS :
  linux-headers-4.19.0-12-amd64{u} linux-headers-4.19.0-12-common{u}
0 paquets mis à jour, 0 nouvellement installés, 1installés, 2 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o/212 ko d'archives. Après dépaquetage, 56,0 Mo seront libérés.

Note: Using '
Simulate' mode.
Voulez-vous continuer ? [Y/n/?]



il va aussi te proposer des solutions

pour nettoyer le cache un clean suivi d un update


apt clean
 


puis


apt update
 



a ta place je commence par aptitude , ça sert a rien de tout casser si il est possible de réparer
il faut que tu teste en simulation (bien que aptitude te demande confirmation par Y/N/ et Q pour quitter )

le noyau actuel


uname -a
Linux debian2 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux
 



vérifie aussi que noyau image et headers  installé


apt policy linux-image-amd64 linux-headers-amd64
linux-image-amd64:
  Installé : 4.19+105+deb10u9
  Candidat : 4.19+105+deb10u9
 Table de version :
 *** 4.19+105+deb10u9 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
        500 https://deb.debian.org/debian-security buster/updates/main amd64 Packages
        100 /var/lib/dpkg/status
linux-headers-amd64:
  Installé : 4.19+105+deb10u9
  Candidat : 4.19+105+deb10u9
 Table de version :
 *** 4.19+105+deb10u9 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
        500 https://deb.debian.org/debian-security buster/updates/main amd64 Packages
        100 /var/lib/dpkg/status
 



ps: version de buster a jour sur ma machine

Dernière modification par robert2a (17-02-2021 04:51:31)

Hors ligne

#20 18-02-2021 03:51:15

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Hello,

J'ai fait un apt clean.

Concernant aptitude, il n'est pas installé chez moi. Et je suis bloqué, je n'arrive pas à l'installer car il essaie de mettre à jour nvidia-legacy-check avant ça (qui bloque tout).

Pour la simulation:

apt-get -s autoremove --purge bumblebee bumblebee-nvidia primus nvidia* xserver-xorg-video-nvidia


Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Le paquet « nvidia-egl-wayland-common » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-304xx-vdpau-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-prime » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-libopencl1-dev » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-current » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-current-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-tesla-alternative » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-glx » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-libs-i386 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-libs-nonglvnd-i386 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-tesla-418-nonglvnd-vulkan-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-tesla-440-opencl-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-tesla-418-opencl-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-tesla-440-vulkan-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-tesla-418-vulkan-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-driver-libs-i386 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-driver-libs-i386 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-driver-libs-nonglvnd-i386 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-304xx-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-304xx-kernel-dkms » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-binary » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-304 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-304-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-304 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-310 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-310-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-310 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-313 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-313-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-313 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-319 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-319-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-319 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-325 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-325-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-325 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-331 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-331-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-331 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-334 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-334-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-334 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-337 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-337-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-337 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-340 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-340-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-340 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-343 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-343-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-343 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-346 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-346-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-346 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-349 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-349-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-349 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-352 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-352-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-352 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-355 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-355-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-355 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-358 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-358-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-358 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-361 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-361-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-361 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-364 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-364-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-364 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-367 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-367-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-367 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-375 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-375-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-375 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-378 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-378-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-378 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-381 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-381-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-381 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-384 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-384-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-384 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-387 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-387-updates » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-experimental-387 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-390 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-410 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-alternative-legacy-173xx » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-alternative-legacy-71xx » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-alternative-legacy-96xx » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-304xx-alternative » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cg-dev » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cg-doc » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cg-toolkit » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cuda-dev » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cuda-doc » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cuda-gdb » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cuda-toolkit » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-nsight » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-opencl-dev » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-openjdk-8-jre » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-profiler » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-visual-profiler » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-cuda-mps » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-detect » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-bin » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-libs » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-driver-libs-nonglvnd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-egl-common » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-egl-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-kernel-dkms » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-kernel-source » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-libopencl1 » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-nonglvnd-vulkan-common » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-nonglvnd-vulkan-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-opencl-common » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-opencl-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-smi » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-vdpau-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-vulkan-common » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-vulkan-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-alternative » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-driver-bin » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-driver-libs » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-kernel-dkms » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-kernel-source » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-kernel-support » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-opencl-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-smi » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-340xx-vdpau-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-driver-bin » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-driver-libs » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-driver-libs-nonglvnd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-egl-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-kernel-source » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-nonglvnd-vulkan-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-opencl-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-smi » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-vdpau-driver » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-legacy-390xx-vulkan-icd » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-persistenced » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-settings » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-settings-legacy-340xx » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-settings-legacy-390xx » n'est pas installé, et ne peut donc être supprimé
Le paquet « nvidia-xconfig » n'est pas installé, et ne peut donc être supprimé
Les paquets suivants seront ENLEVÉS :
  bbswitch-dkms* bumblebee* bumblebee-nvidia* dkms* glx-alternative-mesa*
  glx-alternative-nvidia* glx-diversions* libgles1* libnvidia-cbl*
  libnvidia-eglcore* libnvidia-fatbinaryloader* libnvidia-glcore*
  libnvidia-glvkspirv* libnvidia-ptxjitcompiler1* libnvidia-rtcore*
  libxnvctrl0* linux-headers-4.19.0-12-amd64* linux-headers-4.19.0-12-common*
  linux-image-4.19.0-12-amd64* nvidia-alternative* nvidia-installer-cleanup*
  nvidia-kernel-common* nvidia-kernel-support*
  nvidia-legacy-390xx-alternative* nvidia-legacy-390xx-kernel-dkms*
  nvidia-legacy-390xx-kernel-support* nvidia-legacy-check* nvidia-modprobe*
  nvidia-support* primus* primus-libs* socat* sudo* update-glx*
  xserver-xorg-video-nvidia*
0 mis à jour, 0 nouvellement installés, 35 à enlever et 20 non mis à jour.
1 partiellement installés ou enlevés.
Purg nvidia-legacy-check [418.152.00-1]
Purg primus [0~20150328-7]
Purg bumblebee-nvidia [3.2.1-20]
Purg bumblebee [3.2.1-20]
Purg bbswitch-dkms [0.8-8]
Purg nvidia-legacy-390xx-kernel-dkms [390.141-2~deb10u1]
Purg dkms [2.6.1-4]
Purg nvidia-legacy-390xx-kernel-support [390.141-2~deb10u1]
Purg nvidia-legacy-390xx-alternative [390.141-2~deb10u1]
Purg glx-alternative-nvidia [1.0.0]
Purg glx-diversions [1.0.0]
Purg glx-alternative-mesa [1.0.0]
Purg libgles1 [1.1.0-1]
Purg libnvidia-cbl [418.152.00-1]
Purg libnvidia-eglcore [418.181.07-1]
Purg libnvidia-fatbinaryloader [418.152.00-1]
Purg libnvidia-glcore [418.181.07-1]
Purg libnvidia-glvkspirv [418.181.07-1]
Purg libnvidia-ptxjitcompiler1 [418.152.00-1]
Purg libnvidia-rtcore [418.152.00-1]
Purg libxnvctrl0 [418.74-1]
Purg linux-headers-4.19.0-12-amd64 [4.19.152-1]
Purg linux-headers-4.19.0-12-common [4.19.152-1]
Purg linux-image-4.19.0-12-amd64 [4.19.152-1]
Purg nvidia-alternative
Purg nvidia-installer-cleanup [20151021+9]
Purg nvidia-kernel-common [20151021+9]
Purg nvidia-kernel-support
Purg nvidia-modprobe [418.56-1]
Purg nvidia-support [20151021+9]
Purg primus-libs [0~20150328-7]
Purg socat [1.7.3.2-2]
Purg sudo [1.8.27-1+deb10u3]
Purg update-glx [1.0.0]
Purg xserver-xorg-video-nvidia



Il m'enlève sudo dedans, c'est bizarre ça (mais pas grave en soi vu que je ne l'utilise pas).

apt policy linux-image-amd64 linux-headers-amd64



linux-image-amd64:
  Installé : 4.19+105+deb10u9
  Candidat : 4.19+105+deb10u9
 Table de version :
     5.9.15-1~bpo10+1 100
        100 http://deb.debian.org/debian buster-backports/main amd64 Packages
 *** 4.19+105+deb10u9 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
        100 /var/lib/dpkg/status
linux-headers-amd64:
  Installé : 4.19+105+deb10u9
  Candidat : 4.19+105+deb10u9
 Table de version :
     5.9.15-1~bpo10+1 100
        100 http://deb.debian.org/debian buster-backports/main amd64 Packages
 *** 4.19+105+deb10u9 500
        500 https://deb.debian.org/debian buster/main amd64 Packages
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
 


MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#21 18-02-2021 20:29:43

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonsoir
tente la commande en vrai


apt-get autoremove --purge bumblebee bumblebee-nvidia primus nvidia* xserver-xorg-video-nvidia
 



si correct un update


apt update
 



pour un paquet désinstallé comme "sudo" tu peu le réinstaller sans souci


apt-get autoremove --purge
 




apt-get dist-upgrade
 


il te faut réinstaller bumblebee-nvidia


apt-get -s --reinstall install bumblebee bumblebee-nvidia primus libglx-nvidia0
 



et la tu peu redémarrer

remarque :
voila pour moi le retour en simulation


apt-get -s --reinstall install bumblebee bumblebee-nvidia primus libglx-nvidia0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets supplémentaires suivants seront installés :
  bbswitch-dkms glx-alternative-mesa glx-alternative-nvidia glx-diversions libegl-nvidia0 libegl-nvidia0:i386 libgl1-nvidia-glvnd-glx libgl1-nvidia-glvnd-glx:i386 libgles-nvidia1
  libgles-nvidia1:i386 libgles-nvidia2 libgles-nvidia2:i386 libgles1 libgles1:i386 libgles2:i386 libglx-nvidia0:i386 libnvidia-cbl libnvidia-cfg1 libnvidia-eglcore libnvidia-eglcore:i386
  libnvidia-glcore libnvidia-glcore:i386 libnvidia-glvkspirv libnvidia-glvkspirv:i386 libnvidia-ml1 libnvidia-rtcore libopengl0 libopengl0:i386 libprimus-vk1 libprimus-vk1:i386 libxnvctrl0
  nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-driver-libs:i386 nvidia-egl-common nvidia-egl-icd nvidia-egl-icd:i386 nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-kernel-support nvidia-legacy-check nvidia-modprobe nvidia-persistenced nvidia-primus-vk-common nvidia-primus-vk-wrapper
  nvidia-primus-vk-wrapper:i386 nvidia-settings nvidia-support nvidia-vdpau-driver nvidia-vulkan-common nvidia-vulkan-icd nvidia-vulkan-icd:i386 primus-libs primus-libs:i386
  xserver-xorg-video-nvidia
Paquets suggérés :
  vulkan-utils vulkan-utils:i386 primus-nvidia
 



ps: j'ai le "i386" installé pour Steam (sur un pc de bureau sans carte nvidia )  smile   et le test sur bullseye donc ne tien pas compte des versions (toi en buster )

Hors ligne

#22 20-02-2021 14:43:03

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Ça a fonctionné pour la désinstallation et réinstallation ! (mais j'ai quelques messages d'erreurs dans le journalctl et je dois encore tester pour lancer les appli avec optirun pour lequel j'ai un message d'erreur également avec glxinfo)
J'ai donc d'abord fait la commande:

apt-get autoremove --purge bumblebee bumblebee-nvidia primus nvidia* xserver-xorg-video-nvidia




mais nvidia-legacy-check n'avait quand même pas voulu se désinstaller tout de suite, j'ai dû faire un

apt --fix-broken install




puis j'ai refait à nouveau la commande

apt-get autoremove --purge bumblebee bumblebee-nvidia primus nvidia* xserver-xorg-video-nvidia



Puis update, puis réinstallation des paquets mentionnés dans le post précédent.


Un:

journalctl -r -p err



-- Logs begin at Sat 2021-02-20 13:18:59 CET, end at Sat 2021-02-20 13:31:07 CET. --
fév 20 13:28:33 Antidentity kernel: nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
fév 20 13:28:33 Antidentity kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
fév 20 13:28:33 Antidentity kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 6013d4 [ IBUS ]
fév 20 13:19:00 Antidentity bluetoothd[668]: sap-server: Operation not permitted (1)
fév 20 13:19:00 Antidentity bluetoothd[668]: Sap driver initialization failed.
fév 20 13:18:59 Antidentity kernel: Bluetooth: hci0: unexpected event for opcode 0xfc2f
fév 20 13:18:59 Antidentity kernel: snd_hda_intel 0000:01:00.1: no codecs initialized
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D7: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D6: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D5: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D4: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D3: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D2: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D1: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: hdaudio hdaudioC1D0: no AFG or MFG node found
fév 20 13:18:59 Antidentity kernel: pci 0000:01:00.1: BAR 0: error updating (0xdf080000 != 0xffffffff)
 



dmesg | grep drm



[    1.257183] fb: switching to inteldrmfb from EFI VGA
[    1.257340] [drm] Replacing VGA console driver
[    1.258791] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    1.258791] [drm] Driver supports precise vblank timestamp query.
[    1.259766] [drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)
[    1.543427] [drm] Initialized i915 1.6.0 20180719 for 0000:00:02.0 on minor 0
[    1.579029] fbcon: inteldrmfb (fb0) is primary device
[    2.736146] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    4.097213] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    4.097215] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
[    4.805257] [drm] [nvidia-drm] [GPU ID 0x00000100] Unloading driver
[  579.070507] [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 1
 



glxinfo -B



name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)  (0x191b)
    Version: 18.3.6
    Accelerated: yes
    Video memory: 3072MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.3.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.3.6
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20




optirun glxinfo -B



primus: fatal: failed to load any of the libraries: /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1:/usr/lib/i386-linux-gnu/nvidia/libGL.so.1:/usr/lib/nvidia/libGL.so.1
/usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/i386-linux-gnu/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
 

Dernière modification par Antidentity (20-02-2021 15:00:05)


MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

#23 22-02-2021 11:48:48

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

Bonjour
moi ce que je constate


fév 20 13:28:33 Antidentity kernel: nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
fév 20 13:28:33 Antidentity kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
fév 20 13:28:33 Antidentity kernel: nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 6013d4 [ IBUS ]
 



nouveau ne devrait pas être charger par le noyau

pour intel c'est correct

pour nvidia il y a bien un souci


primus: fatal: failed to load any of the libraries: /usr/lib/x86_64-linux-gnu/nvidia/libGL.so.1
 



je sais pas pourquoi  hmm 

par contre tu a mit a jour buster  ?  c'est correct maintenant ?

ps: pour la commande "bumblebee-nvidia" une erreur peut être


apt-get install bumblebee bumblebee-nvidia primus libglx-nvidia0
 



si debian buster est a jour tu peu refaire l'installation de bumblebee-nvidia

bien purger l'ancien et recommencer

ps: pendant l'installation sûrement des messages d'erreur

Hors ligne

#24 20-03-2021 09:19:11

Antidentity
Membre
Distrib. : See signature
Noyau : Linux amd64
(G)UI : Openbox
Inscription : 03-08-2016

Re : upgrade bloqué par nvidia_legacy_check_418.181.07-1

robert2a a écrit :

par contre tu a mit a jour buster  ?  c'est correct maintenant ?


Oui, pour les mises à jour, c'est correct maintenant, merci !

Par contre, quand je lance la commande optirun, cela m'indique ceci:

optirun chromium --incognito


[10362.913358] [ERROR]You've no permission to communicate with the Bumblebee daemon. Try adding yourself to the 'bumblebee' group
[10362.913375] [ERROR]Could not connect to bumblebee daemon - is it running?



edit1: je me suis rajouté au groupe bumblebee mais le souci persiste

edit2:

optirun -vv --debug bash
 


[ 1212.525760] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[ 1212.526624] [DEBUG]optirun version 3.2.1 starting...
[ 1212.526650] [DEBUG]Active configuration:
[ 1212.526653] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1212.526677] [DEBUG] X display: :8
[ 1212.526679] [DEBUG] LD_LIBRARY_PATH: /usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
[ 1212.526681] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1212.526683] [DEBUG] Accel/display bridge: auto
[ 1212.526685] [DEBUG] VGL Compression: proxy
[ 1212.526709] [DEBUG] VGLrun extra options:
[ 1212.526711] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
[ 1212.526944] [DEBUG]Using auto-detected bridge primus
[ 1214.302025] [INFO]Response: Yes. X is active.

[ 1214.302038] [INFO]Running application using primus.
[ 1214.302162] [DEBUG]Process bash started, PID 2356.


Je vais explorer la piste du fichier de configuration. Peut-être le supprimer ou supprimer le socket (/var/run/bumblebee.socket). Je cherche des infos avant ça.

Dernière modification par Antidentity (20-03-2021 09:54:12)


MSI GE 6QD Apache Pro (Nvidia GTX 960M) - Debian Buster - Openbox / Windows10
Samsung - Debian Stretch - Openbox / Windows10

Hors ligne

Pied de page des forums