Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-02-2021 18:48:13

Che0njiwang
Membre
Inscription : 07-02-2021

[RESOLU] Packet tracer 8 Debian 10 et virtualbox

Bonjour

J'ai un soucis avec l'instalation de packet tracer 8 sur une machine virtuel Débian 10.

J'ai téléchargé Packet Tracer 8 depuis le site (https://www.netacad.com/portal/resource … c40d38d550).

Pour l'installation j'ai fait :

sudo apt update


sudo apt upgrade


sudo dpkg -i PacketTracer_800_amd64_build212_final.deb


sudo apt install -f



packettracer


Starting Packet Tracer 8.0.0



Mais rien ne se passe. Et pareil si je lance le logiciel depuis "Activité".

Merci par avance de votre aide

Bien cordialement

Dernière modification par Che0njiwang (05-03-2021 20:26:45)

Hors ligne

#2 25-02-2021 10:28:09

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Salut
dpkg -i ne gère pas les dépendances , il aurait fallu installer via apt (chemin complet vers le paquet deb) ou en graphique avec gdebi
les dépendances manquante sont

dialog libgl1-mesa-glx libxcb-xinerama0-dev



le script packettracer est sensé il me semble exporté la variable dans le PATH
essai de lancement apres avoir installé les dépendances manquante

/opt/pt/bin/PacketTracer



ne trouve pas certaine librairy partagé , apres avoir installé certain paquet manquant et fait quelque lien symbolique de /opt/pt/bin vers /lib/x86_64-linux-gnu/
j'arrive au résultat suivant

/opt/pt/bin/PacketTracer
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/pt/bin/PacketTracer)
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /opt/pt/bin/PacketTracer)
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /opt/pt/bin/PacketTracer)
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /lib/x86_64-linux-gnu/libQt5QmlModels.so.5)
/opt/pt/bin/PacketTracer: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /lib/x86_64-linux-gnu/libQt5ScriptTools.so.5)
 



Debian 10 n'a pas la bonne version

apt policy libqt5core5a


libqt5core5a:
  Installé : 5.11.3+dfsg1-1+deb10u4
  Candidat : 5.11.3+dfsg1-1+deb10u4
 Table de version :
 *** 5.11.3+dfsg1-1+deb10u4 500
        500 http://deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
     5.11.3+dfsg1-1+deb10u3 500
        500 http://deb.debian.org/debian-security buster/updates/main amd64 Packages
 


https://packages.debian.org/fr/bullseye/libqt5core5a

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
edit
Installation en VM sous Debian testing

apt install /media/stephane/deport/Téléchargements/PacketTracer_800_amd64_build212_final.deb


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « packettracer » au lieu de « /media/stephane/deport/Téléchargements/PacketTracer_800_amd64_build212_final.deb »
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  ibverbs-providers libboost-container1.67.0 libboost-context1.67.0 libboost-coroutine1.67.0 libboost-fiber1.67.0 libboost-graph-parallel1.67.0 libboost-graph1.67.0 libboost-log1.67.0 libboost-math1.67.0
  libboost-mpi1.67.0 libboost-numpy1.67-dev libboost-numpy1.67.0 libboost-program-options1.67.0 libboost-python1.67.0 libboost-random1.67.0 libboost-regex1.67.0 libboost-serialization1.67.0
  libboost-signals1.67.0 libboost-stacktrace1.67.0 libboost-test1.67.0 libboost-timer1.67.0 libboost-type-erasure1.67.0 libboost-wave1.67.0 libboost1.67-tools-dev libcdio18 libevent-core-2.1-7 libevent-dev
  libevent-extra-2.1-7 libevent-openssl-2.1-7 libevent-pthreads-2.1-7 libfabric1 libhwloc-dev libhwloc-plugins libhwloc15 libibverbs-dev libibverbs1 libjs-jquery libjs-jquery-ui libnfs12 libnl-3-dev
  libnl-route-3-dev libnuma-dev libopenmpi-dev libopenmpi3 libpmix-dev libpmix2 libpsm-infinipath1 libpsm2-2 librdmacm1 libucx0 libwxbase3.0-dev libwxgtk3.0-0v5 mpi-default-dev node-jquery openmpi-bin
  openmpi-common python-talloc wx-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  dialog libgl1-mesa-glx libxcb-xinerama0 libxcb-xinerama0-dev
Les NOUVEAUX paquets suivants seront installés :
  dialog libgl1-mesa-glx libxcb-xinerama0-dev packettracer
Les paquets suivants seront mis à jour :
  libxcb-xinerama0
1 mis à jour, 4 nouvellement installés, 0 à enlever et 951 non mis à jour.
Il est nécessaire de prendre 542 ko/184 Mo dans les archives.
Après cette opération, 1456 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://deb.debian.org/debian testing/main amd64 dialog amd64 1.3-20201126-1 [288 kB]
Réception de :2 http://deb.debian.org/debian testing/main amd64 libgl1-mesa-glx amd64 20.3.4-1 [51,1 kB]
Réception de :3 http://deb.debian.org/debian testing/main amd64 libxcb-xinerama0 amd64 1.14-3 [101 kB]
Réception de :4 http://deb.debian.org/debian testing/main amd64 libxcb-xinerama0-dev amd64 1.14-3 [102 kB]
Réception de :5 /media/stephane/deport/Téléchargements/PacketTracer_800_amd64_build212_final.deb packettracer amd64 8.0.0 [184 MB]
542 ko réceptionnés en 4s (140 ko/s)
Préconfiguration des paquets...
Sélection du paquet dialog précédemment désélectionné.
(Lecture de la base de données... 204916 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../dialog_1.3-20201126-1_amd64.deb ...
Dépaquetage de dialog (1.3-20201126-1) ...
Sélection du paquet libgl1-mesa-glx:amd64 précédemment désélectionné.                                                                                                                                            
Préparation du dépaquetage de .../libgl1-mesa-glx_20.3.4-1_amd64.deb ...                                                                                                                                          
Dépaquetage de libgl1-mesa-glx:amd64 (20.3.4-1) ...                                                                                                                                                              
Préparation du dépaquetage de .../libxcb-xinerama0_1.14-3_amd64.deb ...                                                                                                                                          
Dépaquetage de libxcb-xinerama0:amd64 (1.14-3) sur (1.14-2) ...                                                                                                                                                  
Sélection du paquet libxcb-xinerama0-dev:amd64 précédemment désélectionné.                                                                                                                                        
Préparation du dépaquetage de .../libxcb-xinerama0-dev_1.14-3_amd64.deb ...
Dépaquetage de libxcb-xinerama0-dev:amd64 (1.14-3) ...
Sélection du paquet packettracer précédemment désélectionné.
Préparation du dépaquetage de .../PacketTracer_800_amd64_build212_final.deb ...
Dépaquetage de packettracer (8.0.0) ...
Paramétrage de libxcb-xinerama0:amd64 (1.14-3) ...
Paramétrage de dialog (1.3-20201126-1) ...
Paramétrage de libgl1-mesa-glx:amd64 (20.3.4-1) ...
Paramétrage de libxcb-xinerama0-dev:amd64 (1.14-3) ...
Paramétrage de packettracer (8.0.0) ...
gtk-update-icon-cache: No theme index file.
Traitement des actions différées (« triggers ») pour libc-bin (2.31-4) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.3-2) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (2.0-1) ...
Traitement des actions différées (« triggers ») pour mailcap (3.67) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1) ...
 



/opt/pt/packettracer


Starting Packet Tracer 8.0.0

Dernière modification par Croutons (04-03-2021 20:24:28)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 27-02-2021 20:54:44

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Bonsoir Crouton

Tout d'abord merci pour toutes tes réponses et désolé pour le retard dans la réponse.

Après avoir posté j'avais installé toutes les dépendances manquante et aussi essayé de lancé le soft avec

/opt/pt/bin/PacketTracer


Mais avec le même résultat



En suite j'ai pas compris le passage sur les liens symbolique.

apt policy libqt5core5a



J'avais le même résultat que toi.

J'ai donc décidé de reprendre un snapshot avant l'installation de packet tracer car j'ai du faire des conneries.

J'essaye de réinstaller proprement et te dit se qu'il en est.

Encore merci

Edit :

Alors voici se que j'ai fais sur le nouveau snapshot

sudo apt update
sudo apt upgrade
reboot



sudo apt install libqt5core5a


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  libdouble-conversion1 libpcre2-16-0 qttranslations5-l10n
Les NOUVEAUX paquets suivants seront installés :
  libdouble-conversion1 libpcre2-16-0 libqt5core5a qttranslations5-l10n
0 mis à jour, 4 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 3685 ko dans les archives.
Après cette opération, 19,2 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de :1 http://deb.debian.org/debian buster/main amd64 libdouble-conver$
Réception de :2 http://deb.debian.org/debian buster/main amd64 libpcre2-16-0 am$
Réception de :3 http://deb.debian.org/debian buster/main amd64 libqt5core5a amd$
Réception de :4 http://deb.debian.org/debian buster/main amd64 qttranslations5-$
3685 ko réceptionnés en 1s (3746 ko/s)
Sélection du paquet libdouble-conversion1:amd64 précédemment désélectionné.
(Lecture de la base de données... 158518 fichiers et répertoires déjà installés$
Préparation du dépaquetage de .../libdouble-conversion1_3.1.0-3_amd64.deb ...
Dépaquetage de libdouble-conversion1:amd64 (3.1.0-3) ...
Sélection du paquet libpcre2-16-0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libpcre2-16-0_10.32-5_amd64.deb ...
Dépaquetage de libpcre2-16-0:amd64 (10.32-5) ...
Sélection du paquet libqt5core5a:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libqt5core5a_5.11.3+dfsg1-1+deb10u4_amd64.deb$
Dépaquetage de libqt5core5a:amd64 (5.11.3+dfsg1-1+deb10u4) ...
Sélection du paquet qttranslations5-l10n précédemment désélectionné.
Préparation du dépaquetage de .../qttranslations5-l10n_5.11.3-2_all.deb ...
Dépaquetage de qttranslations5-l10n (5.11.3-2) ...
Paramétrage de libpcre2-16-0:amd64 (10.32-5) ...
Paramétrage de qttranslations5-l10n (5.11.3-2) ...
Paramétrage de libdouble-conversion1:amd64 (3.1.0-3) ...
Paramétrage de libqt5core5a:amd64 (5.11.3+dfsg1-1+deb10u4) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
 



sudo apt install /home/shikyo/Téléchargements/PacketTracer_800_amd64_build212_final.deb


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Note : sélection de « packettracer » au lieu de « /home/shikyo/Téléchargements/PacketTracer_800_amd64_build212_$
Les paquets supplémentaires suivants seront installés :
  dialog libgl1-mesa-glx libpthread-stubs0-dev libxau-dev libxcb-xinerama0
  libxcb-xinerama0-dev libxcb1-dev libxdmcp-dev x11proto-core-dev x11proto-dev
  xorg-sgml-doctools
Paquets suggérés :
  libxcb-doc
Les NOUVEAUX paquets suivants seront installés :
  dialog libgl1-mesa-glx libpthread-stubs0-dev libxau-dev libxcb-xinerama0
  libxcb-xinerama0-dev libxcb1-dev libxdmcp-dev packettracer x11proto-core-dev
  x11proto-dev xorg-sgml-doctools
0 mis à jour, 12 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1040 ko/185 Mo dans les archives.
Après cette opération, 3992 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] OO
Réception de :1 http://deb.debian.org/debian buster/main amd64 dialog amd64 1.3-20190211-1 [274 kB]
Réception de :2 http://deb.debian.org/debian buster/main amd64 libgl1-mesa-glx amd64 18.3.6-2+deb10u1 [47,4 kB]
Réception de :3 http://deb.debian.org/debian buster/main amd64 libpthread-stubs0-dev amd64 0.4-1 [5344 B]
Réception de :4 http://deb.debian.org/debian buster/main amd64 xorg-sgml-doctools all 1:1.11-1 [21,9 kB]
Réception de :5 http://deb.debian.org/debian buster/main amd64 x11proto-dev all 2018.4-4 [251 kB]
Réception de :6 http://deb.debian.org/debian buster/main amd64 x11proto-core-dev all 2018.4-4 [3128 B]
Réception de :7 http://deb.debian.org/debian buster/main amd64 libxau-dev amd64 1:1.0.8-1+b2 [23,1 kB]
Réception de :8 http://deb.debian.org/debian buster/main amd64 libxcb-xinerama0 amd64 1.13.1-2 [98,9 kB]
Réception de :9 http://deb.debian.org/debian buster/main amd64 libxdmcp-dev amd64 1:1.1.2-3 [42,2 kB]
Réception de :10 http://deb.debian.org/debian buster/main amd64 libxcb1-dev amd64 1.13.1-2 [174 kB]
Réception de :11 http://deb.debian.org/debian buster/main amd64 libxcb-xinerama0-dev amd64 1.13.1-2 [99,6 kB]
Réception de :12 /home/shikyo/Téléchargements/PacketTracer_800_amd64_build212_final.deb packettracer amd64 8.0.$
1040 ko réceptionnés en 2s (683 ko/s)
Préconfiguration des paquets...
Sélection du paquet dialog précédemment désélectionné.
(Lecture de la base de données... 158832 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-dialog_1.3-20190211-1_amd64.deb ...
Dépaquetage de dialog (1.3-20190211-1) ...
Sélection du paquet libgl1-mesa-glx:amd64 précédemment désélectionné.
Sélection du paquet libpthread-stubs0-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../02-libpthread-stubs0-dev_0.4-1_amd64.deb ...
Dépaquetage de libpthread-stubs0-dev:amd64 (0.4-1) ...
Sélection du paquet xorg-sgml-doctools précédemment désélectionné.
Préparation du dépaquetage de .../03-xorg-sgml-doctools_1%3a1.11-1_all.deb ...
Dépaquetage de xorg-sgml-doctools (1:1.11-1) ...
Sélection du paquet x11proto-dev précédemment désélectionné.
Préparation du dépaquetage de .../04-x11proto-dev_2018.4-4_all.deb ...
Dépaquetage de x11proto-dev (2018.4-4) ...
Sélection du paquet x11proto-core-dev précédemment désélectionné.
Préparation du dépaquetage de .../05-x11proto-core-dev_2018.4-4_all.deb ...
Dépaquetage de x11proto-core-dev (2018.4-4) ...
Sélection du paquet libxau-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../06-libxau-dev_1%3a1.0.8-1+b2_amd64.deb ...
Dépaquetage de libxau-dev:amd64 (1:1.0.8-1+b2) ...
Sélection du paquet libxcb-xinerama0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../07-libxcb-xinerama0_1.13.1-2_amd64.deb ...
Dépaquetage de libxcb-xinerama0:amd64 (1.13.1-2) ...
Sélection du paquet libxdmcp-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../08-libxdmcp-dev_1%3a1.1.2-3_amd64.deb ...
Dépaquetage de libxdmcp-dev:amd64 (1:1.1.2-3) ...
Sélection du paquet libxcb1-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../09-libxcb1-dev_1.13.1-2_amd64.deb ...
Dépaquetage de libxcb1-dev:amd64 (1.13.1-2) ...
Sélection du paquet libxcb-xinerama0-dev:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../10-libxcb-xinerama0-dev_1.13.1-2_amd64.deb ...
Dépaquetage de libxcb-xinerama0-dev:amd64 (1.13.1-2) ...
Sélection du paquet packettracer précédemment désélectionné.
Préparation du dépaquetage de .../11-PacketTracer_800_amd64_build212_final.deb ...
Dépaquetage de packettracer (8.0.0) ...
Paramétrage de libpthread-stubs0-dev:amd64 (0.4-1) ...
Paramétrage de libxcb-xinerama0:amd64 (1.13.1-2) ...
Paramétrage de dialog (1.3-20190211-1) ...
Paramétrage de libgl1-mesa-glx:amd64 (18.3.6-2+deb10u1) ...
Paramétrage de xorg-sgml-doctools (1:1.11-1) ...
Paramétrage de x11proto-dev (2018.4-4) ...
Paramétrage de libxau-dev:amd64 (1:1.0.8-1+b2) ...
Paramétrage de libxdmcp-dev:amd64 (1:1.1.2-3) ...
Paramétrage de x11proto-core-dev (2018.4-4) ...
Paramétrage de libxcb1-dev:amd64 (1.13.1-2) ...
Paramétrage de libxcb-xinerama0-dev:amd64 (1.13.1-2) ...
Paramétrage de packettracer (8.0.0) ...
gtk-update-icon-cache: No theme index file.
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.31.4-3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Traitement des actions différées (« triggers ») pour shared-mime-info (1.10-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
 



sudo reboot



sudo /opt/pt/packettracer


-> rien comme la dernière fois

sudo /opt/pt/bin/PacketTracer


/opt/pt/bin/PacketTracer: error while loading shared libraries: libQt5Multimedia.so.5: cannot open shared object file: No such file or directory



J'ai pas compris quelque chose ?

Dernière modification par Che0njiwang (27-02-2021 21:23:25)

Hors ligne

#4 27-02-2021 23:18:52

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

En cherchant a comprendre se qu'étais les liens symbolique je suis tombé sur la commande ldd qui permet de voir les dépendance manquante si j'ai bien compris.

Je fais donc

ldd /opt/pt/bin/PackerTracer | grep not


/opt/pt/bin/PackerTracer: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/pt/bin/PackerTracer)
/opt/pt/bin/PackerTracer: /lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /opt/pt/bin/PackerTracer)
/opt/pt/bin/PackerTracer: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by /opt/pt/bin/PackerTracer)
  libQt5QmlModels.so.5 => not found
 



J'ai corrigé pas mal de ligne du type "xxx => not found" en installant les paquets manuellement, mais je n'arrive pas installer les dernier paquets. Ces paquets semble être installé mais packettracer ne les trouves pas ?

Hors ligne

#5 28-02-2021 08:15:15

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

hello
pour résumé il te faut avoir Debian 11 pour cette version de PacketTracer
la testing est en phase de freeze et sera bientôt la nouvelle version stable
d’ailleurs je crois bien que les dépôts bullseyes (Debian 11) sont déjà disponible

Dernière modification par Croutons (28-02-2021 08:16:04)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 28-02-2021 10:41:41

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Ok je vais me renseigner sur le passage a la version 11 merci smile

Je comprend quand même toujours pas pourquoi j'ai des packets installé mais non "reconnu" T_T Il faut faire des liens symbolique ?

Dernière modification par Che0njiwang (28-02-2021 10:51:09)

Hors ligne

#7 28-02-2021 12:07:24

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

non avec Debian 11 y'a aucun message d'erreur et l’icône de lancement fonctionne bien

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 01-03-2021 20:51:33

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Bonsoir.

J'ai téléchargé et créer une nouvelle machine virtuelle avec la version Debian 11 Bullseye Alpha 3 et quand je veux faire l'installation de packet tracer j'ai cette erreur

sudo apt install /home/shikyo/Téléchargements/PacketTracer_800_amd64_build212_final.deb


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Note : sélection de « packettracer » au lieu de « /home/shikyo/Téléchargements/PacketTracer_800_amd64_build212_final.deb »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 packettracer : Dépend: libxcb-xinerama0-dev mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Je vais jamais pouvoir l'utiliser ce soft sos.gif

J'ai pas du prendre la bonne version de débian ?

cat /proc/version


Linux version 5.9.0-4-amd64 (debian-kernel@lists.debian.org) (gcc-10 (Debian 10.2.0-19) 10.2.0, GNU ld (GNU Binutils for Debian) 2.35.1) #1 SMP Debian 5.9.11-1 (2020-11-27)

Dernière modification par Che0njiwang (01-03-2021 20:53:19)

Hors ligne

#9 02-03-2021 09:07:22

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

etrange pourtant le paquet existe dans les dépots
que donne

apt policy libxcb-xinerama0-dev



as tu fais un

sudo apt update


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 02-03-2021 18:12:48

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Bonsoir Crouton

Encore merci pour ton aide, c'est très sympa de ta part.

sudo apt update


Ign :1 cdrom://[Debian GNU/Linux bullseye-DI-alpha3 _Bullseye_ - Official Snapshot amd64 DVD Binary-1 20201203-12:51] bullseye InRelease
Err :2 cdrom://[Debian GNU/Linux bullseye-DI-alpha3 _Bullseye_ - Official Snapshot amd64 DVD Binary-1 20201203-12:51] bullseye Release
  Veuillez utiliser apt-cdrom afin de faire reconnaître ce cédérom par votre APT. apt-get update ne peut être employé pour ajouter de nouveaux cédéroms
Réception de :3 [url]http://security.debian.org/debian-security[/url] bullseye-security InRelease [44,1 kB]
Lecture des listes de paquets... Fait
E: Le dépôt cdrom://[Debian GNU/Linux bullseye-DI-alpha3 _Bullseye_ - Official Snapshot amd64 DVD Binary-1 20201203-12:51] bullseye Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.



A priori j'ai un problème avec mon fichier source.list ?

cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux bullseye-DI-alpha3 _Bullseye_ - Official Snapshot amd64 DVD Binary-1 20201203-12:51]/ bullseye contrib main

deb cdrom:[Debian GNU/Linux bullseye-DI-alpha3 _Bullseye_ - Official Snapshot amd64 DVD Binary-1 20201203-12:51]/ bullseye contrib main

deb [url]http://security.debian.org/debian-security[/url] bullseye-security main contrib
deb-src [url]http://security.debian.org/debian-security[/url] bullseye-security main contrib
 



sudo apt policy libxcb-xinerama0-dev


N: Impossible de trouver le paquet libxcb-xinerama0-dev



Il faut que j'essaye d'installer manuellement le paquet ?

Dernière modification par Che0njiwang (02-03-2021 18:14:26)

Hors ligne

#11 03-03-2021 20:19:06

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Bonsoir
Il te faut commenter la ligne  cdrom en mettant # en début de ligne
le fichier sources.list doit etre

# deb cdrom:[Debian GNU/Linux bullseye-DI-alpha3 _Bullseye_ - Official Snapshot amd64 DVD Binary-1 20201203-12:51]/ bullseye contrib main
deb http://ftp.fr.debian.org/debian/ bullseye main contrib non-free
deb http://security.debian.org/debian-security bullseye-security main contrib



Pour l'éditer

sudo apt edit-sources


avec nano  une fois les lignes modifier Ctrl+x pour quitter , sauvegarder en quittant

mise à jour

sudo apt update


sudo apt upgrade

Dernière modification par Croutons (04-03-2021 09:08:15)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#12 04-03-2021 19:10:08

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Bonsoir Crouton

Encore merci pour ta réponse. J'ai refait une installation pour régler le problème des update et des upgrade.

Par contre j'ai toujours exactement le même problème après l'installation de PacketTracer avec un update et upgrade fait.

Je te met l'historique complet des commandes que j'ai utilisé :

history


    1  ls
    2  sudo apt update
    3  sudo apt upgrade
    4  cp VBoxLinuxAdditions.run /home/shikyo/Bureau/
    5  cd /home/shikyo/Bureau/
    6  sudo ./VBoxLinuxAdditions.run [b](Oubli d'installer dkms)[/b]
    7  sudo apt update
    8  sudo apt upgrade
    9  cd /home/shikyo/b
   10  cd /home/shikyo/Bureau/
   11  ls
   12  sudo ./VBoxLinuxAdditions.run [b](Oubli d'installer dkms 2 !!!)[/b]
   13  apt install dkms
   14  sudo apt install dkms [b](Enfin)[/b]
   15  sudo ./VBoxLinuxAdditions.run
   16  reboot
   17  sudo reboot
   18  ls
   19  cd Documents/
   20  nano
   21  sudo apt update
   22  sudo apt upgrade
   23  sudo apt install /home/shikyo/Téléchargements/PacketTracer_800_amd64_build212_final.deb
   24  cd ../../..
   25  ls
   26  cd opt/pt/
   27  ls
   28  ./packettracer
   29  ldd ./packettracer
   30  packettracer
   31  cat /etc/apt/sources.list
   32  ldd packettracer
   33  ldd /opt/pt/bin/PacketTracer
   34  apt policy libxcb-xinerama0-dev
   35  sudo apt edit-sources
   36  history
 



Je vois pas se que je fais de mal.

Dernière modification par Che0njiwang (04-03-2021 19:10:20)

Hors ligne

#13 04-03-2021 20:36:06

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Che0njiwang a écrit :

J'ai refait une installation pour régler le problème des update et des upgrade.


Je comprend pas pourquoi avoir réinstallé

du coup il y a eu des messages d'erreur ou tout c'est bien déroulé?


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#14 04-03-2021 20:53:27

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Croutons a écrit :

Che0njiwang a écrit :

J'ai refait une installation pour régler le problème des update et des upgrade.


Je comprend pas pourquoi avoir réinstallé



J'ai réinstallé car le temps que je trouve comment régler le problème sa m'aurait pris plus de temps que de faire une nouvelle install.

Croutons a écrit :

du coup il y a eu des messages d'erreur ou tout c'est bien déroulé?



Non aucun message d'erreur.

Hors ligne

#15 05-03-2021 09:41:02

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

réinstallation avec la même ISO?
y'a quoi maintenant comme sources.list?

cat /etc/apt/sources.list



dans l'historique des commandes a priori rien de délirant , mais vu que je n'ai pas le retour des commandes , et que je ne sais pas se qui a été fait avec les commandes qui attente une action de ta par , c'est un peu compliqué de dire ou cela coince
le soucis quand tu réinstalles faut reprendre a zéro donc question gain de temps c'est pas gagné sad

Dernière modification par Croutons (05-03-2021 12:15:23)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#16 05-03-2021 14:15:07

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Croutons a écrit :

réinstallation avec la même ISO?


Oui avec "debian-bullseye-DI-alpha3-amd64-netinst"

uname -a


Linux debian 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux



Croutons a écrit :

y'a quoi maintenant comme sources.list?

cat /etc/apt/sources.list


cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 10.8.0 _Buster_ - Official amd64 NETINST 20210206-10:34]/ buster main

#deb cdrom:[Debian GNU/Linux 10.8.0 _Buster_ - Official amd64 NETINST 20210206-10:34]/ buster main

deb http://deb.debian.org/debian/ buster main
deb-src http://deb.debian.org/debian/ buster main

deb http://security.debian.org/debian-security buster/updates main
deb-src http://security.debian.org/debian-security buster/updates main

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main
deb-src http://deb.debian.org/debian/ buster-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 



Croutons a écrit :

dans l'historique des commandes a priori rien de délirant , mais vu que je n'ai pas le retour des commandes , et que je ne sais pas se qui a été fait avec les commandes qui attente une action de ta par , c'est un peu compliqué de dire ou cela coince


Est que l'on peut avoir l'historique des retour ?

Croutons a écrit :

le soucis quand tu réinstalles faut reprendre a zéro donc question gain de temps c'est pas gagné sad


Oups désolé

Hors ligne

#17 05-03-2021 15:13:16

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Tu as le pourquoi du comment dans ton sources.list tu as réinstallé une Debian 10 buster
hors on sait que cette version du logiciel ne fonctionne pas avec buster sad

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#18 05-03-2021 20:05:49

Che0njiwang
Membre
Inscription : 07-02-2021

Re : [RESOLU] Packet tracer 8 Debian 10 et virtualbox

Mais quel C.....N !!!

Comment j'ai fait pour pas m'en rendre compte !!!

packettracer.png

Désolé pour la perte de temps et un grand merci Crouton. Sans toi j'aurais sans doute jamais trouvé big_smile

Hors ligne

Pied de page des forums