Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-02-2021 17:08:52

naute
Membre
Lieu : Bretagne
Distrib. : Debian GNU-Linux Stretch 9.5
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.16.2
Inscription : 24-03-2018

[VirtualBox] Écran noir en fin de démarrage

Bonjour smile .

Quand je lance ma machine virtuelle, configurée pour s'afficher en plein-écran au démarrage, tout se passe bien jusqu'à la demande de mot de passe inclue, mais après validation de celui-ci, mon écran reste vide (noir), à l'exception de l'affichage du curseur de la souris qui, pour info, est bien celui de l'invité.

Ma solution actuelle est de passer en mode fenêtré avec un <HOST-F> puis de repasser en mode plein-écran, à nouveau avec un <HOST-F>. Ça prend deux secondes, ce n'est pas le problème, mais ça fait touriste.

Contexte :
   - hôte : Debian 9 ;
   - invité : Debian 10 ;
   - VirtualBox 6.1.12 (avec toutes les options).

Quelqu'un aurait-il une idée à ce sujet ?

Merci d'avance.

Amicalement,
naute

PS : je ne savais pas trop où poster ce sujet (Mate, Système...?). Merci de le déplacer si besoin ou de me dire où je dois le poster.

Dernière modification par naute (28-02-2021 17:10:45)

Hors ligne

#2 28-02-2021 20:06:00

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [VirtualBox] Écran noir en fin de démarrage

Salut,

(ah tiens, t'es aussi là, toi ? big_smile)

naute a écrit :

Quand je lance ma machine virtuelle, configurée pour s'afficher en plein-écran au démarrage, tout se passe bien jusqu'à la demande de mot de passe inclue, mais après validation de celui-ci, mon écran reste vide (noir), à l'exception de l'affichage du curseur de la souris qui, pour info, est bien celui de l'invité

Et si tu essayais une autre config, juste pour voir ?
Et, just curious, on peut changer l'affichage du curseur ? Explique, en deux mots…

naute a écrit :

mais ça fait touriste.

Bienvenue au club.
Je me tue à répéter que tout se déglingue, mais rien ne change et ça continue à se déglinguer... sad

naute a écrit :

Quelqu'un aurait-il une idée à ce sujet ?

Faudrait voir les logs de /var/log/Xorg.0.log, pour commencer…

À pluche,

EDIT : typo corrigée /EDIT

Dernière modification par jpt (01-03-2021 11:25:45)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#3 28-02-2021 20:25:07

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [VirtualBox] Écran noir en fin de démarrage

jpt a écrit :

Je me tue à répéter que tout se déglingue, mais rien ne change et ça continue à se déglinguer


ta oublié les balises [troll][/troll]
woohoo.gif

naute a écrit :

- VirtualBox 6.1.12 (avec toutes les options).


guestadditions installé sur la VM?
https://download.virtualbox.org/virtualbox/6.1.12/

Dernière modification par Croutons (01-03-2021 10:12:35)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#4 01-03-2021 11:20:30

naute
Membre
Lieu : Bretagne
Distrib. : Debian GNU-Linux Stretch 9.5
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.16.2
Inscription : 24-03-2018

Re : [VirtualBox] Écran noir en fin de démarrage

Bonjour smile .

jpt a écrit :

ah tiens, t'es aussi là, toi ? big_smile


Ben vi ! big_smile

jpt a écrit :

Et si tu essayais une autre config, juste pour voir ?


Ben non ! lol
Si je vais chez mon garagiste parce-que ma 4L est en panne et qu'il me dit d'acheter une 2CV, je dis "Ben non ! J'veux qu'on répare ma 4L".

jpt a écrit :

Et, just curious, on peut changer l'affichage du curseur ? Explique, en deux mots…


Je ne suis pas sûr de comprendre ce que tu veux. Je ne fais allusion au curseur de la souris que pour préciser qu'à ce moment-là mon interface graphique est, à priori, bien chargée avec le thème choisi, puisqu'il s'agit du bon curseur, et que la souris est bien capturée.

jpt a écrit :

Je me tue à répéter que tout se déglingue, mais rien ne change et ça continue à se déglinguer... sad


À commencer par moi, mais je ne peux rien y faire old_geek.gif.

jpt a écrit :

Faudrait voir les logs de /var/log/0/Xorg.log, pour commencer…


Alors je n'ai pas de /var/log/0/Xorg.log, mais j'ai un /var/log/Xorg.0.log (problème de dyslexie, peut-être lol) dont voici le contenu :


[    39.767]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[    39.767] Build Operating System: Linux 4.19.0-12-amd64 x86_64 Debian
[    39.767] Current Operating System: Linux naute 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64
[    39.767] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-14-amd64 root=UUID=ac14876b-830d-45d3-91fa-9997808885e7 ro quiet
[    39.767] Build Date: 01 December 2020  05:59:57PM
[    39.767] xorg-server 2:1.20.4-1+deb10u2 (https://www.debian.org/support)
[    39.767] Current version of pixman: 0.36.0
[    39.767]  Before reporting problems, check http://wiki.x.org
  to make sure that you have the latest version.
[    39.767] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    39.767] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar  1 09:26:41 2021
[    39.815] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    39.836] (==) No Layout section.  Using the first Screen section.
[    39.836] (==) No screen section available. Using defaults.
[    39.836] (**) |-->Screen "Default Screen Section" (0)
[    39.836] (**) |   |-->Monitor "<default monitor>"
[    39.837] (==) No monitor specified for screen "Default Screen Section".
  Using a default monitor configuration.
[    39.837] (==) Automatically adding devices
[    39.838] (==) Automatically enabling devices
[    39.838] (==) Automatically adding GPU devices
[    39.838] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    39.880] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    39.880]  Entry deleted from font path.
[    39.884] (==) FontPath set to:
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
  built-ins
[    39.884] (==) ModulePath set to "/usr/lib/xorg/modules"
[    39.884] (II) The server relies on udev to provide the list of input devices.
  If no devices become available, reconfigure udev or disable AutoAddDevices.
[    39.884] (II) Loader magic: 0x55f12c58be20
[    39.884] (II) Module ABI versions:
[    39.884]  X.Org ANSI C Emulation: 0.4
[    39.884]  X.Org Video Driver: 24.0
[    39.884]  X.Org XInput driver : 24.1
[    39.884]  X.Org Server Extension : 10.0
[    39.885] (++) using VT number 7

[    39.885] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    39.887] (II) xfree86: Adding drm device (/dev/dri/card0)
[    39.890] (--) PCI:*(0@0:2:0) 15ad:0405:15ad:0405 rev 0, Mem @ 0xf0000000/67108864, 0xf4000000/2097152, I/O @ 0x0000d010/16, BIOS @ 0x????????/131072
[    39.890] (II) LoadModule: "glx"
[    39.927] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    40.007] (II) Module glx: vendor="X.Org Foundation"
[    40.008]  compiled for 1.20.4, module version = 1.0.0
[    40.008]  ABI class: X.Org Server Extension, version 10.0
[    40.008] (==) Matched vmware as autoconfigured driver 0
[    40.008] (==) Matched modesetting as autoconfigured driver 1
[    40.008] (==) Matched fbdev as autoconfigured driver 2
[    40.008] (==) Matched vesa as autoconfigured driver 3
[    40.008] (==) Assigned the driver to the xf86ConfigLayout
[    40.008] (II) LoadModule: "vmware"
[    40.008] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[    40.926] (II) Module vmware: vendor="X.Org Foundation"
[    40.926]  compiled for 1.20.0, module version = 13.3.0
[    40.926]  Module class: X.Org Video Driver
[    40.926]  ABI class: X.Org Video Driver, version 24.0
[    40.926] (II) LoadModule: "modesetting"
[    40.926] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    40.937] (II) Module modesetting: vendor="X.Org Foundation"
[    40.937]  compiled for 1.20.4, module version = 1.20.4
[    40.937]  Module class: X.Org Video Driver
[    40.937]  ABI class: X.Org Video Driver, version 24.0
[    40.937] (II) LoadModule: "fbdev"
[    40.937] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    40.951] (II) Module fbdev: vendor="X.Org Foundation"
[    40.951]  compiled for 1.20.0, module version = 0.5.0
[    40.951]  Module class: X.Org Video Driver
[    40.951]  ABI class: X.Org Video Driver, version 24.0
[    40.951] (II) LoadModule: "vesa"
[    40.951] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    40.956] (II) Module vesa: vendor="X.Org Foundation"
[    40.956]  compiled for 1.20.1, module version = 2.4.0
[    40.956]  Module class: X.Org Video Driver
[    40.956]  ABI class: X.Org Video Driver, version 24.0
[    40.956] (II) vmware: driver for VMware SVGA: vmware0405, vmware0710
[    40.956] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    40.957] (II) FBDEV: driver for framebuffer: fbdev
[    40.957] (II) VESA: driver for VESA chipsets: vesa
[    40.959] (WW) Falling back to old probe method for modesetting
[    40.960] (WW) Falling back to old probe method for fbdev
[    40.960] (II) Loading sub module "fbdevhw"
[    40.960] (II) LoadModule: "fbdevhw"
[    40.960] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    40.970] (II) Module fbdevhw: vendor="X.Org Foundation"
[    40.970]  compiled for 1.20.4, module version = 0.0.2
[    40.970]  ABI class: X.Org Video Driver, version 24.0
[    40.970] (II) vmware(0): Creating default Display subsection in Screen section
  "Default Screen Section" for depth/fbbpp 24/32
[    40.970] (--) vmware(0): DRM driver version is 2.15.0
[    40.970] (==) vmware(0): Depth 24, (--) framebuffer bpp 32
[    40.970] (==) vmware(0): RGB weight 888
[    40.970] (==) vmware(0): Default visual is TrueColor
[    40.970] (--) vmware(0): Min width 1, Max Width 8192.
[    40.970] (--) vmware(0): Min height 1, Max Height 8192.
[    40.970] (II) vmware(0): Output Virtual1 has no monitor section
[    40.970] (II) vmware(0): Output Virtual2 has no monitor section
[    40.970] (II) vmware(0): Output Virtual3 has no monitor section
[    40.970] (II) vmware(0): Output Virtual4 has no monitor section
[    40.971] (II) vmware(0): Output Virtual5 has no monitor section
[    40.971] (II) vmware(0): Output Virtual6 has no monitor section
[    40.971] (II) vmware(0): Output Virtual7 has no monitor section
[    40.971] (II) vmware(0): Output Virtual8 has no monitor section
[    40.971] (II) vmware(0): Printing probed modes for output Virtual1
[    40.971] (II) vmware(0): Modeline "800x600"x60.0   42.75  800 850 900 950  600 650 700 750 -hsync +vsync (45.0 kHz eP)
[    40.971] (II) vmware(0): Modeline "2560x1600"x60.0  348.50  2560 2752 3032 3504  1600 1603 1609 1658 -hsync +vsync (99.5 kHz e)
[    40.971] (II) vmware(0): Modeline "1920x1440"x60.0  234.00  1920 2048 2256 2600  1440 1441 1444 1500 -hsync +vsync (90.0 kHz e)
[    40.971] (II) vmware(0): Modeline "1856x1392"x60.0  218.25  1856 1952 2176 2528  1392 1393 1396 1439 -hsync +vsync (86.3 kHz e)
[    40.971] (II) vmware(0): Modeline "1792x1344"x60.0  204.75  1792 1920 2120 2448  1344 1345 1348 1394 -hsync +vsync (83.6 kHz e)
[    40.971] (II) vmware(0): Modeline "1920x1200"x59.9  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync (74.6 kHz e)
[    40.971] (II) vmware(0): Modeline "1600x1200"x60.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
[    40.971] (II) vmware(0): Modeline "1680x1050"x60.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
[    40.971] (II) vmware(0): Modeline "1400x1050"x60.0  121.75  1400 1488 1632 1864  1050 1053 1057 1089 -hsync +vsync (65.3 kHz e)
[    40.971] (II) vmware(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[    40.971] (II) vmware(0): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz e)
[    40.971] (II) vmware(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz e)
[    40.971] (II) vmware(0): Modeline "1360x768"x60.0   85.50  1360 1424 1536 1792  768 771 777 795 +hsync +vsync (47.7 kHz e)
[    40.971] (II) vmware(0): Modeline "1280x800"x59.8   83.50  1280 1352 1480 1680  800 803 809 831 +hsync -vsync (49.7 kHz e)
[    40.971] (II) vmware(0): Modeline "1152x864"x75.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz e)
[    40.971] (II) vmware(0): Modeline "1280x768"x59.9   79.50  1280 1344 1472 1664  768 771 778 798 -hsync +vsync (47.8 kHz e)
[    40.971] (II) vmware(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
[    40.971] (II) vmware(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
[    40.971] (II) vmware(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 489 492 525 -hsync -vsync (31.5 kHz e)
[    40.971] (II) vmware(0): EDID for output Virtual2
[    40.971] (II) vmware(0): EDID for output Virtual3
[    40.971] (II) vmware(0): EDID for output Virtual4
[    40.971] (II) vmware(0): EDID for output Virtual5
[    40.971] (II) vmware(0): EDID for output Virtual6
[    40.971] (II) vmware(0): EDID for output Virtual7
[    40.971] (II) vmware(0): EDID for output Virtual8
[    40.971] (II) vmware(0): Output Virtual1 connected
[    40.971] (II) vmware(0): Output Virtual2 disconnected
[    40.971] (II) vmware(0): Output Virtual3 disconnected
[    40.971] (II) vmware(0): Output Virtual4 disconnected
[    40.972] (II) vmware(0): Output Virtual5 disconnected
[    40.972] (II) vmware(0): Output Virtual6 disconnected
[    40.972] (II) vmware(0): Output Virtual7 disconnected
[    40.972] (II) vmware(0): Output Virtual8 disconnected
[    40.972] (II) vmware(0): Using exact sizes for initial modes
[    40.972] (II) vmware(0): Output Virtual1 using initial mode 800x600 +0+0
[    40.972] (==) vmware(0): DPI set to (96, 96)
[    40.972] (==) vmware(0): Using gamma correction (1.0, 1.0, 1.0)
[    40.972] (II) Loading sub module "fb"
[    40.972] (II) LoadModule: "fb"
[    40.972] (II) Loading /usr/lib/xorg/modules/libfb.so
[    40.986] (II) Module fb: vendor="X.Org Foundation"
[    40.986]  compiled for 1.20.4, module version = 1.0.0
[    40.986]  ABI class: X.Org ANSI C Emulation, version 0.4
[    40.986] (II) Loading sub module "dri2"
[    40.986] (II) LoadModule: "dri2"
[    40.986] (II) Module "dri2" already built-in
[    40.986] (II) Loading sub module "dri3"
[    40.986] (II) LoadModule: "dri3"
[    40.986] (II) Module "dri3" already built-in
[    40.986] (II) UnloadModule: "modesetting"
[    40.986] (II) Unloading modesetting
[    40.987] (II) UnloadModule: "fbdev"
[    40.987] (II) Unloading fbdev
[    40.987] (II) UnloadSubModule: "fbdevhw"
[    40.987] (II) Unloading fbdevhw
[    40.987] (II) UnloadModule: "vesa"
[    40.987] (II) Unloading vesa
[    41.004] (II) vmware(0): Initialized VMWARE_CTRL extension version 0.2
[    41.190] (II) vmware(0): Gallium3D XA version: 2.4.0.
[    41.190] (II) vmware(0): Path of drm device is "/dev/dri/card0".
[    41.190] (II) vmware(0): [DRI2] Setup complete
[    41.190] (II) vmware(0): [DRI2]   DRI driver: vmwgfx
[    41.190] (EE) vmware(0): Failed to initialize direct rendering DRI3.
[    41.190] (--) vmware(0): Render acceleration is enabled.
[    41.190] (==) vmware(0): Rendercheck mode is disabled.
[    41.190] (--) vmware(0): Direct rendering (DRI2 3D) is enabled.
[    41.190] (--) vmware(0): Direct rendering (DRI3 3D) is disabled.
[    41.190] (==) vmware(0): Direct presents are disabled.
[    41.190] (==) vmware(0): Hardware only presents are disabled.
[    41.190] (==) vmware(0): Backing store enabled
[    41.190] (==) vmware(0): Silken mouse enabled
[    41.193] (==) vmware(0): DPMS enabled
[    41.193] (II) Initializing extension Generic Event Extension
[    41.193] (II) Initializing extension SHAPE
[    41.193] (II) Initializing extension MIT-SHM
[    41.193] (II) Initializing extension XInputExtension
[    41.194] (II) Initializing extension XTEST
[    41.194] (II) Initializing extension BIG-REQUESTS
[    41.195] (II) Initializing extension SYNC
[    41.195] (II) Initializing extension XKEYBOARD
[    41.195] (II) Initializing extension XC-MISC
[    41.195] (II) Initializing extension SECURITY
[    41.195] (II) Initializing extension XFIXES
[    41.195] (II) Initializing extension RENDER
[    41.196] (II) Initializing extension RANDR
[    41.196] (II) Initializing extension COMPOSITE
[    41.196] (II) Initializing extension DAMAGE
[    41.196] (II) Initializing extension MIT-SCREEN-SAVER
[    41.196] (II) Initializing extension DOUBLE-BUFFER
[    41.196] (II) Initializing extension RECORD
[    41.197] (II) Initializing extension DPMS
[    41.197] (II) Initializing extension Present
[    41.197] (II) Initializing extension DRI3
[    41.197] (II) Initializing extension X-Resource
[    41.197] (II) Initializing extension XVideo
[    41.197] (II) Initializing extension XVideo-MotionCompensation
[    41.197] (II) Initializing extension SELinux
[    41.197] (II) SELinux: Disabled on system
[    41.197] (II) Initializing extension GLX
[    41.424] (II) AIGLX: Loaded and initialized vmwgfx
[    41.424] (II) GLX: Initialized DRI2 GL provider for screen 0
[    41.424] (II) Initializing extension XFree86-VidModeExtension
[    41.424] (II) Initializing extension XFree86-DGA
[    41.424] (II) Initializing extension XFree86-DRI
[    41.424] (II) Initializing extension DRI2
[    41.429] (II) vmware(0): Setting screen physical size to 211 x 158
[    41.767] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    41.767] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[    41.767] (II) LoadModule: "libinput"
[    41.767] (II) Loading /usr/lib/xorg/modules/input/libinput_drv.so
[    41.794] (II) Module libinput: vendor="X.Org Foundation"
[    41.794]  compiled for 1.20.4, module version = 0.28.2
[    41.794]  Module class: X.Org XInput Driver
[    41.794]  ABI class: X.Org XInput driver, version 24.1
[    41.794] (II) Using input driver 'libinput' for 'Power Button'
[    41.794] (**) Power Button: always reports core events
[    41.794] (**) Option "Device" "/dev/input/event1"
[    41.794] (**) Option "_source" "server/udev"
[    41.846] (II) event1  - Power Button: is tagged by udev as: Keyboard
[    41.846] (II) event1  - Power Button: device is a keyboard
[    41.846] (II) event1  - Power Button: device removed
[    41.860] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event1"
[    41.860] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    41.860] (**) Option "xkb_model" "pc105"
[    41.860] (**) Option "xkb_layout" "fr"
[    41.860] (**) Option "xkb_variant" "latin9"
[    41.891] (II) event1  - Power Button: is tagged by udev as: Keyboard
[    41.892] (II) event1  - Power Button: device is a keyboard
[    41.892] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[    41.892] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[    41.892] (II) Using input driver 'libinput' for 'Sleep Button'
[    41.892] (**) Sleep Button: always reports core events
[    41.892] (**) Option "Device" "/dev/input/event2"
[    41.892] (**) Option "_source" "server/udev"
[    41.893] (II) event2  - Sleep Button: is tagged by udev as: Keyboard
[    41.893] (II) event2  - Sleep Button: device is a keyboard
[    41.893] (II) event2  - Sleep Button: device removed
[    41.908] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSLPBN:00/input/input3/event2"
[    41.908] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 7)
[    41.908] (**) Option "xkb_model" "pc105"
[    41.908] (**) Option "xkb_layout" "fr"
[    41.908] (**) Option "xkb_variant" "latin9"
[    41.909] (II) event2  - Sleep Button: is tagged by udev as: Keyboard
[    41.909] (II) event2  - Sleep Button: device is a keyboard
[    41.910] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[    41.910] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[    41.910] (II) Using input driver 'libinput' for 'Video Bus'
[    41.910] (**) Video Bus: always reports core events
[    41.910] (**) Option "Device" "/dev/input/event3"
[    41.910] (**) Option "_source" "server/udev"
[    41.911] (II) event3  - Video Bus: is tagged by udev as: Keyboard
[    41.911] (II) event3  - Video Bus: device is a keyboard
[    41.911] (II) event3  - Video Bus: device removed
[    41.940] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/LNXVIDEO:00/input/input4/event3"
[    41.940] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[    41.940] (**) Option "xkb_model" "pc105"
[    41.940] (**) Option "xkb_layout" "fr"
[    41.940] (**) Option "xkb_variant" "latin9"
[    41.941] (II) event3  - Video Bus: is tagged by udev as: Keyboard
[    41.941] (II) event3  - Video Bus: device is a keyboard
[    41.943] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/event7)
[    41.943] (**) VirtualBox mouse integration: Applying InputClass "libinput pointer catchall"
[    41.943] (II) Using input driver 'libinput' for 'VirtualBox mouse integration'
[    41.943] (**) VirtualBox mouse integration: always reports core events
[    41.943] (**) Option "Device" "/dev/input/event7"
[    41.943] (**) Option "_source" "server/udev"
[    41.944] (II) event7  - VirtualBox mouse integration: is tagged by udev as: Mouse
[    41.944] (II) event7  - VirtualBox mouse integration: device is a pointer
[    41.944] (II) event7  - VirtualBox mouse integration: device removed
[    41.980] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.0/input/input8/event7"
[    41.980] (II) XINPUT: Adding extended input device "VirtualBox mouse integration" (type: MOUSE, id 9)
[    41.980] (**) Option "AccelerationScheme" "none"
[    41.980] (**) VirtualBox mouse integration: (accel) selected scheme none/0
[    41.980] (**) VirtualBox mouse integration: (accel) acceleration factor: 2.000
[    41.980] (**) VirtualBox mouse integration: (accel) acceleration threshold: 4
[    41.981] (II) event7  - VirtualBox mouse integration: is tagged by udev as: Mouse
[    41.982] (II) event7  - VirtualBox mouse integration: device is a pointer
[    41.982] (II) config/udev: Adding input device VirtualBox mouse integration (/dev/input/js1)
[    41.982] (II) No input driver specified, ignoring this device.
[    41.982] (II) This device may have been added with another device file.
[    41.983] (II) config/udev: Adding input device VirtualBox USB Tablet (/dev/input/event5)
[    41.984] (**) VirtualBox USB Tablet: Applying InputClass "libinput pointer catchall"
[    41.984] (II) Using input driver 'libinput' for 'VirtualBox USB Tablet'
[    41.984] (**) VirtualBox USB Tablet: always reports core events
[    41.984] (**) Option "Device" "/dev/input/event5"
[    41.984] (**) Option "_source" "server/udev"
[    42.046] (II) event5  - VirtualBox USB Tablet: is tagged by udev as: Mouse
[    42.047] (II) event5  - VirtualBox USB Tablet: device is a pointer
[    42.047] (II) event5  - VirtualBox USB Tablet: device removed
[    42.076] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:0c.0/usb1/1-1/1-1:1.0/0003:80EE:0021.0001/input/input6/event5"
[    42.076] (II) XINPUT: Adding extended input device "VirtualBox USB Tablet" (type: MOUSE, id 10)
[    42.076] (**) Option "AccelerationScheme" "none"
[    42.076] (**) VirtualBox USB Tablet: (accel) selected scheme none/0
[    42.076] (**) VirtualBox USB Tablet: (accel) acceleration factor: 2.000
[    42.076] (**) VirtualBox USB Tablet: (accel) acceleration threshold: 4
[    42.138] (II) event5  - VirtualBox USB Tablet: is tagged by udev as: Mouse
[    42.139] (II) event5  - VirtualBox USB Tablet: device is a pointer
[    42.140] (II) config/udev: Adding input device VirtualBox USB Tablet (/dev/input/js0)
[    42.140] (II) No input driver specified, ignoring this device.
[    42.141] (II) This device may have been added with another device file.
[    42.142] (II) config/udev: Adding input device VirtualBox USB Tablet (/dev/input/mouse1)
[    42.142] (II) No input driver specified, ignoring this device.
[    42.142] (II) This device may have been added with another device file.
[    42.143] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[    42.143] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[    42.143] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[    42.143] (**) AT Translated Set 2 keyboard: always reports core events
[    42.143] (**) Option "Device" "/dev/input/event0"
[    42.143] (**) Option "_source" "server/udev"
[    42.145] (II) event0  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    42.145] (II) event0  - AT Translated Set 2 keyboard: device is a keyboard
[    42.146] (II) event0  - AT Translated Set 2 keyboard: device removed
[    42.156] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[    42.156] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[    42.156] (**) Option "xkb_model" "pc105"
[    42.156] (**) Option "xkb_layout" "fr"
[    42.156] (**) Option "xkb_variant" "latin9"
[    42.158] (II) event0  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    42.158] (II) event0  - AT Translated Set 2 keyboard: device is a keyboard
[    42.160] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/event4)
[    42.160] (**) ImExPS/2 Generic Explorer Mouse: Applying InputClass "libinput pointer catchall"
[    42.160] (II) Using input driver 'libinput' for 'ImExPS/2 Generic Explorer Mouse'
[    42.160] (**) ImExPS/2 Generic Explorer Mouse: always reports core events
[    42.160] (**) Option "Device" "/dev/input/event4"
[    42.160] (**) Option "_source" "server/udev"
[    42.162] (II) event4  - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[    42.162] (II) event4  - ImExPS/2 Generic Explorer Mouse: device is a pointer
[    42.163] (II) event4  - ImExPS/2 Generic Explorer Mouse: device removed
[    42.196] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input5/event4"
[    42.196] (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE, id 12)
[    42.196] (**) Option "AccelerationScheme" "none"
[    42.196] (**) ImExPS/2 Generic Explorer Mouse: (accel) selected scheme none/0
[    42.196] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration factor: 2.000
[    42.196] (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration threshold: 4
[    42.198] (II) event4  - ImExPS/2 Generic Explorer Mouse: is tagged by udev as: Mouse
[    42.198] (II) event4  - ImExPS/2 Generic Explorer Mouse: device is a pointer
[    42.199] (II) config/udev: Adding input device ImExPS/2 Generic Explorer Mouse (/dev/input/mouse0)
[    42.199] (II) No input driver specified, ignoring this device.
[    42.199] (II) This device may have been added with another device file.
[    42.200] (II) config/udev: Adding input device PC Speaker (/dev/input/event6)
[    42.200] (II) No input driver specified, ignoring this device.
[    42.200] (II) This device may have been added with another device file.
[    89.453] (EE) No surface to present from.

 


pour l'analyse duquel mes compétences sont malheureusement insuffisante sad .

Amicalement,
neute

Hors ligne

#5 01-03-2021 11:41:52

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [VirtualBox] Écran noir en fin de démarrage

Yep !

naute a écrit :

jpt a écrit :

Et si tu essayais une autre config, juste pour voir ?

Ben non ! lol
Si je vais chez mon garagiste parce-que ma 4L est en panne et qu'il me dit d'acheter une 2CV, je dis "Ben non ! J'veux qu'on répare ma 4L".

Oui, mais je disais ça juste pour voir si le bazar se comporterait autrement en lui changeant son contexte.

naute a écrit :

jpt a écrit :

Et, just curious, on peut changer l'affichage du curseur ? Explique, en deux mots…

Je ne suis pas sûr de comprendre ce que tu veux. Je ne fais allusion au curseur de la souris que pour préciser qu'à ce moment-là mon interface graphique est, à priori, bien chargée avec le thème choisi, puisqu'il s'agit du bon curseur, et que la souris est bien capturée.

Je ne l'avais pas compris comme ça, c'est vrai que là c'est plus clair.

naute a écrit :

jpt a écrit :

Je me tue à répéter que tout se déglingue, mais rien ne change et ça continue à se déglinguer... sad

À commencer par moi, mais je ne peux rien y faire https://debian-facile.org/img/smilies/x … d_geek.gif.

Oui, mais certains sont plus lucides de d'autres, j'adore la vision du fondateur d'OpenBSD :

Wikipedia a écrit :

De Raadt déclarait ceci à propos du système d'exploitation GNU/Linux dans une interview au journal Forbes : « C'est terrible [...] Tout le monde l'utilise, et ils ne réalisent pas à quel point il est mauvais. Et les utilisateurs de Linux s'en contenteront et l'étofferont plutôt que de prendre du recul et de dire "C'est n'importe quoi et nous devrions y remédier". »

source

naute a écrit :

jpt a écrit :

Faudrait voir les logs de /var/log/0/Xorg.log, pour commencer…

Alors je n'ai pas de /var/log/0/Xorg.log, mais j'ai un /var/log/Xorg.0.log (problème de dyslexie, peut-être lol) dont voici le contenu :


[    39.767] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 

pour l'analyse duquel mes compétences sont malheureusement insuffisante sad .

(typo corrigée)
Mais si mais si, c'est facile (même si décourageant, vu la quantité d'infos), y a qu'à lire avec ça présent à l'esprit :

[    39.767] Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

EDIT
et donc on trouve vers le milieu

[s][    41.190] (EE) vmware(0): Failed to initialize direct rendering DRI3.[/s]

à googler et, plus intéressant peut-être, la toute dernière ligne du log :

[s][    89.453] (EE) No surface to present from.[/s]

, à googler aussi./EDIT voir le post 7.

Et désolé, je ne connais pas du tout vmware.
Mais il serait intéressant de comparer avec un log en mode pas plein écrantongue
À moins qu'un spécialiste vmware passe par là.

Dernière modification par jpt (01-03-2021 14:32:00)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#6 01-03-2021 13:34:58

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [VirtualBox] Écran noir en fin de démarrage

installé ou pas les guestadditions?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#7 01-03-2021 14:27:54

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [VirtualBox] Écran noir en fin de démarrage

jpt a écrit :

et donc on trouve vers le milieu

[    41.190] (EE) vmware(0): Failed to initialize direct rendering DRI3.


à googler et, plus intéressant peut-être, la toute dernière ligne du log :

[    89.453] (EE) No surface to present from.


, à googler aussi.

Bon, j'ai répondu un peu vite (c'est mon défaut), en seconde analyse une recherche dans ton log comme dans le mien remonte les mots virtualbox ET vmware alors qu'en ce qui me concerne je n'ai jamais installé le second.

En gros c'est la pagaille, quoi, un peu comme le disait De Raadt…

Dernière modification par jpt (01-03-2021 14:28:48)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#8 02-03-2021 12:02:34

naute
Membre
Lieu : Bretagne
Distrib. : Debian GNU-Linux Stretch 9.5
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.16.2
Inscription : 24-03-2018

Re : [VirtualBox] Écran noir en fin de démarrage

Croutons a écrit :

installé ou pas les guestadditions?


Oui, bien sûr. Comme spécifié dans mon premier post, je dispose actuellement de VirtualBox 6.1.12 avec toutes les options, à savoir Extension Pack et Guest Additions.

jpt a écrit :

une recherche dans ton log comme dans le mien remonte les mots virtualbox ET vmware alors qu'en ce qui me concerne je n'ai jamais installé le second.


Pareil : je me demande, du coup, si VirtualBox n'embarque pas une partie du code VMware.

J'ai "googlé" (avec DuckDuckGo, je n'utilise pas Google) suivant tes conseils mais ça n'a rien donné de constructif.

Je peux préciser que j'ai trois machines virtuelles, une Debian 9 et deux Debian 10, et que le problème est identique pour les trois, ce qui laisse à penser que le problème vient de VirtualBox : quand je quitte la machine en mode fenêtré, elle redémarre en mode fenêtré (normal) et tout se passe bien, par contre, quand je quitte la machine en mode plein écran, elle redémarre en mode plein écran (normal également), mais l'écran reste noir, à part le curseur de la souris. Il faut que je repasse par le mode fenêtré, avec CTRL-F par exemple, pour obtenir l'affichage de l'écran. Dans les deux cas, quand je repasse en mode plein écran, tout va bien.

Comme je le disais, ce n'est pas dramatique, mais ce n'est pas normal : il y a forcément une solution.

Hors ligne

#9 02-03-2021 12:51:17

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [VirtualBox] Écran noir en fin de démarrage

Salut,

alors j'ai testé avec une mv de la DF 10-6.1, que j'ai passée en plein écran pendant le boot : l'écran est devenu tout noir avec une minable 640x480 au milieu jusqu'à la fenêtre d'authentification, et ensuite ça a basculé en plein écran automagiquement : full screen (= sans les barres d'outil en bas et de menu en haut), ma foi, ça a l'air sympa.
J'ai rebooté et tout pareil : ridicule du boot au login et parfait après.

Mais je suis en vbox 6.1.18.

EDIT : correction, ça a donc survécu au reboot mais pas au power off / power on de la machine : maintenant je suis comme toi, écran noir après le login, et juste le pointeur au milieu.

Quelle bouse, non mais quelle bouse... sad mad sad

Dernière modification par jpt (02-03-2021 13:03:51)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#10 13-03-2021 10:34:22

naute
Membre
Lieu : Bretagne
Distrib. : Debian GNU-Linux Stretch 9.5
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.16.2
Inscription : 24-03-2018

Re : [VirtualBox] Écran noir en fin de démarrage

Bonjour smile .

J'ai installé Haiku sur une machine virtuelle pour voir où en est le projet, ce que je fais assez régulièrement : pour info, ça démarre sans problème en plein écran.

L'étau se resserre sur le couple Debian/VirtualBox lol .

Amicalement,
naute

Hors ligne

#11 13-03-2021 14:31:20

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : [VirtualBox] Écran noir en fin de démarrage

Salut, camarade,

naute a écrit :

L'étau se resserre sur le couple Debian/VirtualBox lol .

Oh tu sais, comme je dis toujours, Debian ce n'est plus ce que c'était.
Quand je lis ça

Debian 10.8 was released on February 6th, 2021. Debian 10.0 was initially released on July 6th, 2019. The release included many major changes, described in our press release and the Release Notes.
[…]
Contrary to our wishes, there may be some problems that exist in the release, even though it is declared stable. We've made a list of the major known problems, and you can always report other issues to us.
source : https://www.debian.org/releases/stable/

, perso, je prends peur.
Et c'est confirmé par le nombre de posts qu'on peut voir ici et ailleurs du genre "gros problème après mise à jour", qui me rappelle un OS à fenêtres bien connu pour ce genre de souci…


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#12 14-03-2021 11:57:59

naute
Membre
Lieu : Bretagne
Distrib. : Debian GNU-Linux Stretch 9.5
Noyau : Linux 4.9.0-7-amd64
(G)UI : Mate 1.16.2
Inscription : 24-03-2018

Re : [VirtualBox] Écran noir en fin de démarrage

Salut jpt smile,

en même temps, ce que tu lis là (dites-le avec des fleurs), Debian le propose à la lecture depuis la version 2.2 qui remonte à 2000 :

Debian GNU/Linux 2.2 (a.k.a. Potato) was released on August 14th, 2000. The latest point release of Debian 2.2 is 2.2r7, released on July 13th, 2002.
[...]
Contrary to our wishes, there are some problems that exist in the potato release, even though it is declared stable. We've made a list of the major known problems, and you can always report other issues to us.


Ce n'est donc pas obligatoirement, à mon avis, un signe de dégradation, mais plutôt un avertissement qui devrait accompagner le produit de tout éditeur de logiciel (en général, et d'OS, en particulier) un tant soit peu honnête, surtout s'il s'agit d'un logiciel payant, comme "l'OS à fenêtre" dont tu parles.
Qu'un logiciel (au sens large) gratuit comme Debian mette en garde ses utilisateurs contre "d'éventuels" dysfonctionnements est donc à porter à son crédit.

Le problème, et on en est tous plus ou moins responsable, est qu'on est dans une logique de fuite en avant qui impose le développement de nouvelles fonctionnalités avant même d'avoir réglé les problèmes liés aux fonctionnalités existantes. C'est comme ça et ce n'est pas prêt de changer. Ça s'appelle le progrès, je crois lol .

Amicalement,
naute

Hors ligne

Pied de page des forums