Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-03-2021 10:23:00

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Perte wifi après dernière MAJ

Bonjour, tout est dit dans le titre
Voici ce que j'ai comme info.
Help

nmcli device status
 


DEVICE  TYPE      STATE       CONNECTION          
enp3s0  ethernet  connecté    Connexion filaire 1
wlp1s0  wifi      déconnecté  --                  
lo      loopback  non-géré    --

Dernière modification par vipere (08-04-2021 19:56:40)

Hors ligne

#2 09-03-2021 10:36:01

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

Bonjour il n'y a personne qui a une petite idée?

Hors ligne

#3 09-03-2021 12:25:53

Herve5
Adhérent(e)
Lieu : mi au Sud mi à Paris, France
Distrib. : Debian 5.10.19-1 (2021-03-02) bullseye sid testing
Noyau : Linux 5.10.0-4-amd64
(G)UI : xfce 4.16
Inscription : 02-03-2019

Re : Perte wifi après dernière MAJ

je ne suis pas assez compétent pour répondre mais
- j'ai l'impression que tu donnes trop peu de détails (ta config est-elle bien celle dans ta signature, qu'as-tu mis à jour, etc.)
- il y a pas mal de fils en cours sur des problèmes wifi tout autour du tien : regarde si l'un deux n'est pas proche de ta config
Sur ce, je laisse les pros te poser des questions ;-)

--
Hervé S.
anciennement, machines de type Clevo (donc pas très solides) sous Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian 11 Xfce

Hors ligne

#4 09-03-2021 13:25:27

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

En effet, je n'ai pas tout dit. Désolée.
Le notebook est un Intel (R) Atom(TM) CPU Z520 1.33GHz
Noyau Linux 4.19.0-146686 (i686)
Je pense que je n'ai rien oublié.

J'ai déjà essayer les tutos et dépannages d'èfpé.
J'ai déjà eu ce problème avec la débian de mon profil.
Je n'ai jamais pu la dépanner.
Je sais que ce sont de vieilles breloques, mais avant la dernière MAJ automatique ça fonctionnait.
La wifi fonctionne, détecte la box mais n'accroche pas.

$cat /proc/net/if_inet6



00000000000000000000000000000001 01 80 10 80       lo
fe80000000000000c82128e19e580cb4 02 40 20 80   enp3s0



ça veut dire que la wifi ne fonctionne pas avec IPv6?

Hors ligne

#5 09-03-2021 21:12:20

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

Me revoilà au bon endroit, je pense.
Merci Chalu

Hors ligne

#6 09-03-2021 22:59:54

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Perte wifi après dernière MAJ

Oui c’est bien ici wink
Donne le retour pour identifier ta carte

 lspci -nnkd ::0280

Hors ligne

#7 12-03-2021 18:51:17

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

Bonjour
@Chalu voici la réponse

lspci -nnkd ::0280
 


01:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
  Subsystem: AzureWave AW-NE785 / AW-NE785H 802.11bgn Wireless Full or Half-size Mini PCIe Card [1a3b:1089]
  Kernel driver in use: ath9k
  Kernel modules: ath9k

Hors ligne

#8 13-03-2021 16:48:51

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Perte wifi après dernière MAJ

Bonjour,
Tout semble bon pour ce retour de commande.
Que donne

ip a


As-tu un voyant sur le clavier qui indique que la carte wifi est bien activée ?
Tu peux installer rfkill pour voir si c’est bloqué (https://debian-facile.org/doc:reseau:rfkill )

 rfkill list

Hors ligne

#9 15-03-2021 14:49:23

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

Bonjour Chalu,
voici les infos demandées

ip a


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether e0:cb:4e:88:5f:50 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.23/24 brd 192.168.0.255 scope global dynamic noprefixroute enp3s0
       valid_lft 863635sec preferred_lft 863635sec
    inet6 fe80::c821:28e1:9e58:cb4/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: wlp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether 00:25:d3:ea:ac:2c brd ff:ff:ff:ff:ff:ff



rfkill list
 


0: eeepc-wlan: Wireless LAN
  Soft blocked: no
  Hard blocked: no
1: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no



merci

Hors ligne

#10 15-03-2021 17:50:56

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Perte wifi après dernière MAJ

Que donne la commande

nmcli connection up wlp1s0



et je crois que je ne pourrai pas aller plus loin, je ne maitrise pas assez ces problèmes de connexions.
On va appeler à la rescousse les membres experts sur le sujet wink (il y en a !)

Hors ligne

#11 15-03-2021 19:48:20

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

C'est assez drôle Chalu,
je suis rentrée chez moi et la wifi fonctionne. J'en déduis que c'est un problème avec la box de chez pas moi. Je retesterai quand j'y retournerai dans quelques jours.
Par contre j'ai testé ta commande par curiosité et le retour est étrange

nmcli connection up wlp1s0


Erreur : connexion inconnue : « wlp1s0 »



pourtant je suis connectée en wifi.

si je fais

nmcli


wlp1s0: connecté to FREEBOX_xxxxx
        "Qualcomm Atheros AR9285"
        wifi (ath9k), 00:25:D3:EA:AC:2C, hw, mtu 1500
        ip4 default, ip6 default
        inet4 192.168.0.40/24
        route4 0.0.0.0/0
        route4 192.168.0.0/24
        inet6 2a01:e0a:1:5bb0:8153:1502:5920:5051/64
        inet6 fe80::a779:7ad:a6ee:a5c0/64
        route6 fe80::/64
        route6 2a01:e0a:1:5bb0::/64
        route6 ::/0

enp3s0: indisponible
        "Qualcomm Atheros AR8132"
        ethernet (atl1c), E0:CB:4E:88:5F:50, hw, mtu 1500

lo: non-géré
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
        servers: 192.168.0.254
        interface: wlp1s0

        servers: fd0f:ee:b0::1
        interface: wlp1s0

Utilisez « nmcli device show » pour obtenir des informations complètes sur les p

Consultez les pages de manuel nmcli(1) et nmcli-examples(5) pour les détails com



J'aimerais bien comprendre.
Y a un fantôme dans cette Debian:/

Hors ligne

#12 15-03-2021 19:56:31

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Perte wifi après dernière MAJ

c'est peut-être car elle était déjà active.
Le wiki sur nmcli est là
https://debian-facile.org/doc:reseau:ne … e-commande

Hors ligne

#13 15-03-2021 20:05:22

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

OK merci,
je ferai un retour quand j'aurai accès à l'autre box. Le wiki sur la commande nmcli devrait m'aider.
Bonne soirée

Dernière modification par vipere (15-03-2021 20:08:27)

Hors ligne

#14 07-04-2021 18:03:42

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

Bonjour me revoilà,
suite à vos différentes remarques et après avoir épluché la doc pour la commande nmcli je suis toujours en échec.
Mais j'ai eu droit à quelques messages d'erreur que je m'empresse de vous montrer ;-)

nmcli connection show wlp1s0


Erreur : wlp1s0 - profil de connexion introuvable.



Et pour répondre à  Chalu

nmcli device disconnect wlp1s0


Erreur : échec de la déconnexion du périphérique « wlp1s0 » (/org/freedesktop/NetworkManager/Devices/3) : This device is not active



Je pense que c'est un problème lié à la box d'ici, car chez moi ça fonctionne très bien.
La différence est qu'ici je ne suis pas en fibre ni dégroupé. La box est moins performante (c'est une crystal) mais d'un autre côté j'ai eu le même problème avec un autre notebook  et à la maison avec une Revolution. Je n'ai pas réussi à me dépanner.
D'autant que le problème est intervenu après une MAJ pour les deux.
Il doit y avoir un réglage à faire mais je sèche.

toutes les aides sont acceptées

le bonus est que si j'en dépanne un je dépanne l'autre big_smile

Hors ligne

#15 07-04-2021 18:34:43

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Tumbleweed
Noyau : Linux 5.12
(G)UI : KDE 5.21.4
Inscription : 11-03-2016

Re : Perte wifi après dernière MAJ

Et quand tu n'es pas chez toi, quel est le retour de

nmcli device wifi list

Hors ligne

#16 08-04-2021 10:08:13

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

Bonjour,

nmcli device wifi list


IN-USE  SSID              MODE   CHAN  RATE      SIGNAL  BARS  SECURITY
        FREEBOX_XXXXX_ZN  Infra  7     270 Mo/s  95      ▂▄▆█  WPA1



ça devrait fonctionner, la wifi détecte le réseau

Hors ligne

#17 08-04-2021 12:04:25

vipere
Membre
Lieu : le sud
Distrib. : Debian GNU/Linux 10 (buster)
Noyau : Linux 4.19.0-8-amd64
Inscription : 22-04-2020

Re : Perte wifi après dernière MAJ

Suite à un problème technique, j'ai changé le nom de réseau et la clé de la box.
Après redémarrage, j'ai récupéré la wifi. Las ça n'a pas duré.
De nouveau inactive avec le même message d'erreur.
Comprends pas.
Quelqu'un peut m'aider à défricher ça? Je me suis tapée tout le man de nmcli mais je ne sais pas décoder ça.
D'autant que les messages d'erreur me retournent un périf introuvablekernal_panic.gif

nmcli -f GENERAL,WIFI-PROPERTIES dev show wlp1s0

 


GENERAL.DEVICE:                         wlp1s0
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Qualcomm Atheros
GENERAL.PRODUCT:                        AR9285 Wireless Network Adapter (PCI-Exp
GENERAL.DRIVER:                         ath9k
GENERAL.DRIVER-VERSION:                 4.19.0-16-686
GENERAL.FIRMWARE-VERSION:               N/A
GENERAL.HWADDR:                         00:25:D3:EA:AC:2C
GENERAL.MTU:                            1500
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.1/000
GENERAL.IP-IFACE:                       --
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   no

Dernière modification par vipere (08-04-2021 18:11:14)

Hors ligne

Pied de page des forums