Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-03-2021 15:10:08

manet42
Membre
Lieu : Lorraine
Distrib. : Stretch 9 et Buster
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

RESOLU GeneWeb et localhost

Bonjour
Depuis quelque temps, je n'arrive plus à me contacter sur localhost: 2317 par le logiciel de généalogie Geneweb.avec mon portable 32 bits utilisant firefox 86.0 32 bits.
Voici le message:
Impossible d'exécuter la commande " /usr/bin/x-www-browser http localhost:2317" Aucun fichier ou dossier de ce type ;

Je peux cependant y accéder directement en tapant dans Firefox (barre d'adresse : http://localhost:2717

Par contre même logiciel, même firefox (86.0 64 bits) ça fonctionne ! Ouverture directe avec geneweb.
Merci

Dernière modification par manet42 (13-03-2021 11:46:59)


Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 2 GO, 533 Mhz avec Stretch i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch  DDext et Win 7 DD int en dual boot.+ Buster sur HP Compaq.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#2 09-03-2021 15:19:02

DarKou
Membre
Lieu : Bordeaux
Distrib. : Gentoo / Debian Buster
Noyau : stable de chez kernel.org
(G)UI : Sway
Inscription : 06-04-2020
Site Web

Re : RESOLU GeneWeb et localhost

manet42 a écrit :

Bonjour
Depuis quelque temps, je n'arrive plus à me contacter sur localhost: 2317 par le logiciel de généalogie Geneweb.avec mon portable 32 bits utilisant firefox 86.0 32 bits.
Voici le message:
Impossible d'exécuter la commande " /usr/bin/x-www-browser http localhost:2317" Aucun fichier ou dossier de ce type ;

Je peux cependant y accéder directement en tapant dans Firefox (barre d'adresse : http://localhost:2717

Par contre même logiciel, même firefox (86.0 64 bits) ça fonctionne ! Ouverture directe avec geneweb.
Merci



2317 ou 2717 ? big_smile

En ligne

#3 09-03-2021 15:24:31

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : RESOLU GeneWeb et localhost

Bonjour,

Ça ne serait pas le lien que constitue ce fichier /usr/bin/x-www-browser vers le browser réellement utilisé (firefox, chromium...) qui aurait disparu?

Tout est un sauf zéro. - Wau Holland

Hors ligne

#4 09-03-2021 18:24:35

manet42
Membre
Lieu : Lorraine
Distrib. : Stretch 9 et Buster
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU GeneWeb et localhost

Désolé de mon inattention...oui c'est bien 2317 !!!

Vérifié: le fichier x-www-browser est absent dans usr/bin/

pourquoi a-t-il disparu ???
Comment le rétablir dans un dossier protégé ?

Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 2 GO, 533 Mhz avec Stretch i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch  DDext et Win 7 DD int en dual boot.+ Buster sur HP Compaq.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#5 10-03-2021 00:55:40

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : RESOLU GeneWeb et localhost

manet42 a écrit :

pourquoi a-t-il disparu ?


Je ne sais pas ce qui à été fait sur cette machine, tu es le mieux placé pour nous le dire wink

manet42 a écrit :

Comment le rétablir dans un dossier protégé ?


Je ne suis pas certain que ça soit la méthode orthodoxe mais tu peux déjà recréer le lien et voir si ca se reproduit. Tu peux aussi vérifier l'existance d'un lien tel que ci-après dans /etc/alternatives:

$ ls -l /etc/alternatives/


[...]
lrwxrwxrwx 1 root root  20 juin  27  2016 x-www-browser -> /usr/bin/firefox-esr



Dans tous les cas, tenter de "protéger" le fichier disparu ne me paraît pas indiqué, je suppute que ça risque de casser des mécanismes de mise à jour qui devraient normalement pouvoir intervenir sur ce fichier.

Dernière modification par tux12 (10-03-2021 00:56:30)


Tout est un sauf zéro. - Wau Holland

Hors ligne

#6 10-03-2021 11:17:54

manet42
Membre
Lieu : Lorraine
Distrib. : Stretch 9 et Buster
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU GeneWeb et localhost

Je n'ai rien fait de particulier , à part les mises à jour auto...

Pas de x-www-browser dans la liste de /etc/alternatives/ !

Je vais tenter une mise à jour avec apt-get update et dist-upgrade.

Si ça ne marche pas, je passerai par localhost pour accéder à Geneweb..ça ne fait qu'une manip en plus...

Dernière modification par manet42 (10-03-2021 11:18:25)


Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 2 GO, 533 Mhz avec Stretch i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch  DDext et Win 7 DD int en dual boot.+ Buster sur HP Compaq.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#7 10-03-2021 13:19:47

manet42
Membre
Lieu : Lorraine
Distrib. : Stretch 9 et Buster
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU GeneWeb et localhost

Mise à jour faite;;;
Changement de version pour Firefox...
Même problème...
Donc abandon..

Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 2 GO, 533 Mhz avec Stretch i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch  DDext et Win 7 DD int en dual boot.+ Buster sur HP Compaq.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#8 10-03-2021 17:00:43

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : RESOLU GeneWeb et localhost

Hmm je n'ai pas de Buster sous la main, mais sur le site debian le package firefox-esr est en version 78.8.0 et tu nous indiques utiliser une version 86.0 dans ton premier post.

Donnes nous le retour d'un

aptitude search firefox | grep ^i



Edit: aptitude n'est sans doute pas installé par défaut sur le système. Je cherche en fait à savoir si tu as installé Firefox autrement que par apt* depuis les dépôts, ce qui pourrait expliquer l'absence des liens /usr/bin/x-www-browser et /etc/alternatives/x-www-browser.

Dernière modification par tux12 (10-03-2021 18:12:58)


Tout est un sauf zéro. - Wau Holland

Hors ligne

#9 11-03-2021 16:16:39

manet42
Membre
Lieu : Lorraine
Distrib. : Stretch 9 et Buster
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU GeneWeb et localhost

Le portable utilise  Stretch.
Non aptitude n'est pas installé;
Depuis le non fonctionnement, sur le site de mozilla j"ai téléchargé et installé "firefox-86.0.1.tar.bz2" pour 32 bits.

Avec Synaptic je ne trouve que:
-firefox-esr-dev  52.9.0esr.1 Développement files.....
-firefox-esr |10n-fr  78.7.0esr 1 localisation française..

Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 2 GO, 533 Mhz avec Stretch i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch  DDext et Win 7 DD int en dual boot.+ Buster sur HP Compaq.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#10 11-03-2021 22:59:12

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : RESOLU GeneWeb et localhost

manet42 a écrit :

sur le site de mozilla j"ai téléchargé et installé "firefox-86.0.1.tar.bz2"


Ok, un début de piste donc, même si tu dis que le problème à commencé avant l'installation de ce paquet.
La gestion des "alternatives", et donc des liens x-www-browser évoqués précédemment, étant si je ne m'abuse gérés par le système d'installation, l'installation d'un paquet qui n'est pas intégré à la disitribution n'assure donc pas la gestion de ces liens. Ça ne nous explique pas pourquoi les liens ont disparus (possiblement lors de la désinstallation du paquet fourni par la distro?) mais me confirme dans l'idée qu'il doit suffire de recréer un lien x-www-browser pointant vers le binaire firefox présent pour retrouver le fonctionnement de GeneWeb. Tu peux toujours essayer, ça ne risque rien.


Tout est un sauf zéro. - Wau Holland

Hors ligne

#11 12-03-2021 10:32:00

manet42
Membre
Lieu : Lorraine
Distrib. : Stretch 9 et Buster
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU GeneWeb et localhost

Merci! mais voilà n'étant pas expert, je ne sais pas recréer un lien dans /etc/alternatives/
C'est un dossier protégé.
Pour l'instant j'utilise geneweb en passant par localhost que j'ai mis dans mes favoris !

Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 2 GO, 533 Mhz avec Stretch i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch  DDext et Win 7 DD int en dual boot.+ Buster sur HP Compaq.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#12 12-03-2021 15:11:47

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : RESOLU GeneWeb et localhost

Re,

Je suggère de ne pas toucher à /etc/alternatives et de se contenter de créer le lien demandé au lancement de GeneWeb.
Pour ce faire, considérant que firefox se trouve en /usr/bin/,

ln -s /usr/bin/firefox /usr/bin/x-www-browser



Pour savoir ou se trouve le binaire firefox

whereis firefox


Tout est un sauf zéro. - Wau Holland

Hors ligne

#13 13-03-2021 11:54:01

manet42
Membre
Lieu : Lorraine
Distrib. : Stretch 9 et Buster
Noyau : i 386 et amd 64 + Win 7
(G)UI : Xfce
Inscription : 30-06-2017

Re : RESOLU GeneWeb et localhost

Encore merci !!
En fait pas de firefox à la commande "whereis" !!
J'ai donc supprimé ce firefox 86.0 venu du  site Mozilla et utilisé. J'ai installé celui des dépôts  avec la commande suivante:

apt-get install firefox-esr firefox-esr-l10n-fr



Tout fonctionne y compris Geneweb yes.gifyes.gifyes.gif

Cordialement.

Dernière modification par manet42 (14-03-2021 11:09:58)


Vieux HP 510; Intel Pentium M 2,26 Ghz; Memoire: 2 GO, 533 Mhz avec Stretch i386 + PC bureau H81M-S1, Intel Pentium cpu G342O 3,2 Ghz- Memoire  4 Go : Stretch  DDext et Win 7 DD int en dual boot.+ Buster sur HP Compaq.
En essayant continuellement, on finit par réussir. Donc plus ça rate, plus on a de chance que ça marche

Hors ligne

#14 14-03-2021 00:06:57

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : RESOLU GeneWeb et localhost

Ok, la commande "whereis" ne cherche en effet que dans les répertoires déclarés dans la variable $PATH. Dans le cas ou firefox est installé ailleurs il faut connaître et préciser son chemin d'accès complet à la création du lien symbolique.

Mais l'installation de la version de firefox packagée dans Buster constitue aussi une alternative valable. Content que ton problème soit résolu smile

Tout est un sauf zéro. - Wau Holland

Hors ligne

Pied de page des forums