Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-03-2021 17:13:25

Herve5
Adhérent(e)
Lieu : mi au Sud mi à Paris, France
Distrib. : Debian 5.10.19-1 (2021-03-02) bullseye sid testing
Noyau : Linux 5.10.0-4-amd64
(G)UI : xfce 4.16
Inscription : 02-03-2019

[résolu (à la dure)] compositeur de fenêtres (X11?) planté

Bonjour à tous,
J'ai un souci : sur ma config Testing avec carte graphique Nvidia séparée, j'ai installé une série de mises à jour, notamment deNVidia mais aussi beaucoup d'autres choses, et au reboot les fenêtres de mon user habituel sont plantées, alors qu'un user secondaire les affiche bien.
J'ai le vague souvenir qu'il doit y avoir un ou des fichiers de conf associé à X dans le dossier user, mais je n'arrive pas à y retrouver mes petits...
Sauriez-vous ce qu'il me faut effacer, au besoin remplacer en provenance de mon user2 avec le chown qui va bien?
Pour être plus précis : les fenêtres n'ont plus de bord (impossible de les déplacer, de les agrandir, d'en changer avec alt-tab), je n'arrive pas à lancer le tableau de bord "gestionnaire des fenêtres", et je n'ai plus qu'un écran virtuel au lieu des quatre habituel. J'ai perdu aussi le fond d'écran.

Merci pour vos conseils!
Je poste ceci dans "système" alors que je me demande si je n'aurais pas dû le mettre dans xfce...
Merci encore!

Dernière modification par Herve5 (15-03-2021 11:15:48)


--
Hervé S.
anciennement, machines de type Clevo (donc pas très solides) sous Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian 11 Xfce

Hors ligne

#2 11-03-2021 19:34:28

robert2a
Membre
Inscription : 15-11-2014

Re : [résolu (à la dure)] compositeur de fenêtres (X11?) planté

Bonjour
j'ai un fichier dans mon /home/robert/  cacher  => .nvidia-settings-rc

j'ai aussi un dossier caché /home/robert/.nv/

sinon je ne vois rien d' autre

Dernière modification par robert2a (11-03-2021 19:40:43)

Hors ligne

#3 11-03-2021 19:47:23

Herve5
Adhérent(e)
Lieu : mi au Sud mi à Paris, France
Distrib. : Debian 5.10.19-1 (2021-03-02) bullseye sid testing
Noyau : Linux 5.10.0-4-amd64
(G)UI : xfce 4.16
Inscription : 02-03-2019

Re : [résolu (à la dure)] compositeur de fenêtres (X11?) planté

robert2a a écrit :


j'ai aussi un dossier caché /home/robert/.nv/


Merci robert2a! J'ai des fichiers semblables; le premier n'a pas bougé depuis janvier et semble juste une description ascii de la config, par contre le dossier .nv comporte des tonnes de choses modifiées hier... Je vais voir ce que me dit mon user2!

[edit] j'ai recopié le .nv de l'user d'à côté dans le mien, mais ça ne marche pas mieux semble-t-il. Et dans l'intervalle j'ai complètement perdu le bureau : Thunar se lance encore dans une fenêtre mais le fond d'écran est juste vide autrement...
[edit2] j'ai vérifié que les fichiers invisibles .Xauthority et .ICEAuthority étaient bien propriété de l'utilisateur (mais je ne les ai pas changés); j'ai aussi supprimé un dossier ".themes" qui contenait des changements d'aspects pour les fenêtres, dont je ne me servais plus et qui de mémoire avaient déjà esquinté l'afficnage l'an dernier. Mais ça ne marche toujours pas.
[edit3] après un second reboot (!) et avoir attendu énormément longtemps entre l'entrée du mot de passe et l'affichage du bureau... ça semble remarcher. En tout cas, les fenêtres sont là, fond d'écran et bureaux virtuels aussi. Je pense que c'est ce foutu dossier .themes. Je vais encore rebooter, car ces trois minutes avant affichage restent fort louches. Mais peut-être était-ce le temps de tout remettre d'équerre la première fois...

[edit3] Eh ben non sad
Après un nouveau reboot, ça foire à nouveau. J'écris ceci depuis user2...

Dernière modification par Herve5 (12-03-2021 09:30:13)


--
Hervé S.
anciennement, machines de type Clevo (donc pas très solides) sous Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian 11 Xfce

Hors ligne

#4 12-03-2021 17:45:30

jarek
Membre
Lieu : Haute Loire
Distrib. : testing
Noyau : linux 5.10 amd64
(G)UI : xfce4 - lightdm
Inscription : 24-06-2014

Re : [résolu (à la dure)] compositeur de fenêtres (X11?) planté

Casse pas la tête !
Les choses finissent par se remettre d'aplomb.

Définitivement pour ce qui est contre et contre ce qui est pour.
Ryzen3 3200G - Asrock B450

Hors ligne

#5 15-03-2021 11:19:00

Herve5
Adhérent(e)
Lieu : mi au Sud mi à Paris, France
Distrib. : Debian 5.10.19-1 (2021-03-02) bullseye sid testing
Noyau : Linux 5.10.0-4-amd64
(G)UI : xfce 4.16
Inscription : 02-03-2019

Re : [résolu (à la dure)] compositeur de fenêtres (X11?) planté

Bon, je m'en suis sorti de façon sordide mais efficace : après un n-ième reboot foireux, et un login sous l'user2 (bénie soit cette idée de créer un user2 juste comme ça!!), j'ai effacé en sudo TOUTES les préférences invisibles de mon user qui plantait, dossiers et fichiers, qui avaient été modifiées depuis la veille.
Je ne vous dis pas l'impact, il y a un certain nombre d'applications qui s'en remettent mal, comme Telegram (bien fait pour lui, de toute façon moi c'est Jami et Signal), et il faut refaire lanceurs, fonds d'écran etc.
Mais au moins, tout est nettoyé, et ça marche vite big_smile

--
Hervé S.
anciennement, machines de type Clevo (donc pas très solides) sous Ubuntu 16LTS, plus depuis peu un beau Lenovo Thinkpad P53 sous Debian 11 Xfce

Hors ligne

Pied de page des forums