Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-03-2021 17:53:53

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Bizarreries sur nouvelle install 10.8

Bonjour à toutes et tous,

depuis l'install récente de la 10.8 des évènements curieux se sont produits.

D'abord, j'en ai ch... pour installer. J'ai dû passer par la console rescue pour résoudre des problèmes de microcode.

Ensuite, après "stabilisation" du système, il m'est arrivé des trucs bizarres comme : impossible de remplir le champ du mot de passe après le boot, pas d'écho à l'écran.

Une autre fois, j'ai entré à 3 reprises mon mot de passe qui est... ben non, je vais pas le donner ici lol et 3 fois de suite, je me suis fait jeter.

Tout ça n'est pas très grave, un reboot a réglé le problème mais je suis confronté à un autre truc, plus sérieux.

Veracrypt, qui m'est indispensable et que j'ai installé sur toutes mes partitions bootables, affiche dans Nautilus des signes cabalistiques en lieu et place des lettres accentuées... C'est un problème d'UTF, je sais, mais comment le régler ?

A noter que je n'ai jamais eu ça nulle part, même pas sous Win-daube. Faute de mieux, je désinstallerai avec l'option "purge" et réinstallerai ensuite mais je préférerais comprendre ce qui se passe d'abord.

Merci d'avance pour vos contributions (directes et indirectes out.gif )

Dernière modification par Old tired coder (26-03-2021 15:12:21)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#2 17-03-2021 18:18:38

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : Bizarreries sur nouvelle install 10.8

Old tired coder a écrit :

impossible de remplir le champ du mot de passe après le boot, pas d'écho à l'écran.

Une autre fois, j'ai entré à 3 reprises mon mot de passe qui est... ben non, je vais pas le donner ici lol et 3 fois de suite, je me suis fait jeter.



Bonjour, Si j'ai bien compris tu n'arrives pas à te connecter à ta session quand tu rentres le mot de passe dans le gestionnaire de session ou Display Manager ?

Si c'est bien ça, dis-moi quel gestionnaire de session tu utilises ?

Car j'ai rencontré le même problème avec lightdm

Il suffit donc changer de gestionnaire de session en choisissant parmi ceux là sauf lightdm bien sure smile : https://wiki.debian.org/DisplayManager

Donc tu installes un autre Gestionnaire de session avec la commande:

apt install <nom_du_paquet>

Dernière modification par Jean-Pierre Pinson (17-03-2021 18:21:33)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#3 17-03-2021 18:52:54

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

En fait, mon post est un peu brouillon...

Les problèmes de boot ne sont pas récurrents. Il y a peut-être une cause matérielle mais dans ce cas, il s'agirait d'une panne intermittente, donc difficile à identifier.

Ce que je dois résoudre, c'est la question de l'affichage des noms de dossier et de fichier sous Veracrypt. En lecture, RAB mais je ne peux plus écrire, ça foutrait le Bronx.

Dernière modification par Old tired coder (28-03-2021 22:22:38)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#4 17-03-2021 19:00:20

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Bizarreries sur nouvelle install 10.8

Bonjour,

Et si tu lis ces dossiers et fichiers depuis un terminal/console, tu as aussi des caractères hiéroglyphiques ?

EDIT: un sujet qui ressemble à ton souci : https://debian-facile.org/viewtopic.php?id=19553

EDIT2: oups - rajout politesse de courtoisie (bonjour) - rarement omis de ma part.

Dernière modification par Tawal (18-03-2021 10:16:14)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#5 18-03-2021 10:41:56

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Tawal a écrit :

Bonjour,

Et si tu lis ces dossiers et fichiers depuis un terminal/console, tu as aussi des caractères hiéroglyphiques ?

EDIT: un sujet qui ressemble à ton souci : https://debian-facile.org/viewtopic.php?id=19553

EDIT2: oups - rajout politesse de courtoisie (bonjour) - rarement omis de ma part.



Bonjour,

Je n'ai pas essayé de lire avec le terminal des fichiers cryptés, ça ne fonctionnerait pas et puis je ne fais pas d'essais sur des données importantes.
Le problème de @galinette était différent, je ne rencontre ce problème qu’avec Veracrypt.
Le jour où j'ai téléchargé ce paquet, le site officiel était en rideau. Du coup, j'ai pompé le paquet sur un torrent.

J'ai vu qu'une version spéciale Debian 10 a été faite, je suppose que l'auteur aura corrigé ce bug dedans. Donc ça va être désinstall avec purge et réinstall propre... Faire et défaire, l'activité principale du programmagitateur kernal_panic.gif

[EDIT:]
J'ai installé proprement le paquet :
veracrypt-1.24-Update7-Debian-10-amd64.deb
trouvé sur le miroir du site officiel mais c'est exactement pareil...
[/EDIT:]

Dernière modification par Old tired coder (18-03-2021 11:16:02)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#6 18-03-2021 11:20:18

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Bizarreries sur nouvelle install 10.8

Bonjour,

Old tired coder a écrit :

Je n'ai pas essayé de lire avec le terminal des fichiers cryptés, ça ne fonctionnerait pas et puis je ne fais pas d'essais sur des données importantes.


Ah oui, j'ai zappé le coté crypté. Sorry.
Quand je disais "lire ces fichiers/dossiers", je parlais juste d'un listage, donc sans danger sur les données.

En fait, si ce ne sont que les noms de fichiers/dossiers cryptés qui posent problème avec les caractères "spéciaux", je pense que c'est Veracrypt le responsable de la "mauvaise" interprétation de ces caractères.
Ce n'est pas un problème d'UTF... (ou jeu de caractères) du système mais plutôt, comme tu l'as identifié, un souci lié à Veracrypt qui ne possède pas le bon jeu de caractères.

Au plaisir.

Dernière modification par Tawal (18-03-2021 11:20:38)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#7 18-03-2021 11:31:46

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Tawal a écrit :

Bonjour,


Quand je disais "lire ces fichiers/dossiers", je parlais juste d'un listage, donc sans danger sur les données.

En fait, si ce ne sont que les noms de fichiers/dossiers cryptés qui posent problème avec les caractères "spéciaux", je pense que c'est Veracrypt le responsable de la "mauvaise" interprétation de ces caractères.
Ce n'est pas un problème d'UTF... (ou jeu de caractères) du système mais plutôt, comme tu l'as identifié, un souci lié à Veracrypt qui ne possède pas le bon jeu de caractères.

Au plaisir.



Re,

Oui mais dans ce cas, pourquoi Veracrypt 1.24 Update7 tourne au poil sous Ubuntu 20 et Windows 10 ?

Je pense plutôt à une dépendance codée avec les genoux par un développeur sous acide big_smile

Je soupçonne ce paquet :
libwxbase3.0-0v5_3.0.4+dfsg-8_amd64.deb
de foutre le Bronx.

La façon dont Veracrypt organise ses données rend toute exploration "normale" des dossiers cryptés impossible.

Dernière modification par Old tired coder (18-03-2021 11:38:00)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#8 18-03-2021 12:33:28

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Bizarreries sur nouvelle install 10.8

Old tired coder a écrit :

Oui mais dans ce cas, pourquoi Veracrypt 1.24 Update7 tourne au poil sous Ubuntu 20 et Windows 10 ?

Je ne saurais te répondre.

Old tired coder a écrit :

Je pense plutôt à une dépendance codée avec les genoux par un développeur sous acide big_smile

Tu as certainement raison. Même s'il a comme "Loulou mis de l'eau dedans" (Cf Thiéfaine), la réflexion en est largement altérée big_smile


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#9 18-03-2021 13:22:54

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Tawal a écrit :

Old tired coder a écrit :

Oui mais dans ce cas, pourquoi Veracrypt 1.24 Update7 tourne au poil sous Ubuntu 20 et Windows 10 ?

Je ne saurais te répondre.

Old tired coder a écrit :

Je pense plutôt à une dépendance codée avec les genoux par un développeur sous acide big_smile

Tu as certainement raison. Même s'il a comme "Loulou mis de l'eau dedans" (Cf Thiéfaine), la réflexion en est largement altérée big_smile



J'ai trouvé cette page d'informations sur ce paquet. J'ai noté 2 bizarreries :
1) le paquet n'a pas été releasé depuis 2019
2) et surtout, il est dit qu'il n'est d'aucune utilité en gui... C'est curieux, Veracrypt version gui le réclame.

J'avoue que je suis un peu perdu, là.

Thiéfaine c'est cool : la fille du coupeur de joints, alligators 427, affaire Rimbaud, la cancoillotte, l'ascenseur de 22H43...

Dernière modification par Old tired coder (18-03-2021 13:43:42)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#10 18-03-2021 13:59:09

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Bizarreries sur nouvelle install 10.8

Pour moi la bizarrerie, c'est l’inutilité pour les  GUI.
Le fait qu'il ne soit pas "releasé" depuis un moment indique soit un paquet obsolète soit un vieux paquet solide.

Par contre le paquet libwxbase3.0-0v5_3.0.4+dfsg-8_amd64.deb n'est pas dans les dépôts officiels (pour Debian stable).
Tandis que le paquet libwxbase3.0-0v5 l'est.

Même si je ne vois pas trop le rapport de ce paquet avec ton souci, je te conseillerai de revenir à une version des dépôts.

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#11 18-03-2021 14:56:33

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Tawal a écrit :

Pour moi la bizarrerie, c'est l’inutilité pour les  GUI.
Le fait qu'il ne soit pas "releasé" depuis un moment indique soit un paquet obsolète soit un vieux paquet solide.

Par contre le paquet libwxbase3.0-0v5_3.0.4+dfsg-8_amd64.deb n'est pas dans les dépôts officiels (pour Debian stable).
Tandis que le paquet libwxbase3.0-0v5 l'est.

Même si je ne vois pas trop le rapport de ce paquet avec ton souci, je te conseillerai de revenir à une version des dépôts.



L'absence de release récente est une bizarrerie au sens où je devrais avoir le même problème avec Ubuntu qui est une installation récente aussi.

Voici mon sources.list :

# deb cdrom:[Debian GNU/Linux 10.8.0 _Buster_ - Unofficial amd64 NETINST with firmware 20210206-10:38]/ buster contrib main non-free

# deb cdrom:[Debian GNU/Linux 10.8.0 _Buster_ - Unofficial amd64 NETINST with firmware 20210206-10:38]/ buster contrib main non-free

deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free #Added by software-properties

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free #Added by software-properties

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free #Added by software-properties

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 

.

Je n'y vois rien d'anormal...

Donc ce paquet vient bien des dépôts Debian.

Bon : foutu pour foutu, je vais tenter de "forcer" son remplacement par libwxbase3.0-0v5.deb en espérant que ça ne fasse pas couiner Veracrypt.

[EDIT:]
Bon, j'ai eu le fin mot de l'histoire. J'ai fait :

sudo apt-get remove libwxbase3.0-0v5_3.0.4+dfsg-8_amd64


et je me suis fait jeter. Par contre, avec :

sudo apt-get remove libwxbase3.0-0v5


la désinstall de 3 paquets m'est proposée... ce que j'ai refusé, naturellement.
Donc, on appelle ce paquet par la racine de son nom et apt installera la bonne version.
[/EDIT:]

Dernière modification par Old tired coder (18-03-2021 16:52:39)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#12 18-03-2021 15:40:54

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Bizarreries sur nouvelle install 10.8

Et pourtant :
Debian Package - libwxbase3.0-0v5_3.0.4+dfsg-8_amd64


Oups : https://packages.debian.org/search?suit … ase3.0-0v5

Edit:

Old tired coder a écrit :

L'absence de release récente est une bizarrerie au sens où je devrais avoir le même problème avec Ubuntu

sauf si ce n'est pas ce paquet qui est en cause ...
Car je ne vois toujours pas de rapport avec ce paquet et le souci de caractères.

Dernière modification par Tawal (18-03-2021 15:55:18)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#13 18-03-2021 17:08:27

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Tawal a écrit :

Et pourtant :
Debian Package - libwxbase3.0-0v5_3.0.4+dfsg-8_amd64


Oups : https://packages.debian.org/search?suit … ase3.0-0v5

Edit:

Old tired coder a écrit :

L'absence de release récente est une bizarrerie au sens où je devrais avoir le même problème avec Ubuntu

sauf si ce n'est pas ce paquet qui est en cause ...
Car je ne vois toujours pas de rapport avec ce paquet et le souci de caractères.



C'est exactement ce que je pense aussi. J'avais pas vu ton dernier post, j'ai donc édité mon précédent message.

Je crois qu'il faut chercher ailleurs mais où ?

Je suis prêt à parier le contenu de ton livret A contre celui de mon compte en Suiiiiiiiiiiiiiiiiiiiiiiiiiisse cool que le paquet Veracrypt est sain aussi.

Là, j’atteins les limites de mes connaissances système, peut-être une dépendance présente avant l'install du paquet Veracrypt et qui serait par conséquent transparente ? Je vais essayer de lister toutes les dépendances nécessaires à ce soft.

Bon, c'est fait avec apt-depends, mais quel bazard ! 718 lignes :

veracrypt
  Depends: dmsetup
  Depends: libfuse2
  Depends: libwxgtk3.0-gtk3-0v5
  Depends: sudo
dmsetup
  Depends: libc6 (>= 2.14)
  Depends: libdevmapper1.02.1 (>= 2:1.02.138)
libc6
  Depends: libgcc1
libgcc1
  Depends: gcc-8-base (= 8.3.0-6)
  Depends: libc6 (>= 2.14)
gcc-8-base
libdevmapper1.02.1
  Depends: dmsetup (>= 2:1.02.155-3)
  Depends: libblkid1 (>= 2.16)
  Depends: libc6 (>= 2.28)
  Depends: libselinux1 (>= 1.32)
  Depends: libudev1 (>= 183)
libblkid1
  Depends: libc6 (>= 2.25)
  Depends: libuuid1 (>= 2.16)
libuuid1
  Depends: libc6 (>= 2.25)
libselinux1
  Depends: libc6 (>= 2.14)
  Depends: libpcre3
libpcre3
  Depends: libc6 (>= 2.14)
libudev1
  Depends: libc6 (>= 2.28)
libfuse2
  Depends: libc6 (>= 2.28)
libwxgtk3.0-gtk3-0v5
  Depends: libc6 (>= 2.15)
  Depends: libcairo2 (>= 1.10.0)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libgdk-pixbuf2.0-0 (>= 2.22.0)
  Depends: libgl1
  Depends: libglib2.0-0 (>= 2.33.14)
  Depends: libgtk-3-0 (>= 3.19.12)
  Depends: libjpeg62-turbo (>= 1.3.1)
  Depends: libnotify4 (>= 0.7.0)
  Depends: libpango-1.0-0 (>= 1.18.0)
  Depends: libpangocairo-1.0-0 (>= 1.14.0)
  Depends: libpng16-16 (>= 1.6.2-1)
  Depends: libsm6
  Depends: libstdc++6 (>= 5.2)
  Depends: libtiff5 (>= 4.0.3)
  Depends: libwxbase3.0-0v5 (>= 3.0.4+dfsg)
  Depends: libx11-6
  Depends: libxxf86vm1
libcairo2
  Depends: libc6 (>= 2.14)
  Depends: libfontconfig1 (>= 2.12.6)
  Depends: libfreetype6 (>= 2.9.1)
  Depends: libpixman-1-0 (>= 0.30.0)
  Depends: libpng16-16 (>= 1.6.2-1)
  Depends: libx11-6
  Depends: libxcb-render0
  Depends: libxcb-shm0
  Depends: libxcb1 (>= 1.6)
  Depends: libxext6
  Depends: libxrender1
  Depends: zlib1g (>= 1:1.1.4)
libfontconfig1
  Depends: fontconfig-config (>= 2.13.1-2)
  Depends: libc6 (>= 2.14)
  Depends: libexpat1 (>= 2.0.1)
  Depends: libfreetype6 (>= 2.3.9)
  Depends: libuuid1 (>= 2.16)
fontconfig-config
  Depends: debconf (>= 0.5)
  Depends: debconf-2.0
  Depends: fonts-dejavu-core
  Depends: fonts-freefont
  Depends: fonts-liberation
  Depends: ttf-bitstream-vera
  Depends: ucf (>= 0.29)
debconf
  PreDepends: perl-base (>= 5.20.1-3~)
perl-base
  PreDepends: dpkg (>= 1.17.17)
  PreDepends: libc6 (>= 2.28)
dpkg
  Depends: tar (>= 1.28-1)
  PreDepends: libbz2-1.0
  PreDepends: libc6 (>= 2.15)
  PreDepends: liblzma5 (>= 5.2.2)
  PreDepends: libselinux1 (>= 2.3)
  PreDepends: zlib1g (>= 1:1.1.4)
tar
  PreDepends: libacl1 (>= 2.2.23)
  PreDepends: libc6 (>= 2.17)
  PreDepends: libselinux1 (>= 1.32)
libacl1
  Depends: libattr1 (>= 1:2.4.46-8)
  Depends: libc6 (>= 2.14)
libattr1
  Depends: libc6 (>= 2.4)
libbz2-1.0
  Depends: libc6 (>= 2.4)
liblzma5
  Depends: libc6 (>= 2.17)
zlib1g
  Depends: libc6 (>= 2.14)
debconf-2.0
fonts-dejavu-core
fonts-freefont
fonts-liberation
ttf-bitstream-vera
ucf
  Depends: coreutils (>= 5.91)
  Depends: debconf (>= 1.5.19)
  Depends: sensible-utils
coreutils
  PreDepends: libacl1 (>= 2.2.23)
  PreDepends: libattr1 (>= 1:2.4.44)
  PreDepends: libc6 (>= 2.28)
  PreDepends: libselinux1 (>= 2.1.13)
sensible-utils
libexpat1
  Depends: libc6 (>= 2.25)
libfreetype6
  Depends: libc6 (>= 2.14)
  Depends: libpng16-16 (>= 1.6.2-1)
  Depends: zlib1g (>= 1:1.1.4)
libpng16-16
  Depends: libc6 (>= 2.14)
  Depends: zlib1g (>= 1:1.2.11.dfsg)
libpixman-1-0
  Depends: libc6 (>= 2.14)
libx11-6
  Depends: libc6 (>= 2.15)
  Depends: libx11-data
  Depends: libxcb1 (>= 1.11.1)
libx11-data
libxcb1
  Depends: libc6 (>= 2.14)
  Depends: libxau6
  Depends: libxdmcp6
libxau6
  Depends: libc6 (>= 2.4)
libxdmcp6
  Depends: libbsd0 (>= 0.2.0)
  Depends: libc6 (>= 2.4)
libbsd0
  Depends: libc6 (>= 2.25)
libxcb-render0
  Depends: libc6 (>= 2.14)
  Depends: libxcb1 (>= 1.8)
libxcb-shm0
  Depends: libc6 (>= 2.4)
  Depends: libxcb1 (>= 1.12)
libxext6
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
libxrender1
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
libgdk-pixbuf2.0-0
  Depends: libc6 (>= 2.14)
  Depends: libgdk-pixbuf2.0-common (= 2.38.1+dfsg-1)
  Depends: libglib2.0-0 (>= 2.48.0)
  Depends: libjpeg62-turbo (>= 1.3.1)
  Depends: libpng16-16 (>= 1.6.2-1)
  Depends: libtiff5 (>= 4.0.3)
  Depends: libx11-6
  Depends: shared-mime-info
libgdk-pixbuf2.0-common
libglib2.0-0
  Depends: libc6 (>= 2.28)
  Depends: libffi6 (>= 3.0.4)
  Depends: libmount1 (>= 2.28)
  Depends: libpcre3
  Depends: libselinux1 (>= 1.32)
  Depends: zlib1g (>= 1:1.2.2)
libffi6
  Depends: libc6 (>= 2.14)
libmount1
  Depends: libblkid1 (>= 2.17.2)
  Depends: libc6 (>= 2.25)
  Depends: libselinux1 (>= 2.6-3~)
libjpeg62-turbo
  Depends: libc6 (>= 2.14)
libtiff5
  Depends: libc6 (>= 2.14)
  Depends: libjbig0 (>= 2.0)
  Depends: libjpeg62-turbo (>= 1.3.1)
  Depends: liblzma5 (>= 5.1.1alpha+20120614)
  Depends: libwebp6 (>= 0.5.1)
  Depends: libzstd1 (>= 1.3.2)
  Depends: zlib1g (>= 1:1.1.4)
libjbig0
  Depends: libc6 (>= 2.4)
libwebp6
  Depends: libc6 (>= 2.14)
libzstd1
  Depends: libc6 (>= 2.14)
shared-mime-info
  Depends: libc6 (>= 2.14)
  Depends: libglib2.0-0 (>= 2.35.9)
  Depends: libxml2 (>= 2.7.4)
libxml2
  Depends: libc6 (>= 2.28)
  Depends: libicu63 (>= 63.1-1~)
  Depends: liblzma5 (>= 5.1.1alpha+20120614)
  Depends: zlib1g (>= 1:1.2.3.3)
libicu63
  Depends: libc6 (>= 2.14)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libstdc++6 (>= 5.2)
libstdc++6
  Depends: gcc-8-base (= 8.3.0-6)
  Depends: libc6 (>= 2.18)
  Depends: libgcc1 (>= 1:4.2)
libgl1
  Depends: libc6 (>= 2.14)
  Depends: libglvnd0 (= 1.1.0-1)
  Depends: libglx0 (= 1.1.0-1)
libglvnd0
  Depends: libc6 (>= 2.14)
libglx0
  Depends: libc6 (>= 2.14)
  Depends: libglvnd0 (= 1.1.0-1)
  Depends: libglx-mesa0
  Depends: libx11-6 (>= 2:1.4.99.1)
  Depends: libxext6
libglx-mesa0
  Depends: libc6 (>= 2.28)
  Depends: libdrm2 (>= 2.4.75)
  Depends: libexpat1 (>= 2.0.1)
  Depends: libgl1-mesa-dri
  Depends: libglapi-mesa (= 18.3.6-2+deb10u1)
  Depends: libx11-6 (>= 2:1.4.99.1)
  Depends: libx11-xcb1
  Depends: libxcb-dri2-0 (>= 1.8)
  Depends: libxcb-dri3-0 (>= 1.13)
  Depends: libxcb-glx0 (>= 1.8)
  Depends: libxcb-present0
  Depends: libxcb-sync1
  Depends: libxcb1 (>= 1.9.2)
  Depends: libxdamage1 (>= 1:1.1)
  Depends: libxext6
  Depends: libxfixes3
  Depends: libxshmfence1
  Depends: libxxf86vm1
libdrm2
  Depends: libc6 (>= 2.17)
  Depends: libdrm-common (>= 2.4.97-1)
libdrm-common
libgl1-mesa-dri
  Depends: libc6 (>= 2.28)
  Depends: libdrm-amdgpu1 (>= 2.4.90)
  Depends: libdrm-intel1 (>= 2.4.38)
  Depends: libdrm-nouveau2 (>= 2.4.66)
  Depends: libdrm-radeon1 (>= 2.4.31)
  Depends: libdrm2 (>= 2.4.75)
  Depends: libelf1 (>= 0.142)
  Depends: libexpat1 (>= 2.0.1)
  Depends: libgcc1 (>= 1:3.4)
  Depends: libglapi-mesa
  Depends: libllvm7 (>= 1:7~svn298832-1~)
  Depends: libsensors5 (>= 1:3.5.0)
  Depends: libstdc++6 (>= 5.2)
  Depends: zlib1g (>= 1:1.1.4)
libdrm-amdgpu1
  Depends: libc6 (>= 2.28)
  Depends: libdrm2 (>= 2.4.89)
libdrm-intel1
  Depends: libc6 (>= 2.17)
  Depends: libdrm2 (>= 2.4.38)
  Depends: libpciaccess0
libpciaccess0
  Depends: libc6 (>= 2.7)
  Depends: zlib1g (>= 1:1.1.4)
libdrm-nouveau2
  Depends: libc6 (>= 2.14)
  Depends: libdrm2 (>= 2.4.38)
libdrm-radeon1
  Depends: libc6 (>= 2.4)
  Depends: libdrm2 (>= 2.4.38)
libelf1
  Depends: libc6 (>= 2.16)
  Depends: zlib1g (>= 1:1.1.4)
libglapi-mesa
  Depends: libc6 (>= 2.14)
libllvm7
  Depends: libc6 (>= 2.15)
  Depends: libedit2 (>= 2.11-20080614-0)
  Depends: libffi6 (>= 3.0.4)
  Depends: libgcc1 (>= 1:3.3)
  Depends: libstdc++6 (>= 6)
  Depends: libtinfo6 (>= 6)
  Depends: zlib1g (>= 1:1.2.0)
libedit2
  Depends: libbsd0 (>= 0.0)
  Depends: libc6 (>= 2.14)
  Depends: libtinfo6 (>= 6)
libtinfo6
  Depends: libc6 (>= 2.16)
libsensors5
  Depends: libc6 (>= 2.14)
  Depends: libsensors-config
libsensors-config
libx11-xcb1
  Depends: libc6 (>= 2.2.5)
libxcb-dri2-0
  Depends: libc6 (>= 2.4)
  Depends: libxcb1
libxcb-dri3-0
  Depends: libc6 (>= 2.4)
  Depends: libxcb1 (>= 1.12)
libxcb-glx0
  Depends: libc6 (>= 2.4)
  Depends: libxcb1
libxcb-present0
  Depends: libc6 (>= 2.4)
  Depends: libxcb1
libxcb-sync1
  Depends: libc6 (>= 2.14)
  Depends: libxcb1
libxdamage1
  Depends: libc6 (>= 2.4)
  Depends: libx11-6 (>= 2:1.4.99.1)
  Depends: libxfixes3
libxfixes3
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
libxshmfence1
  Depends: libc6 (>= 2.27)
libxxf86vm1
  Depends: libc6 (>= 2.4)
  Depends: libx11-6 (>= 2:1.6.0)
  Depends: libxext6
libgtk-3-0
  Depends: adwaita-icon-theme
  Depends: hicolor-icon-theme
  Depends: libatk-bridge2.0-0 (>= 2.5.3)
  Depends: libatk1.0-0 (>= 2.15.1)
  Depends: libc6 (>= 2.14)
  Depends: libcairo-gobject2 (>= 1.10.0)
  Depends: libcairo2 (>= 1.14.0)
  Depends: libcolord2 (>= 0.1.10)
  Depends: libcups2 (>= 1.6.0)
  Depends: libepoxy0 (>= 1.4.3)
  Depends: libfontconfig1 (>= 2.12.6)
  Depends: libfreetype6 (>= 2.2.1)
  Depends: libgdk-pixbuf2.0-0 (>= 2.30.1)
  Depends: libglib2.0-0 (>= 2.55.2)
  Depends: libgtk-3-common (>= 3.24.5-1)
  Depends: libharfbuzz0b (>= 1.2.6)
  Depends: libjson-glib-1.0-0 (>= 0.12.0)
  Depends: libpango-1.0-0 (>= 1.42.0)
  Depends: libpangocairo-1.0-0 (>= 1.41.0)
  Depends: libpangoft2-1.0-0 (>= 1.41.0)
  Depends: librest-0.7-0 (>= 0.7)
  Depends: libsoup2.4-1 (>= 2.4.0)
  Depends: libwayland-client0 (>= 1.9.91)
  Depends: libwayland-cursor0 (>= 1.9.91)
  Depends: libwayland-egl1 (>= 1.15.0)
  Depends: libx11-6 (>= 2:1.4.99.1)
  Depends: libxcomposite1 (>= 1:0.3-1)
  Depends: libxcursor1 (>> 1.1.2)
  Depends: libxdamage1 (>= 1:1.1)
  Depends: libxext6
  Depends: libxfixes3
  Depends: libxi6 (>= 2:1.2.99.4)
  Depends: libxinerama1
  Depends: libxkbcommon0 (>= 0.5.0)
  Depends: libxml2 (>= 2.6.27)
  Depends: libxrandr2 (>= 2:1.5.0)
  Depends: shared-mime-info
adwaita-icon-theme
  Depends: gtk-update-icon-cache
  Depends: hicolor-icon-theme
  Depends: librsvg2-common
gtk-update-icon-cache
  Depends: libc6 (>= 2.4)
  Depends: libgdk-pixbuf2.0-0 (>= 2.30.0)
  Depends: libglib2.0-0 (>= 2.55.2)
hicolor-icon-theme
librsvg2-common
  Depends: libgdk-pixbuf2.0-0 (>= 2.23.5-2)
  Depends: libglib2.0-0 (>= 2.24.0)
  Depends: librsvg2-2 (= 2.44.10-2.1)
librsvg2-2
  Depends: libc6 (>= 2.18)
  Depends: libcairo2 (>= 1.15.8)
  Depends: libcroco3 (>= 0.6.2)
  Depends: libfontconfig1 (>= 2.12.6)
  Depends: libgcc1 (>= 1:4.2)
  Depends: libgdk-pixbuf2.0-0 (>= 2.25.2)
  Depends: libglib2.0-0 (>= 2.37.3)
  Depends: libpango-1.0-0 (>= 1.38.0)
  Depends: libpangocairo-1.0-0 (>= 1.38.0)
  Depends: libpangoft2-1.0-0 (>= 1.38.0)
  Depends: libxml2 (>= 2.8.0)
libcroco3
  Depends: libc6 (>= 2.14)
  Depends: libglib2.0-0 (>= 2.16.0)
  Depends: libxml2 (>= 2.7.4)
libpango-1.0-0
  Depends: fontconfig (>= 2.1.91)
  Depends: libc6 (>= 2.14)
  Depends: libfribidi0 (>= 1.0.0)
  Depends: libglib2.0-0 (>= 2.55.2)
  Depends: libthai0 (>= 0.1.25)
fontconfig
  Depends: fontconfig-config
  Depends: libc6 (>= 2.4)
  Depends: libfontconfig1 (>= 2.13.0)
  Depends: libfreetype6 (>= 2.2.1)
libfribidi0
  Depends: libc6 (>= 2.3.4)
libthai0
  Depends: libc6 (>= 2.14)
  Depends: libdatrie1 (>= 0.2.0)
  Depends: libthai-data (>= 0.1.10)
libdatrie1
  Depends: libc6 (>= 2.14)
libthai-data
libpangocairo-1.0-0
  Depends: libc6 (>= 2.4)
  Depends: libcairo2 (>= 1.12.10)
  Depends: libfontconfig1 (>= 2.12.6)
  Depends: libfreetype6 (>= 2.2.1)
  Depends: libglib2.0-0 (>= 2.55.2)
  Depends: libpango-1.0-0 (>= 1.37.5)
  Depends: libpangoft2-1.0-0 (>= 1.28.1)
libpangoft2-1.0-0
  Depends: libc6 (>= 2.4)
  Depends: libfontconfig1 (>= 2.13.0)
  Depends: libfreetype6 (>= 2.3.5)
  Depends: libglib2.0-0 (>= 2.55.2)
  Depends: libharfbuzz0b (>= 1.4.2)
  Depends: libpango-1.0-0 (>= 1.42.0)
libharfbuzz0b
  Depends: libc6 (>= 2.14)
  Depends: libfreetype6 (>= 2.9.1)
  Depends: libglib2.0-0 (>= 2.31.8)
  Depends: libgraphite2-3 (>= 1.2.2)
libgraphite2-3
  Depends: libc6 (>= 2.14)
libatk-bridge2.0-0
  Depends: libatk1.0-0 (>= 2.30.0)
  Depends: libatspi2.0-0 (>= 2.9.90)
  Depends: libc6 (>= 2.4)
  Depends: libdbus-1-3 (>= 1.9.14)
  Depends: libglib2.0-0 (>= 2.41.1)
libatk1.0-0
  Depends: libatk1.0-data (>= 2.30.0-2)
  Depends: libc6 (>= 2.4)
  Depends: libglib2.0-0 (>= 2.55.2)
libatk1.0-data
libatspi2.0-0
  Depends: libc6 (>= 2.7)
  Depends: libdbus-1-3 (>= 1.9.14)
  Depends: libglib2.0-0 (>= 2.37.3)
  Depends: libx11-6
libdbus-1-3
  Depends: libc6 (>= 2.17)
  Depends: libsystemd0
libsystemd0
  PreDepends: libc6 (>= 2.28)
  PreDepends: libgcrypt20 (>= 1.8.0)
  PreDepends: liblz4-1 (>= 0.0~r122)
  PreDepends: liblzma5 (>= 5.1.1alpha+20120614)
libgcrypt20
  Depends: libc6 (>= 2.15)
  Depends: libgpg-error0 (>= 1.25)
libgpg-error0
  Depends: libc6 (>= 2.15)
liblz4-1
  Depends: libc6 (>= 2.14)
libcairo-gobject2
  Depends: libcairo2 (>= 1.10.0)
  Depends: libglib2.0-0 (>= 2.14.0)
libcolord2
  Depends: libc6 (>= 2.4)
  Depends: libglib2.0-0 (>= 2.37.3)
  Depends: liblcms2-2 (>= 2.6)
  Depends: libudev1 (>= 196)
liblcms2-2
  Depends: libc6 (>= 2.14)
libcups2
  Depends: libavahi-client3 (>= 0.6.16)
  Depends: libavahi-common3 (>= 0.6.16)
  Depends: libc6 (>= 2.17)
  Depends: libgnutls30 (>= 3.6.6)
  Depends: libgssapi-krb5-2 (>= 1.17)
  Depends: zlib1g (>= 1:1.2.0)
libavahi-client3
  Depends: libavahi-common3 (>= 0.6.22)
  Depends: libc6 (>= 2.4)
  Depends: libdbus-1-3 (>= 1.9.14)
libavahi-common3
  Depends: libavahi-common-data
  Depends: libc6 (>= 2.14)
libavahi-common-data
libgnutls30
  Depends: libc6 (>= 2.25)
  Depends: libgmp10 (>= 2:6.0.0)
  Depends: libhogweed4 (>= 3.4.1~rc1~)
  Depends: libidn2-0 (>= 2.0.0)
  Depends: libnettle6 (>= 3.4~)
  Depends: libp11-kit0 (>= 0.23.11)
  Depends: libtasn1-6 (>= 4.12)
  Depends: libunistring2 (>= 0.9.7)
libgmp10
  Depends: libc6 (>= 2.14)
libhogweed4
  Depends: libc6 (>= 2.14)
  Depends: libgmp10 (>= 2:6.0.0)
  Depends: libnettle6 (= 3.4.1-1)
libnettle6
  Depends: libc6 (>= 2.14)
libidn2-0
  Depends: libc6 (>= 2.14)
  Depends: libunistring2 (>= 0.9.7)
libunistring2
  Depends: libc6 (>= 2.14)
libp11-kit0
  Depends: libc6 (>= 2.26)
  Depends: libffi6 (>= 3.0.4)
libtasn1-6
  Depends: libc6 (>= 2.14)
libgssapi-krb5-2
  Depends: libc6 (>= 2.27)
  Depends: libcom-err2 (>= 1.43.9)
  Depends: libk5crypto3 (>= 1.16)
  Depends: libkeyutils1 (>= 1.4)
  Depends: libkrb5-3 (= 1.17-3+deb10u1)
  Depends: libkrb5support0 (>= 1.15~beta1)
libcom-err2
  Depends: libc6 (>= 2.17)
libk5crypto3
  Depends: libc6 (>= 2.14)
  Depends: libkeyutils1 (>= 1.4)
  Depends: libkrb5support0 (>= 1.16)
libkeyutils1
  Depends: libc6 (>= 2.14)
libkrb5support0
  Depends: libc6 (>= 2.14)
  Depends: libkeyutils1 (>= 1.4)
libkrb5-3
  Depends: libc6 (>= 2.16)
  Depends: libcom-err2 (>= 1.43.9)
  Depends: libk5crypto3 (>= 1.15~beta1)
  Depends: libkeyutils1 (>= 1.5.9)
  Depends: libkrb5support0 (= 1.17-3+deb10u1)
  Depends: libssl1.1 (>= 1.1.0)
libssl1.1
  Depends: debconf (>= 0.5)
  Depends: debconf-2.0
  Depends: libc6 (>= 2.25)
libepoxy0
  Depends: libc6 (>= 2.7)
libgtk-3-common
  Depends: dconf-gsettings-backend
  Depends: gsettings-backend
dconf-gsettings-backend
  Depends: dconf-service (<< 0.30.1-2.1~)
  Depends: libc6 (>= 2.14)
  Depends: libdconf1 (= 0.30.1-2)
  Depends: libglib2.0-0 (>= 2.55.2)
dconf-service
  Depends: dbus-session-bus
  Depends: default-dbus-session-bus
  Depends: libc6 (>= 2.28)
  Depends: libdconf1 (= 0.30.1-2)
  Depends: libglib2.0-0 (>= 2.55.2)
dbus-session-bus
default-dbus-session-bus
libdconf1
  Depends: libc6 (>= 2.14)
  Depends: libglib2.0-0 (>= 2.55.2)
gsettings-backend
libjson-glib-1.0-0
  Depends: libc6 (>= 2.4)
  Depends: libglib2.0-0 (>= 2.41.1)
  Depends: libjson-glib-1.0-common (>= 1.4.4-2)
libjson-glib-1.0-common
librest-0.7-0
  Depends: libc6 (>= 2.4)
  Depends: libglib2.0-0 (>= 2.37.3)
  Depends: libsoup-gnome2.4-1 (>= 2.27.4)
  Depends: libsoup2.4-1 (>= 2.30)
  Depends: libxml2 (>= 2.7.4)
libsoup-gnome2.4-1
  Depends: libc6 (>= 2.4)
  Depends: libglib2.0-0 (>= 2.39.90)
  Depends: libsoup2.4-1 (>= 2.41.90)
libsoup2.4-1
  Depends: glib-networking (>= 2.32.0)
  Depends: libc6 (>= 2.14)
  Depends: libglib2.0-0 (>= 2.39.90)
  Depends: libgssapi-krb5-2 (>= 1.14+dfsg)
  Depends: libpsl5 (>= 0.16.0)
  Depends: libsqlite3-0 (>= 3.5.9)
  Depends: libxml2 (>= 2.7.4)
glib-networking
  Depends: glib-networking-common (>= 2.58.0-2+deb10u2)
  Depends: glib-networking-services (<< 2.58.0-2+deb10u2.1~)
  Depends: gsettings-desktop-schemas
  Depends: libc6 (>= 2.14)
  Depends: libglib2.0-0 (>= 2.55.0)
  Depends: libgnutls30 (>= 3.6.6)
  Depends: libproxy1v5 (>= 0.4.14)
glib-networking-common
glib-networking-services
  Depends: glib-networking-common (>= 2.58.0-2+deb10u2)
  Depends: libc6 (>= 2.4)
  Depends: libglib2.0-0 (>= 2.55.0)
  Depends: libproxy1v5 (>= 0.4.14)
libproxy1v5
  Depends: libc6 (>= 2.14)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libstdc++6 (>= 5.2)
gsettings-desktop-schemas
  Depends: dconf-gsettings-backend
  Depends: gsettings-backend
libpsl5
  Depends: libc6 (>= 2.4)
  Depends: libidn2-0 (>= 0.16)
  Depends: libunistring2 (>= 0.9.7)
libsqlite3-0
  Depends: libc6 (>= 2.28)
libwayland-client0
  Depends: libc6 (>= 2.14)
  Depends: libffi6 (>= 3.0.4)
libwayland-cursor0
  Depends: libc6 (>= 2.14)
  Depends: libwayland-client0 (>= 1.3.92)
libwayland-egl1
  Depends: libc6 (>= 2.2.5)
libxcomposite1
  Depends: libc6 (>= 2.4)
  Depends: libx11-6 (>= 2:1.4.99.1)
libxcursor1
  Depends: libc6 (>= 2.4)
  Depends: libx11-6 (>= 2:1.4.99.1)
  Depends: libxfixes3
  Depends: libxrender1
libxi6
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
  Depends: libxext6
libxinerama1
  Depends: libc6 (>= 2.4)
  Depends: libx11-6 (>= 2:1.6.0)
  Depends: libxext6
libxkbcommon0
  Depends: libc6 (>= 2.17)
  Depends: xkb-data
xkb-data
libxrandr2
  Depends: libc6 (>= 2.14)
  Depends: libx11-6 (>= 2:1.6.0)
  Depends: libxext6
  Depends: libxrender1
libnotify4
  Depends: libc6 (>= 2.7)
  Depends: libgdk-pixbuf2.0-0 (>= 2.22.0)
  Depends: libglib2.0-0 (>= 2.37.3)
libsm6
  Depends: libc6 (>= 2.14)
  Depends: libice6 (>= 1:1.0.0)
  Depends: libuuid1 (>= 2.16)
libice6
  Depends: libbsd0 (>= 0.2.0)
  Depends: libc6 (>= 2.14)
  Depends: x11-common
x11-common
  Depends: lsb-base (>= 1.3-9ubuntu2)
lsb-base
libwxbase3.0-0v5
  Depends: libc6 (>= 2.28)
  Depends: libexpat1 (>= 2.0.1)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libstdc++6 (>= 5.2)
  Depends: zlib1g (>= 1:1.1.4)
sudo
  Depends: libaudit1 (>= 1:2.2.1)
  Depends: libc6 (>= 2.27)
  Depends: libpam-modules
  Depends: libpam0g (>= 0.99.7.1)
  Depends: libselinux1 (>= 1.32)
  Depends: lsb-base
libaudit1
  Depends: libaudit-common (>= 1:2.8.4-3)
  Depends: libc6 (>= 2.14)
  Depends: libcap-ng0 (>= 0.7.9)
libaudit-common
libcap-ng0
  Depends: libc6 (>= 2.8)
libpam-modules
  PreDepends: debconf (>= 0.5)
  PreDepends: debconf-2.0
  PreDepends: libaudit1 (>= 1:2.2.1)
  PreDepends: libc6 (>= 2.27)
  PreDepends: libdb5.3
  PreDepends: libpam-modules-bin (= 1.3.1-5)
  PreDepends: libpam0g (>= 1.3.1)
  PreDepends: libselinux1 (>= 2.1.9)
libdb5.3
  Depends: libc6 (>= 2.17)
libpam-modules-bin
  Depends: libaudit1 (>= 1:2.2.1)
  Depends: libc6 (>= 2.14)
  Depends: libpam0g (>= 0.99.7.1)
  Depends: libselinux1 (>= 1.32)
libpam0g
  Depends: debconf (>= 0.5)
  Depends: debconf-2.0
  Depends: libaudit1 (>= 1:2.2.1)
  Depends: libc6 (>= 2.14)



1er constat : libwxgtk3.0-gtk3-0v5 occupe presque tout le lit. Avec autant de sous-dépendances, je ne serais pas surpris que l'une d'entre elles soit en cause.

L'enfer des dépendances vaut bien celui des DLL chez petit@mou...

Dernière modification par Old tired coder (18-03-2021 18:01:39)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#14 18-03-2021 18:14:39

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : Bizarreries sur nouvelle install 10.8

On incrimine Veracrypt et/ou une dépendance.
J'ai complètement écarté un peu vite un problème au niveau système .
Mais ...

Si ça venait tout simplement des locales ?
Peut-être qu'un

dpkg-reconfigure locales

suffirait (avec les bons choix lors de la reconfiguration)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#15 18-03-2021 18:36:23

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Tawal a écrit :

On incrimine Veracrypt et/ou une dépendance.
J'ai complètement écarté un peu vite un problème au niveau système .
Mais ...

Si ça venait tout simplement des locales ?
Peut-être qu'un

dpkg-reconfigure locales

suffirait (avec les bons choix lors de la reconfiguration)



J'ai reconfiguré les locales mais je doute que ça change quelque chose : toutes les options étaient correctes. (fr-fr, UTF8, le reste je me souviens plus).

Par acquit de conscience, je vais lister mes données cryptées mais il n'y aura pas de changement.

Il me reste 4 solutions :
1) attendre une MAJ
2) rebasculer sur Ubuntu
3) faire tout un micmac sur clé USB pour sauvegarder dans mes données cryptées avec Ubuntu ou Windows
4) attendre qu'un ingénieur système spécialisé dans l'enfer des dépendances intervienne sur ce fil.

En attendant, je vais toujours aller me verser un bourbon : c'est bon pour mon palais old_geek.gif


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#16 26-03-2021 13:37:05

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Et un petit "up"...

Après la MAJ du 25 Mars, j'espérais un retour à la normale mais peau de balle et balai de crin...

Pire : j'ai découvert un autre os dans le potage. Pour pas tout mélanger, j'ouvre un autre topic.

Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#17 26-03-2021 13:53:14

Toulibre
Membre
Lieu : Ganges, Cévennes
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Bizarreries sur nouvelle install 10.8

apt-get install locales-all


????

Dernière modification par Toulibre (26-03-2021 13:53:50)

Hors ligne

#18 26-03-2021 14:17:50

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Mouais... Et pourquoi pas

kill *.*


Avec cette commande BASIC, on pouvait lessiver un disque dans les années 80 sur je ne sais plus trop quel mini-ordinateur...

Donc : ???? aussi.

Parce qu'il y a une chose que je ne ferai jamais : entrer une commande que je ne connais pas dans un terminal sans en avoir exploré les tenants et les aboutissants.

À mon âge, on ne me dit plus "mange ta soupe et tais-toi" comme il y a plus de 60 ans.

[EDIT:]

Finalement, après avoir bien étudié le paquet locales-all, je l'ai installé en surveillant le moniteur système parce que je tiens a garder une bécane rapide malgré son âge : j'ai lu quelque part que ce module est gourmand en mémoire, c'est pas la seule connerie dans le genre.

Avant install paquet locales-all :

2,1 GO de RAM utilisés sur 3,3

Swap file : 0 octet sur 976 MO

Après install :

2,1 GO de RAM utilisés

Swap : 1,3 MO utilisés

Après reboot :

1,8 GO de RAM utilisés

Swap : 0 octet



Mesures effectuées avec mes applis habituelles ouvertes : le renard de feu et ses 10 pages web, l'oiseau d'orage pour les courriels et Nautilus.

Après un dpkg-reconfigure locales et un autre reboot pour faire bonne mesure, nouveau test avec Veracrypt : les signes cabalistiques à la place des lettres accentuées sont toujours là...

Il y a de quoi se la couper et la bouffer entre deux tranches de pain avec de la moutarde kernal_panic.gif

[/EDIT:]

Dernière modification par Old tired coder (27-03-2021 18:06:08)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#19 27-03-2021 22:47:48

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Bon, je vais changer de tactique. Commande :

sudo dmesg |grep -iE "err|fail|warn" > errors.txt
 



Retour :

[    0.113502] ACPI: IRQ0 used by override.
[    0.113506] ACPI: IRQ9 used by override.
[    0.901708] ACPI: EC: interrupt blocked
[    0.902328] ACPI: Using IOAPIC for interrupt routing
[    0.971157] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.971416] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.971679] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.972057] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.972282] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.972446] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.972611] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.972775] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 10 11 12 14 15) *0
[    0.973678] ACPI: EC: interrupt unblocked
[    7.033108] ACPI Warning: SystemIO range 0x0000000000000B00-0x0000000000000B08 conflicts with OpRegion 0x0000000000000B00-0x0000000000000B0F (\_SB.PCI0.SMBS.SMB0) (20180810/utaddress-213)
[    7.179426] sdhci: Copyright(c) Pierre Ossman
[   17.923359] EXT4-fs (sda3): re-mounted. Opts: errors=remount-ro
[   19.510740] acpi_cpufreq: overriding BIOS provided _PSD data
[   19.962390] wdat_wdt: probe of wdat_wdt failed with error -16
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[  394.690943] print_req_error: I/O error, dev sdb, sector 6152
[  394.691066] print_req_error: I/O error, dev sdb, sector 6152
[  394.691080] Buffer I/O error on dev sdb5, logical block 1, async page read
[ 1159.028411] perf: interrupt took too long (2517 > 2500), lowering kernel.perf_event_max_sample_rate to 79250
[ 2410.695961] perf: interrupt took too long (3175 > 3146), lowering kernel.perf_event_max_sample_rate to 63000
[19246.030884] perf: interrupt took too long (3978 > 3968), lowering kernel.perf_event_max_sample_rate to 50250



Commande :

sudo journalctl -ab |grep -iE "err|fail|warn" > errors2.txt



Retour :

mars 27 20:14:37 Aspire-V2-123 tracker-extract[13261]: Could not insert metadata for item "file:///home/thierry/Documents/Dossiers%20class%C3%A9s/~~Repository/Prog_Data/Data%20COM/cgi-bin/dc/data/ecrire/tools/mysql/help/fr/index.html": 10.17: invalid UTF-8 character
mars 27 20:14:37 Aspire-V2-123 tracker-extract[13261]: If the error above is recurrent for the same item/ID, consider running "tracker-extract" in the terminal with the TRACKER_VERBOSITY=3 environment variable, and filing a bug with the additional information



Ce retour est très partiel : j'ai sélectionné les 2 dernières des 21000 et quelques lignes d'erreur quasi-identiques. Apparemment, Tracker n'aime pas indexer mes sources de codage de sites internet... C'est pour ça que je codais toujours sous Windows, il me suffisait ensuite de virer les fichiers de formatage (comme thumbs.db) par FTP en poussant mon travail sur des serveurs de la côte Est des States et au Canada.

La méthode m'a réussi pour le Bluetooth hier, puisque  @èfpé m'a donné l'absolution - la solution, voulais-je écrire, Amen.

J'espère que ça permettra à une âme charitable de m'aider parce que sur Linux, je suis un newbie, mon job commençait avec Apache (.htaccess principalement).

Dernière modification par Old tired coder (27-03-2021 23:15:16)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#20 28-03-2021 00:46:45

Toulibre
Membre
Lieu : Ganges, Cévennes
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Bizarreries sur nouvelle install 10.8

que donne le retour de cette commande ?

locale


en cas s'il faut régénérer (exemple de langue ci-dessous)

locale-gen "en_US.UTF-8"


puis

dpkg-reconfigure locales

Hors ligne

#21 28-03-2021 01:16:20

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Bonsoir @Toulibre et merci de t'intéresser à ce topic.

Retour de locale :

LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
 



J'ai conservé le paquet locales-all pour plus tard, afin de gérer plusieurs langues que je pratique plus ou moins bien. Mais le résultat ci-dessus me semble indiquer qu'il n'est pas nécessaire de régénérer.

Je note que LC_ALL= n'est pas définie : tant mieux, en principe cette constante ne doit pas l'être.

En fonction de ce qui précède, il est inutile de reconfigurer les locales...

En fait, le problème se situe ailleurs, oui, mais où ?

Dernière modification par Old tired coder (28-03-2021 01:18:07)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#22 28-03-2021 01:27:24

Toulibre
Membre
Lieu : Ganges, Cévennes
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Bizarreries sur nouvelle install 10.8

Avec plaisir, je suis tombé sur ça https://bugs.archlinux.org/task/56781, est-ce que cela aurait un rapport avec tes ennuis ?

Hors ligne

#23 28-03-2021 01:50:18

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

Toulibre a écrit :

Avec plaisir, je suis tombé sur ça https://bugs.archlinux.org/task/56781, est-ce que cela aurait un rapport avec tes ennuis ?



Difficile à dire. A priori, je ne crois pas : le disc externe sur lequel se trouve ma partition cryptée est au format NTFS. Et puis no problem avec Windows 10 ni avec Ubuntu 20 et le charset ne correspond pas non plus.

Je suis certain que la solution réside dans un réglage de Debian 10.8 ou de la correction d'un bug dans une dépendance.

Il y a un truc qui m'interpelle : pourquoi Veracrypt a-t-il sorti une version spécifique de son soft pour Debian 10 ? Une version Gui pour AMD 64 portable sur tous les systèmes basés Linux aurait dû suffire.

Je ne vois franchement plus où chercher...

Dernière modification par Old tired coder (28-03-2021 01:51:46)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

#24 28-03-2021 11:24:33

Toulibre
Membre
Lieu : Ganges, Cévennes
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : xfce-thunar
Inscription : 10-08-2020
Site Web

Re : Bizarreries sur nouvelle install 10.8

Quelle est ta version ? il y en a tellement
les issues sont nombreuses aussi
J'oserais à peine te dire d'essayer d'installer la version pour ubuntu qui réglerait peut-être le souci de dépendances que tu évoques.
ou selon si tu utilises la version console ou GUI

apt remove veracrypt-console


redémarrage
télécharges la dernière version veracrypt debian 10
puis

./veracrypt-console-1.24-Update7-Debian-10-amd64.deb .


ou

./veracrypt-1.24-Update7-Debian-10-amd64.deb .

Hors ligne

#25 28-03-2021 11:59:15

Old tired coder
Membre
Lieu : Belgique une fois
Distrib. : Debian 10.9
Noyau : Linux 4.19.0-16-amd64
(G)UI : XFCE
Inscription : 17-03-2021

Re : Bizarreries sur nouvelle install 10.8

J'ai installé cette version, c'est la GUI et sur mes deux autres systèmes, il s'agit toujours de la 1.24-Update7 GUI aussi.

J'ai jeté un œil sur les tickets, ouverts et fermés, je n'ai rien trouvé de comparable à ce problème de charset.

Je vais peut-être tenter une réinstall de la version GUI pour Ubuntu 20, ne serait-ce que pour comparer les dépendances requises.

Pour désinstaller, je préfère utiliser apt --purge autoremove veracrypt pour laisser les lieux dans l'état où je les ai trouvés en arrivant big_smile

Dernière modification par Old tired coder (28-03-2021 12:07:56)


Cordialement,
Thierry
1 - Acer Aspire V5-123 4GB de RAM HD 500GB, dual-boot Ubuntu-Debian
2 - Schneider de très bas de gamme sous Windows 10 - bécane de secours : sans ordi, je meurs hara-kiri.png?1590583466

Hors ligne

Pied de page des forums