Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-04-2021 21:49:52

mito77
Adhérent(e)
Lieu : le mée sur seine
Inscription : 20-04-2021

[tootle] manque des dépendances

bonjour, je ne sais pas encore bien gérer l'installation de logiciel sur Debian buster, j'ai besoin de ces paquets pour installer tootle :

valac libglib-2.0-dev libjson-glib-dev libxml2-dev libgee-0.8-dev libsoup2.4-dev libgtk-3-dev  libhandy-1.0-dev libsecret-1-dev



malheureusement quand j'essaie de les ajouter j'ai droit a ces messages d'erreurs :

$ sudo apt-get install valac libglib-2.0-dev libjson-glib-dev libxml2-dev libgee-0.8-dev libsoup2.4-dev libgtk-3-dev  libhandy-1.0-dev libsecret-1-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libglib-2.0-dev
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libglib-2.0-dev »
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libglib-2.0-dev »
E: Impossible de trouver le paquet libhandy-1.0-dev
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libhandy-1.0-dev »
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libhandy-1.0-dev »



le paquet existe aussi sur flathub, et aussi sur debian unstable ! Mais j'ai peur de passer par ces méthodes ça risquerait de casser des dépendances. Je ne sais pas comment faire cette installation.

Dernière modification par mito77 (20-04-2021 21:50:48)

Hors ligne

#2 21-04-2021 11:06:47

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [tootle] manque des dépendances

Hello

libhandy-1-dev/buster-backports 1.0.0-2~bpo10+1 amd64
  Development files for libhandy
libglib2.0-dev/stable,now 2.58.3-2+deb10u2 amd64  [installé]
  fichiers de développement pour la bibliothèque GLib


est ce que ce serait bon?


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 21-04-2021 12:00:23

robert2a
Membre
Inscription : 15-11-2014

Re : [tootle] manque des dépendances

Bonjour

@Croutons
je pense que c'est disponible sous buster => https://packages.debian.org/buster/libglib2.0-dev
et backports => https://packages.debian.org/buster-back … bhandy-1-0

sous bullseye une simulation est correcte , tous les paquets sont disponible

a priori un souci d'écriture pour ces 2 paquets


apt-get -s --reinstall install valac libglib2.0-dev libjson-glib-dev libxml2-dev libgee-0.8-dev libsoup2.4-dev libgtk-3-dev  libhandy-1-dev libsecret-1-dev
 




0 mis à jour, 129 nouvellement installés, 0 à enlever et 0 non mis à jour.
 

Hors ligne

Pied de page des forums