Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-04-2021 07:48:28

sagamore.fr
Membre
Lieu : Beaumont le Roger
Distrib. : Debian 8 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 23-12-2015
Site Web

print _reg_error: I/O error, dev fd0, sector 0

Depuis quelques jours j'ai çà au démarrage :


[ 0.4090121 ] ACPI Error  : AE_NOT_FOUND , while resolving a named reference package element - LNKD (20180810/dspkginit-414)
 


Puis vient d'apparaitre en plus:


[ 15.297000 ] print _reg_error: I/O error, dev fd0, sector 0
/dev/sda1: clean, 255135/1338240 files, 2270360/5352704 blocks
 



Une recherche me donne cette solution.
https://techantidote.com/how-to-fix-pri … r-0-error/

Mais là je suis hors de mes limites.

Votre avis ?

Merci d'avance.

Hors ligne

#2 27-04-2021 10:53:54

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : print _reg_error: I/O error, dev fd0, sector 0

Bonjour
on dirait que le système voit un floppy (lecteur de disquette ) , dans le bios tu peu le désactiver ?


[ 15.297000 ] print _reg_error: I/O error, dev fd0, sector 0
 



pour la première , une erreur acpi (ou un warning) , ça arrive souvent , je dirai pas très grave.

ps: une question , ta pile de bios est bonne ? si effectivement ta carte mère a un menu pour disquette et que celui ci apparaît maintenant

Hors ligne

#3 27-04-2021 20:04:56

sagamore.fr
Membre
Lieu : Beaumont le Roger
Distrib. : Debian 8 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 23-12-2015
Site Web

Re : print _reg_error: I/O error, dev fd0, sector 0

Pas de lecteur de disquette.
Lecteur de disquette mis en disabled dans le bios.
J'ai changé la pile.
Pareil.

Hors ligne

#4 27-04-2021 21:43:25

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : print _reg_error: I/O error, dev fd0, sector 0

alors je sais pas  ,  je pensais que fd0 était un lecteur de disquette sous linux

Hors ligne

#5 28-04-2021 11:53:37

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : print _reg_error: I/O error, dev fd0, sector 0

Bonjour,

fd0 est bien le premier lecteur de disquettes, mais il remonte à tort comme expliqué dans le lien

lien_fourni a écrit :

This is because your kernel thinks you have a floppy disk fd0, but can't find one.

donc trifouiller dans le setup de la carte-mère ne changera rien à part risquer de tout casser...

La solution est dans le lien, et je remets les 3 lignes utiles là :

sudo rmmod floppy
echo "blacklist floppy" | tee /etc/modprobe.d/blacklist-floppy.conf
sudo dpkg-reconfigure initramfs-tools

Dernière modification par jpt (28-04-2021 11:54:38)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#6 28-04-2021 12:35:10

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : print _reg_error: I/O error, dev fd0, sector 0

tout recyclé CM avec lecteur de disquette
jamais eu ça sous debian (bios avec lecteur disquette désactivé)
mais ton truc doit le faire "blacklist floppy"

Hors ligne

#7 28-04-2021 13:08:42

sagamore.fr
Membre
Lieu : Beaumont le Roger
Distrib. : Debian 8 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 23-12-2015
Site Web

Re : print _reg_error: I/O error, dev fd0, sector 0

root@debian:/home/daniel# rmmod floppy
bash: rmmod : commande introuvable
 

Hors ligne

#8 28-04-2021 13:26:13

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : print _reg_error: I/O error, dev fd0, sector 0

$ locate rmmod
/sbin/rmmod
/usr/share/bash-completion/completions/rmmod
/usr/share/man/man8/rmmod.8.gz
 


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#9 28-04-2021 13:43:54

raleur
Membre
Inscription : 03-10-2014

Re : print _reg_error: I/O error, dev fd0, sector 0

jpt a écrit :

La solution est dans le lien, et je remets les 3 lignes utiles


Je n'appelle pas ça une solution mais plutôt un contournement.
La seconde ligne est incorrecte. Il manque un sudo avant tee pour l'exécuter en tant qu'utilisateur normal ayant les droits sudo, et le bazar avec tee est inutile si on l'exécute en tant que root.
La troisième ligne serait beaucoup plus explicite sous la forme

update-initramfs -u



sagamore.fr a écrit :

bash: rmmod : commande introuvable


Voilà ce qui arrive quand on passe root avec "su" tout court au lieu de "su -" ou "su -l".

Dernière modification par raleur (28-04-2021 13:45:35)


Il vaut mieux montrer que raconter.

Hors ligne

#10 28-04-2021 14:14:48

sagamore.fr
Membre
Lieu : Beaumont le Roger
Distrib. : Debian 8 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : KDE
Inscription : 23-12-2015
Site Web

Re : print _reg_error: I/O error, dev fd0, sector 0

Merci de vos réponses.

Ca va beaucoup mieux.

Bon je n'ai pas tout compris, je dois bien l'avouer. Je vais voir pour su - et su -l

Hors ligne

Pied de page des forums