Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-04-2021 23:26:09

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

[RÉSOLU] installation problèmatique

Bonsoir

Pour rendre service, j'essaie d'installer Debian 10 sur un Lenovo neuf (caractéristiques à la fin).
J'ai créé un clé USB bootable avec la commande :

dd if=debian-live-10.9.0-amd64-gnome+nonfree.iso of=/dev/sdb bs=4M

J'ai pris cette version "nonfree" car je sais que sa carte wifi RTL8192EU n'est pas reconnue.
L'installation a réussie sans réseau mais si je tape la commande lspci
le PC plante et tente de rebooter après 1 à 2 secondes.

Je dis "tente de rebooter" car cela non plus ne fonctionne pas. Il faut éteindre la machine et là, elle redémarre normalement.
Il y a des messages d'erreur pendant l'amorçage mais je n'ai pas trouvé comment mettre en pause pour les noter.
J'ai envoyé le résultat de la commande

journalctl -r -p err

dans un fichier. Dites-moi comment le partager ici si nécessaire.
Merci !

--
Lenonvo Idapad S145
RAM 6.8 Gio
processeur AMD A6-9225 radeon r4, 5 compute cores 2c+3gx2
carte graphique AMD Stoney
Disque 1 TO

Dernière modification par cherbe (01-05-2021 01:35:01)

Hors ligne

#2 28-04-2021 04:56:47

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : [RÉSOLU] installation problèmatique

Bonjour
"Lenovo neuf" donc récent avec un kernel qui date de plus de 2 ans ça ne fait pas bon ménage.
Si possible installe le kernel via les backports ou bien tu refais une installation mais cette fois avec debian bullseye

En ligne

#3 28-04-2021 08:16:01

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [RÉSOLU] installation problèmatique

cherbe a écrit :

dans un fichier. Dites-moi comment le partager ici si nécessaire.


Bonjour,

Sur le forum df au bandeau d'accueil tu as accès aux outils df dont le paste.
Tu l'ouvres, tu copies/colles le résultat de la commande :

 ljournalctl -r -p err


et tu notes l'url obtenue après validation pour la transmettre sur le forum.

Force et courage, Joel smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 28-04-2021 10:00:59

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

bartaba a écrit :


Si possible installe le kernel via les backports ou bien tu refais une installation mais cette fois avec debian bullseye


Heu... Comment on fait ?
Je ne comprends pas la suggestion car je n'ai jamais fait cela.

Hors ligne

#5 28-04-2021 10:19:45

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

smolski a écrit :


et tu notes l'url obtenue après validation pour la transmettre sur le forum.


la voici :
https://debian-facile.org/paste-EB87051399
La commande journalctl ne s'exécute pas en simple utilisateur

Hors ligne

#6 28-04-2021 13:26:09

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

J'ai le message suivant affiché en tout début d'amorçage :
0238282 [firmware bug] AMD-VI:IOAPIC[4] not in IVRS table

Dernière modification par cherbe (28-04-2021 13:27:34)

Hors ligne

#7 28-04-2021 14:39:45

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

bartaba a écrit :

ou bien tu refais une installation mais cette fois avec debian bullseye


Aucun changement avec Debian 11

Hors ligne

#8 28-04-2021 14:47:15

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

Bonjour
si la machine est vraiment instable , essaie une installation minimale (sans bureau) , on pourra vérifier les firmwares nonfree
selon ton lien un des soucis vient de la :


avril 28 12:02:28 debian kernel: [drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connect
 



comme en mode "install minimal" le nombre de paquet est faible , directement passage a bullseye si besoin
pour le bureau c'est simple de l'installer par la suite
je regarde si je trouve quelque chose pour ce cpu amd (et son apu AMD Stoney)

sortie en 2018 => https://www.amd.com/en/products/specifi … /2131,8231

Dernière modification par robert2a (28-04-2021 14:52:49)

En ligne

#9 28-04-2021 14:57:40

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

robert2a a écrit :


pour le bureau c'est simple de l'installer par la suite


Simple même sans réseau et sans CD ?

Hors ligne

#10 28-04-2021 15:05:34

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

un exemple de ma machine avec un cpu + apu AMD


dmesg | grep  AMD-Vi
 



[    0.793685] pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
[    0.797221] pci 0000:00:00.2: AMD-Vi: Found IOMMU cap 0x40
[    0.797224] pci 0000:00:00.2: AMD-Vi: Extended features (0x4f77ef22294ada):
[    0.797228] AMD-Vi: Interrupt remapping enabled
[    0.797228] AMD-Vi: Virtual APIC enabled
[    0.797457] AMD-Vi: Lazy IO/TLB flushing enabled
[    0.806978] AMD-Vi: AMD IOMMUv2 driver by Joerg Roedel <jroedel@suse.de>
 



si tu peu regarde dans ton bios si une option "IOMMU" et si possible sur "enabled"
ce que je trouve étonnant c'est que ce matériel est mal reconnu sous debian 10 (buster)

la priorité je pense c'est d'avoir le réseau (tu est en  cable sur ce portable ? (ou wifi )  => de ton #1  "carte wifi RTL8192EU")

En ligne

#11 28-04-2021 15:13:13

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

robert2a a écrit :


la priorité je pense c'est d'avoir le réseau (tu est en  cable sur ce portable ? (ou wifi )  => de ton #1  "carte wifi RTL8192EU")


La machine ne possède pas de carte réseau. Sa carte wifi interne est une Realtek 8821CE non vue.
la RTL8192EU est un dongle qui ne fonctionne pas sur cette machine mais je pense que c'est un soucis de paramètrage car elle est vue. J'ai déjà eu ce problème avec une autre machine. C'était une histoire d'antenne avec plusieurs options.

Hors ligne

#12 28-04-2021 15:14:35

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

celui la => https://www.lenovo.com/fr/fr/laptops/id … 8IPS101207
il n'est plus vendu sur le site roll

on va chercher pour les deux références du wifi

pour celle interne pas terrible :
https://debian-facile.org/viewtopic.php?id=24695  ou  => https://www.debian-fr.org/t/impossible- … or/81013/3

le lien est assez vieux , elle risque de fonctionner => https://debian-facile.org/viewtopic.php?id=17870&p=2
pour le wifi on a des références comme membre pour ce genre de soucis  wink

donc comme réponse partant pour installer bullseye ?
en juin elle risque de passer stable "debian 11 bullseye" déjà proposé en #2
mais pas sur que tout soit résolu , faudra bricoler un peu .........

une chose importante désactivé le "secure-boot" dans le bios


dmesg | grep -i secure
 



[    0.000000] secureboot: Secure boot could not be determined (mode 0)
[    0.837802] Loaded X.509 cert 'Debian Secure Boot CA: 6ccece7e4c6c0d1f6149f3dd27dfcc5cbb419ea1'
[    0.837842] Loaded X.509 cert 'Debian Secure Boot Signer 2021 - linux: 4b6ef5abca669825178e052c84667ccbc0531f8c'
 



ceci dit qu'il est désactivé =>  "secureboot: Secure boot could not be determined (mode 0)"

Dernière modification par robert2a (28-04-2021 15:36:36)

En ligne

#13 28-04-2021 15:54:47

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

cherbe a écrit :

robert2a a écrit :


pour le bureau c'est simple de l'installer par la suite


Simple même sans réseau et sans CD ?



oui si tu a une clé usb avec debian DVD1 tu peu faire une installation sans réseau (système et bureau )
encore mieux si tu utilise un iso avec les paquets nonfree (non officiel) pour les firmwares nonfree

=> https://cdimage.debian.org/cdimage/bull … 4/iso-dvd/

avec nonfree => https://cdimage.debian.org/cdimage/unof … 4/iso-dvd/

gnome est lourd comme bureau et par défaut il utilise "Wayland"
mate est une alternative , il utilise le serveur X
sinon une installation minimale (sans bureau) le temps de vérifier si tout est correct
tu a un autre PC sous la main , ou seulement celui la ?

Dernière modification par robert2a (28-04-2021 16:03:52)

En ligne

#14 28-04-2021 16:15:44

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

robert2a a écrit :


tu a un autre PC sous la main , ou seulement celui la ?


Oui j'ai un autre PC connecté !

Hors ligne

#15 28-04-2021 16:41:24

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

Ça devient compliqué pour moi. Je ne sais plus quoi faire.
Je suis en train de créer une clé avec firmware-bullseye-DI-rc1-amd64-DVD-1.iso


robert2a a écrit :

celui la => https://www.lenovo.com/fr/fr/laptops/id … 8IPS101207
il n'est plus vendu sur le site roll

on va chercher pour les deux références du wifi

pour celle interne pas terrible :
https://debian-facile.org/viewtopic.php?id=24695  ou  => https://www.debian-fr.org/t/impossible- … or/81013/3

le lien est assez vieux , elle risque de fonctionner => https://debian-facile.org/viewtopic.php?id=17870&p=2
pour le wifi on a des références comme membre pour ce genre de soucis  wink

donc comme réponse partant pour installer bullseye ?
en juin elle risque de passer stable "debian 11 bullseye" déjà proposé en #2
mais pas sur que tout soit résolu , faudra bricoler un peu .........

une chose importante désactivé le "secure-boot" dans le bios


dmesg | grep -i secure
 



[    0.000000] secureboot: Secure boot could not be determined (mode 0)
[    0.837802] Loaded X.509 cert 'Debian Secure Boot CA: 6ccece7e4c6c0d1f6149f3dd27dfcc5cbb419ea1'
[    0.837842] Loaded X.509 cert 'Debian Secure Boot Signer 2021 - linux: 4b6ef5abca669825178e052c84667ccbc0531f8c'
 



ceci dit qu'il est désactivé =>  "secureboot: Secure boot could not be determined (mode 0)"

Hors ligne

#16 28-04-2021 17:01:37

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

tu a une autre commande pour avoir les erreurs du système
pour moi par exemple actuellement


journalctl -r -p err
 


retour


-- Journal begins at Wed 2021-04-28 16:12:37 CEST, ends at Wed 2021-04-28 16:13:26 CEST. --
avril 28 16:12:55 raven2200g pulseaudio[761]: Error opening PCM device front:1: Aucun fichier ou dossier de ce type
avril 28 16:12:37 raven2200g kernel: pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
 



sur Bullseye un mode archivage a été mit en place (conserve tous les messages )
pour revenir a l'état normal , uniquement les messages actuel depuis le dernier démarrage de la machine
tu supprime le dossier "journal"


rm -R /var/log/journal
 


avec le dossier journal (mode persistent )
tu a des dates qui séparent chaque démarrage de la machine ; le premier dans la console est du dernier démarrage , puis le second  j'uqu'au plus ancien
sans réseau ça va t' aider a noter ce qui va pas

pour revenir au mode par défaut de bullseye  ( persistent )


mkdir /var/log/journal
 



moi je trouve plus pratique le mode "non persistent" , quand il y a beaucoup d'erreur c'est lourd a lire hmm
si ils l' ont mit en place sûrement pour une raison

En ligne

#17 28-04-2021 17:04:46

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

ok en plus moi je met une couche avec mon blabla
tu a choisi le DVD1 avec firmware , quand il est prêt je te laisse faire l'installation.
tu va installer gnome ?

nota: en plus c'est pas ton portable "pour rendre service"  arrfffffffff  hmm   de ton #1
tu utilise debian sinon ?

Dernière modification par robert2a (28-04-2021 18:08:12)

En ligne

#18 28-04-2021 18:37:26

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

robert2a a écrit :

ok en plus moi je met une couche avec mon blabla
tu a choisi le DVD1 avec firmware , quand il est prêt je te laisse faire l'installation.


C'est fait. Je n'ai pas mis Gnome mais Cinnamon. Maintenant j'ai un soucis avec la carte graphique mais on verra plus tard (pas d'accélération...)

robert2a a écrit :


tu utilise debian sinon ?


Oui depuis 2013 sur le portable HP où j'ai déjà eu des soucis de Wifi.
Avant 2013, j'avais au boulot un des tout premiers "ultraportable" Dell et pas le moindre soucis d'installation de Debian.
Vraiment bizarre, plus on avance et plus la technique recule !

Hors ligne

#19 28-04-2021 19:09:35

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

tu a testé la commande "journalctl -r -p err"  (en root) et si quelque en rapport avec la carte graphique

avec cette commande vérifie les firmwares installés


apt policy firmware-realtek firmware-amd-graphics amd64-microcode
 



le firmware-realtek  contient ce qu'il faut pour le wifi externe


* Realtek RTL8192EU Bluetooth firmware (rtl_bt/rtl8192eu_fw.bin)
* rtlwifi/rtl8192eu_ap_wowlan.bin
 * Realtek RTl8192EU non-WoWLAN firmware (rtlwifi/rtl8192eu_nic.bin)
 * Realtek RTl8192EU WoWLAN firmware (rtlwifi/rtl8192eu_wowlan.bin)
 



tu a network manager installé ?


apt policy network-manager
 



pour le  le gpu


dmesg | grep drm
 



et


dmesg | grep firmware
 



par contre en wifi pas très bon , je n'utilise pas sur mes machines de bureau , je regarde si un wiki
=>  https://debian-facile.org/doc:materiel:wifi:detecter
ici tu a les liens pour le configurer  => https://debian-facile.org/doc:reseau:wi … on-du-wifi

Dernière modification par robert2a (28-04-2021 19:33:37)

En ligne

#20 28-04-2021 19:37:13

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

robert2a a écrit :

tu a testé la commande "journalctl -r -p err"  (en root) et si quelque en rapport avec la carte graphique



C'est ici : https://debian-facile.org/paste-40C37C0AFF

robert2a a écrit :


avec cette commande vérifie les firmwares installés


apt policy firmware-realtek firmware-amd-graphics amd64-microcode
 



firmware-realtek:
  Installé : 20210315-2
  Candidat : 20210315-2
Table de version :
*** 20210315-2 500
        500 cdrom://[Debian GNU/Linux bullseye-DI-rc1 _Bullseye_ - Unofficial amd64 DVD Binary-1 with firmware 20210415-20:27] bullseye/non-free amd64 Packages
        100 /var/lib/dpkg/status
firmware-amd-graphics:
  Installé : (aucun)
  Candidat : 20210315-2
Table de version :
     20210315-2 500
        500 cdrom://[Debian GNU/Linux bullseye-DI-rc1 _Bullseye_ - Unofficial amd64 DVD Binary-1 with firmware 20210415-20:27] bullseye/non-free amd64 Packages
amd64-microcode:
  Installé : (aucun)
  Candidat : 3.20191218.1
Table de version :
     3.20191218.1 500
        500 cdrom://[Debian GNU/Linux bullseye-DI-rc1 _Bullseye_ - Unofficial amd64 DVD Binary-1 with firmware 20210415-20:27] bullseye/non-free amd64 Packages

robert2a a écrit :


le firmware-realtek  contient ce qu'il faut pour le wifi externe


* Realtek RTL8192EU Bluetooth firmware (rtl_bt/rtl8192eu_fw.bin)
* rtlwifi/rtl8192eu_ap_wowlan.bin
 * Realtek RTl8192EU non-WoWLAN firmware (rtlwifi/rtl8192eu_nic.bin)
 * Realtek RTl8192EU WoWLAN firmware (rtlwifi/rtl8192eu_wowlan.bin)
 



tu a network manager installé ?



Oui

Hors ligne

#21 28-04-2021 19:55:52

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

ÇA Y EST : LE WIFI FONCTIONNE !!!!!!!!!!!!!!
mais je n'ai pas compris comment ni pourquoi !

Hors ligne

#22 28-04-2021 20:03:22

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

donc il te manque firmware-amd-graphics installe le mais avant corrige ton sources.list


#bullseye11 http
deb http://security.debian.org/debian-security bullseye-security/updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye main contrib non-free
 



ajoute ça et commente le reste avec "#" en début de ligne (copier/coller)

un update


apt update
 



apt install firmware-amd-graphics
 



et reboot la machine

nota: lequel de wifi , clé usb ou interne ?

Dernière modification par robert2a (28-04-2021 20:10:28)

En ligne

#23 28-04-2021 20:14:52

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [RÉSOLU] installation problèmatique


Trisquel 8 64bits
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

En ligne

#24 28-04-2021 20:20:08

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [RÉSOLU] installation problèmatique

@Jean-Pierre Pinson
je crois que c'est pas le moment , il met sur un ordi d une personne une debian et c'est compliquer
je pense que ça peut attendre roll

En ligne

#25 29-04-2021 00:05:51

cherbe
Membre
Lieu : Lorraine
Distrib. : Debian 9.13 (x86-64)
Noyau : 4.9.0-15-amd64
(G)UI : Cinnamon 3.2.7
Inscription : 27-04-2021
Site Web

Re : [RÉSOLU] installation problèmatique

Suivi tes conseils qui ont fontionné. Je n'ai plus de message d'erreur carte graphique.
En revanche, la commande lspci plante toujours le système mais on avance, merci merci infiniment !

robert2a a écrit :

nota: lequel de wifi , clé usb ou interne ?


Les deux fonctionnent. J'ai retiré le dongle. La carte interne affiche un rendement de 75 % alors que je suis à 2 mètres de la box mais on verra ça plus tard.

Hors ligne

Pied de page des forums