Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-04-2021 20:45:19

lherbaux
Membre
Distrib. : debian 10
Noyau : Linux 4.9.0-8-amd64
(G)UI : mate
Inscription : 23-12-2010

[résolu] cacher menu grub

bonjour,
au démarrage, j'ai le menu de grub qui apparait.
comment faire pour le cacher? je prend toujours le même.
merci d'avance. à bientôt.

Dernière modification par lherbaux (02-05-2021 21:21:30)

Hors ligne

#2 30-04-2021 21:05:36

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] cacher menu grub

Il faut modifier /etc/default/grub puis exécuter update-grub pour appliquer la configuration.

Pour supprimer le délai et booter immédiatement :

GRUB_TIMEOUT=0


(mais je ne ferais pas ça, car ça empêche d'accéder au menu en cas de besoin.

Pour conserver le délai mais ne pas afficher le menu tant qu'on n'appuie pas sur Esc :

GRUB_TIMEOUT_STYLE=hidden



Source : https://www.gnu.org/software/grub/manua … figuration


Il vaut mieux montrer que raconter.

Hors ligne

#3 01-05-2021 21:16:44

lherbaux
Membre
Distrib. : debian 10
Noyau : Linux 4.9.0-8-amd64
(G)UI : mate
Inscription : 23-12-2010

Re : [résolu] cacher menu grub

j'ai rajouté ce que tu m'a dit , mais ça ne change rien.
je te montre le fichier grub :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
GRUB_TIMEOUT="0"
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_DISABLE_OS_PROBER="true"
GRUB_HIDDEN_TIMEOUT="0"

Hors ligne

#4 01-05-2021 23:06:39

solar66
Membre
Distrib. : debian buster
Noyau : Linux 4-19-0-12-amd64
(G)UI : cinnamon
Inscription : 23-08-2016

Re : [résolu] cacher menu grub

c'est : GRUB_TIMEOUT=0 et non GRUB_TIMEOUT="0"
as tu fais dans un terminal?

update-grub


comme, d'ailleurs précisé à la 1° ligne du fichier grub
et,

Pour conserver le délai mais ne pas afficher le menu tant qu'on n'appuie pas sur Esc :
GRUB_TIMEOUT_STYLE=hidden


donc, si je comprend bien, vu que tu as mis 0 cette ligne: GRUB_TIMEOUT_STYLE=hidden n'a pas à être rajouté

Dernière modification par solar66 (01-05-2021 23:17:20)

Hors ligne

#5 01-05-2021 23:07:34

Cyberbleuet
Membre
Lieu : Alma, Québec
Distrib. : Debian 10 buster
Noyau : x86_64 Linux 4.19.0-14-amd64
(G)UI : KDE 5.54.0 / Plasma 5.14.5
Inscription : 27-02-2017

Re : [résolu] cacher menu grub

Un ptit :   sudo update-grub

https://itsfoss.com/update-grub/

Salutation!
Cyberbleuet

Laptop:Acer Aspire-A115-31 15'', Intel Celeron N4000 graphic Intel, eMMC 64G, 4G mémoire Os / Linux
Aspire F5-573T V1.04 15'' touch screen, Intel i5-6200U (4) @ 2.800 graphic Intel- Skylake GT2, 8G mémoire, SSD-500G Os / Linux

Infiniment libre smile

Hors ligne

#6 01-05-2021 23:10:47

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] cacher menu grub

Bonjour
ne met pas "GRUB_TIMEOUT=0" ça va te bloquer si tu dois intervenir sur grub , voir le #2
sinon


update-grub
 


pour appliquer


GRUB_TIMEOUT_STYLE=hidden
 

Hors ligne

#7 02-05-2021 12:40:38

raleur
Membre
Inscription : 03-10-2014

Re : [résolu] cacher menu grub

solar66 a écrit :

c'est : GRUB_TIMEOUT=0 et non GRUB_TIMEOUT="0"


Je ne pense pas que ça fasse une différence, s'agissant d'une variable d'environnement du shell.


Il vaut mieux montrer que raconter.

Hors ligne

#8 02-05-2021 21:21:05

lherbaux
Membre
Distrib. : debian 10
Noyau : Linux 4.9.0-8-amd64
(G)UI : mate
Inscription : 23-12-2010

Re : [résolu] cacher menu grub

merci à tous, ça marche.

Hors ligne

Pied de page des forums