Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-05-2021 16:12:24

Lucroz94
Membre
Inscription : 06-05-2021

Problème interface graphique sur un Laptop Lenovo Ideapad 5 15ARE05

Bonjour à tous,

Tout d’abord, je poste ce message, car cela va bientôt faire un an que je bataille pour migrer mon ordinateur Lenovo Ideapad 5 15ARE05 81YQCT01WW sous Linux.

Pour vous faire un petit historique, il y a un an (presque jour pour jour !) j’ai reçu ce PC et j’ai essayé d’installer plusieurs distributions.

Debian 7/8/9 = aucun souci tout fonctionnait, je n’aimais juste pas les GUI proposés, je trouvais ça trop vieillot et obsolète et je n’avais pas les compétences pour personnaliser Ubuntu LTS 18.04 et 20.X (un petit doute sur la dernière version) : pareil, tout était nickel, juste un petit souci avec la gestion de luminosité, mais c’était réglable avec de la bidouille.

Manjaro : là, j’ai eu beaucoup de soucis, luminosité réglable défaillante, lors de certains inputs clavier il y avait des BIP provenant de ma carte mère (je n’ai jamais réussi à les enlever malgré de l’aide sur des forums FR/ENG), problème sur certains paquets et kernel, etc. un enfer pendant 3 semaines de travail journalier, j’ai fini par abandonné.

J’ai donc lâchement abandonné et je suis resté sur Windows… Sauf que mon choix ma frustré pendant 1 an.

Maintenant que j’ai du temps et plus autant besoin de ce PC (étant étudiant à l’époque et ayant un mémoire à rendre, je ne m’y étais pas pris au meilleur moment) je réitère !

Sauf que cette fois-ci, ma philosophie à changé. Ce n’est plus grave si mon Desktop n’est pas aussi sexy que Manjaro KDE (que j’aime vraiment énormément), je veux surtout apprendre à utiliser Debian autant côté Desktop que Server.

Donc j’ai réessayé ! Et là… horreur. Maintenant, c’est Debian qui refuse catégoriquement de s’installer sans problème.

Une fois sur deux, lors de l’installation, ma carte réseau n’est pas reconnue, malgré un branchement permanent d’un adaptateur USB vers Ethernet (pas de port natif RJ45). Bon, il suffit juste de reboot et après la détection fonctionne…

Pas de trackpad utilisable pendant l’installation, alors qu’avec les autres distrib (ubuntu et manjaro) aucun souci.

Et surtout… impossible d’installer un GUI.

J’ai tout essayé, Gnome, KDE, XFCE, Mate… rien n’y fait, je me retrouve toujours avec l’invite de commande.

J’ai écumé internet et il semblerait que cela soit dû à un problème de driver lié à mon ordinateur et/ou de kernel Linux… Déjà à l’époque, le support technique de Lenovo (j’ai appelé tout le monde chez eux haha) n’avait pas été capable de me certifier la compatibilité du PC sous Linux (on ma quand même dit que j’étais un alien de vouloir faire ça et qu’ils n’avaient jamais eu d’appels d’un type voulait installer Linux sur Lenovo…)

Pour info, cet ordinateur n’a pas de GPU primaire, il utilise le chipset graphique du CPU AMD Ryzen 7 4800U.

J’ai écumé la doc debian officiel, j’ai utilisé tous les paquets AMD que j’ai trouvés (officiel et non officiel) j’ai utilisé « tasksel » pour relancer les installs, j’ai utilisé pleins d’ISO de debian (10 et 11, toujours en format DVD et avec des drivers non-free aussi) et il m’est impossible d’avoir l’installation d’une interface graphique.

Je ne sais plus quoi essayer pour solutionner mon problème… j’ai même upgrade mon kernel en 5.8/5.9/5.10, mais lors du reboot sur ce kernel, mon système ne fonctionne juste plus du tout.

Si vous avez des pistes pour m’aider à troubleshoot, je suis preneur ! Je veux vraiment pouvoir utiliser Debian 10 ou 11 sous KDE (ou XFCE si ça n’est pas possible autrement) et vraiment me dire, si ça ne fonctionne pas, que j’aurais tout essayé (et j’irais sur Manjaro qui fonctionne impeccablement).

Voici quelques images avec des infos correspondant à mon matériel et problème rencontré lors du boot.

Merci d’avance pour votre aide !

PS : j'ai posté le même message sur plusieurs forums FR afin de pouvoir obtenir le maximum d'informations de la communauté, je ferais en sorte d'actualisé chacun de mes posts pour la postérité smile

Édit 1 : ne pouvant inclure une autre image, je retranscris ici l'erreur que j'obtiens au boot, qui est persistant même après l'installation de tous les paquets GPU que j'ai trouvés :

[drm:amdgpu_pci_probe [amdgpu]] *ERROR* amdgpu requires firmware installed amdgpu: See https://wiki.debian.org/Firmware for information about missing firmware

https://www.debian-fr.org/uploads/defau … 286b3.jpeg

Dernière modification par Lucroz94 (06-05-2021 16:29:37)

Hors ligne

#2 06-05-2021 18:27:05

lagrenouille
Adhérent(e)
Lieu : Saturne
Distrib. : debian buster - openbsd
Noyau : d'olive
(G)UI : env i3w - openbox_bépo
Inscription : 28-03-2012
Site Web

Re : Problème interface graphique sur un Laptop Lenovo Ideapad 5 15ARE05

salut
tu dis que tu as un écran noir et un prompt qui clignote
tu as essayé de te loger en console
Contrôl + Alt + F1  (ou F2), etc F6 étant réservé au graphique
login et passwd demandé

as tu regardé dans le bios si il ne faut pas activer quelque chose ?

si tu arrives à te loger en console, passe en root avec  su -l et

apt update



apt install libdrm-amdgpu1  xserver-xorg-video-amdgpu



on peut voir ton source.list

Dernière modification par lagrenouille (06-05-2021 20:00:31)


La liberté est le crime qui contient tous les crimes, c’est notre arme absolue !

Hors ligne

#3 07-05-2021 00:44:57

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème interface graphique sur un Laptop Lenovo Ideapad 5 15ARE05

Bonsoir

assez récente cette machine => https://www.lenovo.com/fr/fr/laptops/id … 8IPS501393  (bien celle ci ? )
l'image que tu montre c'est  pas grand chose , je dirai que pas de boot sur debian.
donc commencer par le début tu installe debian avec quoi ? (une clé usb)
quel iso le DVD1 de buster ?
désactiver le "sécure-boot" dans le bios et  et activer "CMS"  (sur ce portable je sais pas si c'est possible)
tu a deux disques , un ssd et un DD ? , il y a quoi comme OS autre que debian sur cette machine ,  et tu installe debian sur quel disque ?

Hors ligne

#4 07-05-2021 09:27:29

Lucroz94
Membre
Inscription : 06-05-2021

Re : Problème interface graphique sur un Laptop Lenovo Ideapad 5 15ARE05

Bonjour à vous,

Merci pour vos retours !

Lagrenouille : me loger en console, c'est à dire ? c'est sur un laptop donc j'ai l'accès direct, et je suis TOUJOURS en CLI, justement parce que le GUI refuse de s'afficher
Dans l'UEFI (le BIOS c'est déjà daté tongue) rien n’a activé en particulier, j'ai déjà désactivé le secure-boot et j'ai essayé l'install en UEFI ou boot legacy déjà. Rien ne change.

J'ai déjà installé les paquets que tu as mentionnés, que ça soit ceux dispo en Debian Buster ou Bullseye, non-free ou pas, rien n'y fait.

La sources.list :

deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free

deb http://deb.debian.org/debian buster-updates main contrib non-free
deb-src http://deb.debian.org/debian buster-updates main contrib non-free

deb http://deb.debian.org/debian buster-backports main contrib non-free
deb-src http://deb.debian.org/debian buster-backports main contrib non-free

Robert2a : oui c'est bien ce laptop mais la configuration est modulable, voici le détail (facture lenovo)

Nom du produit:
81YQCTO1WW - IdeaPad 5 15


Processeur  -  Processeur AMD Ryzen 7 4800U (1,80 GHz, Max Boost jusqu'à 4,20 GHz, 8 cœurs, 8 Mo de cache)
Operating System  -  Free-DOS
Operating System Language  -  Free-DOS
Memory  -  16 Go de mémoire DDR4 3 200 MHz intégrés
Second Hard Drive  -  Disque SSD 256 Go, M.2 2242, PCIe-NVMe, TLC
Extra Storage Holder  -  Kit de mise à jour disque dur (uniquement SSD simple)
Écran  -  Écran Full HD 15,6 pouces (1920x1080), IPS, anti-reflets, épaisseur 2,6 mm, 300 nits, cadre étroit
Graphic Card  -  Carte graphique intégrée
Couleur  -  Gris graphite
Clavier  -  Clavier rétroéclairé Gris acier Français
Webcam  -  Caméra 720p HD avec microphone
Surface Treatment  -  Anodisation
Fingerprint Reader  -  Lecteur d'empreintes digitales
Palmrest  -  Métal
Batterie  -  Batterie interne lithium-polymère à 3 cellules, 57 Wh
Power Cord  -  Adaptateur secteur 95 W (3 broches) - Europe (USB Type C)
Wireless  -  Wi-Fi 6 2 x 2 AX, Bluetooth Version 4.1 ou supérieure
Language Pack  -  Publication - français
Garantie  -  2 ans retour en atelier ou transport en atelier par le client

Oui, j'ai bien un 2e SSD de 1To en 2"5 dedans qui est complètement formaté en EXT4 et vide, j'installe l'OS sur le NVME de 256GB.

J'ai utilisé beaucoup d'ISO différents de Debian 10 et 11. Tous récupérés sur le site officiel. Tous mis sur une clef USB bootable utilisant le soft "Ventoy" pour le multiboot
Pas de CMS en option, secure boot déjà désactivé.

https://cdimage.debian.org/debian-cd/cu … so.torrent  -> Problème affichage graphique
https://cdimage.debian.org/debian-cd/cu … -DVD-1.iso      -> Pareil
https://cdimage.debian.org/debian-cd/cu … 64-kde.iso  -> Pareil
https://cdimage.debian.org/debian-cd/10 … -DVD-1.iso   -> Pareil
http://cdimage.debian.org/cdimage/weekl … -DVD-1.iso -> Pareil

J'ai essayé d'upgrade les Kernel, c'était encore pire, ça ne fonctionne qu'en 4.9

Merci pour l'aide smile

Hors ligne

#5 07-05-2021 13:25:52

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème interface graphique sur un Laptop Lenovo Ideapad 5 15ARE05

Bonjours
ça ne sert a rien de tenter plusieurs ISO , le DVD1 de buster est très bien .
donc sans bureau en CLI , voir comment le système est pris en charge
pour l'instant on a rien de concret pour te donner des solutions


deb http://deb.debian.org/debian buster main contrib non-free
#deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
#deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free

deb http://deb.debian.org/debian buster-updates main contrib non-free
#deb-src http://deb.debian.org/debian buster-updates main contrib non-free

#deb http://deb.debian.org/debian buster-backports main contrib non-free
#deb-src http://deb.debian.org/debian buster-backports main contrib non-free
 



ps: j'ai commenté ce qui n'est pas utile pour l'instant , toujours en CLI , sauf si tu a des paquets de backports installés ou il faut enlever le "#"
vérifier si a jours


apt update
 


nettoyer
purger plymouth


apt-get remove --purge plymouth plymouth-label libplymouth5
 



apt-get autoremove --purge
 



apt-get autoclean
 


si tout va bien on va  chercher pourquoi le bureau ne fonctionne pas
donc en CLI toujours
comme tu a une machine AMD


apt install firmware-amd-graphics amd64-microcode
 




lspci
 



journalctl -r -p err
 


a toi de trouver un moyen pour récupérer les retours et les poster sur le forum

ps : pour l'instant on ne sait pas ce qui bloque , donc on cherche des erreurs de "firmware" par exemple
pour ta réflexion , c'est mieux avec un vieux noyau , normal le noyau ne détecte pas le matériel donc il bug moins .
pour buster ou bullseye je ne sais pas encore lequel serait le mieux pour cette machine
si ton système est propre on installera un petit bureau pour finir les tests
par exemple (un mate minimal sous X )


apt install lightdm mate-core pluma
 


si tout va bien tu pourra mettre ensuite le bureau de ton choix

remarque : voila pour les grandes lignes , sinon une machine AMD (ou intel) normalement sans soucis sous debian avec le "non-free"
donc un cpu amd + un apu (gpu intégrer au processeur) ça doit tourner
comme la machine a priori a moins d un an (ou pas beaucoup plus ) peut être que debian11 (bullseye sera mieux pour ce matériel )

donc actuellement ton installation démarre bien a partir du ssd 1 (256Go) , le menu de grub aussi , jusque a l' invite de connexion du cli ?

Dernière modification par robert2a (07-05-2021 13:39:53)

Hors ligne

#6 11-05-2021 17:36:22

Lucroz94
Membre
Inscription : 06-05-2021

Re : Problème interface graphique sur un Laptop Lenovo Ideapad 5 15ARE05

robert2a a écrit :

Bonjours
ça ne sert a rien de tenter plusieurs ISO , le DVD1 de buster est très bien .
donc sans bureau en CLI , voir comment le système est pris en charge
pour l'instant on a rien de concret pour te donner des solutions


deb http://deb.debian.org/debian buster main contrib non-free
#deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://deb.debian.org/debian-security/ buster/updates main contrib non-free
#deb-src http://deb.debian.org/debian-security/ buster/updates main contrib non-free

deb http://deb.debian.org/debian buster-updates main contrib non-free
#deb-src http://deb.debian.org/debian buster-updates main contrib non-free

#deb http://deb.debian.org/debian buster-backports main contrib non-free
#deb-src http://deb.debian.org/debian buster-backports main contrib non-free
 



ps: j'ai commenté ce qui n'est pas utile pour l'instant , toujours en CLI , sauf si tu a des paquets de backports installés ou il faut enlever le "#"
vérifier si a jours


apt update
 


nettoyer
purger plymouth


apt-get remove --purge plymouth plymouth-label libplymouth5
 



apt-get autoremove --purge
 



apt-get autoclean
 


si tout va bien on va  chercher pourquoi le bureau ne fonctionne pas
donc en CLI toujours
comme tu a une machine AMD


apt install firmware-amd-graphics amd64-microcode
 




lspci
 



journalctl -r -p err
 


a toi de trouver un moyen pour récupérer les retours et les poster sur le forum

ps : pour l'instant on ne sait pas ce qui bloque , donc on cherche des erreurs de "firmware" par exemple
pour ta réflexion , c'est mieux avec un vieux noyau , normal le noyau ne détecte pas le matériel donc il bug moins .
pour buster ou bullseye je ne sais pas encore lequel serait le mieux pour cette machine
si ton système est propre on installera un petit bureau pour finir les tests
par exemple (un mate minimal sous X )


apt install lightdm mate-core pluma
 


si tout va bien tu pourra mettre ensuite le bureau de ton choix

remarque : voila pour les grandes lignes , sinon une machine AMD (ou intel) normalement sans soucis sous debian avec le "non-free"
donc un cpu amd + un apu (gpu intégrer au processeur) ça doit tourner
comme la machine a priori a moins d un an (ou pas beaucoup plus ) peut être que debian11 (bullseye sera mieux pour ce matériel )

donc actuellement ton installation démarre bien a partir du ssd 1 (256Go) , le menu de grub aussi , jusque a l' invite de connexion du cli ?





Bonjour, désolé pour le retour tardif, j'ai essayé pleins de choses.

Toutes tes indications ont été suivis et n'ont pas amélioré la situation, je n'ai toujours aucun GUI.
même les live-boot ISO de Debian 10 KDE ne fonctionne pas, j'ai l'espace d'une fraction de seconde le gestionnaire de session qui s'affiche puis je me retrouve en CLI.

Lorsque j'essaie d'installer un bureau avec "tasksel" ou la commande que tu m'as donné, ça se DL et installe mais ça ne démarre jamais avec et ça n'est pas reconnu.

J'en ai profité pour installer un W10 et upgrade mon BIOS/UEFI (dernière MAJ en février 2021). Lenovo ne fournit aucun moyen de le faire via USB ou Linux.

Voici aussi en vidéo un problème que j'ai sous Debian 9 (qui fonctionne avec une GUI) : https://youtu.be/qwg71l2PNjI

Sous Manjaro XFCE tout fonctionne correctement sauf les bips de la CM.
Sur KDE, la luminosité ne se gère pas bien et j'ai des bips aussi.


"donc actuellement ton installation démarre bien a partir du ssd 1 (256Go) , le menu de grub aussi , jusque a l' invite de connexion du cli ? "
Exactement. Tout démarre sur le NVME, pareil pour le GRUB et le CLI.

J'ai testé l'install de Debian 10 et 11 avec des drivers free et non free ainsi que l'install des packages amgpu etc et rien n'y fait.

Je suis à court d'idées pour debuguer sur Debian, est-ce vous auriez d'autres pistes ?

Dernière modification par Lucroz94 (11-05-2021 17:37:14)

Hors ligne

Pied de page des forums