Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-05-2021 06:32:42

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

.deb à installler sur pclos->RESOLU<-

Bonjour à toutes/tous
j'ai un petit problème d’installation de ce vpn Suedois(~15 eyes~) mais
Synaptic/smart/rpm-installeur veulent rien savoir...
Je suis trés trés moyen en réseaux...
En terminal j'ai ça:
# dpkg -i MullvadVPN-2021.3_amd64.deb
dpkg: error: failed to open package info file '/var/lib/dpkg/status' for reading: No such file or directory
Et:
# nano /var/lib/dpkg/status... C'est encore là mais vide !
Et chez download ark me dit:
file:///home/fwa/Downloads/MullvadVPN-2021.3_amd64/control.tar.gz
file:///home/fwa/Downloads/MullvadVPN-2021.3_amd64/data.tar.xz
file:///home/fwa/Downloads/MullvadVPN-2021.3_amd64/debian-binary
A priori c'est pas mort...
Quelqu'un à une idée pour installer le "client" ?J'ai aussi téléchargé le .rpm
Bien à vous & belle journée
Fred.

Dernière modification par Ourck20-1 (21-05-2021 20:14:53)

Hors ligne

#2 21-05-2021 09:11:08

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : .deb à installler sur pclos->RESOLU<-

Hello

Ourck20-1 a écrit :

nano /var/lib/dpkg/status... C'est encore là mais vide !


oui pour sur vu que c'est toi qui créé le fichier si il n'existe pas avec nano
ce qu'il faut fait c'est lire le fichier avec cat ou less(car le fichier peut etre long)

cat /var/lib/dpkg/status



Ourck20-1 a écrit :

Et chez download ark me dit:


la j'ai pas compris

en utilisant dpkg -i les dépendances ne seront pas satisfaite
utilise plutôt apt install

apt install /chemin/verslefichierDeb



edit: voici le contenu du répertoire sous ma Debian

ls -l /var/lib/dpkg/


total 6912
drwxr-xr-x 2 root root    4096 avril 28 14:26 alternatives
-rw-r--r-- 1 root root      11 avril 26  2019 arch
-rw-r--r-- 1 root root  124816 févr. 13  2019 available
-rw-r--r-- 1 root root       8 févr. 13  2019 cmethopt
-rw-r--r-- 1 root root     571 juin   9  2020 diversions
-rw-r--r-- 1 root root     685 juin   9  2020 diversions-old
drwxr-xr-x 2 root root  573440 mai   18 20:36 info
-rw-r----- 1 root root       0 mai   18 20:36 lock
-rw-r----- 1 root root       0 févr.  7 09:38 lock-frontend
drwxr-xr-x 2 root root    4096 juin  26  2018 parts
-rw-r--r-- 1 root root     276 mai   25  2020 statoverride
-rw-r--r-- 1 root root     230 févr. 18  2019 statoverride-old
-rw-r--r-- 1 root root 3164729 mai   18 20:36 status
-rw-r--r-- 1 root root 3165037 mai   18 20:36 status-old
drwxr-xr-x 2 root root    4096 mars  27 20:33 triggers
drwxr-xr-x 2 root root    4096 mai   18 20:36 updates



le fichier status est bien plein

Dernière modification par Croutons (21-05-2021 09:14:35)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 21-05-2021 10:11:39

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

Bonjour "Croutons", merci , en retour j'ai ça:

$ cat /var/lib/dpkg/status
cat: /var/lib/dpkg/status: No such file or directory (!)

bash-5.1$ ls -l /var/lib/dpkg/
total 16
drwxr-xr-x 2 root root 4096 Oct 26  2017 alternatives/
drwxr-xr-x 2 root root 4096 Oct 26  2017 info/
-rw-r----- 1 root root    0 May 18 06:28 lock
drwxr-xr-x 2 root root 4096 Oct 26  2017 parts/
drwxr-xr-x 2 root root 4096 Oct 26  2017 updates/
bash-5.1$
ET ocazou:
$ uname -sr
Linux 5.12.5-pclos1

ET:
sudo apt install /home/fwa/downloads/MullvadVPN-2021.3_amd64.deb
[sudo] password for fwa:
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package

Là je sais plus trop... Le .deb est pourtant là ! un "s" en trop à download ?

J'vas y arriver !
Bien
F.

Hors ligne

#4 21-05-2021 10:38:28

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

La gestion des droits et des chemins a changé avec Buster.

En tapant su - (avec un tiret), on se retrouve dans le répertoire /root, et ton paquet .deb n'est pas dans ce dossier. Il semblerait que ça soit pareil avec tes réglages de sudo. Tu dois te trouver dans le dossier /root. Tu peux sans doute le vérifier en tapant sudo pwd

En tapant su (sans le tiret), on reste dans le dossier où l'on a ouvert le shell, mais on perd la possibilité d'utiliser les outils comme dpkg...

Une solution est de placer ton paquet .deb dans le dossier /root avec cp.

Puis :

su -
dpkg -i ton_paquet.deb
 

Dernière modification par hybridemoineau (21-05-2021 10:39:13)

Hors ligne

#5 21-05-2021 10:59:07

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : .deb à installler sur pclos->RESOLU<-

sur ma debian c'est Téléchargements le dossier
tu as quoi si tu fais

ls /home/fwa


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 21-05-2021 14:11:48

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

RE Crouton:
ls /home/fwa
Desktop/  Documents/  Downloads/  MullvadVPN-2021.3_x86_64.rpm  Music/  Pictures/  Templates/  Videos/  tmp/

Si je comprends bien ce xlRBdssx°°__ fichier est dans "Documents"...
Il me semble avoir eu des dépendances manquantes...dbus-libs et libnsl
Suis plus trop sûr !
Merci à tous(toutes) les deux
Il pleut pas, je vais tondre ça va peut-être éviter des conn.ries ?
Juste 1700M2
Ahahah
Fred.

Hors ligne

#7 21-05-2021 14:14:24

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

Où est passé le .deb ???
Bien sûr je peux re-télécharger mais ~64Mb ne disparaissent pas comme ça...
F.

Hors ligne

#8 21-05-2021 14:20:25

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

MERCI à hybridemoineau que j'ai "zappé"...
F.
"La gestion des droits et des chemins a changé avec Buster"
Je ne suis plus avec Buster mais pclos et aussi Bullseye qui  ronronne...
F.

Hors ligne

#9 21-05-2021 15:56:31

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : .deb à installler sur pclos->RESOLU<-

Ourck20-1 a écrit :

Où est passé le .deb ???
Bien sûr je peux re-télécharger mais ~64Mb ne disparaissent pas comme ça...
F.

je crois que tu as ta réponse Downloads avec un D et pas un d


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#10 21-05-2021 16:03:18

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

Désolé du feuilletage de réponses...

Buster, Bullseye, Pcos en tant qu'elle est basée de près ou de loin sur du Red Hat : même fonctionnement. Les installations doivent se faire par défaut via su - et placent dans le dossier /root.

Hors ligne

#11 21-05-2021 16:36:10

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

@hybridemoineau & @Croutons, yen a marre...
J'ai réussi à flinguer la courroie d’entraînement tondeuse!!!Cool
Du coup j'ai re-téléchargé le vpn en .deb (67.4Mb)
Et apt me sort:
# apt install ~/Downloads/MullvadVPN-2021.3_amd64.deb
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package
GRRRRR
Synaptic ne connais pas aptitude en plus...Smart pareil !PCMan idem
@hybridemoineau PCLOS à l'air plutôt...hybride!
Pas systemd & sysv comme init! A l'ancienne!
Les packets en .deb ET .rpm devraient être acceptés...
Bon, je suis pas dev, ni mécano d’ailleurs...
Mais j'aimerais bien arriver à mes fins AVANT
de tout dézinguer !
Trop bête d'en arriver là.
Bien à vous & votre patience.
F.

Hors ligne

#12 21-05-2021 16:54:33

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

Les paquets deb sont-ils acceptés comme les rpm ?

Et le problème est que le paquet n'est pas trouvé par apt ou dpkg. Soit il n'est pas dans le dossier où tu crois qu'il est, soit apt ou dpkg le cherchent au mauvais endroit.

Que donne :

ls ~/Downloads/



et

locate MullvadVPN-2021.3_amd64.deb

Hors ligne

#13 21-05-2021 17:41:03

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

Ahahah hybidemoineau ne bosse pas pour Hadoppi, I presume ? Ils sont bien au chaud dans leur hôtel particulier du 16ème...
ET grassement payés !
Donc:
ls ~/Downloads/
1588px-John_Everett_Millais_-_Ophelia_-_Google_Art_Project.jpg  'Tex A.jpg'
Botero_CardPlayers.jpg                                           Transfigurazione_Raffaello.jpg
CPBD0420-Alain-Michel-Boucher-Peinture-originale-Gouache.jpg     Unicorn_Aberdin_bestiary.jpg
Fish199902-1179613087.jpg                                        adbook.csv
Germinal.jpg                                                     adbook.ldif
'H2...Hydrog'$'\303\250''ne'                                      adbook.vcf
John_Everett_Millais,_1852_Study_for_Ophelia.jpg                 licorne.jpg
John_Everett_Millais_Ophelia.jpg                                 licorne2.jpg
MullvadVPN-2021.3_amd64/                                         licorne3
'MullvadVPN-2021.3_amd64(1)'/                                     magnifier-linux-3.5.tar.bz2
'MullvadVPN-2021.3_amd64(1).deb'*                                'pas mal.jpg'
MullvadVPN-2021.3_amd64.deb*                                    'pclos snap. Ourck20-1.png'
MullvadVPN-2021.3_x86_64.rpm                                    'picto death.jpg'
'Nymphe et Faunesse'                                             'picto pollution.gif'
PrettyFae-1122640254.jpg                                         pictogramme-danger-haute-tension.jpg
SCANS/                                                           rohingya-first-person.jpg
Ça va encore, pas trop de Copy-right !!! Et:
$ locate MullvadVPN-2021.3_amd64.deb
/home/fwa/.local/share/RecentDocuments/MullvadVPN-2021.3_amd64.deb.desktop  <---
/home/fwa/.local/share/RecentDocuments/MullvadVPN-2021.3_amd64.deb[2].desktop<---
/home/fwa/.local/share/RecentDocuments/MullvadVPN-2021.3_amd64.deb[3].desktop<---
/home/fwa/.local/share/RecentDocuments/MullvadVPN-2021.3_amd64.deb[4].desktop<---
/home/fwa/.local/share/RecentDocuments/MullvadVPN-2021.3_amd64.deb[5].desktop<---
/home/fwa/Downloads/MullvadVPN-2021.3_amd64.deb <--- C'EST LUI QUE JE VEUX
Chuis fou où quoi ??? Il est bien là...
Ça à l'air étrange mais .deb ET .rpm DEVRAIENT être acceptés...
F.

Hors ligne

#14 21-05-2021 17:47:37

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

d'où :

su -



puis

cp /home/fwa/Downloads/MullvadVPN-2021.3_amd64.deb /root
apt MullvadVPN-2021.3_amd64.deb



et si apt grogne


dpkg -i MullvadVPN-2021.3_amd64.deb

Hors ligne

#15 21-05-2021 18:14:41

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

GRRRRRR:
# cp /home/fwa/Downloads/MullvadVPN-2021.3_amd64.deb /root
cp: overwrite '/root/MullvadVPN-2021.3_amd64.deb'?
[root@localhost ~]# apt MullvadVPN-2021.3_amd64.deb
E: Invalid operation MullvadVPN-2021.3_amd64.deb
[root@localhost ~]# dpkg -i MullvadVPN-2021.3_amd64.deb
dpkg: error: failed to open package info file '/var/lib/dpkg/status' for reading: No such file or directory
Il parait que patience & longueur de temps font plus que force ni que rage...
Bon !
Que dire... J'oublie Mullvad sur cette distro...
Tant pis.
F.

Hors ligne

#16 21-05-2021 18:20:24

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

Je m'étais trompé, c'est :

apt install MullvadVPN-2021.3_amd64.deb



Par ailleurs, l'erreur avec dkg ne vient pas de l'absence du paquet, mais d'une erreur antérieure, qui fait peut-être aussi planter apt. Essaie :

dpkg --configure -a

Hors ligne

#17 21-05-2021 18:27:19

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

# apt install MullvadVPN-2021.3_amd64.deb
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package MullvadVPN-2021.3_amd64.deb
[root@localhost ~]# dpkg --configure -a
dpkg: error: failed to open package info file '/var/lib/dpkg/status' for reading: No such file or directory

Il trouve pas on dirait !
F.

Hors ligne

#18 21-05-2021 18:35:11

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

Eh beh.

pour l'erreur dpkg, essaie ça :

cat /var/lib/apt/lists/*_Packages >/var/lib/dpkg/available
dpkg --configure -a



En espérant que ça règle l'erreur avec apt install, parce que, après un su - et puisque le .deb est dans /root, ça devrait marcher.

Hors ligne

#19 21-05-2021 18:40:06

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

Et, si ça ne suffisait pas pour l'erreur dpkg (voir message 18), utilise une sauvegarde plus générale :

cp /var/lib/dpkg/available-old /var/lib/dpkg/available



puis les autres commandes, dpkg --configure -a et apt install données plus haut.

Dernière modification par hybridemoineau (21-05-2021 18:41:58)

Hors ligne

#20 21-05-2021 19:29:45

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : .deb à installler sur pclos->RESOLU<-

c'est quoi ce truc copier un paquet deb dans root pour l'installer?
ça part dans tout les sens hmm

hybridemoineau a écrit :

# apt install ~/Downloads/MullvadVPN-2021.3_amd64.deb


forcement qu'il trouve pas le paquet , le tilde représente le dossier de l'utilisateur , dans la cas présent root
vu que tu utilises sudo tu peux utiliser ~ si ton prompt est encore en user $

sudo apt install ~/Downloads/MullvadVPN-2021.3_amd64.deb



hybridemoineau a écrit :

apt install MullvadVPN-2021.3_amd64.deb


en l'absence de chemin apt utilisera le sources.lit et forcement ne trouvera pas le paquet a installer dans les dépôts Debian


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#21 21-05-2021 19:43:37

hybridemoineau
Membre
Inscription : 21-02-2016

Re : .deb à installler sur pclos->RESOLU<-

Oui, je me suis bien planté avec apt, que je n'utilise pas pour installer de paquet - seulement dpkg -i, et avec le tidle aussi par inattention.

pour ce qui est de copier dans le dossier root, je procède comme ça plutôt qu'indiquer le chemin, ça ne change rien.

En tous cas au #14, le


dpkg -i MullvadVPN-2021.3_amd64.deb



aurait dû marcher. dpkg a l'air cassé. Le #17 le confirme.

Dernière modification par hybridemoineau (21-05-2021 19:44:36)

Hors ligne

#22 21-05-2021 20:12:54

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

@hybridemoineau & Crouton...
Mes très très maigres connaissances me renvoient à #3
$ cat /var/lib/dpkg/status
cat: /var/lib/dpkg/status: No such file or directory
Ce système fonctionne encore mais dpkg à bien l'air cassé !
Bref tout ça vous prends beaucoup de temps ET de bande passante...
J'ai merd. , ça arrive ! Je vois pas encore trop où, mais c'est comme une courroie...
Quand elle casse, ben y'a comme un drôle de bruit !
Pas trop de conséquences fâcheuses non plus, j'ai des HDD lisibles en backup.
Je vous remercie vraiment ainsi que Smolsky qui m'a envoyé ici (réseaux).
A quelque, chose malheur est bon et tout reconfigurer...
Bah y'a pas mort d'homme.
Je vais surtout être plus vigilant, essayer en tout cas!
Merci encore.
On va dire résolu donc...
Je vais remonter à mon 1er post
Fred.merci.gif

Hors ligne

#23 22-05-2021 06:30:26

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

Bonjour à toutes/tous
ce matin, mise à jour par Synaptic ok,112Mb...
J'ai le week. pour gérer >dpkg<
Tétu !
On va bien voir !
F.

Hors ligne

#24 22-05-2021 07:29:37

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : .deb à installler sur pclos->RESOLU<-

Un tuto complet pour dpkg :
https://debian-facile.org/doc:systeme:apt:dpkg

Des fois qu'heu ?

Force et courage ... 2975.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#25 22-05-2021 09:24:25

Ourck20-1
Membre
Lieu : pas bien loin...vers l'Ouest
Distrib. : Pclos/Arch/Bullseye
Noyau : 5.12.5
Inscription : 10-04-2020

Re : .deb à installler sur pclos->RESOLU<-

Bonjour smolski, MERCI pour l'info !
J'ai remarqué un truc étrange (...pour moi!)
Sur PCLos j'ai kernel+headers 5.12.5 depuis au moins 2jours
Et lors de ma mise à jour Arch ce matin ce même kernel arrive tout juste -pas seul bien sûr !
(avec Syyu et pas simplement Syu)
Bizarre, je pensouillait qu'Arch avait toujours une longueur d'avance...
Bien
F.

Hors ligne

Pied de page des forums