Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-05-2021 23:30:08

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

[Résolu] Impossible d'installer un nouveau noyau !

Bonjour,

J'ai installé une Debian 9 sur un serveur dédié Dedibox (nouveau serveur) j'ai recompilé un nouveau noyau en Vserver, au paravent j'avais installé un noyau backport linux-image-4.19.0-0.bpo.16-amd64 et depuis IMPOSSIBLE D'INSTALLER UN NOUVEAU NOYAU !

L'installation se fait bien sans messages d'erreur par contre GRUB boote toujours sur le noyau linux-image-4.19.0-0.bpo.16-amd64 !

J'ai modifié mon /etc/default/grub pour le forcer à booter sur mon noyau comme ceci:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="gnulinux-4.9.159-vs2.3.9.8-samp-amd64-advanced-c2ebbc31-7fa0-40d1-a2fc-341702266b8d>gnulinux-4.9.159-vs2.3.9.8-samp-amd64-advanced-c2ebbc31-7fa0-40d1-a2fc-341702266b8d"
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""



Lancé "update-grub" et au reboot je suis toujours sur le même noyau ! - en 20 ans de Linux c'est la première fois que je vois ça !!!

Je sèche lamentablement... HELP !

Sam.

Dernière modification par samprz (28-05-2021 13:26:10)

Hors ligne

#2 28-05-2021 03:46:35

Velociraptux
Membre
Inscription : 23-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

Salut
Lister les noyeaux installés

dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3 | column -t"}'


Si ton noyeau n'apparait pas c'est qu'il doit y avoir un probleme de compilation. Ou qu'il manque des trucs. Comme les header ou des pilotes. Qui sait.
Essaye un

sudo apt-get autoremove --purge


Ou desinstalle manuellement ceux que tu ne veux pas. Attention il faux generallement garder les deux derniers  car en cas d'impossibilité de démarrer sur le dernier noyau (une incompatibilité des pilotes par exemple), il restera toujours la possibilité d'utiliser le noyau précédent.

Hors ligne

#3 28-05-2021 08:08:55

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible d'installer un nouveau noyau !

On peut voir le contenu de /boot/grub/grub.cfg ?

Il vaut mieux montrer que raconter.

Hors ligne

#4 28-05-2021 12:36:51

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

raleur a écrit :

On peut voir le contenu de /boot/grub/grub.cfg ?



menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-c2ebbc31-7fa0-40d1-a2fc-34170226$
submenu 'Options avancées pour Debian GNU/Linux' $menuentry_id_option 'gnulinux-advanced-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, avec Linux 4.19.0-0.bpo.16-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulin$
        menuentry 'Debian GNU/Linux, with Linux 4.19.0-0.bpo.16-amd64 (systemd)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_opti$
        menuentry 'Debian GNU/Linux, with Linux 4.19.0-0.bpo.16-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_i$
        menuentry 'Debian GNU/Linux, avec Linux 4.9.159-vs2.3.9.8-samp-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option $
        menuentry 'Debian GNU/Linux, with Linux 4.9.159-vs2.3.9.8-samp-amd64 (systemd)' --class debian --class gnu-linux --class gnu --class os $menuentry_$
        menuentry 'Debian GNU/Linux, with Linux 4.9.159-vs2.3.9.8-samp-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menu$
        menuentry 'Debian GNU/Linux, avec Linux 4.9.0-15-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.$
        menuentry 'Debian GNU/Linux, with Linux 4.9.0-15-amd64 (systemd)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnu$
        menuentry 'Debian GNU/Linux, with Linux 4.9.0-15-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_optio$



En fait j'ai trouvé et solutionné le problème qui venait de /etc/default/grub en mettant:

GRUB_DEFAULT="1>3" (pour booter sur le bon noyau dans /boot/grub/grub.cfg)

et surtout:

GRUB_SAVEDEFAULT=false <--- et je pense que c'est ce qui a débloqué la situation !

En tout cas merci de vos réponses.

Sam.

Hors ligne

#5 28-05-2021 13:20:41

smolski
quasi...modo
Lieu : AIN
Distrib. : backports (buster) 10
Noyau : Linux 4.19.0-8-amd64
(G)UI : gnome
Inscription : 21-10-2008

Re : [Résolu] Impossible d'installer un nouveau noyau !

Ah !
Si c'est résolu, fô le rajouter dans le titre du post :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. cool

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 28-05-2021 13:27:12

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

smolski a écrit :

Ah !
Si c'est résolu, fô le rajouter dans le titre du post :
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre. cool



J'allais le faire, c'est fait !

Merci.

Sam.

Hors ligne

#7 28-05-2021 21:52:44

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible d'installer un nouveau noyau !

Le contenu du fichier grub.cfg que tu as posté est incomplet. Visiblement tu as utilisé nano pour l'afficher, ce qui est une erreur : c'est un éditeur, pas un visualisateur, et il tronque les lignes à la largeur du terminal. Et il manque de nombreuses lignes.

Il vaut mieux montrer que raconter.

Hors ligne

#8 29-05-2021 00:44:04

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

raleur a écrit :

Le contenu du fichier grub.cfg que tu as posté est incomplet. Visiblement tu as utilisé nano pour l'afficher, ce qui est une erreur : c'est un éditeur, pas un visualisateur, et il tronque les lignes à la largeur du terminal. Et il manque de nombreuses lignes.



Oui c'est juste un "grep gnulinux /boot/grub/grub.cfg" pour n'avoir que les infos utiles.

Sam.

Hors ligne

#9 29-05-2021 00:49:24

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

raleur a écrit :

Le contenu du fichier grub.cfg que tu as posté est incomplet. Visiblement tu as utilisé nano pour l'afficher, ce qui est une erreur : c'est un éditeur, pas un visualisateur, et il tronque les lignes à la largeur du terminal. Et il manque de nombreuses lignes.



C'est mieux comme ça? :

enuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-c2ebbc31-7fa0-40d1-a2fc-341702266b8d'
{
submenu 'Options avancées pour Debian GNU/Linux' $menuentry_id_option 'gnulinux-advanced-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, avec Linux 4.19.0-0.bpo.16-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.1
9.0-0.bpo.16-amd64-advanced-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, with Linux 4.19.0-0.bpo.16-amd64 (systemd)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gn
ulinux-4.19.0-0.bpo.16-amd64-init-systemd-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, with Linux 4.19.0-0.bpo.16-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_opti
on 'gnulinux-4.19.0-0.bpo.16-amd64-recovery-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, avec Linux 4.9.159-vs2.3.9.8-samp-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnuli
nux-4.9.159-vs2.3.9.8-samp-amd64-advanced-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, with Linux 4.9.159-vs2.3.9.8-samp-amd64 (systemd)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_opt
ion 'gnulinux-4.9.159-vs2.3.9.8-samp-amd64-init-systemd-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, with Linux 4.9.159-vs2.3.9.8-samp-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_
id_option 'gnulinux-4.9.159-vs2.3.9.8-samp-amd64-recovery-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, avec Linux 4.9.0-15-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.9.0-15-a
md64-advanced-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, with Linux 4.9.0-15-amd64 (systemd)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-
4.9.0-15-amd64-init-systemd-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
        menuentry 'Debian GNU/Linux, with Linux 4.9.0-15-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnu
linux-4.9.0-15-amd64-recovery-c2ebbc31-7fa0-40d1-a2fc-341702266b8d' {
 



Sam.

Hors ligne

#10 29-05-2021 10:30:45

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible d'installer un nouveau noyau !

Ça reste perfectible : il y a des sauts de lignes intempestifs qui gênent la lecture et la recherche de texte notamment. Ça vient peut-être du terminal utilisé.

Pour revenir au problème initial, si tu veux utiliser les id il faut spécifier "id du sous-menu>id de l'entrée de menu" comme expliqué dans https://www.gnu.org/software/grub/manua … ml#default. Or tu avais spécifié deux fois l'id de l'entrée de menu.

Quant à GRUB_SAVEDEFAULT, il n'est pas défini par défaut et il ne figure pas dans ton /etc/default/grub initial donc je ne vois aucune raison de le définir explicitement à false. D'autre part cette fonctionnalité ne sert que si GRUB_DEFAULT=saved.

Il vaut mieux montrer que raconter.

Hors ligne

#11 29-05-2021 12:20:40

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

raleur a écrit :

Ça reste perfectible : il y a des sauts de lignes intempestifs qui gênent la lecture et la recherche de texte notamment. Ça vient peut-être du terminal utilisé.

Pour revenir au problème initial, si tu veux utiliser les id il faut spécifier "id du sous-menu>id de l'entrée de menu" comme expliqué dans https://www.gnu.org/software/grub/manua … ml#default. Or tu avais spécifié deux fois l'id de l'entrée de menu.

Quant à GRUB_SAVEDEFAULT, il n'est pas défini par défaut et il ne figure pas dans ton /etc/default/grub initial donc je ne vois aucune raison de le définir explicitement à false. D'autre part cette fonctionnalité ne sert que si GRUB_DEFAULT=saved.



Oui effectivement je l'ai vu après c'est pour ça que l'option GRUB_DEFAULT="1>3" est plus lisible et parlante.

Sam.

Hors ligne

#12 29-05-2021 12:42:03

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible d'installer un nouveau noyau !

Oui, mais les numéros ne sont pas aussi fiables que les id. Ils peuvent changer en cas d'installation ou suppression d'un autre noyau, ou dans ton cas si tu installes systemd-sysv comme gestionnaire d'init par défaut à la place de sysvinit-core et désinstalles sysvinit (ça supprimera les entrées supplémentaires "systemd").

Il vaut mieux montrer que raconter.

Hors ligne

#13 29-05-2021 12:51:52

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

raleur a écrit :

Oui, mais les numéros ne sont pas aussi fiables que les id. Ils peuvent changer en cas d'installation ou suppression d'un autre noyau, ou dans ton cas si tu installes systemd-sysv comme gestionnaire d'init par défaut à la place de sysvinit-core et désinstalles sysvinit (ça supprimera les entrées supplémentaires "systemd").



C'est sûr qu'avant de bidouiller il faut revérifier les entrées quand on installe ou enlève un noyau, concernant le gestionnaire d'Init je suis obligé d'utiliser SysV à cause de mon outil de virtualisation (VServer) qui n'est pas compatible avec Systemd d'ailleurs je n'ose pas trop upgrader en Debian 10 au cas où il forcerait l'installation de Systemd, je n'ai pas encore eu le temps de vérifier.

Sam.

Hors ligne

#14 29-05-2021 13:52:01

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Impossible d'installer un nouveau noyau !

Il faut vérifier si le paquet sysvinit-core est toujours disponible dans buster et contient /sbin/init (apparemment oui). Lors de la mise à niveau et notamment du dist-upgrade, il faut bien vérifier que ce paquet ne va pas être désinstallé avant d'accepter.

Il vaut mieux montrer que raconter.

Hors ligne

#15 29-05-2021 14:00:56

samprz
Membre
Lieu : Cannes FR
Distrib. : Debian 9.13
Inscription : 27-05-2021

Re : [Résolu] Impossible d'installer un nouveau noyau !

raleur a écrit :

Il faut vérifier si le paquet sysvinit-core est toujours disponible dans buster et contient /sbin/init (apparemment oui). Lors de la mise à niveau et notamment du dist-upgrade, il faut bien vérifier que ce paquet ne va pas être désinstallé avant d'accepter.



Tiens c'est une idée, je vais tester un dist-upgrade sur VirtualBox sur ma Ubuntu 20.04 LTS.

Sam.

Hors ligne

Pied de page des forums