Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-05-2021 07:54:15

Oursonobo
Membre
Inscription : 12-12-2017

Crash LO suite mise à jour

Bonjour,

J'ai LibreOffice qui crash au démarrage depuis ma dernière mise à jour auto. Elle s'est faite pendant que j'utilisais LO.
Pas eu de message à la fermeture.
Quand je vais voir dans dpkg.log j'ai ça :

2021-05-25 21:32:08 startup archives unpack
2021-05-25 21:32:08 upgrade liblz4-1:amd64 1.8.3-1 1.8.3-1+deb10u1
2021-05-25 21:32:08 status triggers-pending libc-bin:amd64 2.28-10
2021-05-25 21:32:08 status half-configured liblz4-1:amd64 1.8.3-1
2021-05-25 21:32:08 status unpacked liblz4-1:amd64 1.8.3-1
2021-05-25 21:32:08 status half-installed liblz4-1:amd64 1.8.3-1
2021-05-25 21:32:09 status unpacked liblz4-1:amd64 1.8.3-1+deb10u1
2021-05-25 21:32:09 startup packages configure
2021-05-25 21:32:09 configure liblz4-1:amd64 1.8.3-1+deb10u1 <none>
2021-05-25 21:32:09 status unpacked liblz4-1:amd64 1.8.3-1+deb10u1
2021-05-25 21:32:09 status half-configured liblz4-1:amd64 1.8.3-1+deb10u1
2021-05-25 21:32:09 status installed liblz4-1:amd64 1.8.3-1+deb10u1
2021-05-25 21:32:10 startup archives unpack
2021-05-25 21:32:10 upgrade libx11-6:amd64 2:1.6.7-1+deb10u1 2:1.6.7-1+deb10u2
2021-05-25 21:32:10 status half-configured libx11-6:amd64 2:1.6.7-1+deb10u1
2021-05-25 21:32:10 status unpacked libx11-6:amd64 2:1.6.7-1+deb10u1
2021-05-25 21:32:10 status half-installed libx11-6:amd64 2:1.6.7-1+deb10u1
2021-05-25 21:32:11 status unpacked libx11-6:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:11 upgrade libx11-xcb1:amd64 2:1.6.7-1+deb10u1 2:1.6.7-1+deb10u2
2021-05-25 21:32:11 status half-configured libx11-xcb1:amd64 2:1.6.7-1+deb10u1
2021-05-25 21:32:11 status unpacked libx11-xcb1:amd64 2:1.6.7-1+deb10u1
2021-05-25 21:32:11 status half-installed libx11-xcb1:amd64 2:1.6.7-1+deb10u1
2021-05-25 21:32:12 status unpacked libx11-xcb1:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:12 startup packages configure
2021-05-25 21:32:12 configure libx11-xcb1:amd64 2:1.6.7-1+deb10u2 <none>
2021-05-25 21:32:12 status unpacked libx11-xcb1:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:12 status half-configured libx11-xcb1:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:12 status installed libx11-xcb1:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:12 configure libx11-6:amd64 2:1.6.7-1+deb10u2 <none>
2021-05-25 21:32:12 status unpacked libx11-6:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:12 status half-configured libx11-6:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:12 status installed libx11-6:amd64 2:1.6.7-1+deb10u2
2021-05-25 21:32:12 configure filius:all 1.9.0 <none>
2021-05-25 21:32:12 status half-configured filius:all 1.9.0
2021-05-25 21:32:51 trigproc libc-bin:amd64 2.28-10 <none>
2021-05-25 21:32:51 status half-configured libc-bin:amd64 2.28-10
2021-05-25 21:32:52 status installed libc-bin:amd64 2.28-10



J'ai deux questions :
Comment savoir quel paquet a bien pu mettre le bazar ? comme ça je dirai libc-bin.
Comment faire pour revenir à la version précédente de ce paquet?

Je suis en version 7.1 de LO avec le dépôt backport

Merci

Hors ligne

#2 31-05-2021 10:25:50

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Crash LO suite mise à jour

LO est-il entièrement installé en version 7 backports ?

2:1.6.7-1+deb10u1



status half-configured

Hors ligne

#3 31-05-2021 10:59:51

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Crash LO suite mise à jour

En complément de mon poste précédent, pour connaître l'état des paquets :

dpkg -l | grep ^ii | grep libreoffice



Chez moi, ça donne :

 ii  liblibreoffice-java                   1:7.0.4~rc2-1~bpo10+2                   all          LibreOffice UNO runtime environment -- Java library
ii  libreoffice                           1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite (metapackage)
ii  libreoffice-base                      1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- database
ii  libreoffice-base-core                 1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- shared library
ii  libreoffice-base-drivers              1:7.0.4~rc2-1~bpo10+2                   amd64        Database connectivity drivers for LibreOffice
ii  libreoffice-calc                      1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- spreadsheet
ii  libreoffice-common                    1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- arch-independent files
ii  libreoffice-core                      1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- arch-dependent files
ii  libreoffice-draw                      1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- drawing
ii  libreoffice-gtk3                      1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- GTK+ 3 integration
ii  libreoffice-impress                   1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- presentation
ii  libreoffice-java-common               1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- arch-independent Java support files
ii  libreoffice-l10n-fr                   1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- French language package
ii  libreoffice-math                      1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- equation editor
ii  libreoffice-nlpsolver                 0.9+LibO6.1.5-3+deb10u7                 all          "Solver for Nonlinear Programming" extension for LibreOffice
ii  libreoffice-report-builder            1:7.0.4~rc2-1~bpo10+2                   all          LibreOffice component for building database reports
ii  libreoffice-report-builder-bin        1:7.0.4~rc2-1~bpo10+2                   amd64        LibreOffice component for building database reports -- libraries
ii  libreoffice-script-provider-bsh       1:7.0.4~rc2-1~bpo10+2                   all          BeanShell script support provider for LibreOffice scripting framework
ii  libreoffice-script-provider-js        1:7.0.4~rc2-1~bpo10+2                   all          JavaScript script support provider for LibreOffice scripting framework
ii  libreoffice-script-provider-python    1:7.0.4~rc2-1~bpo10+2                   all          Python script support provider for LibreOffice scripting framework
ii  libreoffice-sdbc-firebird             1:7.0.4~rc2-1~bpo10+2                   amd64        Firebird SDBC driver for LibreOffice
ii  libreoffice-sdbc-mysql                1:7.0.4~rc2-1~bpo10+2                   amd64        MariaDB/MySQL SDBC driver for LibreOffice
ii  libreoffice-sdbc-postgresql           1:7.0.4~rc2-1~bpo10+2                   amd64        PostgreSQL SDBC driver for LibreOffice
ii  libreoffice-style-colibre             1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- colibre symbol style
ii  libreoffice-wiki-publisher            1.2.0+LibO6.1.5-3+deb10u7               all          LibreOffice extension for working with MediaWiki articles
ii  libreoffice-writer                    1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- word processor
 

Hors ligne

#4 31-05-2021 11:22:22

Oursonobo
Membre
Inscription : 12-12-2017

Re : Crash LO suite mise à jour

J'ai fait

apt show libreoffice


J'en ai extrait ça

Package: libreoffice
Version: 1:7.0.4~rc2-1~bpo10+2
 



J'ai tenté de lancer LO depuis le terminal. Ça a fonctionné, mais j'ai de nouveau un message d'erreur quand je veux enregistrer ou ouvrir un document

Impossible de créer le module d'entrée / sortie. Impossible de créer un socket avec un module d'entrée / sortie pour le protocole « file ».



Merci

Hors ligne

#5 31-05-2021 11:27:20

Oursonobo
Membre
Inscription : 12-12-2017

Re : Crash LO suite mise à jour

Avec la commande que tu as donné ça donne ça :

ii  liblibreoffice-java                           1:7.0.4~rc2-1~bpo10+2                   all          LibreOffice UNO runtime environment -- Java library
ii  libreoffice                                   1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite (metapackage)
ii  libreoffice-base                              1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- database
ii  libreoffice-base-core                         1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- shared library
ii  libreoffice-base-drivers                      1:7.0.4~rc2-1~bpo10+2                   amd64        Database connectivity drivers for LibreOffice
ii  libreoffice-calc                              1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- spreadsheet
ii  libreoffice-common                            1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- arch-independent files
ii  libreoffice-core                              1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- arch-dependent files
ii  libreoffice-draw                              1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- drawing
ii  libreoffice-help-common                       1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- common files for LibreOffice help
ii  libreoffice-help-en-us                        1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- English_american help
ii  libreoffice-help-fr                           1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- French help
ii  libreoffice-impress                           1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- presentation
ii  libreoffice-java-common                       1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- arch-independent Java support files
ii  libreoffice-kde5                              1:7.0.4~rc2-1~bpo10+2                   amd64        transitional package for LibreOffice "KDE 5" integration
ii  libreoffice-kf5                               1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- KDE Frameworks 5 integration
ii  libreoffice-l10n-fr                           1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- French language package
ii  libreoffice-math                              1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- equation editor
ii  libreoffice-nlpsolver                         0.9+LibO6.1.5-3+deb10u7                 all          "Solver for Nonlinear Programming" extension for LibreOffice
ii  libreoffice-plasma                            1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- some Plasma integration
ii  libreoffice-qt5                               1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- Qt 5 integration
ii  libreoffice-report-builder                    1:7.0.4~rc2-1~bpo10+2                   all          LibreOffice component for building database reports
ii  libreoffice-report-builder-bin                1:7.0.4~rc2-1~bpo10+2                   amd64        LibreOffice component for building database reports -- libraries
ii  libreoffice-script-provider-bsh               1:7.0.4~rc2-1~bpo10+2                   all          BeanShell script support provider for LibreOffice scripting framework
ii  libreoffice-script-provider-js                1:7.0.4~rc2-1~bpo10+2                   all          JavaScript script support provider for LibreOffice scripting framework
ii  libreoffice-script-provider-python            1:7.0.4~rc2-1~bpo10+2                   all          Python script support provider for LibreOffice scripting framework
ii  libreoffice-sdbc-firebird                     1:7.0.4~rc2-1~bpo10+2                   amd64        Firebird SDBC driver for LibreOffice
ii  libreoffice-sdbc-hsqldb                       1:7.0.4~rc2-1~bpo10+2                   amd64        HSQLDB SDBC driver for LibreOffice
ii  libreoffice-sdbc-mysql                        1:7.0.4~rc2-1~bpo10+2                   amd64        MariaDB/MySQL SDBC driver for LibreOffice
ii  libreoffice-sdbc-postgresql                   1:7.0.4~rc2-1~bpo10+2                   amd64        PostgreSQL SDBC driver for LibreOffice
ii  libreoffice-style-breeze                      1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- Breeze symbol style
ii  libreoffice-style-colibre                     1:7.0.4~rc2-1~bpo10+2                   all          office productivity suite -- colibre symbol style
ii  libreoffice-wiki-publisher                    1.2.0+LibO6.1.5-3+deb10u7               all          LibreOffice extension for working with MediaWiki articles
ii  libreoffice-writer                            1:7.0.4~rc2-1~bpo10+2                   amd64        office productivity suite -- word processor



Je pense bien être sur la totalité de LO installée via le  Backport

Hors ligne

#6 31-05-2021 17:51:57

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Crash LO suite mise à jour

Nous avons les mêmes paquets, et en regardant mieux ton premier post, il ne me semble pas qu'un paquet ait été mal installé.

Donc : je sèche.

A part redémarrer l'ordi, faire un dpkg-configure -a ou réinstaller LO, je ne vois pas, et ne vois pas non plus où rechercher simplement des infos complémentaires...

Dernière modification par hybridemoineau (31-05-2021 17:54:45)

Hors ligne

Pied de page des forums