Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-06-2021 17:00:28

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Problème d'export vers pdf depuis LO-writer (6.1.5.2)

Bonjour,

dans un document de 26 pages A5 constituées à 90 % d'images de tailles diverses et variées accompagnées de petites légendes, images toutes générées en png avec The Gimp, il se trouve que les pages 4 et 13 sont présentes mais vides, sans aucune raison.

J'ai retourné tout le web pour ne trouver que des solutions inappropriées, alors je viens voir ici des fois que quelqu'un aurait une bonne idée.

PS : mon document LO-writer doit être correct puisque si je le transfère dans une machine virtuelle Windows7, son LO (6.3.6.2) me l'exporte impeccablement.

Le grand frère de ce document, 64 pages au lieu de 26, souffre du même problème : pages 4 et 5 blanches, ainsi que les 24, 30 et 51. Un truc de malade qui ne mérite qu'une chose : passer LO par la fenêtre.

Et si on ajoute à ça le fait que pendant mon travail sur ce document, récemment (trois ou quatre jours), sans rien faire de spécial, environ les deux tiers des images ont disparu d'un coup sans autre forme de procès et quand j'ai enregistré cette catastrophe sous un autre nom elle pesait deux fois moins lourd que la sauvegarde de la veille de l'autre, vous comprendrez que ma confiance en la fiabilité des outils informatiques va en s'amenuisant, de jour en jour.

Car n'oublions pas que parfois, lors de l'export pdf, je me prends une fenêtre "Certains objets ont été convertis en image afin de supprimer les transparences parce que le format PDF cible ne prend pas en charge les transparences. Vous obtiendrez un meilleur résultat si vous supprimez les objets transparents avant l'export."
D'accord, mais lesquels ? Cette imbécile de fenêtre se garde bien de me le préciser.
Et on s'étonne que je roumègue ! Mais il y a de quoi ! Ça fait des années que je me tape cette fenêtre, quelle que soit la version LO, c'est lassant !
Thanks God il me reste une machine virtuelle Windows pour me sortir de la mouise dans laquelle me plonge le Libre. C'est malheureux mais c'est comme ça.

PS2 : pour tester cette histoire, je tente une autre machine virtuelle mais mal m'en a pris : sur celle-ci unattended-upgrade fonctionne et on se croirait sous Windows, il se lance au démarrage (proc à bloc, indicateur à côté de l'horloge intégralement vert) sans me demander mon avis, et arrêter le service systemd ben, c'est du Windows, y a pas moyen : la commande est prise par le terminal mais ça ne rend pas la main et je ne peux pas bosser tant que cézigue n'aura pas fini son taf -- sans me dire ce qu'il fait, bien sûr.
Et moi, qu'est-ce que je peux faire pendant ce temps ? Ben, venir déverser ma bile sur les forums, je connais au moins un lecteur que ça va amuser...

Ah, la machine virtuelle a fini son bazar perso, je peux enfin bosser avec son LO (6.1.5.3 deb10u7) et là c'est bon. Enfin, pour le petit fichier (60 Mo). Car pour le gros (180 Mo), c'est une erreur d'entrée-sortie générale après la petite fenêtre des objets transparents, et dmesg ne donne rien -- elle est pas belle la vie ?
Ce qui n'a pas empêché le fichier d'être correctement enregistré là où je l'ai demandé -- de moins en moins confiance, je vous dis...

Bon, allez, je me doute bien que personne n'aura de solution, il nous faut juste apprendre à vivre avec ces galères, un peu comme avec la covid…

Dernière modification par jpt (03-06-2021 17:03:46)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

En ligne

#2 03-06-2021 19:41:43

robert2a
Membre
Distrib. : debian 11
(G)UI : Mate
Inscription : 15-11-2014

Re : Problème d'export vers pdf depuis LO-writer (6.1.5.2)

Bonjour
pour ceci


PS2 : pour tester cette histoire, je tente une autre machine virtuelle mais mal m'en a pris :
sur celle-ci unattended-upgrade fonctionne et on se croirait sous Windows,
 il se lance au démarrage (proc à bloc, indicateur à côté de l'horloge intégralement vert)
sans me demander mon avis, et arrêter le service systemd ben, c'est du Windows, y a pas moyen :
la commande est prise par le terminal mais ça ne rend pas la main
et je ne peux pas bosser tant que cézigue n'aura pas fini son taf -- sans me dire ce qu'il fait, bien sûr.
Et moi, qu'est-ce que je peux faire pendant ce temps ?
Ben, venir déverser ma bile sur les forums, je connais au moins un lecteur que ça va amuser...
 



je l'ai utiliser pendant longtemps sans aucun souci , juste bien le configurer.
ps: par défaut  il ne fait que les mises a jours de sécurité , donc sur une stable , il ne fait pas grand chose  , du moins pas souvent .
sinon sur stable j'utilise "gpk-update-viewer" qui est sympatique (icone sur le bureau , mise a jour disponible ) qui est différer au démarrage.
il me semble aussi qu'il se lance en tache de fond , tu parle d un indicateur , c'est louche tongue

Hors ligne

#3 03-06-2021 19:57:35

leonlemouton
Adhérent(e)
Distrib. : Buster
(G)UI : Mate ∨ LXQt
Inscription : 14-08-2012

Re : Problème d'export vers pdf depuis LO-writer (6.1.5.2)

Bonsoir,
L'export est réalisé pour la norme pdf/a-1 ?
Cela peut poser problème avec la transparence.
https://fr.m.wikipedia.org/wiki/PDF/A#Description
Bon courage.

Leonlemouton
°(")°

Hors ligne

#4 03-06-2021 20:16:41

jpt
Membre
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Problème d'export vers pdf depuis LO-writer (6.1.5.2)

leonlemouton a écrit :

L'export est réalisé pour la norme pdf/a-1 ?
Cela peut poser problème avec la transparence.


Ben oui, histoire de ne pas avoir de soucis chez les copyshop_n_center's.
Effectivement, en décochant l'option je n'ai plus le message des "objets transparents" qui n'existent de toute façon pas, dans la mesure où j'aplatis mes images.

Mais ça ne règle pas le pb des pages 4 et 13 toujours blanches sans aucune bonne raison... Truc de ouf'

J'ai même tenté, sur la nouvelle machine, après l'ouverture du .odt en provenance de l'ancienne machine, de récrire le fichier avec donc la version 6.1.5.2 puis de l'exporter, mais bernique...

Par contre, utiliser le vieux LO 3.5 de la vieille machine (Debian Wheezy 32 bits) fonctionne très bien -- pourquoi migrer, alors…

Merci pour ton retour,

Quant à la piste pour les mises à jour de robert2a, je n'aurai que quatre mots, garçon, tu me désespères ! lol


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

En ligne

Pied de page des forums