Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-07-2021 19:28:51

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[fermé - résolu sans solution] Boutons rapides désormais inactifs

Bonjour,

Ma debian est sous MATE 1.24.1

depuis deux semaines, deux de mes boutons rapides ont cessé de répondre:
1) Power : qui avait était programmé dans  Préférences / Matériel / Raccourcis clavier  pour questionner Mettre en veille, éteindre .... ne provoque plus de question.  Quand je touche le bouton, il éteint la machine sans tenir compte de la programmation MATE.

2) Wifi : le bouton Wifi devrait activer / désactiver la connexion sans fil.  Il est, depuis le même temps que le bouton Power, bloqué en rouge, interdisant de ce fait l'activation du wifi.


Ici je parle d'un HP Probook 6360b n'ayant que quatre boutons rapides ( Power / Wifi / Internet / Son ). 
Les boutons Internet et Son fonctionnent, le premier ouvrant un fureteur FireFox en page d'accueil, le second allumant et éteignant correctement le son des haut parleurs

Comment retrouver l'usage des mes boutons ?


Je soupçonne que ce problème soit lié à des tentatives d'installation de Zoom et Rstudio ou autre logiciel externe, c'est pourquoi je vous retransmets ci-bas l'historique de mes commande root de la période visée.

Merci de votre aide.


  213  dpkg -i zoom_amd64.deb
  214  apt-get install libegl1-mesa
  215  apt-get intall ibus
  216  exit
  217  apt -y install lsb-release apt-transport-https ca-certificates
  218  wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
  219  apt-get update
  220  apt-get upgrade
  244  dpkg -i zoom_amd64.deb
  245  dpkg -i zoom_amd64.deb
  246  apt-get install ibus
  247  apt-get purge zoom
  248  apt --fix-broken install
  249  dpkg -i zoom_amd64.deb
  250  apt --fix-broken install
  251  nano /etc/apt/sources.list
  252  apt-get update
  253  /etc/init.d/apache2 stop
  254  /etc/init.d/php7.4-fpm stop
  255  /etc/init.d/php8.0-fpm stop
  256  apt-get remove ibus
  257  apt-get purge zoom
  258  apt-get purge ibus ibus-data ibus-gtk ibus-gtk3 im-config libibus-1.0-5 python3-ibus-1.0
  259  apt-get autoremove

  261  apt-get remove tracker-store tracker-extract tracker-miner-fs
  262  apt-get remove tracker-extract tracker-miner-fs
  263  apt autoremove

  265  /etc/init.d/php8.0-fpm stop
  266  apt-get remove php8
  267  apt-get remove php8.0
  268  apt-get remove php7.3-sqlite3
  269  apt-get install php7.4-mysql
  272  apt-get autoremove
  273  apt-get update
  282  cat lutris.list
  283  nano libfaudio.list
  284  nano libfaudio.list.save
  285  nano lutris.list
  286  apt-get update
  287  apt-get upgrade
  288  dmesg
  289  rmmod sdhci sdhci_pci sdhci_acpi
  290   modprobe sdhci debug_quirks2="0x10000"
  291      Load the sdhci_pci module again with modpr
  292   modprobe sdhci debug_quirks2="0x10000"
  293      Load the sdhci_pci module again with modpr~
  294  rmmod sdhci sdhci_pci sdhci_acpi
  295  modprobe sdhci debug_quirks2="0x10000"
  296  modprobe sdhci debug_quirks2="0x10000"
  297  rmmod sdhci sdhci_pci sdhci_acpi
  298  modprobe sdhci debug_quirks2="0x10000"
  304  rmmod sdhci sdhci_pci sdhci_acpi
  306  rmmod sdhci sdhci_pci sdhci_acpi
  307  modprobe sdhci debug_quirks2="0x10000"
  308  modprobe sdhci sdhci_pci sdhci_acpi
  309  modprobe sdhci sdhci_pci sdhci_acpi debug_quirks2="0x10000"
  310  rmmod sdhci sdhci_pci sdhci_acpi
  311  modprobe sdhci sdhci_pci sdhci_acpi debug_quirks2="0x10000"
  312  rmmod sdhci sdhci_pci sdhci_acpi
  313  modprobe sdhci debug_quirks2="0x10000"
  314  modprobe sdhci_pci
  315  modprobe sdhci_acpi
  330  dmesg
  331  mount.exfat-fuse /dev/sdb1 /media/exfat
  332  mount.exfat-fuse /dev/sdb1 /media/exfat
  333  mount.exfat-fuse /dev/sdb1 /media/exfat
  337  apt-get install exfat
  338  apt-get install exfat-fuse exfat-utils
  339  apt-get install exfat-fuse exfat-utils -f
  340  apt-get purge exfat-fuse exfat-utils
  341  apt-get purge exfat-fuse exfat-utils
  342  apt-autoremove
  343  apt autoremove
  344  apt-get install exfat-fuse exfat-utils
  345  apt-get install r-base
  346  apt-get install gdebi-core
  347  wget https://download2.rstudio.org/server/bionic/amd64/rstudio-server-1.4.1717-amd64.deb
  348  gdebi rsturio-server-1.4.1717-amd64.deb
  350  gdebi rstudio-server-1.4.1717-amd64.deb
  351  apt-get install libclang-dev
  352  apt-get install -f libc6-dev
  353  apt-get install -f libcc-8-dev
  354  apt-get install -f libcc-8-devls
  356  dpkg -i libgcc-8-dev_8.3.0-6_amd64.deb
  361  dpkg -i libasan5_8.3.0-6_amd64.deb
  362  dpkg -i libgcc-8-dev_8.3.0-6_amd64.deb
  364  dpkg -if libc6-dev_2.28-10_amd64.deb
  365  dpkg -i libc6-dev_2.28-10_amd64.deb
  366  apt autofix
  367  apt-get fix
  368  apt-get --help

  371  apt-get autoclean
  372  apt-get autoremove
  373  apt-get remove gfortran-10
  374  apt --fix-broken install
  375  apt-get update
  376  apt-get upgrade
  377  apt autoremove
  379  gdebi rstudio-server-1.4.1717-amd64.deb
  380  apt-get install libclang-dev
  381  apt --fix-boken
  382  apt --fix-boken install
  383  apt --fix-broken install
  384  apt-get install libclang-dev
  385  apt-get install libc6
  386  apt-get install libc-dev-bin
  387  apt-get install libc-dev-bin --force
  388  apt-get install -force libc-dev-bin
  389  apt-get install -f libc-dev-bin
  390  apt --fix-broken install
 

Dernière modification par Patriboom (10-07-2021 00:21:26)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 03-07-2021 13:30:31

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Hello
Regarde les options depuis le centre de contrôle -->gestionnaire d'énergie
tu as 2 menus déroulant qui te permettent de sélectionner l'action voulu en cas d'appui sur le bouton power et en cas d'appui sur le bouton veille

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 03-07-2021 13:48:54

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Merci Croutons,

la config est bien à "Poser la question".
Ça illustre ce que j'écris ci-haut:  les configuration de MATE ne sont pas prises en considération.  Je suis revenu aux config par défaut de la machine.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 03-07-2021 14:20:25

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

ce que je vois dans ton historique il y a apt autoremove qui parfois peu mettre le boxon
consulte les logs apt et vois les paquet supprimé par apt autoremove

pour exemple : une fois j'avais voulu viré la calculatrice mate et la remplacer par celle de gnome, mais c'était une mauvaise idée car elle fait partie d'un metapaquet
du coup apt autoremove m'avais viré network manager (plus d'internet)
tu peux rechercher dans les logs
/var/apt/history.log ou les fichiers compressé si plus ancien
dans menu -->outils système il y a la visionneuse de journaux système que te permet d'ouvrir les fichiers log pour les consulter
coupler avec un filtre avec un surlignage de autoremove
KV7imFNy.png

ou sinon depuis un terminale affichage sur 5 lignes

cat /var/log/apt/history.log|grep -A5 autoremove


zcat /var/log/apt/history.log.1.gz|grep -A5 autoremove


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 03-07-2021 14:46:24

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Merci encore croutons,
pour ma part, je ne reconnais pas de bibliothèque incriminante dans la liste ci-bas.  Je compte 4 autoremove dans mes commandes et j'ai ici classé par ordre alphabétique le résultat de ces 4 commandes


dconf-cli:amd64 (0.38.0-2)
dwz:amd64 (0.13+20210201-1), ecj-gcj:amd64 (3.11.1-1),
ecj1:amd64 (3.11.1-1),
gcj-6-jre:amd64 (6.3.0-18+deb9u1),
gcj-jre:amd64 (4:6.3.0-4),
gir1.2-gtk-2.0:amd64 (2.24.33-1),
gir1.2-harfbuzz-0.0:amd64 (2.7.4-1),
intltool-debian:amd64 (0.35.0+20060710.5),
libantlr-java:amd64 (2.7.7+dfsg-10),
libarchive-cpio-perl:amd64 (0.10-1.1)
libarchive-zip-perl:amd64 (1.68-1),
libboost-atomic1.55.0:amd64 (1.55.0+dfsg-3),
libboost-chrono1.55.0:amd64 (1.55.0+dfsg-3),
libboost-context1.55.0:amd64 (1.55.0+dfsg-3),
libboost-serialization1.55.0:amd64 (1.55.0+dfsg-3),
libboost-system1.55.0:amd64 (1.55.0+dfsg-3),
libbrotli-dev:amd64 (1.0.9-2+b2),
libc-dev-bin:amd64 (2.31-9),
libcrypt-dev:amd64 (1:4.4.17-1),
libcue2:amd64 (2.2.1-3),
libecj-java-gcj:amd64 (3.11.1-1),
libegl1-mesa:amd64 (20.3.4-1),
libexif-doc:amd64 (0.6.22-3),
libfile-stripnondeterminism-perl:amd64 (1.1.2-1),
libgfortran-10-dev:amd64 (10.2.1-6),
libgfortran-6-dev:amd64 (6.3.0-18+deb9u1),
libgfortran3:amd64 (6.3.0-18+deb9u1),
libglib2.0-dev-bin:amd64 (2.66.7-1),
libgraphite2-dev:amd64 (1.3.14-1),
libgssrpc4:amd64 (1.18.3-4),
libharfbuzz-gobject0:amd64 (2.7.4-1),
libkadm5clnt-mit12:amd64 (1.18.3-4),
libkadm5srv-mit12:amd64 (1.18.3-4),
libkdb5-10:amd64 (1.18.3-4),
libltdl-dev:amd64 (2.4.6-15),
libmbim-glib4:amd64 (1.24.6-0.1),
libmbim-proxy:amd64 (1.24.6-0.1),
libnsl-dev:amd64 (1.3.0-2),
libosinfo-1.0-0:amd64 (1.2.0-1),
libpcre16-3:amd64 (2:8.44-2+0~20210301.9+debian10~1.gbpa278ad),
libpcre2-32-0:amd64 (10.36-2+0~20210212.6+debian10~1.gbp6138a4),
libpcre2-posix2:amd64 (10.36-2+0~20210212.6+debian10~1.gbp6138a4),
libpcre32-3:amd64 (2:8.44-2+0~20210301.9+debian10~1.gbpa278ad),
libpixman-1-dev:amd64 (0.40.0-1),
libpng-tools:amd64 (1.6.37-3),
libqmi-glib5:amd64 (1.26.10-0.1)
libqmi-proxy:amd64 (1.26.10-0.1),
librpmbuild8:amd64 (4.14.2.1+dfsg1-1),
librpmsign8:amd64 (4.14.2.1+dfsg1-1),
libsepol1-dev:amd64 (3.1-1),
libtirpc-dev:amd64 (1.3.1-1),
libtotem-plparser-common:amd64 (3.26.5-5),
libtotem-plparser18:amd64 (3.26.5-5)
libtracker-miner-2.0-0:amd64 (2.3.6-2),
libxcb-shm0-dev:amd64 (1.14-3),
libxcomposite-dev:amd64 (1:0.4.5-1),
libxcursor-dev:amd64 (1:1.2.0-2),
libxi-dev:amd64 (2:1.7.10-1),
libxrandr-dev:amd64 (2:1.5.1-1),
libxrender-dev:amd64 (1:0.9.10-1),
osinfo-db:amd64 (0.20210215-1),
pango1.0-tools:amd64 (1.42.4-8~deb10u1),
po-debconf:amd64 (1.0.21+nmu1),
re2c:amd64 (2.0.3-1),
rpm:amd64 (4.14.2.1+dfsg1-1),
usbutils:amd64 (1:010-3),

 




Peut-être   intltool-debian:amd64 (0.35.0+20060710.5) ?????

Merci


Portez la paix
Patrick Allaire, ptre

Hors ligne

#6 03-07-2021 20:34:42

èfpé
Membre
Inscription : 10-07-2016

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Bonsoir,

Patriboom a écrit :

Comment retrouver l'usage des mes boutons ?


La perte du bouton Wi-Fi, évoque une régression du noyau... as-tu conservé la version 4.19.0-16 ?
Si oui, redémarrer sur cette version permettrait de faire rapidement/simplement la part des choses !

Cette mise à jour du noyau, avec changement d'ABI (Bump ABI to 17), a dû se faire vers le 12 juin.

Hors ligne

#7 04-07-2021 05:06:22

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Bonjour à tous,

merci èfpé

J'ai tenté un démarrage en 4.19-0-17, 0-14, et en 0-13  : toujours la même chose.
J'ai aussi essayé avec i3 et wmp plutôt que MATE : toujours la même chose.

J'ai regardé le lien auquel tu me réfères

èfpé a écrit :


Cette mise à jour du noyau, avec changement d'ABI (Bump ABI to 17), a dû se faire vers le 12 juin.


Mais je n'y comprends rien.
Que dois-je faire de toutes ces informations ?


Merci.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 04-07-2021 09:17:00

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

les préférences de réglage sont géré par une base de données
regarde ce que te renvoie

ps aux|grep dconf


stephane  1550  0.0  0.1 160004  5948 ?        Sl   08:17   0:00 /usr/lib/dconf/dconf-service



chez moi dconf-cli c'est installé avec le paquet mate-tweak
si je consulte les valeurs de la base de donnée

dconf read /org/mate/power-manager/button-power


'shutdown'


dconf read /org/mate/power-manager/button-suspend


'suspend'


je retrouve bien les même réglages qu'il y a dans le gestionnaire d’énergie


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 04-07-2021 12:36:42

èfpé
Membre
Inscription : 10-07-2016

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Bonjour,

Patriboom a écrit :

J'ai tenté un démarrage en 4.19-0-17, 0-14, et en 0-13 : toujours la même chose.


Le problème ne vient donc pas du noyau c'est déjà ça. Du coup le lien posté en #6 est sans intérêt.

Patriboom a écrit :

Ma debian est sous MATE 1.24.1


Cette version n'existe pas et la version 1.24.1 n'a pas été rétroportée, elle vient du dépôt bullseye ?
Tu as supprimé des paquets intéressants (ex. : usbutils) ; un historique APT complet pourrait aider.

Hors ligne

#10 04-07-2021 14:43:50

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Bonjour,

èfpé a écrit :

Tu as supprimé des paquets intéressants (ex. : usbutils) ; un historique APT complet pourrait aider.



Oui, c'est bien ce que je pense, mais je n'arrive pas à trouver lequel ou lesquels.

je vais chercher l'historique d'APT et vous reviendrai.
Merci.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#11 04-07-2021 19:53:03

subreptice
Membre
Distrib. : opensuse11.1
Noyau : vintage ...
(G)UI : bole
Inscription : 22-05-2021

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Bonjour.

Le paquet gir1.2-matekbd-1.0 a pour dépendance gir1.2-gtk-3.0.
J'ai vu qu'autoremove t'avait désinstallé gir1.2-gtk-2.0.
Je sait pas si c'est une piste sérieuse, mais au cas ou tu n'ai pas le ...3.0 d'installé ...

Hors ligne

#12 09-07-2021 21:08:24

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Belle piste, subreptice, mais la ré-installation de ces paquets n'a rien changé.
Je cherche encore, mais les mots-clefs  "debian quick button HP" ne mènent à rien d'utile sur internet.  Peut-être auriez-vous d'autres suggestions de recherche.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#13 10-07-2021 00:16:52

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Buster (10)
Noyau : Linux 4.19.37-5
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [fermé - résolu sans solution] Boutons rapides désormais inactifs

Eh bien!

J'ai désinstallé des paquets, plusieurs paquets et mon wifi est de retour.  Je reste incapable d'identifier quels paquets créaient des conflits.

Outre les paquets  r-...
Les paquets suivants ont été supprimés:

clustalo cpufrequtils dssp fonts-font-awesome libargtable2-0 libboost-program-options1.67.0 libcpufreq0 libcsv-java libjs-d3 libjs-es5-shim libjs-highlight.js libjs-jquery-datatables libjs-jquery-selectize.js libjs-jquery-ui libjs-json libjs-microplugin.js libjs-modernizr libjs-prettify libjs-sifter.js
  libjs-twitter-bootstrap-datepicker libqt5script5 muscle mustang node-highlight.js pandoc pandoc-data r-doc-html salliere smplayer

Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums