Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-07-2021 19:39:45

Martinperdu
Membre
Inscription : 17-07-2021

Debian plante au démarrage !

Bonjour je suis débutant il y a peu j'ai acheter un L380 Yoga j'ai fait un dualboot avec Windows et debian 10 tout fonctionnait bien et puis un jour je n'arrive plus à me connecter avec ces messages d'erreur :

[2,86404921] i915 0000:00:02.0: firmware: failed ta load i915/kbl_dnc-ver1_04.bin

[2.564053] firmare class: See :/wiki.debian.org/Firware for information about missing firmware

[ 2.6000673] i2c_hid 12c-INT3515:02: unexpected HID descriptor bcdVersion (0x0 000)




Je peux lancer le mode mode recovery mais j'ai des problème pour apt update

Hors ligne

#2 17-07-2021 20:01:18

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : Debian plante au démarrage !

bonjour martin,
t'arrives plus à te connecter (genre ça se passe comment ?), je sais pas quoi te répondre dessus, et je suis pas sur que le message sur le firmware manquant en soit la cause:

i915 0000:00:02.0: firmware: failed ta load i915/kbl_dnc-...


tu peux toujours installer ce microcode manquant, inclus dans le paquet firmware-misc-nonfree
cf : https://packages.debian.org/buster/firm … sc-nonfree
Pour l'installer, faudra que tu ajoutes non-free aux lignes de ton sources-list (dans /etc/apt/sources.list )
ca te feras toujours un message d'erreur en moins ....

Hors ligne

#3 17-07-2021 20:16:01

raleur
Membre
Inscription : 03-10-2014

Re : Debian plante au démarrage !

Martinperdu a écrit :

e n'arrive plus à me connecter


Cette phrase n'apporte aucune information utile.
Ces messages d'erreur n'arrivent pas tout seuls du jour au lendemain. Ils pourraient très bien avoir toujours été là sans que tu y fasses attention jusqu'à ce qu'un problème plus grave se produise.

Martinperdu a écrit :

j'ai des problème pour apt update


Cette phrase n'apporte aucune information utile.
Les services responsables de la gestion du réseau ne sont pas démarrés en mode recovery. Si tu sais lequel est installé, tu peux le démarrer manuellement. Par exemple pour les plus courants :

systemctl start NetworkManager
systemctl start wicd
systemctl start networking


Il vaut mieux montrer que raconter.

Hors ligne

#4 17-07-2021 21:01:31

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

Merci pour vos réponse j'ai testé les trois systemctl mais j'ai eu failed to connect to bus : host is down

Hors ligne

#5 17-07-2021 21:05:19

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

Le problème c'est que seul le recovery marche. Si je démarre depuis grub Debian j'obtiens les messages d'erreurs de mon premier post

Hors ligne

#6 17-07-2021 21:08:02

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

Je peux pas installer fimware-misc-non-free car j'ai des problème au niveau par exemple ping  Google.fr ne marche pas

Hors ligne

#7 18-07-2021 08:39:39

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

Le dernier message a disparu après un

apt-get clean

mais je peux installer le fichier car après install est bloqué

failed to fetch

Hors ligne

#8 18-07-2021 09:24:10

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Debian plante au démarrage !

Bonjour,

En gros tu as un problème de réseau non opérationnel, et là, il peut y avoir plein de causes, plein de raisons, mais tu ne nous aides pas à t'aider :

Martinperdu a écrit :

ping  Google.fr ne marche pas

n'est pas un message d'erreur valide. roll

Est-ce que tu vas voir le toubib en lui disant "doc', je suis malade" ? Est-ce que tu appelles le garagiste en lui disant "ma voiture elle marche pô", mmmh ?

Alors regarde les logs, il y a probablement plein d'informations utiles.


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#9 18-07-2021 19:41:38

raleur
Membre
Inscription : 03-10-2014

Re : Debian plante au démarrage !

Martinperdu a écrit :

testé les trois systemctl mais j'ai eu failed to connect to bus : host is down


C'est tout ? Il n'y a pas autre chose avant ?

Martinperdu a écrit :

Le problème c'est que seul le recovery marche. Si je démarre depuis grub Debian j'obtiens les messages d'erreurs de mon premier post


Je suis dubitatif sur les deux points.
- Les messages d'erreur : ce sont des messages du noyau, il n'y a pas de raison qu'ils se produisent dans un cas et pas dans l'autre. A mon avis ils sont simplement noyés dans le flot des messages d'information affichés en mode recovery et tu ne les vois pas passer.
- Le mode normal "ne marche pas" : un problème assez courant est que le gestionnaire de connexion graphique ne se lance pas correctement. Mais on peut souvent ouvrir une session en console texte en basculant avec Ctrl+Alt+F1 à F6 (à essayer les uns après les autres).

jpt a écrit :

Alors regarde les logs


C'est un débutant, tu lui parles chinois.


Il vaut mieux montrer que raconter.

Hors ligne

#10 18-07-2021 21:54:04

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

 [ ok ] Starting Setting kernel variables: syscti.

[....] Configuring network interfaces...ifquery: /etc/netwrk/interfaces:
ifquery: couldn't read interfaces file "/etc/network/interfaces” ifquery: /etc/netwrk/interfaces:1: misplaced option

ifquery: could not read interfaces file ‘/etc/network/interfaces”

ifup: /etc/netwrk/interfaces:1: misplaced option

ifup: couldn't read interfaces file ‘/etc/netuwork/interfaces”

failed.

[ ok ] Cleaning up temporary files...

[ ok J Setting up AL SA, ,.done.

[ ok ] Setting sensors 1imits...done.

[ ok ] Setting up X socket directories.., /tmp/
 



Ce que j'ai comme message dans le recovery mode

Hors ligne

#11 18-07-2021 23:17:23

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : Debian plante au démarrage !

Bonjour,

ifup: /etc/netwrk/interfaces:1: misplaced option


Il semble y avoir une erreur dans le fichier interfaces, il faudrait voir ce qu'il contient et corriger l'erreur.


Tout est un sauf zéro. - Wau Holland

Hors ligne

#12 19-07-2021 11:19:48

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

$ cat /etc/network/interfaces

dns-nameserver 8.8.8.8



J'obtiens ceci mais ça m'aide pas trop

Hors ligne

#13 19-07-2021 11:27:02

jpt
Banni(e)
Distrib. : Debian 10.8
Noyau : Linux 5.7.10 (backports)
(G)UI : LXDE
Inscription : 12-09-2020

Re : Debian plante au démarrage !

Martinperdu a écrit :

dns-nameserver 8.8.8.8

dns-nameservers 8.8.8.8

Dernière modification par jpt (19-07-2021 11:27:25)


AMD Ryzen3 3200G sur Gigabyte B450M & Make Love Not War

Hors ligne

#14 19-07-2021 11:44:34

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

root@martin-pc:# lwlist scan

wlp2s0   Interface doesn't support scaning network is down

lo    Interface doesnt support scanning.

enp0s31f6 Interface doesn t support scanning,
 


Je crois que je vais devoir refaire le fichier etc/network/interfaces

Hors ligne

#15 19-07-2021 11:46:38

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

jpt a écrit :

Martinperdu a écrit :

dns-nameserver 8.8.8.8

dns-nameservers 8.8.8.8


Ca ne marche pas non plus après correction du s

Hors ligne

#16 19-07-2021 11:50:02

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

Je tiens a préciser que je lance debian puis le message d'erreur apparaît quelques secondes après je vois l'écran de chargement de debian et au lieux d'arriver sur ma session j'ai un écran noir avec les deux messages précédents

Hors ligne

#17 19-07-2021 12:14:23

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

J'ai réussi a me débarrasser du message


  ifup: /etc/netwrk/interfaces:1: misplaced option


Mais quand je fais apt-get update j'ai couldn't resolve deb.debian.org

Hors ligne

#18 19-07-2021 14:18:35

phlinux
Membre
Distrib. : Buster
Noyau : 4.19
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Debian plante au démarrage !

Bjr,

Je pense qu'il faudrait indiquer comment tu t'es débarrassé de la ligne d'erreur ci-dessus; ça permet de suivre le sujet.
Sinon quand tu arrives à l'écran "noir" et aux messages d'erreur (lequels ?) est-ce que tu as essayé de passer sur une autre console (tty) ? Touches : Ctrl+Alt+F2, par exemple

Pages perso : feh, omegat, udisks, passerelle, schroot vraiment transparent

Hors ligne

#19 19-07-2021 16:01:43

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

Bjr merci pour votre aide ! J'ai lancé la console tty et voici voici comment je me suis débarrassé de l'erreur j'ai remplacé le fichiers /etc/network/interfaces en collant ceci:

auto lo iface lo inet loopback

allow-hotplug enpds3if6

auto enpos31if6

iface enp0s31f6 inet static
address 192.168.1.42
netmask 255.255.255.0
broadcast 192.168.10.255
network 192.166.10.254
gateway 192.168.10.254
 

Hors ligne

#20 19-07-2021 16:05:54

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

Les messages d'erreur sont ceux-ci :

2,86404921] i915 0000:00:02.0: firmware: failed ta load i915/kbl_dnc-ver1_04.bin

[2.564053] firmare class: See :/wiki.debian.org/Firware for information about missing firmware

 


Je pourrais installer les firmware le problème est que je peux toujours pas utiliser apt et je crois avoir un problème dans ce fichier /etc/network/interfaces

Hors ligne

#21 19-07-2021 16:10:35

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

J'ai une autre erreur également en tty dans la liste de chargement j'ai
Setting AppArmor...
At least one profile failed to load
Dans la liste de plusieurs applications

Dernière modification par Martinperdu (19-07-2021 16:13:27)

Hors ligne

#22 19-07-2021 17:40:33

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Debian plante au démarrage !

Bonjour
tu a 3 commandes avec "ip"


ip link
 



ip address
 



ip route
 


et donner les retours des 3 commandes
si tu est derrière une box utiliser "dhcp" plutôt qu'une ip fixe
du genre


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp0s31f6
#auto enp0s31f6
iface enp0s31f6 inet dhcp
 


redémarrer la machine
ps: vérifier que le nom de la carte est bien "enp0s31f6"

remarque:
quand tu a le réseau , il te manque le firmware "firmware-misc-nonfree" et il faut autoriser le "nonfree" dans le sources.list

Dernière modification par robert2a (19-07-2021 17:44:38)

Hors ligne

#23 19-07-2021 20:01:18

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

$ ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueu state UNKNOWN mode DEFAULT group défaut qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00 :00:00:60

2: enp0s31f6: <NO-CARRIER, BROADCAST ,MULTICAST,UP> mtu 1560 fies qdisc  pfifofast state DOWN mode DEFAULT group default qlen 1000
link/ether 48:20703:54:2f:e8 brd ff: ff: ff: ff: ff: ff

3: wlp2s0: <BROADCAST.MUILTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000 Link/ether 40:70:e0:4b:Sf:cd brd ff:ff: ff: ff: ff:  _
 

Hors ligne

#24 19-07-2021 20:16:25

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

$ip address

    1: lo: <LOOPBACK,UP, LOWER_UP> mtu 65536 qdise noqueue state UNKNOWN group default qlen 1000 link/ loopback 00:00:00:00:00:00 brd 00:00:00:00:00:
 inet 127.0.0.1/8 scope host lo
 valid_ift forever preferred forever
inet6  ::1/128 scope host
valid_ift forever preffered_lft forever
2: wlp2s0 : , <NO-CARRIER,BROADCAST, MULTICAST, UP > mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000« link/ether 48:2a:7e3:Sa:2fre8 brd ff:ff;ff:ff:ff:ff inet 169.254.9.76/16 brd 169.254.255.255 scope link enp0s31f6:avahi
valid_lft ferever preferred_lft forever
3: wlp2s0: <BROADCAST.MULTICAST mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 40:74:e0-4b:5ficd brd  ff:ff;ff:ff:ff:ff

Hors ligne

#25 19-07-2021 20:23:40

Martinperdu
Membre
Inscription : 17-07-2021

Re : Debian plante au démarrage !

$ip route

Default dev enp0s31f6 scope link metric 1002 linkdown
169.254.0.0/16 dev enp0s31f6 proto kernel scope link src 169.254.9.76 linkdown

Hors ligne

Pied de page des forums