Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-08-2021 19:04:46

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

[résolu]bizarrerie mise à jour

Bonjour,
Lançant comme souvent une mise à jour, je m'appercois qu'un paquet peut être mis à jour et ne l'est pas :
apres un apt update  , j'obtiens ceci :

 bla bla bla
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
 


# apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  plocate
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour



apt list --upgradable
En train de lister... Fait
plocate/buster-backports 1.1.8-2~bpo10+1 amd64 [pouvant être mis à jour depuis : 1.1.5-1~bpo10+1]
N: Il y a une version supplémentaire 1. Veuillez utiliser l'opérande « -a » pour la voir.



# apt list --upgradable -a
En train de lister... Fait
plocate/buster-backports 1.1.8-2~bpo10+1 amd64 [pouvant être mis à jour depuis : 1.1.5-1~bpo10+1]
plocate/now 1.1.5-1~bpo10+1 amd64 [installé, pouvant être mis à jour vers : 1.1.8-2~bpo10+1]
 


apt policy plocate
plocate:
  Installé : 1.1.5-1~bpo10+1
  Candidat : 1.1.8-2~bpo10+1
 Table de version :
     1.1.8-2~bpo10+1 100
        100 https://deb.debian.org/debian buster-backports/main amd64 Packages
 *** 1.1.5-1~bpo10+1 100
        100 /var/lib/dpkg/status



Du coup, j'y comprend pas grand chose ...
Y'aurait-il une option «force» (-f) pour apt upgrade ??
Bon, ça va, c'est pas le plus essentiel des paquets ...
Est-ce à cause du gel pour bullseye ??
Dans ce cas, je trouve juste bizarre de proposer qqchose et rien ...
Si qqun saurait éclairer ma lanterne, ce serait avec plaisir
            au plaisir ...

Dernière modification par ubub (05-08-2021 10:20:51)

En ligne

#2 04-08-2021 19:56:39

ylag
Membre
Inscription : 16-03-2020

Re : [résolu]bizarrerie mise à jour

Bonsoir,

Ta version installée est périmée, disponible dans aucuns des dépôts déclarés de tes sources.

Sous toute réserve (je ne peux tester chez-moi) :

Essaie de réinstaller le paquet, ce qui devrait en tirer la dernière version :

sudo apt install --reinstall plocate


...sinon, peut-être commencer par supprimer la version installée (attention aux dépendances qui pourraient être emportées...), puis en retenter l'installation :

sudo apt purge plocate


sudo apt install plocate


?

Dernière modification par ylag (04-08-2021 19:58:00)

Hors ligne

#3 04-08-2021 20:16:56

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [résolu]bizarrerie mise à jour

bonsoir, merci pour ta réponse,

Ta version installée est périmée


ouais, c'est ce que dis le système

1 paquet peut être mis à jour.


Mais ma question demeure, ... Pourquoi  un paquet installé y'a qq mois depuis les dépots ne veut pas se mettre à jour ...
Après, vu que je suis pas chez moi et que je dispose que de peu d'électricité et peu d'internet, et que c'est une commande que j'utilise quasi jamais (me semble que je l'avais installé surtout par curiosité...), je vais pas essayer la réinstallation là ..
C'est surtout pour comprendre que j'ai posé la question. merci en tout cas

En ligne

#4 04-08-2021 20:24:46

raleur
Membre
Inscription : 03-10-2014

Re : [résolu]bizarrerie mise à jour

La mise à jour d'un paquet par "update" est suspendue quand un changement des dépendances entre les versions impose la désinstallation ou l'installation d'autres paquets. A vérifier avec

apt-cache show plocate


Pour faire la mise à jour en installant ou désinstallant les paquets nécessaires, il faut faire un dist-upgrade ou full-upgrade.


Il vaut mieux montrer que raconter.

Hors ligne

#5 04-08-2021 22:18:27

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [résolu]bizarrerie mise à jour

okay, merci pour ta réponse,
J'imagine que du coup, ça "casse" mlocate :

apt-cache show plocate
Package: plocate
Version: 1.1.8-2~bpo10+1
Installed-Size: 520
Maintainer: Steinar H. Gunderson <sesse@debian.org>
Architecture: amd64
Replaces: mlocate
Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libstdc++6 (>= 6), liburing1 (>= 0.7), libzstd1 (>= 1.3.2)
Suggests: systemd-sysv | powermgmt-base, systemd-sysv | nocache
Breaks: mlocate
 


.. on verra plus tard du coup ..

En ligne

#6 04-08-2021 22:25:00

ylag
Membre
Inscription : 16-03-2020

Re : [résolu]bizarrerie mise à jour

raleur a écrit :

La mise à jour d'un paquet par "update" est suspendue quand un changement des dépendances entre les versions impose la désinstallation ou l'installation d'autres paquets. A vérifier avec

apt-cache show plocate


Pour faire la mise à jour en installant ou désinstallant les paquets nécessaires, il faut faire un dist-upgrade ou full-upgrade.



@raleur a raison!
Je n'avais pas remarqué que tu avais simplement passé un sudo apt upgrade.
Avant de tenter la réinstallation du paquet, essaie peut-être:

sudo apt update && sudo apt full-upgrade



A+

Hors ligne

#7 04-08-2021 22:55:19

raleur
Membre
Inscription : 03-10-2014

Re : [résolu]bizarrerie mise à jour

ubub a écrit :

J'imagine que du coup, ça "casse" mlocate


La dépendance "Breaks: mlocate" a été ajoutée entre les deux versions.
Est-ce que mlocate est installé ? Ces deux paquets ne devraient pas être installés en même temps.

Dernière modification par raleur (04-08-2021 22:58:38)


Il vaut mieux montrer que raconter.

Hors ligne

#8 05-08-2021 10:19:46

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [résolu]bizarrerie mise à jour

Effectivement, il est installé :

apt policy mlocate



mlocate:
  Installé : 0.26-3
  Candidat : 0.26-3

En ligne

#9 05-08-2021 12:20:40

ylag
Membre
Inscription : 16-03-2020

Re : [résolu]bizarrerie mise à jour

Bonjour,

raleur a écrit :

La dépendance "Breaks: mlocate" a été ajoutée entre les deux versions.



Corrigez-moi si je me trompe, mais dans ce cas la commande :

sudo apt full-upgrade


...devrait proposer la suppression du paquet mlocate pour permettre la mise à jour de plocate ?

A+

Dernière modification par ylag (05-08-2021 12:21:10)

Hors ligne

#10 05-08-2021 12:58:16

ubub
Membre
Distrib. : debian sid && stable
(G)UI : xfce
Inscription : 14-05-2019

Re : [résolu]bizarrerie mise à jour

Salut Ylag, t'as raison :

apt full-upgrade




Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront ENLEVÉS :
  mlocate
Les paquets suivants seront mis à jour :
  plocate
1 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
                                          .....
Préparation du dépaquetage de .../plocate_1.1.8-2~bpo10+1_amd64.deb ...
Dépaquetage de plocate (1.1.8-2~bpo10+1) sur (1.1.5-1~bpo10+1) ...
Paramétrage de plocate (1.1.8-2~bpo10+1) ...
Installation de la nouvelle version du fichier de configuration /etc/updatedb.conf ...
plocate-updatedb.service is a disabled or a static unit not running, not starting it.

Dernière modification par ubub (05-08-2021 12:59:03)

En ligne

Pied de page des forums