Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-08-2021 12:08:16

Onalicat
Membre
Distrib. : Debian Buster
(G)UI : SSH
Inscription : 09-08-2021

Serveur ne boot plus

Bonjour à tous

J'ai un serveur depuis quelques années qui tourne sous Debian 8
J'ai voulu l'upgrade et partir sur un nettoyage complet de ce serveur, mais comme il y avait presque 1 Tb de données à backup, j'ai choisi de shrink ma partition / (/dev/sda2) afin de mettre mes données à backup sur une seconde partition et réinstaller un système propre (qui est devenu au fil de mes manips : /dev/sda6)
J'ai donc suivi le tuto suivant : https://papy-tux.legtux.org/doc0137/index.html
Sauf que je n'ai pas suivi les manips concernant l'UEFI, mais j'ai quand même installé Grub et fait un update-grub2
J'ai fait toutes ces manips via l'environnement "rescue" de mon hébergeur, et voici l'état des lieux :


root@rescue:/media# parted
GNU Parted 3.2
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p                                                                
Model: ATA HGST HUS726020AL (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system     Name           Flags
 1      20.5kB  1049kB  1029kB                  bios_grub-sda  bios_grub
 2      2097kB  525GB   525GB   ext4            primary
 6      525GB   2000GB  1475GB  ext4            primary
 3      2000GB  2000GB  536MB   linux-swap(v1)  primary

 




root@rescue:/media# sudo dd if=/dev/sda bs=512 count=1 > mbr
1+0 records in
1+0 records out
512 bytes (512 B) copied, 0.00020679 s, 2.5 MB/s

root@rescue:/media# file mbr
mbr: DOS/MBR boot sector, extended partition table (last)
 



J'ai monté /dev/sda2 dans /media/disk


root@rescue:/media/disk# ls boot
config-4.19.0-17-amd64  grub  initrd.img-4.19.0-17-amd64  System.map-4.19.0-17-amd64  vmlinuz-4.19.0-17-amd64
 




root@rescue:/media/disk# cat etc/fstab
# UNCONFIGURED FSTAB FOR BASE SYSTEM
# /etc/fstab: static file system information.
#
# <file system>                                 <mount point>   <type>    <options>       <dump>  <pass>

# Partition ESP
#UUID=EAB2-D953                           /boot/efi     vfat      umask=0077      0       2

# Partition SWAP
UUID=2d67fa0b-4188-47b9-8861-a68f445adc14   none          swap      sw    0       0

# Partition système
UUID=b7a7057a-bf52-4af3-bee0-517e0240a51e   /   ext4    defaults  0   1

# Partition HOME
UUID=1d25592d-0293-4e71-8405-6c3a894eff82       /mnt/backup ext4    defaults  0 2
 



Le souci c'est que le serveur ne boot pas. Il a bien boot ce matin mais mon SSH était mal configuré, j'ai donc redémarré en rescue pour remonter le disque et aller mettre correctement ma clé SSH, puis j'ai reboot et impossible d'accéder au serveur.

Auriez vous une idée pour debugger ça ?

Merci d'avance pour vos réponses

Edit: je pense avoir mal placé mon thread, vraiment désolé, serait-il possible de le bouger dans https://debian-facile.org/viewforum.php?id=10 ?

Dernière modification par Onalicat (09-08-2021 12:11:56)

Hors ligne

#2 09-08-2021 13:51:06

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Serveur ne boot plus

Ben si tu peux accéder au serveur qu'en SSH et que le serveur ne démarre pas, tu ne peux pas passer par là donc... Faut passer soit physiquement, mais vu que c'est probablement une VN ; que ton hébergeur ait prévu un autre moyen d'accès...
J'ai aucune idée d'à quoi correspond "l'environnement rescue" X_X

Dernière modification par otyugh (09-08-2021 13:51:40)


Vous aussi vous devriez avoir vos pages perso ! => https://tk.arzinfo.pw

En ligne

#3 09-08-2021 14:00:53

Onalicat
Membre
Distrib. : Debian Buster
(G)UI : SSH
Inscription : 09-08-2021

Re : Serveur ne boot plus

Merci pour ta réponse smile

C'est effectivement un serveur hebergé chez OVH,"l'environnement rescue" c'est un mode de démarrage du serveur qui boot sur un OS mis à dispo par l'hébergeur, pour pouvoir debug ton serveur, donc là il est boot dessus et j'ai un accès SSH pour pouvoir monter et utiliser le disque dur
Ce qui me bloque un peu c'est que je n'ai pas les logs de démarrage car le système ne boot même pas, j'ai pas accès au log de grub ni à une console tty en remote.
J'ai réinstallé grub, je suis entrain de tenter un reboot

Hors ligne

#4 09-08-2021 14:27:45

otyugh
CA Debian-Facile
Lieu : Quimperlé/Arzano
Distrib. : Debian Stable
Inscription : 20-09-2016
Site Web

Re : Serveur ne boot plus

Tu me fais penser qu'on a eu cette exacte même question de comment réinstaller grub d'un autre système cette semaine. https://debian-facile.org/viewtopic.php?id=30418

Vous aussi vous devriez avoir vos pages perso ! => https://tk.arzinfo.pw

En ligne

#5 09-08-2021 14:36:02

Onalicat
Membre
Distrib. : Debian Buster
(G)UI : SSH
Inscription : 09-08-2021

Re : Serveur ne boot plus

Le reboot n'a pas fonctionné sad
Je vais investiguer avec le thread que tu m'a donné, merci

Hors ligne

#6 09-08-2021 14:53:11

Onalicat
Membre
Distrib. : Debian Buster
(G)UI : SSH
Inscription : 09-08-2021

Re : Serveur ne boot plus

J'ai réussi à boot avec un noyau "de secours" d'OVH :


uname -a
Linux buster 4.19.62-mod-std-ipv6-64-rescue #828825 SMP Tue Jul 30 13:54:49 UTC 2019 x86_64 GNU/Linux
 


J'aimerais réussir à boot avec le bon noyau, peut être que grub n'est pas le même utilisé lorsque on boot avec leur option "Netboot" ?

Hors ligne

#7 09-08-2021 19:01:46

raleur
Membre
Inscription : 03-10-2014

Re : Serveur ne boot plus

Installe boot-info-script et poste le rapport de bootinfoscript.

Il vaut mieux montrer que raconter.

Hors ligne

#8 09-08-2021 20:27:36

Onalicat
Membre
Distrib. : Debian Buster
(G)UI : SSH
Inscription : 09-08-2021

Re : Serveur ne boot plus

Merci pour la réponse, voici le rapport : https://debian-facile.org/paste-C8D3D7FBB8

Hors ligne

#9 09-08-2021 23:18:28

Onalicat
Membre
Distrib. : Debian Buster
(G)UI : SSH
Inscription : 09-08-2021

Re : Serveur ne boot plus

Après quelques tentatives desespérés, j'ai fait redémarré en rescue, j'ai remonté mon disque, j'ai chroot en montant toutes les partitions nécessaires (tuto linké dans mon premier message), j'ai fait un grub-install /dev/sda puis un update-grub "and VOILA !" ça boot ! Enfin !
Merci à vous pour vos réponses smile

Hors ligne

#10 10-08-2021 08:50:13

raleur
Membre
Inscription : 03-10-2014

Re : Serveur ne boot plus

Tant mieux. Je n'ai détecté aucune anomaie dans le rapport de bootinfoscript. Par curiosité tu peux en générer un nouveau et comparer les deux.

Il vaut mieux montrer que raconter.

Hors ligne

Pied de page des forums