Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-08-2021 19:11:54

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Debian ne démarre pas et SSD invisible en EFI mode

Bonjour à tous,

Je viens sur ce forum suite à un problème suite à l'installation de Debian en dual-boot avec Windows 10.

Je suis sur un PC portable Lenovo legion y520 comportant d'usine un SSD nvme Samsung de 128 GB + 1 HDD Toshiba de 1 TB
Après avoir utilisé ce PC sous Windows 10 pendant assez longtemps maintenant, j'ai souhaitais faire comme suivant :

- installer Windows 10 dans une partition de 300 GB sur le HDD pour tout ce qui nécessiterait obligatoirement Windows

- installer Debian sur le SSD et garder le reste du HDD pour la majorité de mes données et tout ce qui est jeux, soft,...

J'ai effectué la réinstallation de Win en premier comme recommandé, qui s'est parfaitement bien passée, puis j'ai enchainé avec celle de Debian.
Toute les procédures ce passe bien jusqu'au redémarrage ou le pc ne redémarre pas avec grub mais sur Windows directement.
J'utilise la commande donnée dans le guide que je suis qui est celle-ci : bcdedit /set '{bootmgr}' path \EFI\debian\grubx64.efi
mais le problème est toujours le même, je décide donc d'aller dans le BIOS pour tenter de démarrer linux manuellement et je me rend compte que mon SSD n'est plus visible dans l'ordre de démarrage EFI (mais il l'est toujours dans le Legacy mode). J'ai donc essayer de démarrer sur le SSD en mode Legacy mais je tombe directement sur le démarrage par le réseau (qui ne trouve évidement rien) et cela enchaine sur le démarrage de Windows.

Sachant que le guide que je suis est pour un dual-boot sur un même disque dur, je me demande si il n'y a pas quelque chose que je devrais faire différemment lors du partitionnement. Je précise d'ailleurs que quand je fais le partitionnement, je vais dans "manuel" puis je fais "partitionner automatiquement dans l'espace disponible" dans le SSD puis je choisi "partition /home séparée".

En espérant avoir été assez précis dans mes explications et merci d'avance pour vos réponses ! merci.gif

Hors ligne

#2 17-08-2021 21:34:06

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Installation de Windows en mode UEFI ou legacy ?
Même question pour Debian.

KyoTensu a écrit :

J'utilise la commande donnée dans le guide que je suis qui est celle-ci : bcdedit /set '{bootmgr}' path \EFI\debian\grubx64.efi


Quel guide ? Précise-t-il que cette méthode n'est valable qu'avec l'amorçage UEFI et ne doit être tentée qu'en tout dernier recours, quand tout le reste a échoué ?
D'autre part je soupçonne qu'elle n'est applicable que si Windows et GRUB partagent la même partition système EFI (mais pas forcément le même disque pour le reste).

KyoTensu a écrit :

je vais dans "manuel" puis je fais "partitionner automatiquement dans l'espace disponible"


Vraiment ? Que je sache, cette option n'est disponible qu'en partitionnement assisté.


Il vaut mieux montrer que raconter.

En ligne

#3 17-08-2021 22:08:39

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Il me semble que les 2 installations sont en UEFI.

Le guide vient de debian-facile je viens de m'en rendre compte : https://debian-facile.org/doc:install:d … -de-l-uefi (partie "résolution des problèmes" puis "grub ne se lance pas")
il n'y a pas plus de précision que le fait que cela doit normalement régler le problème.

Et oui c'est bien comme ceci, c'est aussi ce qui est expliquer dans le guide (j'ai d'ailleurs ressayer entre temps en créant les partitions manuellement tjrs en suivant le guide mais cela n'a rien changé).

Hors ligne

#4 17-08-2021 22:12:11

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

KyoTensu a écrit :

Il me semble que les 2 installations sont en UEFI.


Il vaudrait mieux s'en assurer avant de chercher à aller plus loin.


Il vaut mieux montrer que raconter.

En ligne

#5 17-08-2021 22:25:57

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Windows a bien été installé en UEFI, j'ai créer une clé bootable debian pour UEFI, booté en UEFI et avec un guide pour faire un dual-boot avec UEFI donc je dirais que c'est une installation UEFI, sinon je ne sais pas vraiment comment déterminer si c'est le cas ou non tongue

Hors ligne

#6 17-08-2021 23:14:32

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Lancer un système live.
Installer boot-info-script.
Exécuter bootinfoscript.
Poster le rapport.

Il vaut mieux montrer que raconter.

En ligne

#7 18-08-2021 15:14:07

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Rebonjour big_smile,

alors je reviens avec le rapport, malheureusement je n'arrive pas à accéder au lien à cause apparemment d'une maintenance donc je vais au moins donner le lien :
http://paste.ubuntu.com/p/TysjcNxss6/

Si cela ne marche vraiment pas je pourrai ressayer de générer un rapport.

Hors ligne

#8 18-08-2021 22:23:38

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Toujours indisponible apparemment.
Tu peux poster le rapport ici entre balises "autre code".

Il vaut mieux montrer que raconter.

En ligne

#9 18-08-2021 23:07:49

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Ca y est je l'ai :

boot-repair-4ppa130                                              [20210818_2050]

============================== Boot Info Summary ===============================

 => No boot loader is installed in the MBR of /dev/nvme0n1.
 => No boot loader is installed in the MBR of /dev/sda.
 => Syslinux MBR (3.61-4.03) is installed in the MBR of /dev/sdb.

nvme0n1p1: _____________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/debian/fbx64.efi /efi/debian/grubx64.efi
                       /efi/debian/mmx64.efi /efi/debian/shimx64.efi
                       /efi/debian/grub.cfg

nvme0n1p2: _____________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:
    Operating System:  Debian GNU/Linux 11 (bullseye)
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub

nvme0n1p3: _____________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info:

nvme0n1p4: _____________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:
    Operating System:  
    Boot files:        

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/Boot/bootx64.efi /efi/Microsoft/Boot/bootmgfw.efi
                       /efi/Microsoft/Boot/bootmgr.efi
                       /efi/Microsoft/Boot/memtest.efi

sda2: __________________________________________________________________________

    File system:      
    Boot sector type:  -
    Boot sector info:

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 8 or 10
    Boot files:        /Windows/System32/winload.exe

sda4: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 4.03 2010-10-22 ........>..sr>..........$...0...~.....~...f...M.f.f....f..0~....>E}.u......
    Boot sector info:  Syslinux looks at sector 119457398 of /dev/sdb1 for
                       its second stage. SYSLINUX is installed in the  
                       directory. No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /boot/grub/grub.cfg /syslinux.cfg
                       /efi/boot/grubx64.efi /efi/debian/grub.cfg /ldlinux.sys


================================ 2 OS detected =================================

OS#1:   Debian GNU/Linux 11 (bullseye) on nvme0n1p2
OS#2:   Windows 8 or 10 on sda3

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
Live-session OS is Ubuntu 64-bit (Boot-Repair-Disk 64bit 20200604, bionic, x86_64)


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0004,0005,2003,0001,0003,0000,0002,2001,2002
Boot0000* Realtek PXE B03 D00 BBS(128,Realtek PXE B03 D00,0x0).......................................................................
Boot0001* ST1000LM035-1RK172                BBS(HD,ST1000LM035-1RK172              ,0x500)................-...........A......".............................X|Zk..
Boot0002* SanDisk BBS(HD,SanDisk,0x500)..................].......[..._....................................&k..
Boot0003* SAMSUNG MZVLW128HEGR-000L2        BBS(HD,SAMSUNG MZVLW128HEGR-000L2      ,0x500)................+..P....#..P?..P.................................Xn+k..
Boot0004* Windows Boot Manager  HD(1,GPT,0a6b7cb6-27b9-41c6-b153-9d659e1282c6,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0005* Linpus lite HD(1,MBR,0x19b6a4,0x800,0x729b800)/File(\EFI\Boot\grubx64.efi)RC
Boot0006* EFI Network 0 for IPv4 (8C-16-45-6E-13-39)  PciRoot(0x0)/Pci(0x1c,0x3)/Pci(0x0,0x0)/MAC(8c16456e1339,0)/IPv4(0.0.0.00.0.0.0,0,0)RC
Boot0007* EFI Network 0 for IPv6 (8C-16-45-6E-13-39)  PciRoot(0x0)/Pci(0x1c,0x3)/Pci(0x0,0x0)/MAC(8c16456e1339,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0008* EFI Network 0 for IPv6 (8C-16-45-6E-13-39)  PciRoot(0x0)/Pci(0x1c,0x3)/Pci(0x0,0x0)/MAC(8c16456e1339,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0009* Windows Boot Manager  HD(1,GPT,0a6b7cb6-27b9-41c6-b153-9d659e1282c6,0x800,0x32000)/File(\EFI\debian\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...6................
Boot000A* debian  HD(1,GPT,a2c75aff-7793-465b-9a30-44acdb592316,0x800,0x8e800)/File(\EFI\debian\shimx64.efi)
Boot2001* EFI USB Device  RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
This session has been detected as 'live' because /proc/cmdline contains (boot=casper)
This session has been detected as 'live' because df -Th / contains overlay

0d240e1ce1b2b02dec9bbb162cfb94da   nvme0n1p1/debian/fbx64.efi
1b236359c52f180ce9fe705cbce94703   nvme0n1p1/debian/grubx64.efi
f617c3c1b1bdf56909dcb8e1b996749b   nvme0n1p1/debian/mmx64.efi
cefed90870185ef689f004e686de8fce   nvme0n1p1/debian/shimx64.efi
21d11860807dda64c7ffa7b5aae65044   sda1/Boot/bootx64.efi
21d11860807dda64c7ffa7b5aae65044   sda1/Microsoft/Boot/bootmgfw.efi
8419000ecdb98d3e8e891bbd8f1e10e9   sda1/Microsoft/Boot/bootmgr.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

nvme0n1 : is-GPT, no-BIOSboot,  has---ESP,  not-usb,  not-mmc, has-os,  2048 sectors * 512 bytes
sda : is-GPT, no-BIOSboot,  has---ESP,  not-usb,  not-mmc, has-os,  2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

nvme0n1p1 : no-os,  32, nopakmgr, no-docgrub, nogrub, nogrubinstall,  no-grubenv, noupdategrub, not-far
nvme0n1p2 : is-os,  64, apt-get,  signed grub-efi , grub2,  grub-install, grubenv-ok, update-grub,  not-far
nvme0n1p4 : no-os,  32, nopakmgr, no-docgrub, nogrub, nogrubinstall,  no-grubenv, noupdategrub, farbios
sda1  : no-os,  32, nopakmgr, no-docgrub, nogrub, nogrubinstall,  no-grubenv, noupdategrub, not-far
sda3  : is-os,  32, nopakmgr, no-docgrub, nogrub, nogrubinstall,  no-grubenv, noupdategrub, farbios
sda4  : no-os,  32, nopakmgr, no-docgrub, nogrub, nogrubinstall,  no-grubenv, noupdategrub, farbios

Partitions info (2/3): _________________________________________________________

nvme0n1p1 : is---ESP, part-has-no-fstab,  no-nt,  no-winload, no-recov-nor-hid, no-bmgr,  notwinboot
nvme0n1p2 : isnotESP, fstab-has-goodEFI,  no-nt,  no-winload, no-recov-nor-hid, no-bmgr,  notwinboot
nvme0n1p4 : isnotESP, part-has-no-fstab,  no-nt,  no-winload, no-recov-nor-hid, no-bmgr,  notwinboot
sda1  : is---ESP, part-has-no-fstab,  no-nt,  no-winload, no-recov-nor-hid, no-bmgr,  notwinboot
sda3  : isnotESP, part-has-no-fstab,  no-nt,  haswinload, no-recov-nor-hid, no-bmgr,  notwinboot
sda4  : isnotESP, part-has-no-fstab,  no-nt,  no-winload, recovery-or-hidden, no-bmgr,  notwinboot

Partitions info (3/3): _________________________________________________________

nvme0n1p1 : not-sepboot,  no-boot,  part-has-no-fstab,  not-sep-usr,  no---usr, part-has-no-fstab,  std-grub.d, nvme0n1
nvme0n1p2 : not-sepboot,  with-boot,  fstab-without-boot, not-sep-usr,  with--usr,  fstab-without-usr,  std-grub.d, nvme0n1
nvme0n1p4 : maybesepboot, no-boot,  part-has-no-fstab,  not-sep-usr,  no---usr, part-has-no-fstab,  std-grub.d, nvme0n1
sda1  : not-sepboot,  no-boot,  part-has-no-fstab,  not-sep-usr,  no---usr, part-has-no-fstab,  std-grub.d, sda
sda3  : not-sepboot,  no-boot,  part-has-no-fstab,  not-sep-usr,  no---usr, part-has-no-fstab,  std-grub.d, sda
sda4  : not-sepboot,  no-boot,  part-has-no-fstab,  not-sep-usr,  no---usr, part-has-no-fstab,  std-grub.d, sda

fdisk -l (filtered): ___________________________________________________________

Disk nvme0n1: 119.2 GiB, 128035676160 bytes, 250069680 sectors
Disk identifier: F352811A-A688-4FB1-A304-310B44E59335
             Start       End   Sectors   Size Type
nvme0n1p1     2048    585727    583680   285M EFI System
nvme0n1p2   585728  20117503  19531776   9.3G Linux filesystem
nvme0n1p3 20117504  27930623   7813120   3.7G Linux swap
nvme0n1p4 27930624 250068991 222138368 105.9G Linux filesystem
Disk sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Disk identifier: 2F2CD821-EF7F-4A97-9B60-A6923C417B57
          Start       End   Sectors   Size Type
sda1       2048    206847    204800   100M EFI System
sda2     206848    239615     32768    16M Microsoft reserved
sda3     239616 613329760 613090145 292.4G Microsoft basic data
sda4  613330944 614399999   1069056   522M Windows recovery environment
Disk sdb: 57.3 GiB, 61530439680 bytes, 120176640 sectors
Disk identifier: 0x0019b6a4
      Boot Start       End   Sectors  Size Id Type
sdb1  *     2048 120176639 120174592 57.3G  c W95 FAT32 (LBA)
Disk zram0: 2 GiB, 2084749312 bytes, 508972 sectors
Disk zram1: 2 GiB, 2084749312 bytes, 508972 sectors
Disk zram2: 2 GiB, 2084749312 bytes, 508972 sectors
Disk zram3: 2 GiB, 2084749312 bytes, 508972 sectors

parted -lm (filtered): _________________________________________________________

sda:1000GB:scsi:512:4096:gpt:ATA ST1000LM035-1RK1:;
1:1049kB:106MB:105MB:fat32:EFI system partition:boot, esp;
2:106MB:123MB:16.8MB::Microsoft reserved partition:msftres;
3:123MB:314GB:314GB:ntfs:Basic data partition:msftdata;
4:314GB:315GB:547MB:ntfs::hidden, diag;
sdb:61.5GB:scsi:512:512:msdos:SanDisk Ultra USB 3.0:;
1:1049kB:61.5GB:61.5GB:fat32::boot, lba;
nvme0n1:128GB:nvme:512:512:gpt:SAMSUNG MZVLW128HEGR-000L2:;
1:1049kB:300MB:299MB:fat32::boot, esp;
2:300MB:10.3GB:10.0GB:ext4::;
3:10.3GB:14.3GB:4000MB:linux-swap(v1)::;
4:14.3GB:128GB:114GB:ext4::;
zram3:2085MB:unknown:4096:4096:loop:Unknown:;
1:0.00B:2085MB:2085MB:linux-swap(v1)::;
zram1:2085MB:unknown:4096:4096:loop:Unknown:;
1:0.00B:2085MB:2085MB:linux-swap(v1)::;
zram2:2085MB:unknown:4096:4096:loop:Unknown:;
1:0.00B:2085MB:2085MB:linux-swap(v1)::;
zram0:2085MB:unknown:4096:4096:loop:Unknown:;
1:0.00B:2085MB:2085MB:linux-swap(v1)::;

blkid (filtered): ______________________________________________________________

NAME        FSTYPE   UUID                                 PARTUUID                             LABEL       PARTLABEL
sda                                                                                                        
├─sda1      vfat     764A-9CE2                            0a6b7cb6-27b9-41c6-b153-9d659e1282c6             EFI system partition
├─sda2                                                    c32212b9-c978-4f23-9421-4a90ac161996             Microsoft reserved partition
├─sda3      ntfs     8CE25ADEE25ACBD8                     e94c2937-213a-46d3-8a6b-74b01976e42a             Basic data partition
└─sda4      ntfs     B49C711C9C70DA76                     7a28214a-6cc7-4b57-ae86-66991232d907            
sdb                                                                                                        
└─sdb1      vfat     1810-2A36                            0019b6a4-01                          NETINST_DEB
zram0                                                                                                      
zram1                                                                                                      
zram2                                                                                                      
zram3                                                                                                      
nvme0n1                                                                                                    
├─nvme0n1p1 vfat     29B9-A1DC                            a2c75aff-7793-465b-9a30-44acdb592316            
├─nvme0n1p2 ext4     ad432a28-6093-42eb-9a1b-e1c747a33cc8 82ac604b-46c6-4551-b701-37e3f158a870            
├─nvme0n1p3 swap     ca8ff52d-4de7-4bcb-8019-0fb2688423af 7f014434-6489-446b-b42b-98e6b76abe1c            
└─nvme0n1p4 ext4     43964b8e-bb69-4c7b-922a-96ef6a989153 703f464c-16dd-466a-81ed-8af09a49ce04            

df (filtered): _________________________________________________________________

          Avail Use% Mounted on
nvme0n1p1  281M   1% /mnt/boot-sav/nvme0n1p1
nvme0n1p2  3.4G  58% /mnt/boot-sav/nvme0n1p2
nvme0n1p4 98.4G   0% /mnt/boot-sav/nvme0n1p4
sda1      69.5M  28% /mnt/boot-sav/sda1
sda3       264G  10% /mnt/boot-sav/sda3
sda4      86.1M  84% /mnt/boot-sav/sda4
sdb1      55.9G   2% /cdrom

Mount options: __________________________________________________________________

nvme0n1p1 rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro
nvme0n1p2 rw,relatime
nvme0n1p4 rw,relatime
sda1      rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro
sda3      rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda4      rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sdb1      ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro

=================== nvme0n1p1/efi/debian/grub.cfg (filtered) ===================

search.fs_uuid ad432a28-6093-42eb-9a1b-e1c747a33cc8 root
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

=================== nvme0n1p2/boot/grub/grub.cfg (filtered) ====================

Debian GNU/Linux   ad432a28-6093-42eb-9a1b-e1c747a33cc8
Debian GNU/Linux, with Linux 5.10.0-8-amd64   ad432a28-6093-42eb-9a1b-e1c747a33cc8
Windows Boot Manager (on sda1)   osprober-efi-764A-9CE2
### END /etc/grub.d/30_os-prober ###
System setup   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

======================== nvme0n1p2/etc/fstab (filtered) ========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p2 during installation
UUID=ad432a28-6093-42eb-9a1b-e1c747a33cc8 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=29B9-A1DC  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/nvme0n1p4 during installation
UUID=43964b8e-bb69-4c7b-922a-96ef6a989153 /home           ext4    defaults        0       2
# swap was on /dev/nvme0n1p3 during installation
UUID=ca8ff52d-4de7-4bcb-8019-0fb2688423af none            swap    sw              0       0

==================== nvme0n1p2/etc/default/grub (filtered) =====================

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

================= nvme0n1p2: Location of files loaded by Grub ==================

           GiB - GB             File                                 Fragment(s)
   2.478034973 = 2.660769792    boot/grub/grub.cfg                             1
   0.598148346 = 0.642256896    boot/vmlinuz-5.10.0-8-amd64                    1
   0.598148346 = 0.642256896    vmlinuz                                        1
   0.598148346 = 0.642256896    vmlinuz.old                                    1
   8.247894287 = 8.856109056    boot/initrd.img-5.10.0-8-amd64                 1
   8.247894287 = 8.856109056    initrd.img                                     1
   8.247894287 = 8.856109056    initrd.img.old                                 1

=================== nvme0n1p2: ls -l /etc/grub.d/ (filtered) ===================

-rwxr-xr-x 1 root root 13664 Jul 10 23:37 10_linux
-rwxr-xr-x 1 root root 13726 Jul 10 23:37 20_linux_xen
-rwxr-xr-x 1 root root 12059 Jul 10 23:37 30_os-prober
-rwxr-xr-x 1 root root  1416 Jul 10 23:37 30_uefi-firmware
-rwxr-xr-x 1 root root   214 Jul 10 23:37 40_custom
-rwxr-xr-x 1 root root   216 Jul 10 23:37 41_custom

====================== sdb1/boot/grub/grub.cfg (filtered) ======================

Boot-Repair-Disk session
Boot-Repair-Disk session (failsafe)

========================= sdb1/syslinux.cfg (filtered) =========================

default menu.c32
prompt 0
menu title UNetbootin
timeout 100

label unetbootindefault
menu label Default
kernel /ubnkern
append initrd=/ubninit file=/cdrom/preseed/lubuntu.seed boot=casper quiet splash ---

label ubnentry0
menu label ^Help
kernel /ubnkern
append initrd=/ubninit

label ubnentry1
menu label ^64bit session
kernel /casper/vmlinuz
append initrd=/casper/initrd file=/cdrom/preseed/lubuntu.seed boot=casper  quiet splash ---

label ubnentry2
menu label ^64bit session (failsafe)
kernel /casper/vmlinuz
append initrd=/casper/initrd file=/cdrom/preseed/lubuntu.seed boot=casper  noapic noapm nodma nomce nolapic nomodeset nosmp vga=normal ---

label ubnentry3
menu label Boot-Repair-Disk session
kernel /casper/vmlinuz
append initrd=/casper/initrd file=/cdrom/preseed/lubuntu.seed boot=casper quiet splash --

label ubnentry4
menu label Boot-Repair-Disk session (failsafe)
kernel /casper/vmlinuz
append initrd=/casper/initrd file=/cdrom/preseed/lubuntu.seed boot=casper noapic noapm nodma nomce nolapic nomodeset nosmp vga=normal --


===================== sdb1/efi/debian/grub.cfg (filtered) ======================

search --file --set=root /.disk/info
set prefix=($root)/boot/grub
source $prefix/x86_64-efi/grub.cfg

==================== sdb1: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             boot/grub/grub.cfg                             1

================== sdb1: Location of files loaded by Syslinux ==================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             syslinux.cfg                                   1
            ?? = ??             ldlinux.sys                                    1
            ?? = ??             menu.c32                                       1

=============== sdb1: Version of COM32(R) files used by Syslinux ===============

 menu.c32                           :  COM32R module (v4.xx)


======================== Unknown MBRs/Boot Sectors/etc =========================


/dev/sda1: unknown GPT attributes
8000000000000000

/dev/sda2: unknown GPT attributes
8000000000000000

/dev/sda4: unknown GPT attributes
8000000000000001

=============================== StdErr Messages ================================

File descriptor 63 (pipe:[63839]) leaked on lvs invocation. Parent PID 25010: /bin/bash

Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
nvme0n1p2,
using the following options:        nvme0n1p1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s win-legacy-basic-fix use-standard-efi-file    

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the Debian GNU/Linux 11 (bullseye) entry (nvme0n1p1/efi/****/shim****.efi (**** will be updated in the final message) file) !
If your computer reboots directly into Windows, try to change the boot order in your UEFI firmware.

If your UEFI firmware does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI\****\shim****.efi (**** will be updated in the final message)
 



Voila tongue

Hors ligne

#10 19-08-2021 00:06:25

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

L'entrée d'amorçage EFI debian (000A) n'est pas dans le BootOrder. Normalement, en la mettant en premier c'est GRUB qui devrait démarrer par défaut.

efibootmgr -o 000A,0004,0005,2003,0001,0003,0000,0002,2001,2002


mais je crains que le firmware soit récalcitrant car c'est ce qui aurait déjà dû se passer lors de l'installation.

Tu peux aussi supprimer l'entrée défectueuse 0009 causée par bcdedit.

efibootmgr -b 0009 -B

Dernière modification par raleur (19-08-2021 00:08:49)


Il vaut mieux montrer que raconter.

En ligne

#11 19-08-2021 00:30:10

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Alors les deux commandes ont bien été exécutées mais après avoir quitté le live usb et démarrer le pc je suis retombé directement sur Windows hmm

Hors ligne

#12 19-08-2021 22:25:51

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Je ne suis pas surpris. Il y a plusieurs explications possibles.
- La commande ne modifie pas le BootOrder
- Le BootOrder est modifié mais n'est pas persistant
- Le firmware UEFI ne tient pas compte du BootOrder

Tu peux vérifier si le BootOrder est modifié et persistant avec la commande efibootmgr depuis un système live.

Il vaut mieux montrer que raconter.

En ligne

#13 19-08-2021 22:50:31

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

effectivement j'avais mal regarder, la commande s'execute bien mais elle ne change pas l'ordre de boot. et la commande pour supprimer un element n'a pas non plus fonctionner d'ailleur alors qu'il me semblais que c'etait le cas hmm

Dernière modification par KyoTensu (19-08-2021 23:01:02)

Hors ligne

#14 19-08-2021 23:24:14

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Regarde si tu ne peux pas modifier l'ordre de boot UEFI dans les réglages du BIOS.

Il vaut mieux montrer que raconter.

En ligne

#15 19-08-2021 23:35:27

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Justement je ne vois pas la partition debian dans la liste de boot EFI comme je disais plus tôt donc je ne peut pas gérer cela au travers du bios

Hors ligne

#16 19-08-2021 23:37:49

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Que contient cette liste de boot EFI ?

Il vaut mieux montrer que raconter.

En ligne

#17 19-08-2021 23:42:34

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Il y a uniquement le boot manager Windows et le boot par le réseau. Et en legacy mode j'ai mes deux disques dur et tjrs le boot par le réseau

Hors ligne

#18 20-08-2021 00:03:58

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Une possibilité consisterait à installer GRUB pour un amorçage BIOS/legacy, ainsi le choix du système à lancer se ferait en sélectionnant le mode UEFI ou legacy. Pas très pratique comme multiboot, mais faute de mieux...

Il vaut mieux montrer que raconter.

En ligne

#19 20-08-2021 00:11:26

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Cela pourrais se faire mais le problème est que l'installation de grub se fait totalement automatiquement pour une raison qui m'échappe, sans demander sur quel DD s'installer, ni si il doit s'installer. D'ailleurs sans cela peut être que le problème pourrais être régler car grub n'a pas l'air de vouloir s'installer sur le même DD que linux tongue

Hors ligne

#20 20-08-2021 13:54:22

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

KyoTensu a écrit :

l'installation de grub se fait totalement automatiquement pour une raison qui m'échappe, sans demander sur quel DD s'installer, ni si il doit s'installer.


La raison est simple : pour l'amorçage EFI, GRUB s'installe implicitement dans la partition EFI définie au partitionnement (montée sur /boot/efi), il n'y a donc pas lieu de demander sur quel disque il faut l'installer. Les autres questions concernant GRUB n'ont pas un priorité suffisante pour être posées si on a choisi une installation normale (non expert) donc l'installation se déroule automatiquement. Il faut choisir une installation "expert" ou baisser la priorité des questions à "basse" pour que l'installateur permette de ne pas installer GRUB. Pour cette raison je choisis toujours "expert".

KyoTensu a écrit :

grub n'a pas l'air de vouloir s'installer sur le même DD que linux


Qu'est-ce qui te fait dire cela ? Le rapport de bootinfoscript montre au contraire que GRUB a bien été installé dans la partition EFI du disque de Debian (nvme0n1p1) et non celle du disque de Windows (sda1).

De toute façon il n'est pas nécessaire de refaire toute une installation pour installer GRUB pour l'amorçage legacy. Il suffit de démarrer l'installateur en mode rescue, lancer un shell sur nvme0n1p2, créer une petite partition (100 ko) non formatée de type "BIOS boot", installer le paquet grub-pc-bin et exécuter

grub-install --target=i386-pc /dev/nvme0n1


En passant, tu peux réinstaller GRUB EFI avec

grub-install --force-extra-removable


(la partition EFI doit être montée). On ne sait jamais, ça permettra peut-être de démarrer Debian en mode EFI.


Il vaut mieux montrer que raconter.

En ligne

#21 20-08-2021 15:12:37

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

D'accord très bien, est ce que tu pourrais me dire quelle Commande utiliser pour créer la partition ? Car je ne trouve que des explications général et je preferer éviter de faire une bêtises ^^'

Hors ligne

#22 20-08-2021 15:20:21

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Ça dépend du programme que tu utilises : fdisk, gdisk, parted, Gparted...

Il vaut mieux montrer que raconter.

En ligne

#23 20-08-2021 15:24:08

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Je comptais utiliser fdisk

Hors ligne

#24 20-08-2021 15:41:25

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

fdisk /dev/nvme0n1
créer une nouvelle partition -> n
début de la partition : valeur par défaut
fin de la partition : +250
changer le type -> t
type BIOS boot : 4
enregistrer -> w


Il vaut mieux montrer que raconter.

En ligne

#25 20-08-2021 16:57:56

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

J'ai créer la partition BIOS-boot, mais ensuite en exécutant la commande grub-install j'ai une erreur me disant :

grub-install : erreur : /usr/lib/grub/i386-pc/modinfo.sh n'existe pas. Veuillez utiliser --target ou --directory.

Dernière modification par KyoTensu (20-08-2021 16:58:18)

Hors ligne

Pied de page des forums