Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 20-08-2021 18:09:11

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Le paquet grub-pc-bin est installé ?

Il vaut mieux montrer que raconter.

Hors ligne

#27 20-08-2021 18:16:43

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Je croyais mais apparemment non effectivement désolé. L'installation est bien terminée. Et du coup il y a juste à reboot ou il faut que je remette le bios en priorité "legacy first" ?

Hors ligne

#28 20-08-2021 18:22:22

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Legacy first, sinon c'est UEFI et Windows qui démarre. Ou bien tu sélectionnes le disque en legacy lors du boot.

Dernière modification par raleur (20-08-2021 18:22:46)


Il vaut mieux montrer que raconter.

Hors ligne

#29 20-08-2021 18:51:09

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

C'est bon tout fonctionne grub s'est bien lancer et debian a l'air de marcher à la perfection.

Merci beaucoup big_smile ça a été un peu long et j'ai peut être poser beaucoup de questions (désolé ^^') mais vraiment merci ! Je comprend mieux comment fonctionne le système de partitionnement et de boot

Hors ligne

#30 20-08-2021 19:47:23

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Mais le problème de l'amorçage UEFI récalcitrant n'est pas réglé.

Pour information, le GRUB pour BIOS installé de cette façon ne sera pas mis à jour automatiquement. Pour cela il faudrait installer le paquet grub-pc, mais cela désinstallerait le paquet grub-efi-amd64 donc il faut choisir.

Il vaut mieux montrer que raconter.

Hors ligne

#31 20-08-2021 19:51:30

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Est ce que le fait que grub ne soit pas mis à jour peut poser de gros problèmes ?

Hors ligne

#32 20-08-2021 19:52:53

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Les éventuelles failles de sécurité ne seront pas corrigées.

Dernière modification par raleur (20-08-2021 19:55:28)


Il vaut mieux montrer que raconter.

Hors ligne

#33 20-08-2021 19:55:43

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Oui effectivement j'y avais pas pensé. Tu dit qu'il ne sera pas mis à jour automatiquement mais est ce qu'il peut l'être manuellement ? Car si c'est le cas ça ne me dérange pas de le faire moi même régulièrement

Hors ligne

#34 20-08-2021 19:58:04

raleur
Membre
Inscription : 03-10-2014

Re : Debian ne démarre pas et SSD invisible en EFI mode

Oui, avec grub-install comme pour l'installation, à faire après chaque mise à jour des paquets grub*. Plus besoin de l'option --target si le système a été amorcé en legacy.

Dernière modification par raleur (20-08-2021 19:58:35)


Il vaut mieux montrer que raconter.

Hors ligne

#35 20-08-2021 20:02:13

KyoTensu
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-8-amd64
(G)UI : KDE plasma
Inscription : 17-08-2021

Re : Debian ne démarre pas et SSD invisible en EFI mode

Ok d'accord, perso ça me va de le faire manuellement. Si je veut changer je reviendrai sûrement mais voila big_smile

Hors ligne

Pied de page des forums