Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 22-08-2021 22:58:33

SuShY
CA Debian-Facile
Lieu : Chartres
Distrib. : Debian Sid x86_64
Noyau : Linux > 5.14.x-x-amd64
(G)UI : i3WM - 4.20-1
Inscription : 06-01-2018
Site Web

Re : [Résolu] Installation de paquets

En tout cas Clemiloup tu es bien connecté au channel IRC.

Hors ligne

#27 22-08-2021 22:59:33

Clemiloup
Membre
Distrib. : Debian GNU/Linux 11 (Bullseye)
Noyau : 5.10.0-8-amd64 / 5.10.0-10-amd64
(G)UI : GNOME 3.38.5 (Wayland) / KDE Plasma 5.20.5
Inscription : 21-08-2021

Re : [Résolu] Installation de paquets

cyrille a écrit :

Alors ça m'a supprimé discord hmm


Bah , essaye d'installer les dépendances demandées et relance l'install de discord

sudo apt install libgconf-2-4 libappindicator1  libc++1



et procédure pour installer discord à relancer



Le problème c'est que j'ai déjà essayé mais j'ai à chaque fois cette réponse:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Aucune version du paquet libappindicator1 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libappindicator1 » n'a pas de version susceptible d'être installée
 



Et petit plus, discord est à nouveau apparu comme par magie, mais cela ne résout quand même pas le problème qui revient pour les autres logiciels

Dernière modification par Clemiloup (22-08-2021 23:05:09)

Hors ligne

#28 22-08-2021 23:01:19

Clemiloup
Membre
Distrib. : Debian GNU/Linux 11 (Bullseye)
Noyau : 5.10.0-8-amd64 / 5.10.0-10-amd64
(G)UI : GNOME 3.38.5 (Wayland) / KDE Plasma 5.20.5
Inscription : 21-08-2021

Re : [Résolu] Installation de paquets

SuShY a écrit :

En tout cas Clemiloup tu es bien connecté au channel IRC.



Bon bah c'est au moins un truc qui marche wink
Mais ça me fait juste bizarre de voir un truc ou rien ne se passe, du coup je suis un peu perdue

Hors ligne

#29 22-08-2021 23:08:04

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [Résolu] Installation de paquets

Clemiloup a écrit :

C'est-à-dire que je ne sais pas trop où aller, j'ai juste un terminal devant moi avec un channel apparemment mais sans plus d'info



Quand tu lances weechat dans ton terminal:

weechat-curses


Tu te retrouves dans weechat, et tu passe les commandes dans la partie en bas, par exemple: /server add oftc irc.oftc.net

Et ainsi de suite, jusqu'à la fin:
/join #debian-facile

Et la tu te retrouvera dans le salon (channel en anglais) #debian-facile smile

Ou tu peux discuter, dans la partie du bas, là où tu rentrais tes commande.

Dernière modification par Jean-Pierre Pinson (22-08-2021 23:10:06)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#30 22-08-2021 23:15:05

Clemiloup
Membre
Distrib. : Debian GNU/Linux 11 (Bullseye)
Noyau : 5.10.0-8-amd64 / 5.10.0-10-amd64
(G)UI : GNOME 3.38.5 (Wayland) / KDE Plasma 5.20.5
Inscription : 21-08-2021

Re : [Résolu] Installation de paquets

Je vais juste revenir à la commande permettant d'installer les commandes non satisfaites. Pourquoi est-ce que ça m'enlève discord?

~$ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Correction des dépendances... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libostree-1-1
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
Les paquets suivants seront ENLEVÉS :
  discord
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 181 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n]
 



Et pourquoi après l'avoir fait, quand je réinstalle discord ça me donne ça;

~$ sudo dpkg -i '/home/clemence02/Téléchargements/discord-0.0.15.deb'
Sélection du paquet discord précédemment désélectionné.
(Lecture de la base de données... 143964 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../discord-0.0.15.deb ...
Dépaquetage de discord (0.0.15) ...
dpkg: des problèmes de dépendances empêchent la configuration de discord :
 discord dépend de libgconf-2-4 ; cependant :
  Le paquet libgconf-2-4 n'est pas installé.
 discord dépend de libappindicator1 ; cependant :
  Le paquet libappindicator1 n'est pas installé.
 discord dépend de libc++1 ; cependant :
  Le paquet libc++1 n'est pas installé.

dpkg: erreur de traitement du paquet discord (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1) ...
Traitement des actions différées (« triggers ») pour mailcap (3.69) ...
Des erreurs ont été rencontrées pendant l'exécution :
 discord

Dernière modification par Clemiloup (22-08-2021 23:31:15)

Hors ligne

#31 22-08-2021 23:45:38

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [Résolu] Installation de paquets

Clemiloup, il faut rester plus longtemps connecté sur IRC, pourquoi t'es-tu déconnecté ?

Il faut poser tes questions sur le chat IRC, les gens sont sympa tu verras smile

Dernière modification par Jean-Pierre Pinson (23-08-2021 10:37:28)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#32 23-08-2021 14:17:39

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu] Installation de paquets

Hello
il n'a pas de paquet libappindicator1 pour Bullseye, cela passe de Buster a Sid
sinon pour gedbi pas besoin de télécharger une version de paquet qui se trouve être différente de celle proposé dans les dépôts

apt install gdebi

aurait du installer l'application

Discord est proposé en version conteneur Flatpak

apt update  && apt upgrade


apt install flatpak


flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo


flatpak install discord


Looking for matches…
Found similar ref(s) for ‘discord’ in remote ‘flathub’ (system).
Use this remote? [Y/n]:


voila suffit de répondre y valider et c'est parti smile
Je pense que un icône de lancement doit se créer dans les applications internet

De temps en temps un petit

flatpak update


histoire de voir si il y aurait pas des mises à jour
j'ai vu que pour gnome il existe une application graphique pour la gestion de flatpak

gnome-software-plugin-flatpak

Dernière modification par Croutons (28-08-2021 09:03:39)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#33 27-08-2021 11:10:25

Clemiloup
Membre
Distrib. : Debian GNU/Linux 11 (Bullseye)
Noyau : 5.10.0-8-amd64 / 5.10.0-10-amd64
(G)UI : GNOME 3.38.5 (Wayland) / KDE Plasma 5.20.5
Inscription : 21-08-2021

Re : [Résolu] Installation de paquets

Croutons a écrit :

Hello
il n'a pas de paquet libappindicator1 pour Bullseye, cela passe de Buster a Sid
sinon pour gedbi pas besoin de télécharger une version de paquet qui se trouve être différente de celle proposé dans les dépôts

apt install gdebi

aurait du installé l'application

Discord est proposé en version conteneur Flatpak

apt update  && apt upgrade


apt install flatpak


flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo


flatpak install discord


Looking for matches…
Found similar ref(s) for ‘discord’ in remote ‘flathub’ (system).
Use this remote? [Y/n]:


voila suffit de répondre y valider et c'est parti smile
Je pense que un icône de lancement doit se créer dans les applications internet

De temps en temps un petit

flatpak update


histoire de voir si il y aurait pas des mises à jour
j'ai vu que pour gnome il existe une application graphique pour la gestion de flatpak

gnome-software-plugin-flatpak



Bonjour à toi,

Tout d'abord merci du tuyau, mais comme rien ne va jamais comme il faut chez moi, voici ce que la dernière commande m'a répondu:

~$ flatpak install discord
Looking for matches…
F: An error was encountered searching remote ‘flathub’ for ‘discord’: Unable to load summary from remote flathub: Error resolving “dl.flathub.org”: Nom ou service inconnu
error: No remote refs found similar to ‘discord’

Hors ligne

#34 27-08-2021 11:18:13

Clemiloup
Membre
Distrib. : Debian GNU/Linux 11 (Bullseye)
Noyau : 5.10.0-8-amd64 / 5.10.0-10-amd64
(G)UI : GNOME 3.38.5 (Wayland) / KDE Plasma 5.20.5
Inscription : 21-08-2021

Re : [Résolu] Installation de paquets

Clemiloup a écrit :

Croutons a écrit :

Hello
il n'a pas de paquet libappindicator1 pour Bullseye, cela passe de Buster a Sid
sinon pour gedbi pas besoin de télécharger une version de paquet qui se trouve être différente de celle proposé dans les dépôts

apt install gdebi

aurait du installé l'application

Discord est proposé en version conteneur Flatpak

apt update  && apt upgrade


apt install flatpak


flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo


flatpak install discord


Looking for matches…
Found similar ref(s) for ‘discord’ in remote ‘flathub’ (system).
Use this remote? [Y/n]:


voila suffit de répondre y valider et c'est parti smile
Je pense que un icône de lancement doit se créer dans les applications internet

De temps en temps un petit

flatpak update


histoire de voir si il y aurait pas des mises à jour
j'ai vu que pour gnome il existe une application graphique pour la gestion de flatpak

gnome-software-plugin-flatpak



Bonjour à toi,

Tout d'abord merci du tuyau, mais comme rien ne va jamais comme il faut chez moi, voici ce que la dernière commande m'a répondu:

~$ flatpak install discord
Looking for matches…
F: An error was encountered searching remote ‘flathub’ for ‘discord’: Unable to load summary from remote flathub: Error resolving “dl.flathub.org”: Nom ou service inconnu
error: No remote refs found similar to ‘discord’



Bon, oublie ce que j'ai dit car ça fonctionne maintenant. Petite explication:
Je ne vais sur internet que lorsque mon vpn est actif et quand j'ai voulu installer discord via flatpak il était désactivé. Du coup dès que mon vpn n'est pas connecté, internet ne fonctionne pas sur mon ordi. C'est donc en l'activant que l'installation c'est lancée.
En tout cas merci du coup de main, maintenant tout fonctionne ! smile

Dernière modification par Clemiloup (27-08-2021 11:18:39)

Hors ligne

#35 27-08-2021 12:15:20

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : [Résolu] Installation de paquets


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#36 28-08-2021 14:20:32

Clemiloup
Membre
Distrib. : Debian GNU/Linux 11 (Bullseye)
Noyau : 5.10.0-8-amd64 / 5.10.0-10-amd64
(G)UI : GNOME 3.38.5 (Wayland) / KDE Plasma 5.20.5
Inscription : 21-08-2021

Re : [Résolu] Installation de paquets



Oui, je n'ai pas oublié. J'ai juste laissé ce post "ouvert" au cas où j'aurais des problèmes durant l'installation ou suite à celle-ci. N'en ayant pas eu, je vais à présent le marquer comme résolu wink

Dernière modification par Clemiloup (28-08-2021 14:21:01)

Hors ligne

Pied de page des forums