Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-08-2021 17:50:34

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

[Résolu]verrouillage numérique actif

Bonjour,
Sur mon portable le constructeur (HP) a eu le bon esprit de ne pas mettre de LED pour indiquer l'état du pavé numérique.
Je souhaiterais avoir 'login' le verrouillage actif.
J'ai installé le paquet 'numlockx'.
Dans /etc/default/numlockx j'ai passé à  NUMLOCK=on
Mais aucun résultat...
Je suis sous Xfce , Debian11
Merci pour l'aide.

Dernière modification par gargamel79 (30-08-2021 10:46:13)

Hors ligne

#2 29-08-2021 18:46:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu]verrouillage numérique actif

Bonjour,

gargamel79 a écrit :

Je souhaiterais avoir 'login' le verrouillage actif.


Pour que le verrouillage soit actif dès l'écran de connexion, modifier un fichier de config de LightDM :

nano /etc/lightdm/lightdm.conf

#greeter-setup-script=

devient

greeter-setup-script=/usr/bin/numlockx on


Il s'agit d'une variante fonctionnelle de la proposition faite sur le wiki, testée à l'époque de Debian 9.

Hors ligne

#3 30-08-2021 10:44:51

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]verrouillage numérique actif

Merci pour ta réponse , mais la méthode indiquée ne fonctionne pas sous Debian11.
Merci pour ton lien.
À signaler:  /usr/share/lightdm/lightdm.conf.d/50-numlock.conf  n'existe pas.
Pas contre la modification de : 01_debian.conf avec
[Seat:*]
ajouter la ligne:
greeter-setup-script=/usr/bin/numlockx on

Est OK. Merci pour ton aide smile

Hors ligne

#4 31-08-2021 10:40:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu]verrouillage numérique actif

Re-,

gargamel79 a écrit :

la méthode indiquée ne fonctionne pas sous Debian 11.


Bon j'ai testé, et il apparaît que la méthode fonctionne comme attendu, as-tu décommenté la ligne ?

sed -i 's,#greeter-setup-script=,greeter-setup-script=numlockx on,' /etc/lightdm/lightdm.conf


Redémarrer [le service lightdm]. Il n'est pas nécessaire de spécifier /usr/bin/, testé sous Xfce/MATE.

Hors ligne

#5 31-08-2021 11:13:45

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]verrouillage numérique actif

Chez moi, Debian11 Xfce la ligne:
#greeter-setup-script=
n'existe pas
dans
/etc/lightdm/lightdm.conf
Et je n'ai pas voulu l'ajouter de ma propre initiative. Est-ce qu'il faudrait faire ? Pour moi, c'est OK avec ce que j'ai indiqué, mais cela pourrait servir à d'autres.

Hors ligne

#6 31-08-2021 12:38:45

robert2a
Membre
Inscription : 15-11-2014

Re : [Résolu]verrouillage numérique actif

Bonjour
tester sur bullseye (testing) ne fonctionne pas , le script modifier (la partie de la modification) suite au #4


[Seat:*]
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-backend=
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#unity-compositor-command=unity-system-compositor
#unity-compositor-timeout=60
#greeter-session=example-gtk-gnome
greeter-hide-users=false                        => modif "user"
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
#user-session=default
#allow-user-switching=true
#allow-guest=true
#guest-session=
#session-wrapper=lightdm-session
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
greeter-setup-script=numlockx on  => modif num activer
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false
 



j'ai un curseur clignotant (plus d' invite de connexion ) , remit l' original sans le "num" activer
depuis le début je teste mais ça ne fonctionne pas
seul le #68 ici est correct , l' user est indiquer automatiquement a l' invite de connexion
=> https://debian-facile.org/viewtopic.php … 05#p366005

quand a la solution de gargamel79 pas compris ce qu'il a fait
ps: le wiki ne fonctionne pas non plus
je fais confiance a èfpé , mais je vois pas ce que je fais de mal  roll
pour les tests sous testing + Mate ( enfin c'est une bullseye a peine modifier)

Hors ligne

#7 31-08-2021 13:20:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu]verrouillage numérique actif

Re-,

freedesktop.org a écrit :

greeter-setup-script is run before a greeter starts. It is run as root. If this command returns an
error code the greeter fails to start (which will cause LightDM to stop).

robert2a a écrit :

j'ai un curseur clignotant (plus d'invite de connexion)


Le paquet numlockx est-il bien installé ? ton souci est très facilement reproduit : en le désinstallant.

gargamel79 a écrit :

Et je n'ai pas voulu l'ajouter de ma propre initiative.


Tu pouvais, dans [Seat:*], comme dans le fichier /usr/share/lightdm/lightdm.conf.d/01_debian.conf.

Dernière modification par èfpé (31-08-2021 17:40:42)

Hors ligne

#8 31-08-2021 13:31:46

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-16-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [Résolu]verrouillage numérique actif

Hello
pour voir la config

/usr/sbin/lightdm --show-config


   [Seat:*]
A  greeter-session=lightdm-greeter
A  greeter-hide-users=true
A  session-wrapper=/etc/X11/Xsession
B  greeter-setup-script=/usr/bin/numlockx on

Sources:
A  /usr/share/lightdm/lightdm.conf.d/01_debian.conf
B  /usr/share/lightdm/lightdm.conf.d/50-numlock.conf
C  /etc/lightdm/lightdm.conf
 



gargamel79 a écrit :

Sur mon portable le constructeur (HP) a eu le bon esprit de ne pas mettre de LED pour indiquer l'état du pavé numérique.


Petit script par MIcP
Xfce Affichage NumLock et Capslock
https://debian-facile.org/viewtopic.php?id=27334


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 31-08-2021 18:33:39

robert2a
Membre
Inscription : 15-11-2014

Re : [Résolu]verrouillage numérique actif

re

merci èfpé ça fonctionne wink
par contre j'ai jamais compris l'utilité de l'option du bios , qui ne sert a rien a priori pour le pavé numérique activé
j'espère que ça va résoudre aussi dans certain cas le voyant "Num" allumer , et le pavé numérique inactif
et pourquoi ce paquet ne fait pas parti de l'installation de debian

Hors ligne

#10 31-08-2021 18:58:50

gargamel79
Membre
Lieu : Baugé en Anjou
Distrib. : Buster
Noyau : Linux 4.19.0-12-amd64
(G)UI : xfce
Inscription : 15-11-2009

Re : [Résolu]verrouillage numérique actif

Quand j'écris:
Sur mon portable le constructeur (HP) a eu le bon esprit de ne pas mettre de LED pour indiquer l'état du pavé numérique.
C'est par antiphrase; économiser une LED c'est vraiment mesquin !!!

Hors ligne

Pied de page des forums