Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-09-2021 23:17:12

Switch75
Membre
Distrib. : kali 2020.4 sur VMWARE
Inscription : 28-09-2021

[Résolu] Problème dépendances lors d'installation paquet pour Kali

Bonjour,


J'essaye d'installer un package OSINT pour Kali sur VMWARE (kali-tools-information-gathering), mais j'ai un problème de dépendances.
J'ai essayé de faire quelques manip trouvés sur des forum mais sans succès.
Voici ce que j'ai tapé sur Kali pour l'installation des dépendances et du package en question :

sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libperl5.30 libplymouth4 libpython3.8 libpython3.8-minimal
libpython3.8-stdlib libwireshark13 libwiretap10 libwsutil11 python3.8
python3.8-minimal
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
pipewire-bin
Les NOUVEAUX paquets suivants seront installés :
pipewire-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 841 non mis à jour.
1126 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/286 ko dans les archives.
Après cette opération, 1420 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 270835 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../pipewire-bin_0.3.37-1_amd64.deb ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb (--unpack) :
conffile name 'remove-on-upgrade /etc/pipewire/media-session.d/with-jack' is not an absolute pathname
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 




sudo apt-get install kali-tools-information-gathering
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
kali-tools-information-gathering : Dépend: 0trace mais ne sera pas installé
Dépend: braa mais ne sera pas installé
Dépend: dnsmap mais ne sera pas installé
Dépend: dnstracer mais ne sera pas installé
Dépend: dnswalk mais ne sera pas installé
Dépend: firewalk mais ne sera pas installé
Dépend: fragrouter mais ne sera pas installé
Dépend: ftester mais ne sera pas installé
Dépend: intrace mais ne sera pas installé
Dépend: irpas mais ne sera pas installé
Dépend: metagoofil mais ne sera pas installé
Dépend: ncat mais ne sera pas installé
Dépend: p0f mais ne sera pas installé
Dépend: smtp-user-enum mais ne sera pas installé
Dépend: tlssled mais ne sera pas installé
Dépend: twofi mais ne sera pas installé
Dépend: unicornscan mais ne sera pas installé
Dépend: urlcrazy mais ne sera pas installé
Dépend: xprobe mais ne sera pas installé
pipewire : Dépend: pipewire-bin (= 0.3.37-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
(ou indiquez une solution).




sudo apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libperl5.30 libplymouth4 libpython3.8 libpython3.8-minimal
libpython3.8-stdlib libwireshark13 libwiretap10 libwsutil11 python3.8
python3.8-minimal
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
pipewire-bin
Les NOUVEAUX paquets suivants seront installés :
pipewire-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 841 non mis à jour.
1126 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/286 ko dans les archives.
Après cette opération, 1420 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 270835 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../pipewire-bin_0.3.37-1_amd64.deb ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb (--unpack) :
conffile name 'remove-on-upgrade /etc/pipewire/media-session.d/with-jack' is not an absolute pathname
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



J'ai rajouté le Kali Rolling dans le sources.list mais sans succès. Je n'ai pas touché sources list.d :

cat /etc/apt/sources.list
deb http://http.kali.org/kali kali-rolling main non-free contrib



Voilà. Si vous avez des réponses à ce problème, n'hésitez pas.
Merci à vous

Dernière modification par Switch75 (29-09-2021 16:10:11)

Hors ligne

#2 29-09-2021 11:16:04

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Vu que c’est des paquets liés à pipewire qui posent souci, et qu’une Kali n’est de toutes façons pas prévue pour pour lire de l’audio/vidéo, je te conseille de les retirer pour débloquer la situation :

apt remove pipewire pipewire-bin
apt install -f


Jouer sous Debian ? Facile !

Hors ligne

#3 29-09-2021 12:37:06

Switch75
Membre
Distrib. : kali 2020.4 sur VMWARE
Inscription : 28-09-2021

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Bonjour

Cela me donne ça :

apt remove pipewire pipewire-bin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet « pipewire-bin » n'est pas installé, et ne peut donc être supprimé
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 pipewire-media-session : Dépend: pipewire (= 0.3.37-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).



apt install -f                                                  
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libperl5.30 libplymouth4 libpython3.8 libpython3.8-minimal
  libpython3.8-stdlib libwireshark13 libwiretap10 libwsutil11 python3.8
  python3.8-minimal
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  pipewire-bin
Les NOUVEAUX paquets suivants seront installés :
  pipewire-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 844 non mis à jour.
1126 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/286 ko dans les archives.
Après cette opération, 1420 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 270835 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../pipewire-bin_0.3.37-1_amd64.deb ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb (--unpack) :
 conffile name 'remove-on-upgrade /etc/pipewire/media-session.d/with-jack' is not an absolute pathname
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#4 29-09-2021 12:49:23

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Hello,

Tente de supprimer le paquet indiqué :

apt remove --purge pipewire-media-session


Si ça se passe bien, lance :

apt autoremove


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#5 29-09-2021 12:58:14

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Bonjour
utilise aptitude


apt remove pipewire pipewire-bin
 


par exemple chez moi en simulation


apt -s remove pipewire pipewire-bin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gstreamer1.0-pulseaudio libpipewire-0.3-modules
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  pipewire pipewire-bin
0 mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour.
Remv pipewire [0.3.19-4]
Remv pipewire-bin [0.3.19-4]
 



aptitude va te donner des solutions si cela est possible

je te conseille un apt autoremove --purge aussi au vue de te tes retours


apt autoremove --purge
 



et utilise la simulation avant "-s" le cas ou

Hors ligne

#6 29-09-2021 13:36:52

Switch75
Membre
Distrib. : kali 2020.4 sur VMWARE
Inscription : 28-09-2021

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Il y a un problème de dépendance :

Pour Tawal :

apt remove --purge pipewire-media-session
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 pipewire : Dépend: pipewire-bin (= 0.3.37-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).



Pour Robert :

apt remove pipewire pipewire-bin                                
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet « pipewire-bin » n'est pas installé, et ne peut donc être supprimé
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 pipewire-media-session : Dépend: pipewire (= 0.3.37-1) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).

Hors ligne

#7 29-09-2021 13:42:26

Switch75
Membre
Distrib. : kali 2020.4 sur VMWARE
Inscription : 28-09-2021

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Je me demande si ce n'est pas python qui pose problème (ainsi que pipewire bien sûr) :

apt install -f                                                  
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
[b]Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libperl5.30 libplymouth4 libpython3.8 libpython3.8-minimal
  libpython3.8-stdlib libwireshark13 libwiretap10 libwsutil11 python3.8
  python3.8-minimal[/b]
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  pipewire-bin
Les NOUVEAUX paquets suivants seront installés :
  pipewire-bin
0 mis à jour, 1 nouvellement installés, 0 à enlever et 844 non mis à jour.
1126 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/286 ko dans les archives.
Après cette opération, 1420 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
(Lecture de la base de données... 270835 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../pipewire-bin_0.3.37-1_amd64.deb ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb (--unpack) :
 conffile name 'remove-on-upgrade /etc/pipewire/media-session.d/with-jack' is not an absolute pathname
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/pipewire-bin_0.3.37-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#8 29-09-2021 14:18:51

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Essaie :

apt remove --purge pipewire-media-session pipewire



Et passe ensuite (si tout s'est bien déroulé) un :

apt autoremove --purge



Edit:
Tu peux rajouter l'option "-s" pour ne faire qu'une simulation et voir si des erreurs seront retournées.
Si aucune erreur, fait le en réel.

Dernière modification par Tawal (29-09-2021 14:20:58)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#9 29-09-2021 14:45:08

Switch75
Membre
Distrib. : kali 2020.4 sur VMWARE
Inscription : 28-09-2021

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

Cela a fonctionné!!
je t'épargne l'avalanche de données! il a supprimé le fichier, il a tout reparamétré!
j'ai lancé ensuite la purge!
J'ai installé le pack! Et tout s'est déroulé nickel!! OUUUUUUFFFF!!! cela faisait 2 jours que je galérais dessus!

merci à toi Tawal!! Ainsi qu'à Robert!

Hors ligne

#10 29-09-2021 16:02:29

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Problème dépendances lors d'installation paquet pour Kali

De rien, c'est avec plaisir wink

Je suis tout content que toi smile

Tu peux mettre le sujet en [Résolu] en éditant ton 1er message et en modifiant le titre en conséquence wink

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

Pied de page des forums