Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-10-2021 19:23:47

Pyroxene
Membre
Inscription : 10-10-2021

[Résolu] Mise à jour inopinée vers kernel instable

Bonjour,

Je suis confronté depuis quelques temps à un problème que je n'arrive pas à résoudre. J'ai un serveur tournant sur un Raspberry Pi 3B+ sous Raspbian Buster.

Du jour au lendemain, mon système a l'air de vouloir se mettre à jour vers un kernel instable (testing), alors que j'aimerais qu'il reste bien stable. J'ai essayé de faire la mise à jour et il en a résulté que le Raspberry n'a pas voulu rebooter, donc j'ai réinstallé à partir d'une sauvegarde du disque et depuis je n'ai plus osé mettre à jour.

Plus précisément ce sont tous ces testing qui me font peur :

apt list --upgradable


En train de lister... Fait
apache2-utils/oldstable 2.4.38-3+deb10u6 armhf [pouvant être mis à jour depuis : 2.4.38-3+deb10u5]
firmware-atheros/testing 1:20190114-2+rpt3 all [pouvant être mis à jour depuis : 1:20190114-2+rpt1]
firmware-brcm80211/testing 1:20190114-2+rpt3 all [pouvant être mis à jour depuis : 1:20190114-2+rpt1]
firmware-libertas/testing 1:20190114-2+rpt3 all [pouvant être mis à jour depuis : 1:20190114-2+rpt1]
firmware-misc-nonfree/testing 1:20190114-2+rpt3 all [pouvant être mis à jour depuis : 1:20190114-2+rpt1]
firmware-realtek/testing 1:20190114-2+rpt3 all [pouvant être mis à jour depuis : 1:20190114-2+rpt1]
libntfs-3g883/oldstable 1:2017.3.23AR.3-3+deb10u1 armhf [pouvant être mis à jour depuis : 1:2017.3.23AR.3-3]
libraspberrypi-bin/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
libraspberrypi-dev/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
libraspberrypi-doc/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
libraspberrypi0/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
libssl1.1/oldstable 1.1.1d-0+deb10u7 armhf [pouvant être mis à jour depuis : 1.1.1d-0+deb10u6+rpt1]
linux-libc-dev/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
ntfs-3g/oldstable 1:2017.3.23AR.3-3+deb10u1 armhf [pouvant être mis à jour depuis : 1:2017.3.23AR.3-3]
openssl/oldstable 1.1.1d-0+deb10u7 armhf [pouvant être mis à jour depuis : 1.1.1d-0+deb10u6+rpt1]
pi-bluetooth/testing 0.1.18 all [pouvant être mis à jour depuis : 0.1.17]
raspberrypi-bootloader/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
raspberrypi-kernel/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
raspberrypi-sys-mods/testing 20211005 armhf [pouvant être mis à jour depuis : 20210901]
rpi-eeprom/testing 12.14-1 armhf [pouvant être mis à jour depuis : 12.9-1]
tzdata/oldstable 2021a-0+deb10u2 all [pouvant être mis à jour depuis : 2021a-0+deb10u1]



Voilà quelques informations supplémentaires sur mon système :

uname -r


5.10.60-v7+


lsb_release -a


No LSB modules are available.
Distributor ID: Raspbian
Description:  Raspbian GNU/Linux 10 (buster)
Release:  10
Codename: buster


cat /etc/apt/sources.list


deb http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi


ls /etc/apt/sources.list.d


raspi.list  vscode.list


cat /etc/apt/sources.list.d/*


deb http://archive.raspberrypi.org/debian/ buster main
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ buster main
### Disabled by raspberrypi-sys-mods ###



Quelqu'un saurait-il m'aiguiller sur la marche à suivre pour remédier à cela ?

Dernière modification par Pyroxene (16-10-2021 13:27:50)

Hors ligne

#2 10-10-2021 19:55:22

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Mise à jour inopinée vers kernel instable

Hello,

C'est toi ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2067468
Tu aurais pu prendre le même pseudo,tu as peur de quoi ?

Bon, déjà, tu sera mieux conseillé ici, mais ce n'est pas moi qui vais pouvoir t'aider sad

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#3 10-10-2021 20:50:00

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [Résolu] Mise à jour inopinée vers kernel instable

Les versions "testing" des paquets listées par apt list --upgradable ne viennent pas de nulle part.

J’imagine que tu as modifié tes fichiers de sources de paquets avant de les partager ici, est-ce que tu as bien pensé à lancer un apt update ensuite ? Sinon apt travaille toujours à partir de la liste de sources précédentes.

---

Après relecture, il semble que pour un de tes dépôts "testing" corresponde en fait à "buster". Malheureusement c’est une spécificité de Raspbian, donc hors de mon champ de compétences.

Jouer sous Debian ? Facile !

Hors ligne

#4 10-10-2021 21:40:42

Pyroxene
Membre
Inscription : 10-10-2021

Re : [Résolu] Mise à jour inopinée vers kernel instable

Tawal a écrit :

Hello,

C'est toi ici : https://forum.ubuntu-fr.org/viewtopic.php?id=2067468
Tu aurais pu prendre le même pseudo,tu as peur de quoi ?

Bon, déjà, tu sera mieux conseillé ici, mais ce n'est pas moi qui vais pouvoir t'aider sad



Oui effectivement j'ai d'abord publié ma question sur le forum Ubuntu. D'ailleurs je ne sais pas pourquoi la page n'a pas l'air d'être publique si on n'est pas identifié. Et c'est vrai que je n'ai pas pensé à utiliser le même pseudo. Après, Plagioclase et Pyroxene ça reste dans la même veine des minéraux.

Hors ligne

#5 10-10-2021 21:47:25

Pyroxene
Membre
Inscription : 10-10-2021

Re : [Résolu] Mise à jour inopinée vers kernel instable

vv222 a écrit :

Les versions "testing" des paquets listées par apt list --upgradable ne viennent pas de nulle part.

J’imagine que tu as modifié tes fichiers de sources de paquets avant de les partager ici, est-ce que tu as bien pensé à lancer un apt update ensuite ? Sinon apt travaille toujours à partir de la liste de sources précédentes.

---

Après relecture, il semble que pour un de tes dépôts "testing" corresponde en fait à "buster". Malheureusement c’est une spécificité de Raspbian, donc hors de mon champ de compétences.



Alors, je n'ai jamais touché aux fichiers de source, ce sont vraiment les fichiers tels quels qui étaient présents dans l'image quand j'ai installé le serveur il y a plus d'un an environ. Est-ce que votre dernière remarque présagerait que la branche testing sous Raspbian serait en fait stable ??? Ce serait le comble d'avoir nommé les choses ainsi.

Sinon dans le pire des cas, je pourrais repartir d'une image plus récente et tout réinstaller au propre, mais franchement ce serait fastidieux, même si je pense qu'un jour il faudra bien que je le fasse pour passer à Bullseye.

Hors ligne

#6 10-10-2021 21:59:29

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Mise à jour inopinée vers kernel instable

[Hors-sujet]

Pyroxene a écrit :

Après, Plagioclase et Pyroxene ça reste dans la même veine des minéraux.


Merci de cet enseignement wink

[/Hors-sujet]

Dernière modification par Tawal (10-10-2021 21:59:59)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#7 10-10-2021 22:13:51

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [Résolu] Mise à jour inopinée vers kernel instable

Pyroxene a écrit :

Est-ce que votre dernière remarque présagerait que la branche testing sous Raspbian serait en fait stable ??? Ce serait le comble d'avoir nommé les choses ainsi.


C’est ces lignes qui me laissent penser que pour un des dépôts Raspbian "testing" correspond à "buster" :

libraspberrypi-bin/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
libraspberrypi-dev/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
libraspberrypi-doc/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]
libraspberrypi0/testing 1:1.20210928-1~buster armhf [pouvant être mis à jour depuis : 1:1.20210831-1]


Mais on voit à d’autres endroits que "buster" correspond à "oldstable" pour un autre dépôt actif (les numéros de versions incluant "+deb10u" sont des paquets pour Buster, le "deb10" est une version courte de "Debian 10").

C’est clairement quelque chose de spécifique à Raspbian, que je ne saurais pas expliquer.


Jouer sous Debian ? Facile !

Hors ligne

#8 16-10-2021 13:27:16

Pyroxene
Membre
Inscription : 10-10-2021

Re : [Résolu] Mise à jour inopinée vers kernel instable

J'ai finalement mis à jour mon système, mais en pensant auparavant à éteindre les programmes très gourmands.


sudo systemctl stop nginx
sudo systemctl stop mysql
sudo apt update
sudo apt full-upgrade
sudo apt autoremove
sudo reboot
 



Et houra le système a redémarré sans kernel panic. Peut-être que les autres fois je n'ai pas eu de chance. Mais je pense que éteindre nginx et mysql a aussi aidé.

Hors ligne

Pied de page des forums