Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-10-2021 09:15:24

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux Bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : gdm3
Inscription : 09-03-2016

[RÉSOLU] Clavier Logitech MX-Keys et touche Alt

Bonjour à tous,

J'ai une installation identique à mon domicile et au bureau. Le même matériel, le même type de machine, le même OS Debian Testing.

J'utilise un clavier Logitech MX-KEYS identique sur les 2 machines.

Sauf que... sur une machine à la maison, la touche à côté de la barre d'espacement (cmd|alt-gr) me permet en combinaison avec le "2" d'avoir le @ et au bureau, la même touche et la même combinaison ne me donne pas l'arobase. Elle affiche le "2". Pour avoir le @ je dois me servir de la touche Opt|ctrl qui est à droite de la touche FN qui est à droite de cette fameuse touche cmd|alt-gr.

Bon en résumé j'ai :

barre d'espacement - cmd|alt-gr (qui ne donne rien si ce n'est que le "2") - ensuite à droite j'ai fn - ensuite à droite j'ai cette touche opt|ctrl qui elle me donne le @ en combinaison avec le 2.

Bon, je ne sais pas où chercher ! J'ai déjà fait plusieurs recherches sur google, mais je n'arrive pas à trouver un problème similaire.

Une idée ?

Dernière modification par jettero (26-10-2021 11:20:18)

Hors ligne

#2 26-10-2021 09:34:16

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : [RÉSOLU] Clavier Logitech MX-Keys et touche Alt

T'as vérifié tout simplement l'agencement du clavier dans tes paramètres système ?

Tu en as plusieurs pour le Français. Et selon celui que tu choisis, les touches ne sont pas affectées de la même façon. Je t'invite à vérifier celui que tu as à ton boulot et celui chez toi ... je parie qu'ils sont différents wink

Hors ligne

#3 26-10-2021 09:58:04

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux Bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : gdm3
Inscription : 09-03-2016

Re : [RÉSOLU] Clavier Logitech MX-Keys et touche Alt

Merci hyrr0,

J'aurais aimé que ce soit ça. Mais je viens de tester et ça ne change rien. Je suis en suisse, donc le clavier est un qwertz. Le système propose 3 options, touche morte, mac et normal.

Mais quand je teste en mode graphique, si j'appuie sur la touche opt|ctrl (celle qui est tout à droite de la droite), et à l'écran c'est comme si j'activais la touche cmd|alt-gr (à droite de la barre d'espacement).

ARF pas facile à expliquer !

Hors ligne

#4 26-10-2021 10:16:13

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux Bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : gdm3
Inscription : 09-03-2016

Re : [RÉSOLU] Clavier Logitech MX-Keys et touche Alt

J'ai testé un autre clavier et là pas de problèmes. Serait-ce possible que ce soit un problème de hardware ?

Hors ligne

#5 26-10-2021 11:19:19

jettero
Membre
Lieu : Lausanne (suisse)
Distrib. : Debian GNU/Linux Bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : gdm3
Inscription : 09-03-2016

Re : [RÉSOLU] Clavier Logitech MX-Keys et touche Alt

Bon voilà, j'ai résolu le problème.

J'ai du passer par Windows pour réinstaller le clavier avec l'application de logitech et ensuite redémarrer sur debian. Cette fois les touches sont au bon endroit.

Hors ligne

#6 26-10-2021 12:00:17

hyrr0
Membre
Distrib. : Debian stable
Inscription : 12-01-2018

Re : [RÉSOLU] Clavier Logitech MX-Keys et touche Alt

Donc problème de firmware du clavier. Etonnant.

Content que tu aies résolu ton problème! A bientôt

Hors ligne

Pied de page des forums