Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-10-2021 20:12:09

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

[résolu]KVM bug avec virt-manager

Bonsoir
quand je lance la VM en graphique sur l'hôte ce message


Erreur lors du démarrage du domaine: Requested operation is not valid: network 'default' is not active

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 65, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 101, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 57, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/domain.py", line 1329, in startup
    self._backend.create()
  File "/usr/lib/python3/dist-packages/libvirt.py", line 1353, in create
    raise libvirtError('virDomainCreate() failed')
libvirt.libvirtError: Requested operation is not valid: network 'default' is not active
 



fichier "interfaces"


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto enp3s0
iface enp3s0 inet dhcp

#interface virtuelle
auto tap0
iface tap0 inet manual
vde-switch -t tap0

#pont pour les conteneurs
auto br0
iface br0 inet static
bridge-ports tap0
address 10.0.0.1
netmask 255.255.255.0
 



si je fais une nouvelle installation d'une VM ça va fonctionner un certain temps puis idem plus de réseau virtuel , je peut plus lancer la VM
ps: KVM et virt-manager et je suis en testing (bookworm)

a l'installation on me demande si je veut activer le "nat" => oui (pour le net)

quelqu'un a une idée ?

Dernière modification par robert2a (26-10-2021 20:51:15)

Hors ligne

#2 26-10-2021 20:50:52

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu]KVM bug avec virt-manager

re,

trouver => https://wiki.debian.org/KVM


virsh --connect qemu:///system list --all
 ID   Nom         État
-------------------------
 -    archlinux   fermé
 



export LIBVIRT_DEFAULT_URI='qemu:///system'
 



virsh --connect=qemu:///system net-start default
Réseau default démarré
 



virsh --connect=qemu:///system net-autostart default
Réseau default marqué en démarrage automatique
 



je vais pouvoir finir l'installation de Arch Linux smile

Hors ligne

Pied de page des forums