Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-10-2021 23:37:40

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Jessie obsolète ?

Je suis un mauvais utilisateur de Xcfe Jessie sur une vieille bécane 32 bits de plus de 10 ans que j’utilise rarement et qui me refuse ce soir l’accès à des sites publics type info.gouv, debian.org, que ce soit via Firefox ou chromium.
Est-ce lié à l’obsolescence de Jessie ? Ou à celle de mes navigateurs.
Cela fait quelques temps que je ne peux faire d’update de Jessie.
L’accès aux dépôts me donnent des erreurs 404
Comment faire pour upgrader vers une nouvelle distribution Xcfe sans tout perdre ?
Je maîtrise mal le mode terminal mais je peux faire un effort.
Je ne trouve pas le lien qui explique comment upgrader simplement une distribution Xfce
Merci

Dernière modification par Klod16 (28-10-2021 05:02:57)

Hors ligne

#2 28-10-2021 07:45:20

Anonyme
Invité

Re : Jessie obsolète ?

Salut,

Ta machine est connectée au réseau ? internet ?

Quel est le résultat de :

ping -c 3 debian-facile.org




Même si Jessie est obsolète ( https://www.debian.org/releases/jessie/index.fr.html ) tu devrais quand même pouvoir accéder aux repos qu existe toujours.

#3 28-10-2021 07:54:10

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Jessie obsolète ?

Pour ce qui est de monter en version de Debian 8 vers la 11, il est éventuellement possible d'installer directement une nouvelle version sans perdre tes données personnelles et tes configurations et sans passer par les mises à jours qu'il te faudrait faire (MAJ de jessie, puis vers Stretch, puis vers Buster, puis vers Bullseye).

Tout dépend de si tu as un /home séparé ou pas.

Ouvre un terminal (dans le menu xfce "émulateur de terminal" et entre cette commande :

df -h



et celle-ci

lsblk



En mettant dans ta réponse le copier coller des résultats.

Hors ligne

#4 28-10-2021 10:13:20

jarek
Membre
Lieu : Haute Loire
Distrib. : testing
Noyau : linux 5.14.0-2
(G)UI : xfce4 - lightdm
Inscription : 24-06-2014

Re : Jessie obsolète ?

Klod16 a écrit :

Comment faire pour upgrader vers une nouvelle distribution Xcfe sans tout perdre ?


La distribution c'est Debian xxx, pas XFCE qui est l'environnement graphique.

Pour passer d'une Debian 8 à une 11, il faut effectuer les migrations de 8 vers 9, puis de 9 vers 10, et enfin de10 vers 11.
D'où l'intérêt de migrer vers une nouvelle version sans trop tarder.

Pour faire simple, tu sauvegardes (ou pas) ce que tu veux, puis tu fais une installation de Debian 11 en écrasant tout.


Définitivement pour ce qui est contre et contre ce qui est pour.
Ryzen3 3200G - Asrock B450

Hors ligne

#5 29-10-2021 07:31:40

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

Merci
Oui j’ai une connexion internet, mais bizarrement j’avais accès à certains sites comme Google et pas d’autres avant hier
Ce matin l’accès est rétabli apparemment mais pour combien de temps ?


Voici la réponse à votre question
root@debian:/home/claude# df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
/dev/sdb6          174G     62G  104G  38% /
udev                10M       0   10M   0% /dev
tmpfs              200M    5,0M  195M   3% /run
tmpfs              500M     14M  487M   3% /dev/shm
tmpfs              5,0M    4,0K  5,0M   1% /run/lock
tmpfs              500M       0  500M   0% /sys/fs/cgroup
/dev/sdb7          708G     32K  708G   1% /data
tmpfs              100M    4,0K  100M   1% /run/user/117
tmpfs              100M    8,0K  100M   1% /run/user/1000
root@debian:/home/claude# lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0  74,5G  0 disk
├─sda1   8:1    0  42,7G  0 part
├─sda2   8:2    0     1K  0 part
├─sda5   8:5    0  30,5G  0 part
└─sda6   8:6    0   1,4G  0 part
sdb      8:16   0   1,8T  0 disk
├─sdb1   8:17   0     1K  0 part
├─sdb2   8:18   0 976,6G  0 part
├─sdb5   8:21   0     2G  0 part [SWAP]
├─sdb6   8:22   0 176,9G  0 part /
└─sdb7   8:23   0 707,6G  0 part /data
sr0     11:0    1  1024M  0 rom

Dernière modification par Klod16 (29-10-2021 07:41:57)

Hors ligne

#6 29-10-2021 07:32:45

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

Par contre je ne comprends pas s’il faut passer de 8 à 9 puis 10 puis 11 ou directement installer 11

Hors ligne

#7 29-10-2021 08:49:25

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stable Xfce
Inscription : 30-09-2015

Re : Jessie obsolète ?

Mettre à niveau vers la 9 (qui n'est plus supportée que pour quelques mois encore) ne me paraît pas intéressant.

Mieux vaut installer la 11 après avoir sauvegardé tes données. Tu repartiras sur quelque chose de propre.

Dernière modification par zorzi (29-10-2021 08:49:56)


Desktop: HP Pavilion a6435 (AMD Phenom 9600 2,3Ghz - Nvidia 9500GT - Ram 8 Go - DD 500 Go) / Debian Stable XFCE

Hors ligne

#8 29-10-2021 10:10:09

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Jessie obsolète ?

Les données ne sont pas sur une partition séparée, c'est soit 4 mises à jour, soit une réinstallation à neuf.

La seconde option me paraît aussi la plus préférable - installer directement la 11 - en sauvegardant les données qui sont dans /home sur un support externe (clé usb ou disque dur).

Dans ce cas là, ne pas oublier de sauvegarder les dossiers et fichiers cachés qui contiennent les configurations, et qui commencent par un point. On peut les voir par exemple avec un ctrl+h, ou mieux en faisant :

ls -a



Cela dit, ce n'est pas non plus indispensable. Les configurations risquent d'être elles aussi obsolètes. Pour une utilisation occasionnelle, mieux vaut repartir de 0, en faisant une sauvegarde des données (qui sont dans /home), mais pas des fichiers cachés.

Ne pas oublier de prendre une version 32 bits de Debian 11 (et pas 64 bits).

Dernière modification par hybridemoineau (29-10-2021 10:11:41)

Hors ligne

#9 29-10-2021 11:24:53

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Jessie obsolète ?

Klod16 a écrit :

Par contre je ne comprends pas s’il faut passer de 8 à 9 puis 10 puis 11 ou directement installer 11



Les deux méthodes sont possibles.
Pour ma part je préfère la mise-à-jour (donc 8 → 9 → 10 → 11, il ne faut pas sauter de version) mais la réinstallation est aussi une option valable.


Jouer sous Debian ? Facile !

Hors ligne

#10 29-10-2021 12:19:20

zorzi
Membre
Lieu : Dijon
Distrib. : Debian Stable Xfce
Inscription : 30-09-2015

Re : Jessie obsolète ?

vv222 a écrit :

Klod16 a écrit :

Par contre je ne comprends pas s’il faut passer de 8 à 9 puis 10 puis 11 ou directement installer 11



Les deux méthodes sont possibles.
Pour ma part je préfère la mise-à-jour (donc 8 → 9 → 10 → 11, il ne faut pas sauter de version) mais la réinstallation est aussi une option valable.



Cela me paraît quand même assez fastidieux et usine à gaz de faire trois mises-à-niveau successives...

Ou à la limite mettre à jour vers Stretch (supportée jusqu'en 2022) dans un premier temps. Puis il avisera par la suite.

Dernière modification par zorzi (29-10-2021 12:23:11)


Desktop: HP Pavilion a6435 (AMD Phenom 9600 2,3Ghz - Nvidia 9500GT - Ram 8 Go - DD 500 Go) / Debian Stable XFCE

Hors ligne

#11 29-10-2021 15:07:51

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Jessie obsolète ?

Sauter des versions n’est pas pris en charge, donc c’est soit les trois mises-à-jour soit la réinstallation.

Il y a aussi en effet la possibilité de se contenter d’une ancienne version stable encore partiellement maintenue, mais je trouve que ce serait dommage de ne pas profiter de l’occasion pour mettre vraiment le système à jour.

Pour ma part je ne vois pas grand chose de fastidieux aux mises-à-jour, ça ne demande pas une grande implication (le gros du truc peut se faire sans aucune surveillance). Il y a un peu de lecture préalable, mais même ça c’est plutôt rapide ; il y a rarement d’opérations manuelles hors du commun à effectuer sur un passage d’une version stable à une autre.

Jouer sous Debian ? Facile !

Hors ligne

#12 29-10-2021 15:16:37

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Jessie obsolète ?

C'est vrai pour des utilisateurs un peu avertis, et avec une connexion internet rapide (qui ne se soucient pas trop d'écologie non plus, ça peut tourner autour de 6Go pour les MAJ successives).
Là, il faudrait changer le sources.list trois fois en le faisant pointer sur des archives, en espérant par exemple que la bascule sysvinit / systemd ne crée aucune surprise.

Dernière modification par hybridemoineau (29-10-2021 15:18:00)

Hors ligne

#13 29-10-2021 16:16:35

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

Merci pour tous ces éléments
En pratique quels sont les liens pour faire l’option 1 ou 2 (installation 11)
Faut il une clé bootable à chaque opération ?

Hors ligne

#14 29-10-2021 16:19:20

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

J’ai deux disques sur ma bécane dont un disque de sauvegarde de 1To
Est-ce que c’est possible de réinstaller à neuf sur le premier disque en débranchant le disque 2 puis le rebrancher ensuite ?

Hors ligne

#15 29-10-2021 18:08:13

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Jessie obsolète ?

La documentation pour la mise-à-jour :



La documentation pour une nouvelle installation (de Debian 11) : Manuel d'installation pour la distribution Debian GNU/Linux


Jouer sous Debian ? Facile !

Hors ligne

#16 29-10-2021 19:00:42

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Jessie obsolète ?

Le lien de téléchargement en une fois d'une Debian 11 assez complète pour un ordi de bureau avec xfce et avec le maximum de pilotes :

https://cdimage.debian.org/cdimage/unof … onfree.iso

Pour les autres possibilités, voir là :

https://www.debian.org/download

Le premier lien indiqué fait télécharger une iso, qu'il faut effectivement mettre sur une clé usb ou un dvd.

Pas la peine de débrancher les disques durs, sauf si on ne parvient vraiment pâs à les identifier. Il suffit de lancer l'installation sur le bon.

Dernière modification par hybridemoineau (29-10-2021 19:03:26)

Hors ligne

#17 29-10-2021 19:46:53

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

Un grand Merci pour tous ces éléments
Un des critères de choix sera l’aptitude de mon Pc en 32 bits à tenir et supporter les distributions plus lourdes.
J’avais choisi Jessie sur cette base.
Si vous avez des conseils là dessus je suis preneur
Je m’y mets mercredi

Dernière modification par Klod16 (30-10-2021 03:09:41)

Hors ligne

#18 30-10-2021 15:16:13

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Jessie obsolète ?

Si une Debian Jessie en 32-bit avec XFCE tournait bien sur ta machine, il y a de grandes chances que ce soit aussi le cas d’une Debian Bullseye en 32-bit avec XFCE. XFCE est un environnement dont le développement avance tout doucement, en contrepartie sa "prise de poids" est elle aussi plus lente que celle des environnements au développement plus dynamique.

Jouer sous Debian ? Facile !

Hors ligne

#19 30-10-2021 15:22:08

raleur
Membre
Inscription : 03-10-2014

Re : Jessie obsolète ?

S'il n'y avait que l'environnement de bureau... Mais le noyau, les navigateurs comme firefox et d'autres logiciels d'usage courant ont eux aussi pris beaucoup de poids.

Il vaut mieux montrer que raconter.

Hors ligne

#20 30-10-2021 16:53:39

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Jessie obsolète ?

Je ne m’inquiéterais pas trop au sujet du noyau et de la plupart des logiciels usuels.

Le navigateur Web par contre, que ce soit Firefox ou Chrome et ses mille variantes, c’est une véritable catastrophe au niveau de la consommation de ressources (entre autres). Malheureusement on n’a pas d’alternative valable permettant quand même d’accéder correctement à la plupart des "gros" sites Web.

Jouer sous Debian ? Facile !

Hors ligne

#21 31-10-2021 04:24:20

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

Merci. Après lecture de vos liens, je crois que je vais faire un essai vers stretch d’abord.
Ce que je crains le plus c’est de perdre l’usage de mes périphériques que j’ai eu déjà pas mal de mal à installer comme mon imprimante laser nb et mon vieux scanner sur cette distribution.


Px  : Il y a des sites qui ne marchaient déjà pas depuis longtemps sur Firefox comme le CESU qui fonctionnait sur chromium.
Ce qui me surprend le plus c’est ces réserves d’accès qui apparaissent et disparaissent comme infos.Gov y a trois jours.

Hors ligne

#22 03-11-2021 01:01:27

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

Bon, jusque là j'avance, j'ai passé toutes les étapes jusqu'à 4.3.1 de https://www.debian.org/releases/stretch … eparations
mais je bloque dans la compréhension du point suivant.
4.3.1. Ajouter des sources Internet à APT

---

Je suppose qu'il faut que je remplace tout ca dans sources.list  :


# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official Multi-architecture amd64/i386
NETINST #1 20160917-18:46]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.6.0 _Jessie_ - Official Multi-architecture amd64/i386
NETINST #1 20160917-18:46]/ jessie main

deb http://ftp.fr.debian.org/debian/ jessie main
deb-src http://ftp.fr.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main

par deb http://mirrors.kernel.org/debian stretch main contrib seulement
avant de lancer # apt-get dist-upgrade ???

Dernière modification par Klod16 (03-11-2021 01:02:45)

Hors ligne

#23 03-11-2021 01:14:09

hybridemoineau
Membre
Inscription : 21-02-2016

Re : Jessie obsolète ?

Le sources.list adéquat pour stretch est là :

https://wiki.debian.org/fr/LTS/Using

Hors ligne

#24 03-11-2021 07:35:46

Klod16
Membre
Distrib. : Debian
Noyau : Jessie
(G)UI : Xfce
Inscription : 27-10-2021

Re : Jessie obsolète ?

Un grand merci.
Ca progresse.
J'ai eu un problème de clé résolu avec https://debian-facile.org/viewtopic.php?id=14083
Décompactage OK
dist-upgrade en cours...
Choix de lightdm sans trop savoir si c'était l'interface graphique la plus light...
Fin sans trop de problème.
Redémarrage OK sous Xfce 4.12

Dernière modification par Klod16 (03-11-2021 09:12:00)

Hors ligne

#25 03-11-2021 11:34:26

jarek
Membre
Lieu : Haute Loire
Distrib. : testing
Noyau : linux 5.14.0-2
(G)UI : xfce4 - lightdm
Inscription : 24-06-2014

Re : Jessie obsolète ?

Klod16 a écrit :

Choix de lightdm sans trop savoir si c'était l'interface graphique la plus light...


L'nterface graphique c'est XFCE, lightdm est un gestionnaire de connexion (et d'autres choses . . .).

A mon avis ce n'est pas une bonne idée d'utiliser des vieux OS, sauf pour des usages particuliers.
J'ai installé il y a peu sur un Acer de plus de quinze ans Bullseye LXQt, le fonctionnement est satisfaisant au premier démarrage.


Définitivement pour ce qui est contre et contre ce qui est pour.
Ryzen3 3200G - Asrock B450

Hors ligne

Pied de page des forums