Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-11-2021 15:13:02

gg97469
Membre
Inscription : 02-11-2021

[Résolu] Downgrader version ntfs-3g

Bonjour,

J'ai installé ntfs-3g sur mon raspbian pour pouvoir gérer un disque dur externe formaté en ntfs entre mon windows et mon raspberry. Seulement la dernière version semble poser des problème de lecture et d'écriture et, après recherche, la seule solution serait de downgrader de version ntfs-3g pour utiliser la version 2012 ou 2014.

Je n'ai aucune idée de comment faire ça, j'ai dl une version sur le site de tuxeira mais je ne sais pas du tout comment l'installer...

Pourriez vous m'éclairer svp ?

merci

Dernière modification par gg97469 (02-11-2021 19:57:13)

Hors ligne

#2 02-11-2021 15:38:27

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Downgrader version ntfs-3g

Hello,

Si tu as téléchargé un .deb qui te convient alors voici comment l'installer en local :

dpkg -i /chemin/complet/du/fichier/.deb


Ou pour gérer les dépendances :

apt install ./nom_du_fichier_.deb


en se plaçant avant dans le répertoire où se trouve le fichier .deb.

Nota : ce n'est jamais très bon de "downgrader" un paquet.
Pose-toi la question si c'est vraiment nécessaire wink

Edit:
Avant toutes opérations, il faut désinstaller le paquet ntfs-3g :

apt remove --purge ntfs-3g

Dernière modification par Tawal (02-11-2021 15:40:00)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#3 02-11-2021 15:51:56

gg97469
Membre
Inscription : 02-11-2021

Re : [Résolu] Downgrader version ntfs-3g

Bonjour Tawal,

Merci de ton retour.

Je suis sur qu'il y a un truc que je ne fais pas comme il faut mais j'obtiens ça :

@raspberrypi:~ $ sudo dpkg -i /home/pi/Téléchargements/tufs-tuxera_ntfs-2012.4.17.tar.bz2
dpkg-deb: erreur: '/home/pi/Téléchargements/tufs-tuxera_ntfs-2012.4.17.tar.bz2' is not a Debian format archive
dpkg: erreur de traitement de l'archive /home/pi/Téléchargements/tufs-tuxera_ntfs-2012.4.17.tar.bz2 (--install) :
 dpkg-deb --control subprocess returned error exit status 2
Des erreurs ont été rencontrées pendant l'exécution :
 /home/pi/Téléchargements/tufs-tuxera_ntfs-2012.4.17.tar.bz2



Désolé je suis un newbie, ça doit pas être si compliqué pourtant hmm

merci

Dernière modification par gg97469 (02-11-2021 15:52:06)

Hors ligne

#4 02-11-2021 16:16:47

gg97469
Membre
Inscription : 02-11-2021

Re : [Résolu] Downgrader version ntfs-3g

Re bonjour,

Bon, je ne suis pas sur d'avoir pris la bonne version. En regardant le fichier ABOUT.txt, ça parle de MacFuse... Je ne suis pas sur que ce soit adapté du coup..

Mais comment faire pour downgrader ma version de ntfs-3g ? En fait j'ai une erreur d'entrée/sortie quand je copie un fichier sur mon SSD et c'est apparemment un pb connu sur la dernière version et tout le monde recommande le downgrade mais personne ne dit comment faire (ça doit être tellement simple big_smile)

Une idée ?

Merci

Hors ligne

#5 02-11-2021 18:49:35

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Downgrader version ntfs-3g

Un lien pour les versions ntfs-3g officielles :
https://packages.debian.org/search?lang … ds=ntfs-3g
Essaie d'abord avec la version pour Buster.
Mais avant désinstalle la version que tu as :

apt remove  --autoremove --purge ntfs-3g


Puis installe le paquet .deb téléchargé comme je te l'indique dans mon message précédent wink
Si la version pour Buster n'est pas mieux alors tente avec la version pour Stretch.


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#6 02-11-2021 19:09:48

gg97469
Membre
Inscription : 02-11-2021

Re : [Résolu] Downgrader version ntfs-3g

Merci pour les réponses.

Alors, j'obtiens les erreurs suivantes au moment de l'installation du .deb

Sélection du paquet ntfs-3g précédemment désélectionné.
(Lecture de la base de données... 169967 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../ntfs-3g_2016.2.22AR.1+dfsg-1+deb9u1_armhf.deb ...
Dépaquetage de ntfs-3g (1:2016.2.22AR.1+dfsg-1+deb9u1) ...
dpkg: des problèmes de dépendances empêchent la configuration de ntfs-3g :
 ntfs-3g dépend de libntfs-3g871 (= 1:2016.2.22AR.1+dfsg-1+deb9u1) ; cependant :
  Le paquet libntfs-3g871 n'est pas installé.

dpkg: erreur de traitement du paquet ntfs-3g (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour initramfs-tools (0.133+deb10u1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 ntfs-3g
 



Et j'ai bien lancé la commande de purge avant installation.

Hors ligne

#7 02-11-2021 19:15:29

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Downgrader version ntfs-3g

Oui c'est le problème quand on veut "downgrader" un paquet : les dépendances !
En fait, il te faut aussi installer le paquet libntfs-3g871 mais il n'est disponible que pour la version Stretch.
https://packages.debian.org/stretch/libntfs-3g871
Télécharge ce paquet avec le lien que je viens de donner et essaie d'installer d'abord ce paquet puis si ça passe sans erreur retente l'installation de ntfs-3g version old.

Dernière modification par Tawal (02-11-2021 19:16:16)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#8 02-11-2021 19:57:32

gg97469
Membre
Inscription : 02-11-2021

Re : [Résolu] Downgrader version ntfs-3g

Ça fonctionne, merci beaucoup !

Hors ligne

#9 02-11-2021 20:06:18

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Downgrader version ntfs-3g

Ça va 1 seule dépendance à gérer, c'est pas la mer à boire non plus.
Mais il faut rester vigilant, car ce "downgrade" pourrait impacter d'autres applications.

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

Pied de page des forums