Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-11-2021 06:08:50

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Mate
Inscription : 05-07-2020

[résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Titre: Comment écouter un CD ripé en .wma, mixé et sans micro coupure ?


Bonjour,

À l'époque où j'étais sous Windows, j'avais ripé tous mes CDs avec Windows Média Player. J'en ai un sacré paquet.

Quand je suis passé à Linux avec Debian 7 en 2014, j'ai voulu écouter mes CDs qui sont pour la plupart mixés. Mais il y avait un défaut car à chaque fois que ça passait sur la plage suivante, une micro coupure intervenait, ce qui était très agaçant pour un mix.
J'avais tout essayé à l'époque et puis j'ai abandonné.
J'ai été super déçu et j'ai mis mes mix de côté pour continuer de profiter de Debian car je ne voulais plus être avec Windows.

J'avais jusqu'à maintenant, pris pour habitude d'écouter de la musique avec VLC qui faisait très bien le boulot et n'était pas envahissant.
En testant la distrib Manjaro, je découvre le logiciel Audacious qui est mis dessus. Et en testant un mix tout à fait par hasard, je remarque que la micro coupure est beaucoup plus légère qu'autrefois (moins longue). Donc qu'il y eu de l'amélioration. Cependant il y a toujours une coupure.

Jme demande si ce problème de micro-coupure ne pourrait pas être résolue de nos jours.

Si vous avez des infos...

Dernière modification par totoZero7 (12-11-2021 01:21:07)

Hors ligne

#2 06-11-2021 13:52:33

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Tout dépend de la cause du silence : enregistrée dans les pistes lors du rippage ou du montage des pistes mixées (ça pouvait être demandé par défaut dans certains logiciels), ou provoquée par le saut de pistes.

Ca peut se vérifier en ouvrant les pistes avec Audacity. On peut y voir s'il y a des silences dans les morceaux.

Tu n'as pas dit si tu passais encore par les cds pour l'écoute, ou par une iso, ou par d'autres formats de fichier. Si je comprends bien, c'est une suite de fichiers .wma. Si les silences ne sont pas dans les pistes, en mettant les fichiers sur un disque dur, ils devraient disparaître (plus de latence ou souci mécanique du lecteur cd).

Tu peux aussi essayer d'autres lecteurs audio : mpv, mplayer ou moc par exemple.

Hors ligne

#3 06-11-2021 18:35:46

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Hello
d’après mes test avec mpv , vlc ou SMplayer il y a toujours une coupure
J'ai tenté d'augmenter la taille du cache sur SMplayer mais rien n'y fait
Le logiciel qui s'en sort le mieux est encore vlc mais c'est pas encore top

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#4 06-11-2021 20:15:50

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

La solution que j'ai trouvé c'est coller les fichiers dans le bon ordre et créer un fichier cue qui contiendra l'index , du coup pas d'interruption
Il suffit de lancer d'ouvrir le fichier.cue avec vlc ou mpv
en appuyant sur le bouton suivant le lecteur passera au morceau suivant et affichera le titre en cours de lecture
J'ai fais un test rapide avec ffmpeg

ffmpeg -f concat -i list.txt -c copy output.mp3


mon fichier list.txt contient le nom des fichiers a copier (test sur 2)

cat list.txt


file 'part1.mp3'
file 'part2.mp3'



Par contre il y a peut être une méthode pour créer le fichier cue dans la foulé

Dernière modification par Croutons (06-11-2021 20:16:26)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#5 08-11-2021 23:11:18

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Mate
Inscription : 05-07-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

hybridemoineau a écrit :

Tout dépend de la cause du silence : enregistrée dans les pistes lors du rippage ou du montage des pistes mixées (ça pouvait être demandé par défaut dans certains logiciels), ou provoquée par le saut de pistes.


C'était des disques CDs mixés du commerce, avec index pour se déplacer entres les pistes. Il n'y avait aucun trou.
Je les ai tous rippé avec le même logiciel, celui par défaut de Windows, ça devait être média player. Donc tous les CDs ont été rippé en wma (j'étais teubé à l'époque)
Je les ai tous écouté, plein de fois, sur divers disques dur (avec Windows) sans problème.
C'est seulement quand je suis passé à Linux que la coupure est apparue.

Ca peut se vérifier en ouvrant les pistes avec Audacity. On peut y voir s'il y a des silences dans les morceaux.


je l'ai installé et je n'ai rien vu d'apparent

Tu n'as pas dit si tu passais encore par les cds pour l'écoute, ou par une iso, ou par d'autres formats de fichier. Si je comprends bien, c'est une suite de fichiers .wma. Si les silences ne sont pas dans les pistes, en mettant les fichiers sur un disque dur, ils devraient disparaître (plus de latence ou souci mécanique du lecteur cd).


J'écoute tout depuis un disque dur. Depuis l'époque Windows.
Je n'ai plus les CD d'origine, snif.
Pour les autres formats que j'écoute, ce sont des mp3 de mixes mais en 1 seule piste. Frustré, je me suis mis à télécharger d'autres mixes tout fait en 1 seule piste pour ne plus avoir ce problème.
J'avais testé tous les logiciels dispo à l'époque (sur Linux) et là c'est en testant Audicious que j'observe une très fine coupure comparé aux autres. C'est vrainement infime mais ça marque tout de meme la transition de plage.
Oui j'avais testé mpv, mplayer  (pas moc)  et tous avaient la coupure aussi.

VLC a une sacrée coupure prononcée comparé à Audacious


J'ai essayé ton truc avec wma Croutons mais ça n'a rien donné.


Je me demande si c'est pas un truc de vicieux de microsoft que d'avoir mis un truc qui retarderait ou serait mal détécté.

Dernière modification par totoZero7 (08-11-2021 23:13:09)

Hors ligne

#6 09-11-2021 01:00:11

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

[Fatigue, je parle de mp3, c'est du wma, donc fausse piste, mais le dernier post de ce lien oriente vers le même genre de problème avec les wma encodés il y a longtemps, que je ne comprends pas plus :
https://hydrogenaud.io/index.php?topic=80120.0 ]

Alors, ça semble être une limitation technique du format mp3, rien moins que ça...Il doit y avoir un blanc à l'entrée et à la sortie de chaque piste.

https://lame.sourceforge.io/tech-FAQ.txt

Voir cette page de forum, dernier post.

https://forum.audacityteam.org/viewtopic.php?t=71612

Il semble aussi que la version 4 à venir de vlc corrige cette limitation (faire une recherche avec "vlc gapless").

Ca expliquerait pourquoi les audiophiles passent, encore maintenant alors que les cds sont un souvenir, par une image iso+cue (bien que ni flac ni ape ne posent ce genre de problème, d'après mon expérience). Ou alors, une seule piste mp3, mais ça fait autour de 15 ans que je n'ai pas vu ça.

Dernière modification par hybridemoineau (09-11-2021 01:09:07)

Hors ligne

#7 09-11-2021 02:09:37

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Mate
Inscription : 05-07-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

je n'ai malheureusement pas de Windows pour tester à nouveau mais du coup, comment se fait t'il que (dans mon souvenir) il n' y a aucun blanc sur Windows et il y en a sur Linux ?

Je me souviens que j'utilisais foobar2000 comme player après Windows Media Player. Et je n'ai aucun souvenir de coupure.
Supposons qu'il y ait un blanc comme dans la docu que tu montres, cela veut dire que Windows (ou son logiciel) l'a pris en compte pour que le son soit nickel en sortie (foobar2000 aussi).

Je me demande si d'autres ont eu cette expérience.
Résultat des courses, le mp3 c'est du caca dans toutes ces dimensions big_smile

Hors ligne

#8 09-11-2021 09:44:45

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Je confirme j'ai effectué des tests sur un titre que j'ai scindé en 2 il y a bien une coupure quand j'écoute les 2 d'affilé
j'ai effectué un recollage des 2 parties et la plus de coupure , donc c'est bien au niveau des logiciels, j'ai bien essayé quelque réglage de mémoire tampon mais cela ne change rien

edit: bon d'apres mes recherches il te faut un lecteur qui soit estanpillé gapless, on a pas mal de résultat sur un moteur de recherche (lecteur gapless sous linux)
j'ai pas encore eu le temps de testé mais cela parait prometteur
genre on en parle ici
http://linuxmao.org/Aqualung
comme il y a pléthore de lecteur audio qui se targue de cet fonction gapless c'est a tester savoir qui dit vrai

Dernière modification par Croutons (09-11-2021 10:06:54)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#9 09-11-2021 10:14:37

hybridemoineau
Membre
Inscription : 21-02-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Gapless est sans doute une fonction de correction des défauts de structure des mp3 ou des anciens wma (tout comme vlc saute automatiquement le début des dvd et leurs annonces légales, ce qui n'empêche pas qu'elles y soient).

Hors ligne

#10 09-11-2021 14:24:00

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.14.12-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Bonjour,

une idée comme une autre, fader tes pistes avec ffmpeg ?

Hors ligne

#11 09-11-2021 20:49:44

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Mate
Inscription : 05-07-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

golgot200 a écrit :

une idée comme une autre, fader tes pistes avec ffmpeg ?


Ce que Croutons avait proposé plus haut ?
Déjà j'ai galéré à juste créer un seul fichier list pour un seul CD, avec les noms dedans. Tout fait à la main. (j'me vois mal faire ça sur ~400CD
Ensuite quand j'ai essayé la commande, ça n'a pas fonctionné. J'avais essayé en sortie mp3 ou wma.
J'ai noté le même constat sur un album que j'ai aussi en mp3. Cela voudrait dire convertir chaque nouvel album...

En même temps, si windows peut le faire, linux le peut tongue

Hors ligne

#12 10-11-2021 06:53:11

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.14.12-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Bonjour,

Peut-être un problème de ce style et un réglage à faire au niveau du player. ( plus en bas de page )
Je n'ai aucun problème de ce style chez moi sous Arch hmm

https://github.com/clementine-player/Cl … ssues/4748

Avec ton fichier list pour ce seul CD, ça passe ?

Dernière modification par golgot200 (10-11-2021 06:55:32)

Hors ligne

#13 10-11-2021 09:41:08

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

totoZero7 a écrit :

Ensuite quand j'ai essayé la commande, ça n'a pas fonctionné


ça aide pas vraiment comme retour , la commande fonctionne
j'ai testé : couper un titre en deux , puis recoller avec ffmpeg , résultat aucun silence entre les 2 pistes recollé
après si il y a plein de fichier a traité les listes pourront se faire avec un script c'est pas le problème
le truc c'est de faire le test sur 2 fichiers , si il y a toujours un silence c'est que le silence existe sur les fichiers d'origine
edit: correctionné  lol

Dernière modification par Croutons (10-11-2021 13:14:04)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#14 10-11-2021 11:35:39

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.14.12-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Croutons a écrit :

golgot200 a écrit :

Ensuite quand j'ai essayé la commande, ça n'a pas fonctionné



C'est pas golgot200 qui a essayer wink

Hors ligne

#15 10-11-2021 18:46:20

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Mate
Inscription : 05-07-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Test sur 2 morceaux. Fichier list.txt mis dans le même répertoire

cat list.txt


file '01 Intro.wma'
file '02 Bisou Sucré.wma'




ffmpeg -f concat -i list.txt -c copy output.mp3


ffmpeg version 4.3.3-0+deb11u1 Copyright (c) 2000-2021 the FFmpeg developers
  built with gcc 10 (Debian 10.2.1-6)
  configuration: --prefix=/usr --extra-version=0+deb11u1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-avresample --disable-filter=resample --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libdav1d --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librabbitmq --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-omx --enable-openal --enable-opencl --enable-opengl --enable-sdl2 --enable-pocketsphinx --enable-libmfx --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared
  libavutil      56. 51.100 / 56. 51.100
  libavcodec     58. 91.100 / 58. 91.100
  libavformat    58. 45.100 / 58. 45.100
  libavdevice    58. 10.100 / 58. 10.100
  libavfilter     7. 85.100 /  7. 85.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  7.100 /  5.  7.100
  libswresample   3.  7.100 /  3.  7.100
  libpostproc    55.  7.100 / 55.  7.100
[concat @ 0x557e7dc1d280] Unsafe file name '01 Intro.wma'
list.txt: Operation not permitted
 




Sinon j'ai trouvé un remède avec Audacious!

Sortie > Paramètres du son...
Dans la nouvelle fenêtre choisir "Greffons"
    Onglet "Effets"
        Cocher la case "Suppressions des silences"

Résultat, il n'y a plus de micro-coupure. En revanche il y a une très fine accélération entres les pistes collés. C'est vraiment très fin et je ne le distingue pas sur toutes les transitions. Si je ne ne fais pas attention, je remarque rien. Il faut vraiment avoir l'oreille pour l'entendre.
Je dirais que je vais m'en contenter XD. Je suis même content d'avoir trouvé cela. Je vais écouter des vieux trucs !

Par contre il y a un défaut sur ce logiciel (qu'on peut peut-être corriger en réglant un paramètre ? ). C'est quand on pousse la barre de progression un peu plus loin dans le morceau assez rapidement, cela saute directement sur le morceau suivant. (ça c'est chiant)

Hors ligne

#16 19-11-2021 12:47:00

manon
Membre
Inscription : 21-05-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Un CD mixé ne doit contenir aucune micro-coupure (principe même du mix comme tu dis, sinon c'est agaçant).
Pour qu'il soit lu correctement, il faut un lecteur multimédia avec la fonctionnalité gapless.
Audacious a cette fonctionnalité qui est native, aucun réglage nécessaire à faire.
Du coup si ton CD est mal lu, il faut plutôt soupçonné le rippage qui a mal été fait par le logiciel de Windows.

J'ai des CD mixés (rippés via Asunder, via Freac), des CD mixés achetés dans le commerce, des flacs mixés, des m4a mixés, et je ne rencontre aucun soucis avec Audacious, il lit parfaitement les pistes sans la moindre coupure du début à la fin du CD.

Pour le "soucis" avec la barre de progression sur Audacious, cela vient de toi, je n'ai aucun soucis du genre, et pourtant je m'en sers énormément.

Audacious n'a pas vraiment besoin d'être réglé une fois installé, il est bien paramétré tel quel.
Mais il peut aussi être réglé pour assurer un bit-perfect optimal, communiquer directement avec les DAC, etc, etc, il est très flexible, selon l'utilisation (normale ou poussée) que l'on attend d'un lecteur audio, pour ma part, c'est le meilleur que j'ai trouvé wink

Hors ligne

#17 19-11-2021 15:09:28

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

manon a écrit :

je ne rencontre aucun soucis avec Audacious, il lit parfaitement les pistes sans la moindre coupure du début à la fin du CD.


Pas le cas chez moi :-( y'a toujours une microcupure


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#18 19-11-2021 18:35:09

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Mate
Inscription : 05-07-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

manon a écrit :

Du coup si ton CD est mal lu, il faut plutôt soupçonné le rippage qui a mal été fait par le logiciel de Windows.


C'est possible que cela soit cette cochonnerie de Windows qui a crée le problème. Cependant, j'arrivais à lire correctement les mixes quand j'étais sur Windows, que ce soit avec Windows média player ou foobar2000. C'est des coquins chez microsoft, donc c'est carrément possible qu'ils aientt pu faire un truc pour casser les roupettes des autres. C'est leur ligne de conduite après tout.

Cela dit, comme je l'ai dit au dessus, j'ai découvert le greffon 'Effets' et la case "Suppressions des silences" qui résoud le problème.

Pour le "soucis" avec la barre de progression sur Audacious, cela vient de toi, je n'ai aucun soucis du genre, et pourtant je m'en sers énormément.


Oui je suis un magicien voudou... Sinon as-tu essayé de faire cela avec un format en .wma ? Car c'est avec ce format que cela pose problème chez moi, pas avec les autres formats, de ce que j'observe. C'est peut-etre le format wma qui est juste chiant partout en fait.

Hors ligne

#19 19-11-2021 18:53:38

enicar
Membre
Lieu : ailleurs
Distrib. : sid
Noyau : Linux 5.13.10
(G)UI : openbox
Inscription : 26-08-2010

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

totoZero7 a écrit :

C'est peut-etre le format wma qui est juste chiant partout en fait.


Hum, il me semble que les wma soient décodés avec la libavcodec pour être lus. C'est possible
que ce décodage ne soit pas aussi rapide qu'avec la libmpeg123, la libmp3lame ou la libvorbis qui sont utilisés pour
les mp3 et les ogg, respectivement (par exemple)

Mais je suis pas du tout sûr de ce que j'avance…

Hors ligne

#20 19-11-2021 21:58:26

manon
Membre
Inscription : 21-05-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

j'ai essayé avec du wma, et je n'ai pas ce soucis de barre de progression que tu décris, je fais avancer rapidement la barre jusqu'à quasiment la fin de la piste, et ça reste bien sur la piste actuellement en cours..

Pour les micro-coupures entre les morceaux, je viens de tester et je confirme que chez moi aucune micro-coupure.
Mais par curiosité, je viens de tester sur une Debian Xfce Live, et en effet là il y a une micro-coupure d'à peine un quart de secondes.
J'en déduis que pulseaudio (en tant que serveur de son) doit créer une petite latence au moment du changement de piste, le temps de mixer et de faire sa tambouille !?

Après perso sur Audacious je n'ai fais aucun réglage de ce qui est effet, replaygain, equalizer, il faut essayer avec d'autres formats que le wma, pour voir si le problème persiste.

Dernière modification par manon (19-11-2021 22:06:23)

Hors ligne

#21 20-11-2021 08:42:14

golgot200
Membre
Distrib. : Archlinux 2018-02-03
Noyau : 5.14.12-arch1-1
(G)UI : Mate (Strict Minimum)
Inscription : 05-08-2007

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Bonjour,

passes un de tes wma en wav ( bon tu n'auras plus de tags ) mais juste pour voir si cette micro coupure persiste.
Si cette micro coupure persiste, ce serait alors  tes fichiers eux même qui  auraient du mal .

Dernière modification par golgot200 (20-11-2021 08:43:54)

Hors ligne

#22 20-11-2021 11:32:23

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

totoZero7 a écrit :

Sinon j'ai trouvé un remède avec Audacious!

Sortie > Paramètres du son...
Dans la nouvelle fenêtre choisir "Greffons"
    Onglet "Effets"
        Cocher la case "Suppressions des silences"

Résultat, il n'y a plus de micro-coupure.



Ça laisse penser qu’il y a un court silence intégré à chaque fichier audio (ajouté lors de l’encodage initial de ceux-ci), que Audacious te permet de supprimer.


Jouer sous Debian ? Facile !

Hors ligne

#23 20-11-2021 12:42:29

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Hello,

Je suis de ton avis vv222.
Et donc avec un fondu enchaîné de recouvrement 0s et aucune variation de gain, on devrait entendre ce court silence.

Edit:
Ce qui n'explique pas pourquoi ces mêmes fichiers étaient lus sans coupure. (traitement spécial du lecteur windows ?)

Dernière modification par Tawal (20-11-2021 12:44:08)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#24 20-11-2021 14:28:44

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.10 (amd64)
(G)UI : Openbox
Inscription : 18-11-2013
Site Web

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

Possible oui que certains lecteurs détectent et passent automatiquement les silences en fin de piste. Surtout si c’est un souci d’encodage fréquent avec le format .wma.

Jouer sous Debian ? Facile !

Hors ligne

#25 20-11-2021 16:33:52

totoZero7
Membre
Distrib. : Debian 11 bullseye
Noyau : Linux 5.10.0-8-amd64
(G)UI : Mate
Inscription : 05-07-2020

Re : [résolu] Comment écouter un CD ripé en .wma, mixé et sans coupure ?

J'ai essayé de convertir en wav comme la suggéré golgot200 est je n'ai trouvé aucune différence.
J'ai ensuite ré-sssayé de voir les fichiers avec Audacity et en zoomant à mort au début de chaque piste, il y un blanc de 0.093s précis sur chaque piste.
Donc le rippage a ajouté ce blanc.

Pour le mystère du saut de track quand j'avance rapidement vers la fin de la piste, ne serait-ce pas un lien avec la mise en tampon qui ne se ferait pas correctement avec ce format ? OU ce fichier qui a été rippé à une certaine date de l'histoire de windows et qui aurait une malformation qui serait du coup mal interprété ?.. Je n'y connais rien dans tout ça, je ne fais que balancer une idée en l'air car il y a bel et bien un problème. Cela ne se manifeste pas systématiquement, mais presque.

Croutons a écrit :


Pas le cas chez moi :-( y'a toujours une microcupure


Tu as essayé le greffon ?
car avec lui, les miennes ont disparurent à 99%

Hors ligne

Pied de page des forums