Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-11-2021 20:59:12

Pyroxene
Membre
Inscription : 10-10-2021

[Résolu] Problème de dépendances pour PHP

Bonjour,

J'ai un raspberry pi 3B+ qui me sert de serveur web. Il tourne sous Raspbian Buster. J'ai l'impression que mon disque est assez régulièrement corrompu, parce que j'ai déjà eu souvent des problèmes de noyau corrompu rendant impossible le reboot.

C'est d'ailleurs après le reboot que je me suis aperçu d'un problème de PHP qui ne fonctionnait plus. J'ai alors tenté de mettre à jour mon système, mais maintenant je me retrouve avec un gestionnaire de paquets bloqué sur un problème de dépendances.

J'ai essayé pas mal de commandes mais rien n'y fait. Quelqu'un aurait-il une solution ?

sudo apt update


Atteint :1 http://archive.raspberrypi.org/debian buster InRelease
Atteint :2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
14 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.



sudo apt full-upgrade


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 php7.3-cli : Dépend: php7.3-common (= 7.3.31-1~deb10u1) mais 7.3.29-1~deb10u1 est installé
 php7.3-fpm : Dépend: php7.3-common (= 7.3.31-1~deb10u1) mais 7.3.29-1~deb10u1 est installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).



sudo apt --fix-broken install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  php7.3-bcmath php7.3-common php7.3-curl php7.3-gd php7.3-gmp php7.3-imap php7.3-intl php7.3-json php7.3-mbstring php7.3-mysql php7.3-opcache php7.3-readline php7.3-xml php7.3-zip
Les paquets suivants seront mis à jour :
  php7.3-bcmath php7.3-common php7.3-curl php7.3-gd php7.3-gmp php7.3-imap php7.3-intl php7.3-json php7.3-mbstring php7.3-mysql php7.3-opcache php7.3-readline php7.3-xml php7.3-zip
14 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/1589 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 49669 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../00-php7.3-zip_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-zip (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/00-php7.3-zip_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
Préparation du dépaquetage de .../01-php7.3-xml_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-xml (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/01-php7.3-xml_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
Préparation du dépaquetage de .../02-php7.3-readline_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-readline (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/02-php7.3-readline_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
Préparation du dépaquetage de .../03-php7.3-opcache_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-opcache (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/03-php7.3-opcache_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
Préparation du dépaquetage de .../04-php7.3-mysql_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-mysql (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/04-php7.3-mysql_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
Préparation du dépaquetage de .../05-php7.3-mbstring_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-mbstring (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/05-php7.3-mbstring_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
Préparation du dépaquetage de .../06-php7.3-json_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-json (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/06-php7.3-json_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
Préparation du dépaquetage de .../07-php7.3-intl_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-intl (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/07-php7.3-intl_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
Préparation du dépaquetage de .../08-php7.3-imap_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-imap (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/08-php7.3-imap_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
Préparation du dépaquetage de .../09-php7.3-gmp_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-gmp (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/09-php7.3-gmp_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
Préparation du dépaquetage de .../10-php7.3-gd_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-gd (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/10-php7.3-gd_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gmp 7.3.29-1~deb10u1
Préparation du dépaquetage de .../11-php7.3-curl_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-curl (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/11-php7.3-curl_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
Préparation du dépaquetage de .../12-php7.3-bcmath_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-bcmath (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/12-php7.3-bcmath_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
Préparation du dépaquetage de .../13-php7.3-common_7.3.31-1~deb10u1_armhf.deb ...
Dépaquetage de php7.3-common (7.3.31-1~deb10u1) sur (7.3.29-1~deb10u1) ...
dpkg: erreur de traitement de l'archive /tmp/apt-dpkg-install-p2ErtA/13-php7.3-common_7.3.31-1~deb10u1_armhf.deb (--unpack) :
 tentative de remplacement de « /usr/lib/php/20180731 », qui appartient aussi au paquet php7.3-gd 7.3.29-1~deb10u1
dpkg-deb: erreur: coller subprocess was killed by signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /tmp/apt-dpkg-install-p2ErtA/00-php7.3-zip_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/01-php7.3-xml_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/02-php7.3-readline_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/03-php7.3-opcache_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/04-php7.3-mysql_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/05-php7.3-mbstring_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/06-php7.3-json_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/07-php7.3-intl_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/08-php7.3-imap_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/09-php7.3-gmp_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/10-php7.3-gd_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/11-php7.3-curl_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/12-php7.3-bcmath_7.3.31-1~deb10u1_armhf.deb
 /tmp/apt-dpkg-install-p2ErtA/13-php7.3-common_7.3.31-1~deb10u1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



sudo dpkg --configure -a


dpkg: des problèmes de dépendances empêchent le traitement des actions différées pour php7.3-fpm :
 php7.3-fpm dépend de php7.3-common (= 7.3.31-1~deb10u1) ; cependant :
  La version de php7.3-common sur le système est 7.3.29-1~deb10u1.

dpkg: erreur de traitement du paquet php7.3-fpm (--configure) :
 problèmes de dépendances - actions différées non exécutées
Des erreurs ont été rencontrées pendant l'exécution :
 php7.3-fpm

Dernière modification par Pyroxene (07-11-2021 00:19:06)

Hors ligne

#2 07-11-2021 00:18:43

Pyroxene
Membre
Inscription : 10-10-2021

Re : [Résolu] Problème de dépendances pour PHP

Finalement, j'ai réussi à réinstaller PHP en supprimant manuellement la paquet coupable (php7.3-common). Pour cela j'ai utilisé la méthode radicale décrite sur ce site https://blog.seboss666.info/2016/08/sup … e-de-dpkg/. Ce n'était vraiment pas simple et c'était fastidieux, mais cela m'a sauvé ! J'espère que cela pourra dépanner des gens si un jour leur dpkg ne veut plus rien entendre.

Hors ligne

Pied de page des forums