Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-11-2021 15:45:32

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

[Résolu] Problème de migration vers Debian 11

Bonjour smile .

Dans le cadre d'une migration vers Debian 11 sur une nouvelle machine, le logiciel Candel (anciennement grblControl) que j'utilise sans problème sur une Debian 9 ne veut pas démarrer sur la nouvelle distribution.

Ce n'est pas un paquet Debian, et son installation consiste simplement à décompresser l'archive candle_1.1.7.tar.gz dans un dossier quelconque. Pour démarrer, il suffit de cliquer sur l'exécutable Candel, ce qui fonctionne très bien sous Debian 9  mais pas sous Debian 11.

Le site indique que les exigences suivantes doivent être satisfaites :

System requirements for running "Candle":
    Windows/Linux x86 >>>>>>>>>>>>>>>>>>>>>>>>> OK
    CPU with SSE2 instruction set support >>>>>>>>>>> ?
    Graphics card with OpenGL 2.0 support >>>>>>>>>> OK
    120 MB free storage space >>>>>>>>>>>>>>>>>>>> OK

Build requirements:
Qt 5.4.2 with MinGW/GCC compiler>>>>>>>>>>>>>>> Qt 5.15.2 et gcc-mingw-w64 10.2.1 installés

Donc, dans un premier temps, les problèmes potentiels sont :
  - CPU with SSE2 instruction set support : comment trouver ce renseignement ?
  - est-ce qu'il faut installer Qt 5.4.2 et est-ce possible sans toucher à Qt 5.15.2 qui est la version actuellement installée ?

De plus, quand je dis que Qt 5.15.2 est installé, je ne suis pas sûr-sûr, parce-que en regardant sur Synaptic, tous les modules de la forme qt5-* version 5.15.2 ne sont pas forcément installés et je ne sais pas lequel doit être installé pour affirmer que Qt 5.15.2 est installé.

Quelqu'un peut-il m'aider ?

D'avance merci,
amicalement,
naute

Dernière modification par naute (17-11-2021 11:17:06)

Hors ligne

#2 09-11-2021 16:25:15

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonjour
pour le SSE2 normalement tous les processeurs le prennent en charge
un lscpu peu le confirmer


lscpu
 


par exemple pour mon cpu amd FX8320E


Drapeaux :                              fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2
                                            ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_
                                            apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 popcnt aes xsave avx f16c lah
                                            f_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt
                                             lwp fma4 tce nodeid_msr tbm topoext perfctr_core perfctr_nb cpb hw_pstate ssbd vmmcall bmi1 arat
                                            npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
 



idem pour intel (le sse2 a été mit dans les cpu dans les années 2000 pour intel)

pour le reste j'ai pas la réponse (version qt5 et gcc 10)
un


apt policy gcc
 



pour stable c'est une version 10 il me semble (sid est en version 11)

Hors ligne

#3 09-11-2021 19:17:36

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Merci pour ta réponse yes.gif .

Voilà ce que donne lscpu chez moi (Intel(R) Celeron(R) CPU G1820) :

Drapeaux :                              fpu vme de pse tsc msr pae mce cx8 apic
                                        sep mtrr pge mca cmov pat pse36 clflush
                                        dts acpi mmx fxsr sse sse2 ss ht tm pbe
                                        syscall nx pdpe1gb rdtscp lm constant_ts
                                        c arch_perfmon pebs bts rep_good nopl xt
                                        opology nonstop_tsc cpuid aperfmperf pni
                                         pclmulqdq dtes64 monitor ds_cpl vmx est
                                         tm2 ssse3 sdbg cx16 xtpr pdcm pcid sse4
                                        _1 sse4_2 movbe popcnt xsave rdrand lahf
                                        _lm abm cpuid_fault epb invpcid_single p
                                        ti tpr_shadow vnmi flexpriority ept vpid
                                         ept_ad fsgsbase tsc_adjust erms invpcid
 


Le drapeau sse2 est présent et donc à ce niveau-là, à priori pas de problème !

Maintenant, il faudrait savoir s'il existe une commande permettant de connaître la version de Qt5 installée, savoir si on peut faire cohabiter deux versions différentes de Qt5, et si oui, comment installer une ancienne version.

On avance smile .

Amicalement,
naute

Dernière modification par naute (09-11-2021 19:19:35)

Hors ligne

#4 09-11-2021 19:41:24

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonjour
Lance l'éxécutable dans le terminal pour voir s'il retourne un message d'erreur.

Hors ligne

#5 09-11-2021 20:12:42

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Bonjour,

naute@debian:~/Projets/candle/Candle$ Candle
bash: Candle : commande introuvable

Hors ligne

#6 09-11-2021 20:40:23

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonsoir
par exemple sous bullseye  =>  https://packages.debian.org/fr/bullseye/qt5-doc

et sous buster =>  https://packages.debian.org/fr/buster/qt5-doc

pour stretch debian 9  =>  https://packages.debian.org/fr/stretch/qt5-doc

pour les versions je sais pas ce que tu a besoin , ni les paquets utiles

par contre ta commande ?

Candle est un script ?

Hors ligne

#7 09-11-2021 21:26:20

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème de migration vers Debian 11

Peu importe. Ce n'est pas ainsi qu'on exécute un programme situé dans le répertoire courant qui n'est pas dans le $PATH.

Il vaut mieux montrer que raconter.

Hors ligne

#8 09-11-2021 22:05:08

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Je pense, à la reflexion, que le problème ne vient pas de la version de Qt. Comme Candel fonctionne sur Stretch avec une version 5.7.1 de Qt, donc supérieure à la version 5.4.2 demandée, il devrait fonctionner sur BullsEye avec une version encore supérieure.

En ce qui concerne les paquets nécessaires, je n'ai aucune information autre que celles que j'ai mentionnées. Mais après la manip que Bartaba m'a très judicieusement demandé de faire, si un paquet était manquant, j'aurais dû avoir un retour... ou pas ? Je ne comprends pas du tout ce qui se passe sad .

Candle n'est pas un script : c'est un binaire exécutable issu de la compilation du source en C++.

Hors ligne

#9 09-11-2021 22:38:04

bartaba
Membre
Distrib. : Debian Buster
Noyau : Linux 4.19.0-13-amd64
(G)UI : Mate
Inscription : 04-02-2014

Re : [Résolu] Problème de migration vers Debian 11

étrange : j'ai téléchargé le logiciel par curiosité et moi non plus il ne se lance pas (je suis sous Buster)
et en ligne de commande j'ai cette erreur :

bash: ./Candle: Aucun fichier ou dossier de ce type



alors que je suis dans le bon dossier

System requirements for running "Candle":
    Windows/Linux x86 >>>>>>>>>>>>>>>>>>>>>>>>> OK


x86 donc 32 bits, ça ne serait pas ça le probleme ?

Dernière modification par bartaba (09-11-2021 22:48:08)

Hors ligne

#10 09-11-2021 23:16:58

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Problème de migration vers Debian 11

Hello,

Pour reprendre les dires de raleur :

Bonjour,

naute@debian:~/Projets/candle/Candle$ Candle
bash: Candle : commande introuvable


On n'exécute pas une commande ainsi qui n'est pas le PATH.
Essaie plutôt avec :

naute@debian:~/Projets/candle/Candle$ ./Candle


Mais d'abord, je regarderais que ce soit le bon nom de fichier et qu'il soit exécutable :

ls -l ~/Projets/candle/Candle

Dernière modification par Tawal (09-11-2021 23:18:19)


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#11 09-11-2021 23:41:30

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème de migration vers Debian 11

bartaba a écrit :

x86 donc 32 bits, ça ne serait pas ça le probleme ?


Effectivement c'est un exécutable 32 bits :

file Candle/Candle


Candle/Candle: ELF 32-bit LSB executable, Intel 80386, version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=8c22dcf2420d83c2f3f51e07efa4561ebaa41530, not stripped


Pour pouvoir exécuter un programme 32 bits sur une système 64 bits, il faut ajouter l'architecture i386 dans dpkg et installer le paquet libc6 i386.

dpkg --add-architecture i386
apt-get update
apt-get install libc6:i386


Il faudra peut-être aussi installer des bibliothèques i386, à vérifier avec

ldd chemin/Candle


Il ne doit pas y avoir de "=> not found".

Tawal a écrit :

je regarderais que ce soit le bon nom de fichier et qu'il soit exécutable


S'il n'était pas exécutable l'erreur serait différente : "permission non accordée".


Il vaut mieux montrer que raconter.

Hors ligne

#12 10-11-2021 00:48:41

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-9-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [Résolu] Problème de migration vers Debian 11

raleur a écrit :

S'il n'était pas exécutable l'erreur serait différente : "permission non accordée".


Lancé de la façon que j'indique oui, pas de la sienne wink


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#13 10-11-2021 05:48:21

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonsoir


Dans le cadre d'une migration vers Debian 11 sur une nouvelle machine,
 le logiciel Candel (anciennement grblControl) que j'utilise sans problème sur une Debian 9
 ne veut pas démarrer sur la nouvelle distribution.

Ce n'est pas un paquet Debian, et son installation consiste simplement à décompresser l'archive candle_1.1.7.tar.gz dans un dossier quelconque.
 Pour démarrer, il suffit de cliquer sur l'exécutable Candel, ce qui fonctionne très bien sous Debian 9  mais pas sous Debian 11.
 



./Candle
./Candle: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
 



comment a été faite la migration ?
si le i386 activé sous stretch , il ne disparaît pas sous bulseye après la migration

sur la machine de test (bookworm)  l'archive => Candle_1.1.7.tar.gz


dpkg --print-foreign-architectures
i386
 



dpkg --print-architecture
amd64
 


installé le paquet "lib32stdc++-10-dev (et dépendances)
ensuite


./Candle
./Candle: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory
 


je ne vais pas plus loin ......  roll

remarque: caja me propose de "lancer" Candle (bureau mate , bien sur ça ne fonctionne pas)
=> https://github.com/Denvi/Candle
=> https://github.com/trasz/grblControl
=> https://github.com/gnea/grbl/wiki

sur la migration les paquets sont mit a jour , mais a priori certaines choses ont été cassé . et en plus de debian9 => debian10 => debian11
sur une installation de base de debian11 l'application ne fonctionne pas (idem pour stretch des choses ont été installé pour supporté l'application)
a priori pas aussi simple que cela


son installation consiste simplement à décompresser l'archive candle_1.1.7.tar.gz dans un dossier quelconque
 

Dernière modification par robert2a (10-11-2021 05:58:27)

Hors ligne

#14 10-11-2021 12:05:49

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Bonjour à tous et merci pour vos interventions smile .

Pour clarifier la situation, le mot "migration" est peut-être mal choisi. Il ne s'agit pas du passage de Stretch vers Bullseye sur un même ordinateur, mais d'une nouvelle installation "propre" (en dual boot avec Windows) sur une machine récente que j'ai récupérée. Comme le but est de travailler dessus comme sur ma Stretch actuelle, il faut que j'y installe toutes les applications que j'utilise et que j'y transfère les fichiers que j'ai créés avec ces applications.
Les deux machines sont équivalentes sur le plan matériel. Les seules différences notables, en dehors de la distribution installée, est que la machine sous Stretch possède un cpu AMD et un noyau Linux 4 alors que la machine sous BullsEye possède un cpu Intel et un noyau Linux 5.

@Tawal En ce qui concerne la commande à exécuter, je me déplace dans le dossier contenant l'exécutable Candle et je le lance avec le préfixe ./ (ce que j'ai déjà fait mais ça ne coûte rien de recommencer) et ça donne ceci:

naute@debian:~$ cd /home/naute/Projets/candle/Candle
naute@debian:~/Projets/candle/Candle$ ./Candle
bash: ./Candle: Aucun fichier ou dossier de ce type
naute@debian:~/Projets/candle/Candle$



Ensuite, en ce qui concerne la remarque de bartaba concernant l'architecture 32 bits : en effet, la commande indiquée par robert2a :

dpkg --print-foreign-architectures


me renvoie bien i386 sur la machine Stretch et rien sur la machine BullsEye. Donc le problème, ou du moins une partie du problème, vient de là.

J'exécute la procédure de raleur et voilà ce que ça donne :

naute@debian:~$ su -
Mot de passe :
root@debian:~# dpkg --add-architecture i386
root@debian:~# apt-get update
Atteint :1 http://deb.debian.org/debian bullseye InRelease
Réception de :2 http://security.debian.org/debian-security bullseye-security InRelease [44,1 kB]
Réception de :3 http://deb.debian.org/debian bullseye-updates InRelease [39,4 kB]
Réception de :4 http://deb.debian.org/debian bullseye-backports InRelease [43,7 kB]
Réception de :5 http://deb.debian.org/debian bullseye/main i386 Packages [8119 kB]
Réception de :6 http://security.debian.org/debian-security bullseye-security/main Sources [65,5 kB]
Réception de :7 http://security.debian.org/debian-security bullseye-security/main i386 Packages [90,4 kB]
Réception de :8 http://security.debian.org/debian-security bullseye-security/main amd64 Packages [90,5 kB]
Réception de :9 http://security.debian.org/debian-security bullseye-security/main Translation-en [56,4 kB]
Réception de :10 http://deb.debian.org/debian bullseye-backports/main amd64 Packages.diff/Index [63,3 kB]
Réception de :11 http://deb.debian.org/debian bullseye/non-free i386 Packages [76,7 kB]
Réception de :12 http://deb.debian.org/debian bullseye/contrib i386 Packages [45,3 kB]
Réception de :13 http://deb.debian.org/debian bullseye-updates/main i386 Packages [2592 B]
Réception de :14 http://deb.debian.org/debian bullseye-backports/main i386 Packages [125 kB]
Réception de :15 http://deb.debian.org/debian bullseye-backports/main amd64 Packages T-2021-11-09-2009.28-F-2021-11-09-2009.28.pdiff [285 B]
Réception de :15 http://deb.debian.org/debian bullseye-backports/main amd64 Packages T-2021-11-09-2009.28-F-2021-11-09-2009.28.pdiff [285 B]
8862 ko réceptionnés en 7s (1341 ko/s)                                      
Lecture des listes de paquets... Fait
root@debian:~# apt-get install libc:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
E: Impossible de trouver le paquet libc:i386
root@debian:~#



@ raleur :J'ai trouvé le paquet libc6-i386_2.31-13+deb11u2_amd64.deb sur pkgs.org. Il semblerait donc que le nom du paquet est libc6-i386, qui est dans les dépôts Debian, et non pas libc:i386. Par contre, avant de l'installer, je préférerais avoir une confirmation. Je ne voudrais pas casser une belle distribution toute neuve mrgreen.gif .

Hors ligne

#15 10-11-2021 12:13:28

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonjour
pour le multiarch  => https://wiki.debian.org/fr/Multiarch/HOWTO
donc


dpkg --add-architecture i386
 


puis


apt-get update
 



mais a mon avis ça ne suffira pas (il va manquer des modules)

essaie la commande en console user , depuis le dossier décompressé


./Candle
 



a priori il te faut ces deux paquets au moins

=> https://packages.debian.org/fr/sid/lib32stdc++6
=> https://packages.debian.org/fr/bullseye/libglib2.0-0

Dernière modification par robert2a (10-11-2021 12:47:48)

Hors ligne

#16 10-11-2021 12:38:50

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

robert2a a écrit :

Bonjour
pour le multiarch  => https://wiki.debian.org/fr/Multiarch/HOWTO
donc


dpkg --add-architecture i386
 


puis


apt-get update
 



raleur m'a déjà fourni ces indications, que je me suis empressé de suivre. Merci quand même wink .

J'attends le feu vert pour l'installation de libc6-i386.

Hors ligne

#17 10-11-2021 12:51:58

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

si tu installe ce paquet c'est automatique (pour avoir shared libraries: libstdc++.so.6)


lib32stdc++-10-dev
 


voir mon retour #13
ps : tu aura aussi libc6-i386 et 32 (pas noter  dsl)

Dernière modification par robert2a (10-11-2021 12:54:07)

Hors ligne

#18 10-11-2021 13:02:59

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

en simulation


apt -s install lib32stdc++-10-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Les paquets supplémentaires suivants seront installés :
  lib32asan6 lib32atomic1 lib32gcc-10-dev lib32gcc-s1 lib32gomp1 lib32itm1 lib32quadmath0 lib32stdc++6 lib32ubsan1 libc6-i386 libc6-x32 libstdc++-10-dev libx32asan6 libx32atomic1 libx32gcc-s1 libx32gomp1
  libx32itm1 libx32quadmath0 libx32stdc++6 libx32ubsan1
Paquets suggérés :
  libstdc++-10-doc
Les NOUVEAUX paquets suivants seront installés :
  lib32asan6 lib32atomic1 lib32gcc-10-dev lib32gcc-s1 lib32gomp1 lib32itm1 lib32quadmath0 lib32stdc++-10-dev lib32stdc++6 lib32ubsan1 libc6-i386 libc6-x32 libstdc++-10-dev libx32asan6 libx32atomic1
  libx32gcc-s1 libx32gomp1 libx32itm1 libx32quadmath0 libx32stdc++6 libx32ubsan1
 



tu a bien "libc6-i386 libc6-x32"

Hors ligne

#19 10-11-2021 13:46:16

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Oui, mais sur https://wiki.debian.org/fr/Multiarch/HOWTO dont tu m'as fourni le lien, et que j'ai donc consulté, on trouve :

Multiarch/HOWTO a écrit :

Il est maintenant possible de se référer à un paquet via « paquet:architecture » à peu près partout où il était possible de le faire avant avec « paquet » — nous avons donc libc:i386 et libc:amd64 — malheureusement, les sémantiques comprises par dpkg et apt étant légèrement différentes, les résultats obtenus via ces deux interfaces peuvent être légèrement différents. Cependant, préciser l'architecture d'un paquet devrait toujours être sûr et sans ambigüité, quant au nom « paquet » sans précision, il se réfère au paquet dans l'architecture courante d'apt.


Il semble que la référence au paquet doive se faire sous la forme paquet:architecture et non paquet-architecture. Or, raleur me dit d'installer libc:i386 et non pas libc6-i386. C'est pourquoi je demande la confirmation qu'il s'agit bien du même paquet, ou du moins que je peux remplacer l'un par l'autre. Ce n'est pas évident, d'autant qu'il y a toujours une erreur après l'intallation :

robert2a a écrit :

installé le paquet "lib32stdc++-10-dev (et dépendances)
ensuite

./Candle
./Candle: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory



Pour info, la même simulation chez moi donne :

root@debian:~# apt -s install lib32stdc++-10-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'
état... Fait      
Les paquets supplémentaires suivants seront installés :
  lib32asan6 lib32atomic1 lib32gcc-10-dev lib32gcc-s1 lib32gomp1 lib32itm1 lib32quadmath0 lib32stdc++6 lib32ubsan1
  libc6-i386 libc6-x32 libx32asan6 libx32atomic1 libx32gcc-s1 libx32gomp1 libx32itm1 libx32quadmath0 libx32stdc++6
  libx32ubsan1
Les NOUVEAUX paquets suivants seront installés :
  lib32asan6 lib32atomic1 lib32gcc-10-dev lib32gcc-s1 lib32gomp1 lib32itm1 lib32quadmath0 lib32stdc++-10-dev
  lib32stdc++6 lib32ubsan1 libc6-i386 libc6-x32 libx32asan6 libx32atomic1 libx32gcc-s1 libx32gomp1 libx32itm1
  libx32quadmath0 libx32stdc++6 libx32ubsan1
0 mis à jour, 20 nouvellement installés, 0 à enlever et 10 non mis à jour.
Inst libc6-i386 (2.31-13+deb11u2 Debian:11.1/stable [amd64])
Inst lib32gcc-s1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32asan6 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32atomic1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libc6-x32 (2.31-13+deb11u2 Debian:11.1/stable [amd64])
Inst libx32gcc-s1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32gomp1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libx32gomp1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32itm1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libx32itm1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libx32atomic1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libx32asan6 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32stdc++6 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32ubsan1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libx32stdc++6 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libx32ubsan1 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32quadmath0 (10.2.1-6 Debian:11.1/stable [amd64])
Inst libx32quadmath0 (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32gcc-10-dev (10.2.1-6 Debian:11.1/stable [amd64])
Inst lib32stdc++-10-dev (10.2.1-6 Debian:11.1/stable [amd64])
Conf libc6-i386 (2.31-13+deb11u2 Debian:11.1/stable [amd64])
Conf lib32gcc-s1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32asan6 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32atomic1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libc6-x32 (2.31-13+deb11u2 Debian:11.1/stable [amd64])
Conf libx32gcc-s1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32gomp1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libx32gomp1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32itm1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libx32itm1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libx32atomic1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libx32asan6 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32stdc++6 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32ubsan1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libx32stdc++6 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libx32ubsan1 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32quadmath0 (10.2.1-6 Debian:11.1/stable [amd64])
Conf libx32quadmath0 (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32gcc-10-dev (10.2.1-6 Debian:11.1/stable [amd64])
Conf lib32stdc++-10-dev (10.2.1-6 Debian:11.1/stable [amd64])
root@debian:~#
 


Est-ce que tu penses que je peux installer lib32stdc++-10-dev sans risque ?

Hors ligne

#20 10-11-2021 13:55:40

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

attend je suis passé sur bullseye (j'étais sur bookworm (testing)
j'ai comme toi  hmm


./Candle
bash: ./Candle: Aucun fichier ou dossier de ce type
 



pour lib32stdc++-10-dev je vais le faire sur bullseye (sur testing ça n'a posé aucun problème)
mais bon je comprend pas ce retour "bash: ./Candle: Aucun fichier ou dossier de ce type" , je suis bien dans le dossier ~/test/Candle/Candle

après avoir installé le paquet le retour  roll


./Candle
./Candle: error while loading shared libraries: libgobject-2.0.so.0: cannot open shared object file: No such file or directory
 


par contre je bloque sur ce "libgobject-2.0.so.0"

Dernière modification par robert2a (10-11-2021 14:00:15)

Hors ligne

#21 10-11-2021 14:06:58

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11


apt policy libglib2.0-0
libglib2.0-0:
  Installé : 2.66.8-1
  Candidat : 2.66.8-1
 Table de version :
 *** 2.66.8-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 




apt policy libc6-i386 libc6-x32
libc6-i386:
  Installé : 2.31-13+deb11u2
  Candidat : 2.31-13+deb11u2
 Table de version :
 *** 2.31-13+deb11u2 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
libc6-x32:
  Installé : 2.31-13+deb11u2
  Candidat : 2.31-13+deb11u2
 Table de version :
 *** 2.31-13+deb11u2 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 



voila je suis bloqué la dessus , je comprend pas ce qu'il manque pour avoir "libgobject-2.0.so.0"

Hors ligne

#22 10-11-2021 14:38:44

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Est-ce que le paquet libglib2.0-dev est installé chez toi ? C'est lui qui fournit libgobject-2.0.so.0.

Hors ligne

#23 10-11-2021 14:41:41

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

l'installation du paquet ci dessous ne change rien


libglib2.0-dev
 


il y a aussi un libglib2.0-dev-bin


Ce paquet est nécessaire pour compiler des programmes avec libglib2.0-0. Il contient
les utilitaires de développement s'exécutent généralement pendant la compilation et ne doivent pas être
installé directement. Utilisez plutôt libglib2.0-dev.
 


tu a un matériel connecté a la machine ?
voir la documentation pour ce programme
ci tu installe le paquet " lib32stdc++-10-dev"  ton retour doit changer sur bullseye
ps: il peut être purgé comme ceci


apt remove --purge lib32stdc++-10-dev
 


puis pour les dépendances


apt-get autoremove --purge
 


ps: pour mon sources.list je n'ai pas les sources activé (src)
je n'ai rien cassé sur testing ou stable

Hors ligne

#24 10-11-2021 14:45:25

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

je vient de l'installer sur bullseye , ça change rien


apt policy libglib2.0-dev
libglib2.0-dev:
  Installé : 2.66.8-1
  Candidat : 2.66.8-1
 Table de version :
 *** 2.66.8-1 500
        500 https://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status
 

Hors ligne

#25 10-11-2021 14:56:43

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

dans /usr/lib/x86_64-linux-gnu j'ai


libglib-2.0.a
libglib-2.0.so
libglib-2.0.so.0
libglib-2.0.so.0.-6600.8
 


mais ce sont des librairies 64 dans ce dossier je suppose
je vais tenter d installer ceci tongue


apt policy libglib2.0-dev:i386
libglib2.0-dev:i386:
  Installé : (aucun)
  Candidat : 2.66.8-1
 Table de version :
     2.66.8-1 500
        500 https://deb.debian.org/debian bullseye/main i386 Packages
 

Dernière modification par robert2a (10-11-2021 14:59:16)

Hors ligne

Pied de page des forums