Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 10-11-2021 15:03:57

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

c'est mieux .................. roll


./Candle
./Candle: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
 



apt policy libx11-dev:i386
libx11-dev:i386:
  Installé : 2:1.7.2-1
  Candidat : 2:1.7.2-1
 Table de version :
 *** 2:1.7.2-1 500
        500 https://deb.debian.org/debian bullseye/main i386 Packages
        100 /var/lib/dpkg/status
 



on continue tongue


./Candle
./Candle: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
 


avec un driver vidéo libre et donc mesa


apt policy libglx-mesa0:i386
libglx-mesa0:i386:
  Installé : 20.3.5-1
  Candidat : 20.3.5-1
 Table de version :
 *** 20.3.5-1 500
        500 https://deb.debian.org/debian bullseye/main i386 Packages
        100 /var/lib/dpkg/status
 

Dernière modification par robert2a (10-11-2021 17:13:42)

Hors ligne

#27 10-11-2021 15:38:36

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

voila le dernier message , je suis en nvidia driver propriétaire c'est pas cool pour les tests , installé le paquet libgl1-nvidia-glvnd-glx:i386
le retour


./Candle
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Abandon
 


a priori un souci de driver vidéo , en fait il faut le réinstaller en i386 (un peu comme pour steam)
pour Qt peut être des choses a faire aussi
je sais pas si cette application fonctionne bien en driver libre , intel ou amd par exemple
actuellement j'ai un driver nonfree amd64 avec quelques paquets en i386 , pas très sérieux ça  roll

Hors ligne

#28 10-11-2021 16:41:54

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

le dernier message est celui ci (je suis en driver libre "nouveau" et la prise en charge 2D/3D est correcte )


Cette application n'a pas pu démarrer car elle n'a pas pu trouver ou charger le plugin de plate-forme Qt "xcb".
Les plugins de plate-forme disponibles sont : eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.
Réinstaller l'application peut résoudre ce problème.
Abandonner
 


il faut peut être une version i386 de certain paquet Qt

voila il fonctionne


./Candle
locale: "fr"
style "Windows"
style "GTK+"
QGtkStyle could not resolve GTK. Make sure you have installed the proper libraries.
shader program created
preparing vectors GcodeDrawer(0xa240590)
lines count 0
preparing vectors GcodeDrawer(0xa23f880)
lines count 0
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
 


avec ce paquet


apt install qt5dxcb-plugin:i386
 



apt policy qt5dxcb-plugin:i386
qt5dxcb-plugin:i386:
  Installé : 5.0.17-1
  Candidat : 5.0.17-1
 Table de version :
 *** 5.0.17-1 500
        500 https://deb.debian.org/debian bullseye/main i386 Packages
        100 /var/lib/dpkg/status
 



peut être des choses a faire encore , mais l'application fonctionne sous bullseye
par exemple sur l'application graphique j'ai erreur port serie 1 (no such file or directory) en bas a droite

petit détail important les menus sont vide , sûrement quelques paquets Qt a installer
je connaît pas , tous mes bureaux sont en GTK , mais le logiciel ce lance
je connais le terme "CNC" de nom , mais aucune idée sur le matériel (comme d' ailleurs l'impression 3D que je connais pas non plus)

Dernière modification par robert2a (10-11-2021 17:34:24)

Hors ligne

#29 10-11-2021 19:51:21

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

robert2a a écrit :

tu a un matériel connecté a la machine ?


Pour le moment, non !
En temps normal, pour utiliser Candel (ou grblControl), j'ai une petite graveuse CNC, destinée à la gravure de PCB, connectée en USB.
Mais le logiciel se lance de toute manière, qu'il y ait du matériel connecté ou pas. Simplement, la plupart de ses fonctions sont activées ou désactivées selon le cas.

Sinon, mes retours sont les même que pour toi. Je ne comprends pas ce qui se passe et ma connaissance des entrailles de Linux est dérisoirement insuffisante pour résoudre ce genre de problème, d'autant plus que dans mon souvenir, je n'ai rencontré aucune difficulté quand j'ai "installé" (décompressé serait plus juste) grblControl sur ma Stretch toute neuve (elle venait juste de sortir, il y a 4 ou 5 ans). Si j'avais eu ce genre de soucis, je m'en souviendrais.

Hors ligne

#30 10-11-2021 20:05:37

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Oups ! je n'ai pas rafraîchi l'affichage avant d'écrire le message ci-dessus et je suis donc largement en retard sur l'avancement des travaux biggreen.gif .

Je reviens après dès que j'ai du nouveau.

Hors ligne

#31 10-11-2021 20:34:13

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Donc je suis raccord avec toi jusqu'à l'installation de libglx-mesa0:i386, mais après, le retour est le même que précédemment, c'est-à-dire que j'ai toujours :

naute@debian:~/Projets/candle/Candle$ ./Candle
./Candle: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory


alors que toi, tu obtiens ceci :

./Candle
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Abandon

Hors ligne

#32 10-11-2021 23:12:47

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

l'installation du paquet n'a pas résolu ?


apt install qt5dxcb-plugin:i386
 



sinon ensuite j'ai réinstallé le driver nvidia avec le i386 actif , et j'ai pu utiliser ce dernier pour ouvrir l application au lieu de mesa

il me reste QGtkStyle a optimiser => QGtkStyle could not resolve GTK. Make sure you have installed the proper libraries.


./Candle
locale: "fr"
style "Windows"
style "GTK+"
QGtkStyle could not resolve GTK. Make sure you have installed the proper libraries.
shader program created
preparing vectors GcodeDrawer(0xa25eab0)
lines count 0
preparing vectors GcodeDrawer(0xa25dda0)
lines count 0
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
QCommonStyle::drawComplexControl: Control 1 not handled
 


et sûrement idem pour "QCommonStyle"

Hors ligne

#33 11-11-2021 00:57:30

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Problème de migration vers Debian 11

naute a écrit :

root@debian:~# apt-get install libc:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait     
E: Impossible de trouver le paquet libc:i386


Si tu ne tapes pas correctement les commandes que j'indique, ça marche beaucoup moins bien.


Il vaut mieux montrer que raconter.

Hors ligne

#34 11-11-2021 01:19:28

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

j'ai testé KDE Plasma c'est la même chose
tu dis  installé grblControl , on parle bien de celui ci => Candle_1.1.7.tar.gz
rien d'autre a installer (décompresser) ? 
ps:  a priori ça tourne sur de l' ARM aussi  (arduino , raspberry)
par contre le com1 est actif sur la machine , mais rien de connecté . je sais pas lister ce matériel sur debian
le souci c'est de faire sans prendre de notes , après on oublie  roll

Hors ligne

#35 11-11-2021 11:43:28

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

robert2a a écrit :

l'installation du paquet n'a pas résolu ?


apt install qt5dxcb-plugin:i386
 


Non non ! c'est l'installation du paquet précédent libglx-mesa0:i386 qui n'a rien changé.
Après son installation, si j'ai bien lu, en exécutant ./Candle tu obtiens :

./Candle
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Abandon


alors que moi, j'ai toujours :

./Candle
./Candle: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory


et donc, je n'ai pas tenté l'installation de qt5dxcb-plugin:i386.

raleur a écrit :

Si tu ne tapes pas correctement les commandes que j'indique, ça marche beaucoup moins bien.


Désolé ops.gif : c'est une erreur de lecture, que j'ai répétée par la suite. J'aurai dû faire un copier/coller plutôt que de saisir la commande. Comme quoi, il est parfois préférable d'être fainéant smile . Je l'installe au plus tôt.

robert2a a écrit :

j'ai testé KDE Plasma c'est la même chose
tu dis  installé grblControl , on parle bien de celui ci => Candle_1.1.7.tar.gz


Je travaille avec Plasma et Mate et je confirme que le comportement est le même.
Pour grblControl, c'est seulement l'ancienne version de Candel. Jusqu'à présent, j'utilisais grblControl sur ma distribution Stretch. Quand j'ai voulu l'installer sur BullsEye, j'ai constaté qu'il y avait une nouvelle version qui apportait des fonctionnalités intéressante : Candle. J'ai donc, en toute logique, essayé d'installer cette nouvelle version. Constatant qu'elle ne démarrait pas sur BullsEye, je l'ai installée sur Stretch où elle fonctionne parfaitement. J'ai également, à tout hasard, essayé d'installer grblControl sur BullsEye, pour voir : ça ne démarre pas non plus.
Pour résumer, les deux versions, grblControl et Candle, fonctionnent sous Stretch et pas sous BullsEye.

Je ne vais probablement pas pouvoir bosser là-dessus ce week-end (famille et tout), mais je n'abandonne pas.
Donc, à lundi, à moins que je puisse m'échapper avant lol .

Et encore merci pour toutes vos interventions : j'ai bon espoir, avec votre aide, de trouver une solution à ce problème.

Amicalement,
naute

Dernière modification par naute (11-11-2021 11:48:25)

Hors ligne

#36 11-11-2021 12:20:07

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonjour
pour libGL.so.1 c'est un problème de driver video en i386 , bien connu des utilisateurs de steam
il suffit d'avoir le driver libre en i386 ou nvidia en i386
par exemple pour mesa le paquet libglx-mesa0 et libglx-mesa-dri doit être en i386 et amd64  ainsi que d'autres
lors de la mise en place du i386 certains paquet n'ont pas été installé convenablement pour le driver , pour nvidia j'ai du supprimé le driver puis le réinstaller pour être correct
pour mesa il suffit de vérifier quel paquet n'est pas en i386 (libglx.xxxx  fournit la prise en charge de la 3D et fournit libgl.so.1)
tu peu tenter de le faire manuellement (la en simulation) si tu est en driver libre


apt -s --reinstall install libglx-mesa0:i386 libgl1-mesa-dri:i386
 


tu dois avoir un certain nombre de paquets qui vont se mettre a jour en i386
pour le driver propriétaire même principe

Hors ligne

#37 11-11-2021 21:09:51

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonjour
je sais que tu est en famille , mais je vais tenter sur une installation neuve de bullseye en i386 , toujours le bureau mate
des soucis avec grub mais je peu booter par le premier disque en amd64 sur le disque en i386
pour voir ce que ça donne , et si toujours le menu absent
bon le boot sur le disque en debian i386 correct
mais le logiciel


./Candle
locale: "fr"
style "Windows"
style "GTK+"
QGtkStyle could not resolve GTK. Make sure you have installed the proper libraries.
shader program created
preparing vectors GcodeDrawer(0x90ea4b0)
lines count 0
preparing vectors GcodeDrawer(0x90e97a0)
lines count 0
QCommonStyle::drawComplexControl: Control 1 not handled
 


du premier coup sans installer aucun paquet , j'ai ma fenêtre ouverte mais sans menu toujours
enfin si le menu principal mais a l'ouverture c'est vide
j'ai une piste sur "qt5" et ceci "export QT_STYLE_OVERRIDE=gtk2" dans mon fichier ".bashrc"
de plus on est en gtk3 sur mate il me semble

Dernière modification par robert2a (12-11-2021 00:06:12)

Hors ligne

#38 12-11-2021 00:09:16

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

c'est bon cool


./Candle
locale: "fr"
style "Windows"
style "GTK+"
shader program created
preparing vectors GcodeDrawer(0x93d49b0)
lines count 0
preparing vectors GcodeDrawer(0x93d3d00)
lines count 0
 



avec cette commande


apt install qt5ct qt5-style-plugins qt5-doc qt5-doc-html qt5-assistant
 


ps: sur l'iso debian DVD1 i386 bullseye + Mate

me reste ceci : console


Erreur port serie 1: No such file or directory
 


si je prend ttys0 le retour


Erreur port serie 2: Permission denied
 



qt5-assistant me donne la doc en anglais  (menu mate "programmation" => Qt 5 assistant )
sur AMD64 trop galère , il utilise que des paquets i386
par contre avec une CNC je sais pas si ça fonctionne  wink

le projet  =>  https://doc.qt.io/archives/qt-5.9/index.html
si tu fais une recherche avec "QGtkStyle could not resolve GTK" , c'est pas le seul logiciel a utiliser  Qt   smile

Dernière modification par robert2a (12-11-2021 00:27:32)

Hors ligne

#39 15-11-2021 13:13:24

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Bonjour et merci pour les nouvelles avancées smile .

Retour à une activité normale après ce week-end prolongé (du moins pour certains lol ).

Pour bien me clarifier les idées, je suis reparti à zéro et j'ai créé deux machines virtuelles (VirtualBox) sur ma distribution Stretch 64 bits, une BullsEye 32 bits et une BullsEye 64 bits.

Sur la BullsEye 32 bits, pas de problème : je décompresse l'archive Candle, je clique sur l'exécutable Candle et tout démarre, s'affiche et fonctionne parfaitement.

Sur la BullsEye 64 bits, pas vraiment de surprise : je décompresse l'archive Candle, je clique sur l'exécutable Candle et rien ne se passe, comme vu plus haut.
À partir de là, on ne va pas faire deux fois les mêmes bêtises, je suis les instructions de raleur, à savoir :

dpkg --add-architecture i386
apt-get update
apt-get install libc6:i386


qui, cette fois-ci, fonctionnent parfaitement puisque j'ai exécuté les bonnes instructions mrgreen.gif .
Ensuite, j'exécute :

ldd chemin/Candle


qui m'indique que les fichiers suivants sont manquants (not found) :
libstdc++.so.6
libgobject-2.0.so.0
libglib-2.0.so.0
libgthread-2.0.so.0
libX11.so.6
libGL.so.1

Une petite recherche sur https://packages.debian.org/bullseye/ m'indique que ces fichiers se trouvent dans les packages :
libstdc++6
libglib2.0-0
libx11-6
libgl1

J'installe donc la version i386  de ces packages avec :

apt install libstdc++6:i386 libglib2.0-0:i386 libx11-6:i386 libgl1:i386



Je lance ensuite Candle avec :

./Candle


dans le répertoire qui va bien, et je me retrouve avec le même message que robert2a, à savoir :

./Candle
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Abandon


ce qui semble logique.

J'exécute ensuite :

apt install qt5dxcb-plugin:i386


ce qui au lancement de Candle me donne :

./Candle
locale: "fr"
style "Windows"
style "GTK+"
QGtkStyle could not resolve GTK. Make sure you have installed the proper libraries.
shader program created
...


Là, je fais l'impasse sur la manipulation concernant les drivers vidéo parce-que je ne sais pas où je mets les pieds. Si je n'ai plus d'affichage il faut tout recommencer crash.gif . Je sais que je suis sur une machine virtuelle, mais quand même...
Enfin, je fais la manipulation :

apt install qt5ct qt5-style-plugins qt5-doc qt5-doc-html qt5-assistant


en la modifiant un peu puisqu'il faut, en réalité, installer les versions i386, ce qui donne :

apt install qt5ct:i386 qt5-style-plugins:i386 qt5-assistant:i386


les deux paquets qt5-doc et qt5-doc-html semblent ne pas avoir de version i386.

Le lancement de Candle se passe bien, que ce soit depuis la console ou en cliquant sur l'exécutable. La connexion USB à ma graveuse CNC ne pose pas de problème et la graveuse est opérationnelle, du moins si j'en crois les tests de base que j'ai effectué, à savoir déplacement sur les trois axes et activation de la broche. Je n'ai pas encore essayé de lancer un fichier G-Code, mais je ne vois pas pourquoi ça ne fonctionnerait pas.
Mais, car il y a un "mais", il y a deux problèmes d'affichage.
Le premier, qui n'est pas vraiment dérangeant, concerne la fonte utilisée dans l'interface, et qui est un peu petite, mais bon...
Le second est plus ennuyeux, car en plus, il affecte toutes les fenêtres quand Candle est en fonctionnement : l'affichage des fenêtres, lors d'un déplacement, par exemple, est très lent, c'est-à-dire que quand je déplace une fenêtre avec la souris, la fenêtre ne suit pas la souris mais se déplace lentement jusqu'à l'emplacement où j'ai relâché le bouton. Le phénomène disparaît quand je ferme Candle scratchhead.gif .

Une idée ?

Dernière modification par naute (15-11-2021 13:15:19)

Hors ligne

#40 15-11-2021 16:38:51

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Oui tu évite d'utiliser une VM , donc en dur sur l'hôte ; un souci de driver vidéo en VM
pour les fonts tu installe sur X les xfonts , je te donnerai le nom des paquets

les xfonts sur X


[    44.154] (==) FontPath set to:
  /usr/share/fonts/X11/misc,
  /usr/share/fonts/X11/cyrillic,
  /usr/share/fonts/X11/100dpi/:unscaled,
  /usr/share/fonts/X11/75dpi/:unscaled,
  /usr/share/fonts/X11/Type1,
  /usr/share/fonts/X11/100dpi,
  /usr/share/fonts/X11/75dpi,
 


ps: il en faut peut être d"autres a voir
et pour tester le driver en 3D (du paquet "mesa-utils" )


glxinfo -B
 



je suis pas sur la bonne machine , je testerai tout ça
en VM le driver vidéo est basic je pense

Dernière modification par robert2a (15-11-2021 18:05:03)

Hors ligne

#41 15-11-2021 16:57:58

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

voila le retour pour moi en i386 sur l' hôte , pas en VM


glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: nouveau (0x10de)
    Device: NV117 (0x1381)
    Version: 20.3.5
    Accelerated: yes
    Video memory: 1007MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.3
    Max compat profile version: 4.3
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: nouveau
OpenGL renderer string: NV117
OpenGL core profile version string: 4.3 (Core Profile) Mesa 20.3.5
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.3 (Compatibility Profile) Mesa 20.3.5
OpenGL shading language version string: 4.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.3.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
 



sur une GTX750 en driver libre "nouveau"

pour ceci "Le premier, qui n'est pas vraiment dérangeant, concerne la fonte utilisée dans l'interface, et qui est un peu petite, mais bon... "
effectivement  c'est petit mais lisible , il y a sûrement moyen de modifier cela

donc mon conseil c'est d'utiliser le programme sur ton installation en AMD64 (et pas en VM) pour résoudre le manque de fluidité
et de faire une recherche pour les fonts , (sur X ou sur le système ) fonts et xfonts

remarques:
dans le menu Candle , paramètres je suis passé de 9 a 12 points (écriture => taille => redémarrage nécessaire)
bien plus gros smile

content que tout fonctionne bien pour toi , moi je n'ai pas pu pousser les tests plus loin , pas le matériel et pas de projet a traiter .

pour l'installation des paquets si tu te fais un wiki oui pense que en amd64 il faut préciser ":i386" ; moi les commandes sont pour une debian bullseye  i386   wink

Dernière modification par robert2a (15-11-2021 18:06:19)

Hors ligne

#42 15-11-2021 17:51:28

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

je sais pas si utile , a partir de mon dossier Candle la commande de raleur (ldd) toujours sur bullseye i386


ldd Candle
  linux-gate.so.1 (0xb7eea000)
  libQt5OpenGL.so.5 => /home/robert/test/Candle/./libs/libQt5OpenGL.so.5 (0xb7e8e000)
  libQt5Widgets.so.5 => /home/robert/test/Candle/./libs/libQt5Widgets.so.5 (0xb7814000)
  libQt5Gui.so.5 => /home/robert/test/Candle/./libs/libQt5Gui.so.5 (0xb7232000)
  libQt5SerialPort.so.5 => /home/robert/test/Candle/./libs/libQt5SerialPort.so.5 (0xb7217000)
  libQt5Core.so.5 => /home/robert/test/Candle/./libs/libQt5Core.so.5 (0xb6cd0000)
  libstdc++.so.6 => /lib/i386-linux-gnu/libstdc++.so.6 (0xb6af4000)
  libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xb69f0000)
  libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb69d1000)
  libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb67e8000)
  libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xb67c4000)
  libgobject-2.0.so.0 => /lib/i386-linux-gnu/libgobject-2.0.so.0 (0xb6764000)
  libglib-2.0.so.0 => /lib/i386-linux-gnu/libglib-2.0.so.0 (0xb661a000)
  libX11.so.6 => /lib/i386-linux-gnu/libX11.so.6 (0xb64c8000)
  libGL.so.1 => /lib/i386-linux-gnu/libGL.so.1 (0xb645b000)
  libicui18n.so.53 => /home/robert/test/Candle/./libs/libicui18n.so.53 (0xb6204000)
  libicuuc.so.53 => /home/robert/test/Candle/./libs/libicuuc.so.53 (0xb6085000)
  libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xb607f000)
  libgthread-2.0.so.0 => /lib/i386-linux-gnu/libgthread-2.0.so.0 (0xb607a000)
  librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xb606f000)
  /lib/ld-linux.so.2 (0xb7eec000)
  libffi.so.7 => /lib/i386-linux-gnu/libffi.so.7 (0xb6063000)
  libpcre.so.3 => /lib/i386-linux-gnu/libpcre.so.3 (0xb5fec000)
  libxcb.so.1 => /lib/i386-linux-gnu/libxcb.so.1 (0xb5fbe000)
  libGLdispatch.so.0 => /lib/i386-linux-gnu/libGLdispatch.so.0 (0xb5f41000)
  libGLX.so.0 => /lib/i386-linux-gnu/libGLX.so.0 (0xb5f05000)
  libicudata.so.53 => /home/robert/test/Candle/./libs/libicudata.so.53 (0xb4a7c000)
  libXau.so.6 => /lib/i386-linux-gnu/libXau.so.6 (0xb4a77000)
  libXdmcp.so.6 => /lib/i386-linux-gnu/libXdmcp.so.6 (0xb4a70000)
  libbsd.so.0 => /lib/i386-linux-gnu/libbsd.so.0 (0xb4a58000)
  libmd.so.0 => /lib/i386-linux-gnu/libmd.so.0 (0xb4a49000)
 



mais je pense que au niveau paquet on est bon
ps: j'avais trouvé une version plus récent en amd64 mais sur windows uniquement

Dernière modification par robert2a (15-11-2021 17:53:35)

Hors ligne

#43 16-11-2021 11:17:17

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Bonjour smile .

Donc, effectivement, le problème de déplacement des fenêtres n'existe pas sur la machine réelle (non virtuelle). Problème réglé, encore que je ne comprenne pas le comportement sous VirtualBox. Cela laisse supposer qu'on ne peut pas tout virtualiser, ce qui est étonnant scratchhead.gif .
Cela dit, il reste toujours le petit problème d'affichage au niveau des items du menu qui disparaissent quand on les sélectionne, mais ce n'est qu'un détail. L'application fonctionne et c'est le principal.

Pour les fontes, je vais voir ce que je peux faire, mais le problème me dépasse un peu. Je ne sais pas avec quelle fonte Candle travaille par défaut ni où est située cette fonte ni comment la remplacer. Est-ce que c'est dans le programme lui-même, auquel cas je n'y ai pas accès. Enfin bref, pas simple pour moi. Je vais quand même  regarder.

J'ai déjà augmenté la taille de 1 point dans les paramètres ce qui améliore raisonnablement la présentation. Par contre, ce qui est curieux, c'est que, contrairement à ce qui est stipulé dans la fenêtre de paramétrage, et que tu soulignes :

robert2a a écrit :

remarques:
dans le menu Candle , paramètres je suis passé de 9 a 12 points (écriture => taille => redémarrage nécessaire)
bien plus gros


je n'ai pas besoin de redémarrer : la mise à jour de l'affichage est immédiate.

Concernant glxinfo sur BullsEye (machine réelle), voilà ce que j'obtiens :

naute@debian:~$ glxinfo -B
bash: glxinfo : commande introuvable
naute@debian:~$
 


alors que sur la distribution Stretch, j'ai bien un retour qui correspond au tien.

Dernière modification par naute (16-11-2021 11:43:25)

Hors ligne

#44 16-11-2021 17:19:02

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [Résolu] Problème de migration vers Debian 11

Bonjour
je commence par la fin
installe le paquet "mesa-utils"  pour glxinfo -B

pour "je n'ai pas besoin de redémarrer : la mise à jour de l'affichage est immédiate."    idem pour moi
pour les fonts et xfonts  pas de soucis je pense (pour X le chemin des xfonts => "/usr/share/fonts/X11/"
a mon avis il utilise celle du système (sur mate il y a un utilitaire "visionneuse de police Mate" )

pour la VM fait un lspci tu verra la différence avec l' hôte

pour ceci


il reste toujours le petit problème d'affichage au niveau des items
 


je n'ai pas remarqué ce comportement chez moi (a vérifier)

une liste de paquets xfonts (normalement ils sont déjà installés sur ta debian )


x11-utils
xfonts-100dpi
xfonts-75dpi
xfonts-base
xfonts-cyrillic
xfonts-encodings
xfonts-scalable
xfonts-utils
 



pour la VM je suis pas un utilisateur (je connais pas) , mais je sais que la prise en charge graphique par défaut est basique
si tu tien a utiliser une VM pour Candle il faudra demander comment l'améliorer  (et si c'est possible)

a mon avis Candle n'a pas besoin de fonts ou xfonts particulière (je ne pense pas que cela change quelque chose)
c'est une application graphique (donc Qt et le serveur X (x11) ).

Dernière modification par robert2a (16-11-2021 18:24:31)

Hors ligne

#45 17-11-2021 11:14:34

naute
Membre
Lieu : Bretagne
Distrib. : GNU-Linux Debian 11 BullsEye
Noyau : Linux 5.10.0-9-amd64 x86_64
(G)UI : MATE 1.24.1
Inscription : 24-03-2018

Re : [Résolu] Problème de migration vers Debian 11

Bonjour smile .

Après installation de mesa-utils, j'obtiens :

naute@debian:~$ glxinfo -B
name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Intel Open Source Technology Center (0x8086)
    Device: Mesa DRI Intel(R) HD Graphics (HSW GT1) (0x402)
    Version: 20.3.5
    Accelerated: yes
    Video memory: 1536MB
    Unified memory: yes
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics (HSW GT1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 20.3.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 20.3.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.3.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

naute@debian:~$
 


robert2a a écrit :

pour la VM je suis pas un utilisateur (je connais pas) , mais je sais que la prise en charge graphique par défaut est basique


Jusqu'à présent, je n'ai pas noté de problème à ce niveau-là sur mes machines virtuelles. La virtualisation m'a même permis d'avoir une machine Buster opérationnelle sur un portable Lenovo Windows10 alors que je ne pouvais pas l'installer en dualboot à cause d'un problème de driver vidéo. Quand BullsEye est sorti, j'ai retenté le coup, et là ça a fonctionné. Comme quoi, il ne faut pas désespérer.

robert2a a écrit :

si tu tien a utiliser une VM pour Candle il faudra demander comment l'améliorer  (et si c'est possible)


Je n'ai utilisé la machine virtuelle que pour les tests d'installation, pour limiter les risques ou les mauvaises manipulations. J'utiliserai Candle depuis la machine réelle, bien sûr.

En ce qui concerne les fontes, c'est un problème vraiment mineur qui n'affecte en rien l'utilisation du logiciel, d'autant qu'on peut en régler la taille dans une certaine mesure, ce qui fait que l'affichage est tout à fait satisfaisant, mis à part le petit problème des items du menu. L'item sélectionné n'est pas mis en surbrillance (ou la couleur de surbrillance est la même que la couleur standard) et son libellé, qui, à mon avis, est toujours là, prend la même couleur que le fond, ce qui le rend invisible. Il est cependant opérationnel et se comporte normalement quand je clique dessus. Dès que le curseur de la souris quitte l'item en question, il redevient "non sélectionné" et le libellé redevient visible. Je n'ai aucune idée de ce qui se passe.
EDIT : ça y est, je sais big_smile . Ça vient du thème que j'utilise (Mojave). En changeant de thème, ce phénomène curieux disparaît.

Je note quand même que sur ma Stretch 64 bits, tout a fonctionné parfaitement dès l'installation, sans aucune manipulation de ma part, et qu'il n'y a pas de problème d'affichage avec Mojave.

Cela dit, mon problème de base est réglé et je passe donc en [Résolu].

Un grand merci.gif à toi et à tous ceux qui sont intervenu.

Amicalement,
naute

Dernière modification par naute (17-11-2021 12:12:29)

Hors ligne

Pied de page des forums