Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-11-2021 19:32:23

Hichic
Membre
Inscription : 07-11-2021

Problème affichage des , : € dans une base de données ClarisWorks/Wine

J'ai un Dell Latitude D830 (i686 en 32 bits... ou 64 bits...)
Avec Debian 9 - en utilisant Wine - pour l'application ClarisWorks en Windows (vieux logiciel de Macintosh à l'origine... Successeurs : AppleWorks, FileMaker), j'avais trouvé sur Internet la façon de résoudre le problème d'affichage d'heures, virgules pour nombres décimaux, signes monétaires, etc. dans les rubriques nombre, heures... d'un fichier base de données de CW, mais je n'ai pas noté la procédure et je n'arrive donc plus à résoudre ce problème avec Debian 11 (ni Debian 9 d'ailleurs a priori).
Pour garder mes fichiers ClarisWorks, je suis obligé de repasser à Windows (!) ou je vais devoir les refaire sous LibreOffice...
Qui peut m'aider à retrouver la procédure pour résoudre ce problème d'affichage (a priori les calculs sont corrects, mais impossible de rajouter un nombre décimal (15,33 ou 15.33 par ex.) ou une heure qui ne soit pas entière (10:30 par ex.) !) ?

Dernière modification par Hichic (09-01-2022 17:35:51)

Hors ligne

#2 09-01-2022 17:36:14

Hichic
Membre
Inscription : 07-11-2021

Re : Problème affichage des , : € dans une base de données ClarisWorks/Wine

Sans réponse, je vous relance !
Un problème de polices, de Wine, de Windows ?

Hors ligne

#3 09-01-2022 19:03:04

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème affichage des , : € dans une base de données ClarisWorks/Wine

dur de répondre il faudrait pourvoir tester avec Clarisworks, surement a changer dans les préférence de ClarisWorks
Je me souviens y'a longtemps d'un soucis similaire avec exel de Microsoft qui n'acceptait pas le point du pavé numérique , il lui fallait une virgule

J'ai pas vraiment compris ton soucis , ce sont les touches du clavier qui n'affiche pas le bon symbole ou ta base de données qui est modifié?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#4 10-01-2022 12:53:00

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.4
Noyau : 5.10.0-16-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : Problème affichage des , : € dans une base de données ClarisWorks/Wine

sous Wine pour le séparateur décimal avec le point, ça se passe dans le fichier .wine/user.reg
dans [Control Panel\\International]
avec "sDecimal"="."

sinon passer par la commande

wine regedit

Dernière modification par jce76350 (10-01-2022 13:03:11)


--
Jc E

Hors ligne

#5 11-01-2022 03:03:03

Hichic
Membre
Inscription : 07-11-2021

Re : Problème affichage des , : € dans une base de données ClarisWorks/Wine

En fait la base de donnée ou feuille de calcul n'affiche pas les symboles comme les : (tel que 12:34 pour les horaires), les €, les , ou . (tel que 10,55 (ou 10.55) pour les nombres... Ne "passent" que les nombres entiers (10 au lieu de 10,55)... par contre les calculs sont exacts !)
Sans doute un problème de police Wine/Windows et/ou de codage d'avant les années 2000 : la virgule est remplacée par une sorte de rectangle dans une ancienne base de données...
Et merci pour vos réponses ci-dessus... et futures !

Hors ligne

Pied de page des forums