Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-11-2021 19:49:52

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

[résolu] impossible d installer wine32

salut a tous 
je viens d installer debian 11 64bit
j ai un peut fatt n importe quoi en activant les depots backport
et en faisant un upgrade avec ce depot
maintenant j ai des dépendances non satisfaites

@debian:~# apt-get install wine32
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1 : Dépend: libglx0 (= 1.3.2-1) mais ne sera pas installé
 libglx-mesa0 : Dépend: libgl1-mesa-dri mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
 


meme en essayant d installer winehq j ai des probleme de dépendances non satisfaites

@debian:~$ sudo apt install --install-recommends winehq-stable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 winehq-stable : Dépend: wine-stable (= 6.0.2~bullseye-1)
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 


y a t il un moyen de regler ca??
merci

Dernière modification par malmsteen (18-11-2021 19:01:49)

Hors ligne

#2 17-11-2021 21:24:35

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [résolu] impossible d installer wine32

Tu dois avoir des paquets 64-bit liés à Mesa qui ne sont pas dans les versions attendues par Debian Bullseye. D’où les difficultés a installer les versions 32-bit correspondantes.

Cette commande en dira peut-être plus sur ce qui coince :

apt install libgl1:amd64 libgl1:i386



Mes soupçons sont sur la bibliothèque libvulkan1. Tu peux partager aussi le retour de cette commande ?

apt policy libvulkan1:amd64 libvulkan1:i386


Jouer sous Debian ? Facile !

Hors ligne

#3 17-11-2021 21:35:09

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu] impossible d installer wine32

voila le retour que j ai

@debian:~# apt install libgl1:amd64 libgl1:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
libgl1 est déjà la version la plus récente (1.3.2-1).
libgl1 passé en « installé manuellement ».
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1 : Dépend: libglx0 (= 1.3.2-1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
 



debian:~# apt policy libvulkan1:amd64 libvulkan1:i386
libvulkan1:
  Installé : 1.2.182.0-2~bpo11+1
  Candidat : 1.2.182.0-2~bpo11+1
 Table de version :
 *** 1.2.182.0-2~bpo11+1 100
        100 /var/lib/dpkg/status
     1.2.162.0-1 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
libvulkan1:i386:
  Installé : (aucun)
  Candidat : 1.2.162.0-1
 Table de version :
     1.2.162.0-1 500
        500 http://deb.debian.org/debian bullseye/main i386 Packages
 

Hors ligne

#4 18-11-2021 08:50:48

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] impossible d installer wine32

Bonjour
ton explication pas correcte , les backports ont une priorité faible , on utilise l'option "-t" pour installer quelque chose
donc c'est pas l'upgrade qui a provoqué  ce souci

peut être désactiver  la ligne des backports (montrer ton sources.list actuel)
un update et rechercher les paquets orphelins
tu a aptitude pour chercher les informations et trouver des solutions

si tu a migrer mesa en backports ça va être chaud  tongue

a priori pas de mesa dans les backports de bullseye

pour la première commande il faut activer le i386  => apt-get install wine32
en simulation


apt-get -s install wine32
 



le retour de


dpkg --print-architecture
 


et de


dpkg --print-foreign-architectures
 



remarque : de ton #3 , si tu continue a lancer des commandes "install" ça va pas s'améliorer  roll

pour ajouter le i386  (Mais ne le fait pas maintenant , SUPPRIMER)

Dernière modification par robert2a (18-11-2021 09:27:09)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#5 18-11-2021 08:57:19

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu] impossible d installer wine32

j ai utiliser une commande pour forcer l update avec backport 

sudo apt -t bullseye-backports upgrade


voila les paquets installer depuis backport

debian:~#     dpkg-query -W | grep '~bpo'
at-spi2-core  2.42.0-2~bpo11+1
fonts-opensymbol  2:102.12+LibO7.2.2-1~bpo11+1
gir1.2-atspi-2.0:amd64  2.42.0-2~bpo11+1
iproute2  5.15.0-1~bpo11+1
libatspi2.0-0:amd64 2.42.0-2~bpo11+1
libbrlapi0.8:amd64  6.4-2~bpo11+1
libcpupower1  5.14.9-2~bpo11+1
libepoxy0:amd64 1.5.8-1~bpo11+1
libldap-2.4-2:amd64 2.4.59+dfsg-1~bpo11+1
libldap-common  2.4.59+dfsg-1~bpo11+1
liblouis-data 3.19.0-1~bpo11+1
liblouis20:amd64  3.19.0-1~bpo11+1
libpcap0.8:amd64  1.10.1-4~bpo11+1
libreoffice-base-core 1:7.2.2-1~bpo11+1
libreoffice-calc  1:7.2.2-1~bpo11+1
libreoffice-common  1:7.2.2-1~bpo11+1
libreoffice-core  1:7.2.2-1~bpo11+1
libreoffice-draw  1:7.2.2-1~bpo11+1
libreoffice-gtk3  1:7.2.2-1~bpo11+1
libreoffice-help-ca 1:7.2.2-1~bpo11+1
libreoffice-help-common 1:7.2.2-1~bpo11+1
libreoffice-help-cs 1:7.2.2-1~bpo11+1
libreoffice-help-da 1:7.2.2-1~bpo11+1
libreoffice-help-de 1:7.2.2-1~bpo11+1
libreoffice-help-dz 1:7.2.2-1~bpo11+1
libreoffice-help-el 1:7.2.2-1~bpo11+1
libreoffice-help-en-gb  1:7.2.2-1~bpo11+1
libreoffice-help-en-us  1:7.2.2-1~bpo11+1
libreoffice-help-es 1:7.2.2-1~bpo11+1
libreoffice-help-et 1:7.2.2-1~bpo11+1
libreoffice-help-eu 1:7.2.2-1~bpo11+1
libreoffice-help-fi 1:7.2.2-1~bpo11+1
libreoffice-help-fr 1:7.2.2-1~bpo11+1
libreoffice-help-gl 1:7.2.2-1~bpo11+1
libreoffice-help-hi 1:7.2.2-1~bpo11+1
libreoffice-help-hu 1:7.2.2-1~bpo11+1
libreoffice-help-it 1:7.2.2-1~bpo11+1
libreoffice-help-ja 1:7.2.2-1~bpo11+1
libreoffice-help-km 1:7.2.2-1~bpo11+1
libreoffice-help-ko 1:7.2.2-1~bpo11+1
libreoffice-help-nl 1:7.2.2-1~bpo11+1
libreoffice-help-pl 1:7.2.2-1~bpo11+1
libreoffice-help-pt 1:7.2.2-1~bpo11+1
libreoffice-help-ru 1:7.2.2-1~bpo11+1
libreoffice-help-sk 1:7.2.2-1~bpo11+1
libreoffice-help-sl 1:7.2.2-1~bpo11+1
libreoffice-help-sv 1:7.2.2-1~bpo11+1
libreoffice-help-zh-cn  1:7.2.2-1~bpo11+1
libreoffice-help-zh-tw  1:7.2.2-1~bpo11+1
libreoffice-impress 1:7.2.2-1~bpo11+1
libreoffice-l10n-ar 1:7.2.2-1~bpo11+1
libreoffice-l10n-ast  1:7.2.2-1~bpo11+1
libreoffice-l10n-be 1:7.2.2-1~bpo11+1
libreoffice-l10n-bg 1:7.2.2-1~bpo11+1
libreoffice-l10n-bn 1:7.2.2-1~bpo11+1
libreoffice-l10n-bs 1:7.2.2-1~bpo11+1
libreoffice-l10n-ca 1:7.2.2-1~bpo11+1
libreoffice-l10n-cs 1:7.2.2-1~bpo11+1
libreoffice-l10n-cy 1:7.2.2-1~bpo11+1
libreoffice-l10n-da 1:7.2.2-1~bpo11+1
libreoffice-l10n-de 1:7.2.2-1~bpo11+1
libreoffice-l10n-dz 1:7.2.2-1~bpo11+1
libreoffice-l10n-el 1:7.2.2-1~bpo11+1
libreoffice-l10n-en-gb  1:7.2.2-1~bpo11+1
libreoffice-l10n-en-za  1:7.2.2-1~bpo11+1
libreoffice-l10n-eo 1:7.2.2-1~bpo11+1
libreoffice-l10n-es 1:7.2.2-1~bpo11+1
libreoffice-l10n-et 1:7.2.2-1~bpo11+1
libreoffice-l10n-eu 1:7.2.2-1~bpo11+1
libreoffice-l10n-fa 1:7.2.2-1~bpo11+1
libreoffice-l10n-fi 1:7.2.2-1~bpo11+1
libreoffice-l10n-fr 1:7.2.2-1~bpo11+1
libreoffice-l10n-ga 1:7.2.2-1~bpo11+1
libreoffice-l10n-gl 1:7.2.2-1~bpo11+1
libreoffice-l10n-gu 1:7.2.2-1~bpo11+1
libreoffice-l10n-he 1:7.2.2-1~bpo11+1
libreoffice-l10n-hi 1:7.2.2-1~bpo11+1
libreoffice-l10n-hr 1:7.2.2-1~bpo11+1
libreoffice-l10n-hu 1:7.2.2-1~bpo11+1
libreoffice-l10n-id 1:7.2.2-1~bpo11+1
libreoffice-l10n-is 1:7.2.2-1~bpo11+1
libreoffice-l10n-it 1:7.2.2-1~bpo11+1
libreoffice-l10n-ja 1:7.2.2-1~bpo11+1
libreoffice-l10n-ka 1:7.2.2-1~bpo11+1
libreoffice-l10n-km 1:7.2.2-1~bpo11+1
libreoffice-l10n-ko 1:7.2.2-1~bpo11+1
libreoffice-l10n-lt 1:7.2.2-1~bpo11+1
libreoffice-l10n-lv 1:7.2.2-1~bpo11+1
libreoffice-l10n-mk 1:7.2.2-1~bpo11+1
libreoffice-l10n-ml 1:7.2.2-1~bpo11+1
libreoffice-l10n-mr 1:7.2.2-1~bpo11+1
libreoffice-l10n-nb 1:7.2.2-1~bpo11+1
libreoffice-l10n-ne 1:7.2.2-1~bpo11+1
libreoffice-l10n-nl 1:7.2.2-1~bpo11+1
libreoffice-l10n-nn 1:7.2.2-1~bpo11+1
libreoffice-l10n-pa-in  1:7.2.2-1~bpo11+1
libreoffice-l10n-pl 1:7.2.2-1~bpo11+1
libreoffice-l10n-pt 1:7.2.2-1~bpo11+1
libreoffice-l10n-pt-br  1:7.2.2-1~bpo11+1
libreoffice-l10n-ro 1:7.2.2-1~bpo11+1
libreoffice-l10n-ru 1:7.2.2-1~bpo11+1
libreoffice-l10n-si 1:7.2.2-1~bpo11+1
libreoffice-l10n-sk 1:7.2.2-1~bpo11+1
libreoffice-l10n-sl 1:7.2.2-1~bpo11+1
libreoffice-l10n-sr 1:7.2.2-1~bpo11+1
libreoffice-l10n-sv 1:7.2.2-1~bpo11+1
libreoffice-l10n-ta 1:7.2.2-1~bpo11+1
libreoffice-l10n-te 1:7.2.2-1~bpo11+1
libreoffice-l10n-th 1:7.2.2-1~bpo11+1
libreoffice-l10n-tr 1:7.2.2-1~bpo11+1
libreoffice-l10n-ug 1:7.2.2-1~bpo11+1
libreoffice-l10n-uk 1:7.2.2-1~bpo11+1
libreoffice-l10n-vi 1:7.2.2-1~bpo11+1
libreoffice-l10n-xh 1:7.2.2-1~bpo11+1
libreoffice-l10n-zh-cn  1:7.2.2-1~bpo11+1
libreoffice-l10n-zh-tw  1:7.2.2-1~bpo11+1
libreoffice-math  1:7.2.2-1~bpo11+1
libreoffice-style-colibre 1:7.2.2-1~bpo11+1
libreoffice-writer  1:7.2.2-1~bpo11+1
libuno-cppu3  1:7.2.2-1~bpo11+1
libuno-cppuhelpergcc3-3 1:7.2.2-1~bpo11+1
libuno-purpenvhelpergcc3-3  1:7.2.2-1~bpo11+1
libuno-sal3 1:7.2.2-1~bpo11+1
libuno-salhelpergcc3-3  1:7.2.2-1~bpo11+1
libvulkan1:amd64  1.2.182.0-2~bpo11+1
linux-compiler-gcc-10-x86 5.14.9-2~bpo11+1
linux-headers-5.14.0-0.bpo.2-amd64  5.14.9-2~bpo11+1
linux-headers-5.14.0-0.bpo.2-common 5.14.9-2~bpo11+1
linux-headers-amd64 5.14.9-2~bpo11+1
linux-image-5.14.0-0.bpo.2-amd64  5.14.9-2~bpo11+1
linux-image-amd64 5.14.9-2~bpo11+1
linux-kbuild-5.14 5.14.9-2~bpo11+1
linux-libc-dev:amd64  5.14.9-2~bpo11+1
manpages-de 4.11.0-2~bpo11+1
manpages-es 4.11.0-2~bpo11+1
manpages-fr 4.11.0-2~bpo11+1
manpages-it 4.11.0-2~bpo11+1
manpages-mk 4.11.0-2~bpo11+1
manpages-nl 4.11.0-2~bpo11+1
manpages-pl 1:4.11.0-2~bpo11+1
manpages-pl-dev 1:4.11.0-2~bpo11+1
manpages-pt-br  4.11.0-2~bpo11+1
manpages-ro 4.11.0-2~bpo11+1
mdadm 4.2~rc2-2~bpo11+1
orca  41.0-1~bpo11+1
python3-brlapi:amd64  6.4-2~bpo11+1
python3-louis 3.19.0-1~bpo11+1
python3-uno 1:7.2.2-1~bpo11+1
qemu-block-extra  1:6.1+dfsg-6~bpo11+1
uno-libs-private  1:7.2.2-1~bpo11+1
ure 1:7.2.2-1~bpo11+1
xbrlapi 6.4-2~bpo11+1
 


je pense qui c est vulkan qui fout le bazar ma carte est une intel hd 4600

Dernière modification par malmsteen (18-11-2021 09:00:37)

Hors ligne

#6 18-11-2021 09:05:16

robert2a
Membre
Distrib. : Buster 10 version 10.11
Noyau : kernel buster backports
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] impossible d installer wine32

grosse erreur , ta debian est moins bien maintenant
répond a mon #4

je laisse faire vv222  pour la suite , mais n'installe plus rien tant que le système est pas propre

effectivement il y a des paquets "vulkan" dans les backports de bullseye , mais pas de libc6 ou de libdrm2 ou de mesa tu a de la chance

Dernière modification par robert2a (18-11-2021 09:20:23)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#7 18-11-2021 09:50:42

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu] impossible d installer wine32

debian:~#  apt-get -s install wine32
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 libgl1 : Dépend: libglx0 (= 1.3.2-1) mais ne sera pas installé
 libglx-mesa0 : Dépend: libgl1-mesa-dri mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
 


 @debian:~$  dpkg --print-architecture
amd64


@debian:~$  dpkg --print-foreign-architectures
i386
 

Hors ligne

#8 18-11-2021 10:45:09

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [résolu] impossible d installer wine32

Tu as deux solutions pour régler ton problème.

En utilisant les backports :

apt install libvulkan1:amd64/bullseye-backports libvulkan1:i386/bullseye-backports


En utilisant les versions stables :

apt install libvulkan1:amd64/bullseye libvulkan1:i386/bullseye


Après ça, wine32 devrait accepter de s’installer wink


Jouer sous Debian ? Facile !

Hors ligne

#9 18-11-2021 19:00:54

malmsteen
Membre
Distrib. : Linux debian 10
Noyau : 4.19.0-8-amd64
(G)UI : MATE
Inscription : 26-01-2016

Re : [résolu] impossible d installer wine32

merci a vous
j ai desactiver le depot backport et j ai reussi a installer wine32 apres avoir installer libvulkan1:amd64/bullseye libvulkan1:i386/bullseye

Hors ligne

Pied de page des forums