Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-11-2021 12:53:50

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

[résolu] Invite de connexion en mauvaise résolution

Bonjour
j'ai deux écrans sur une carte nvidia avec le driver "modesetting"
un 27 pouces et un 19 pouces (le 27 pouces est définit en écran principal )
sur le bureau je suis en mode étendu en résolution native pour les deux écrans
sur l'invite de connexion je suis en mode clone et le 27 pouces a la résolution du 19 pouces
le retour de xrandr (partiel )


Screen 0: minimum 320 x 200, current 3360 x 1080, maximum 16384 x 16384
DVI-D-1 connected 1440x900+1920+0 (normal left inverted right x axis y axis) 410mm x 256mm
   1440x900      59.89*+  74.98  

DP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1440x900      59.89 +  59.90  
   1920x1080     60.00*+  59.96    50.00    59.94    59.93

DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
 


sur DP-1 on voit bien les deux résolutions , et je n'arrive pas a supprimer le "1440x900" , sûrement a cause du mode clone a l'invite de connexion
le xorg.conf que j'utilise


Section "Device"
    Identifier    "Device0"
    Driver        "modesetting"
    BusID        "PCI:9:0:0"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    Modeline "1440x900x59.9"  106.50  1440 1520 1672 1904  900 903 909 934
    Option      "PreferredMode" "1440x900"
EndSection


Section "Monitor"
    Identifier    "Monitor1"
    Modeline "1920x1080x60"  148.50  1920 2008 2052 2200  1080 1084 1089 1125
    Option      "PreferredMode" "1920x1080"
    Option      "LeftOf"        "Monitor0"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection "Display"
        Depth        24
        Modes        "1440x900"
    EndSubSection
EndSection

Section "Screen"
    Identifier    "Screen1"
    Device        "Device0"
    Monitor        "Monitor1"
    DefaultDepth    24
    SubSection "Display"
        Depth        24
        Modes        "1920x1080"
    EndSubSection
EndSection


Section "ServerLayout"
    Identifier    "Layout0"
    Screen     0   "Screen0"
    Screen     1   "Screen1"  LeftOf  "Screen0"
EndSection
 


mon bureau est bien sur 1 (27 pouces) , le 2 (19 pouces) est vide en mode étendu
je pensais que a l'invite de connexion , c'est le serveur X qui fait l'affichage mais a priori non
si quelqu'un a une idée pour forcer le mode étendu au démarrage de la machine , et n'avoir qu'un écran qui affiche l'invite de connexion
a l'allumage de la machine seul le 19 pouces affiche le bios , le menu du grub et le chargement du noyau . (le 27 est éteint )

Dernière modification par robert2a (28-11-2021 16:54:24)

Hors ligne

#2 28-11-2021 13:46:44

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-10-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [résolu] Invite de connexion en mauvaise résolution

Hello,

Une info qui pourrait aider : quel gestionnaire de connexion ? ligthdm, GDM ect ?

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#3 28-11-2021 13:52:10

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Invite de connexion en mauvaise résolution

bookworm avec mate + lightdm
en fait je teste le xorg.conf pour ceci => https://debian-facile.org/viewtopic.php … 90#p370890
en fait sa souris (le curseur) disparaît , elle est en étendu sur l'invite de connexion
et moi en clone sur l'invite de connexion


systemctl status lightdm.service
● lightdm.service - Light Display Manager
     Loaded: loaded (/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2021-11-28 11:24:24 CET; 1h 30min ago
       Docs: man:lightdm(1)
   Main PID: 797 (lightdm)
      Tasks: 6 (limit: 38396)
     Memory: 124.2M
        CPU: 1min 36.749s
     CGroup: /system.slice/lightdm.service
             ├─797 /usr/sbin/lightdm
             └─803 /usr/lib/xorg/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

nov. 28 11:24:24 debian11 systemd[1]: Starting Light Display Manager...
nov. 28 11:24:24 debian11 systemd[1]: Started Light Display Manager.
nov. 28 11:24:25 debian11 lightdm[811]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=107) by (uid=0)
nov. 28 11:24:48 debian11 lightdm[918]: gkr-pam: unable to locate daemon control file
nov. 28 11:24:48 debian11 lightdm[918]: gkr-pam: stashed password to try later in open session
nov. 28 11:24:48 debian11 lightdm[918]: pam_unix(lightdm:session): session opened for user robert(uid=1000) by (uid=0)
nov. 28 11:24:49 debian11 lightdm[918]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring
 

Dernière modification par robert2a (28-11-2021 13:55:36)

Hors ligne

#4 28-11-2021 14:09:05

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-10-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [résolu] Invite de connexion en mauvaise résolution

Peut-être regarder ces options de /etc/lightdm/lightdm.conf :

[LightDM]
...
#minimum-display-number=0
...
[SEAT]
...
# xserver-backend = X backend to use (mir)
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
...
# xserver-share = True if the X server is shared for both greeter and session


Ce n'est qu'un peut-être, je n'ai jamais manipulé ces variables.


Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#5 28-11-2021 14:38:40

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Invite de connexion en mauvaise résolution

moi non plus jamais touché a cela , je vais commencé par regarder si sous  bullseye le même comportement (la je suis sous bookworm)

sans le xorg.conf , le fonctionnement est correct
mon écran principal est le 27 pouces a partir du moment ou j'ai l'invite de connexion et a la bonne résolution
j'ai installé "arandr" il me confirme que tout est correct
ps: si j'ai bien compris "xrandr" a pris une place non négligeable dans le fonctionnement de X (mais je l'utilise pas)
donc pour revenir au souci de départ (curseur souris masqué ) , je pense que ça télé est prioritaire , il suffit de changer ça pour avoir son curseur de souri et l'invite de connexion sur son 19 pouces .
je vais quand même tester mon xorg.conf sur une bullseye avec 2 écrans smile
ps: mais bon ça n'explique pas ce comportement , je sais pas ou est le souci dans le script , puisque sur le bureau c'est correct
nota: dans /home/robert/.config  , j'ai trouvé un fichier monitors.xml  sur bookworm  créé le 28/11 a 7h46

Dernière modification par robert2a (28-11-2021 15:09:22)

Hors ligne

#6 28-11-2021 16:53:52

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Invite de connexion en mauvaise résolution

c'est résolu , le problème de curseur souris et moi le mode clone
testé sur une bullseye aussi , même souci avec deux écrans au premier démarrage

Hors ligne

#7 29-11-2021 08:37:21

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-10-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [résolu] Invite de connexion en mauvaise résolution

Et indiquer la solution pour les autres ?

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#8 29-11-2021 09:27:51

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu] Invite de connexion en mauvaise résolution

Bonjour
bonne question smile
je dirai installer les deux écrans sans xorg.conf
configurer son bureau a l'aide de l'utilitaire du bureau , et de xrandr et arandr
si besoin créer un xorg.conf "cela veut dire du matériel physique qui ne change pas"  pour figer la configuration

nota: pour moi la suppression du xorg.conf , j'ai eu de nouveau un fonctionnement normal
je n'ai pas rechercher le problème mais sûrement un conflit entre les diverses configurations ou un xorg.conf mal former
ps: sinon le xorg.conf a résolu le souci d une invite de connexion sur le bon écran et du curseur de souris centrer sur le même écran ( demande  =>  https://debian-facile.org/viewtopic.php … 90#p370890)

je sais pas si ça répond a ta question  smile

Hors ligne

#9 29-11-2021 09:42:11

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-10-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : [résolu] Invite de connexion en mauvaise résolution

Hello,

Ce n'est pas une exactement une solution mais ça indique la source du souci.
C'est déjà pas mal smile

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

Pied de page des forums