Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-12-2021 16:30:22

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Repertoires virtuels de nginx / /etc/hosts

Hello
Sous SID, nginx

J'ai 2 répertoires virtuels, un pour wordpress et un pour du php "à la main"

cat wordpress.conf
server {
        listen 80;
        listen [::]:80;
        root /var/www/html/wordpress;
        index  index.php index.html index.htm;
        server_name wp-local.local;

        error_log /var/log/nginx/wp-local.local_error.log;
        access_log /var/log/nginx/wp-local.local_access.log;
       
        client_max_body_size 100M;
        location / {
                try_files $uri $uri/ /index.php?$args;
        }
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
}




cat php.conf
server {
        listen 80;
        listen [::]:80;
        root /var/www/html/php;
        index  index.php index.html index.htm;
        server_name php-local.local;

        error_log /var/log/nginx/php-local.local_error.log;
        access_log /var/log/nginx/php-local.local_access.log;
       
        client_max_body_size 100M;
        location / {
                try_files $uri $uri/ /index.php?$args;
        }
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
}




SI je les active un à la fois (sites-enabled), ils sont tous les deux  fonctionnels (accès soit en IP_LOCAL (192.168.0.29/) soit 127.0.0.1

Le truc c'est que ça ne fonctionne pas si j'active les 2. Je tombe toujours sur le même.
Pour se faire j'ai modifié le fichier hosts en ajoutant


192.168.0.29    wp-local.local
192.168.0.29    php-local.local



QUe je saisisse en url wp-local.local ou php-local.local je tombe toujours sur le php-local.local

Vous avez une explication ?

Merci d'avance wink

(PS c'est uniquement pour du dev local sur cette machine, je ne me soucie pas de la sécurité ici)

Dernière modification par cyrille (21-12-2021 16:33:50)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#2 21-12-2021 17:13:44

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

Tu n’as que des liens vers ces deux fichiers dans sites-enabled, ou tu en as aussi d’autres qui pourraient venir parasiter tes tests ?

Jouer sous Debian ? Facile !

En ligne

#3 21-12-2021 17:18:58

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

je n'ai que ces 2 liens
Ai vidé aussi le cache de FF

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#4 21-12-2021 17:44:27

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

Il doit y avoir quelque chose qui m’échappe. Tes fichiers de configuration me semblent corrects, et la méthode d’accès par nom de domaine défini dans /etc/hosts devrait bien t’envoyer sur la configuration correcte en fonction des directives server_name.

J’imagine que tu recharges bien la configuration de nginx (nginx -t && service nginx reload) après chaque modification du contenu de sites-enabled ?

Jouer sous Debian ? Facile !

En ligne

#5 21-12-2021 18:48:58

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

Oui bien sûr mais j'utilse

 systemctl restart nginx


Ce qui marche très bien quand je les active 1 par 1

J’utilisais la même méthode avec apache sans soucis
Il y a à un moyen pour l'obliger à  relire le fichier hosts après modification de celui ci (je me demande s'il ne garde pas l'ancienne en mémoire....) ---> d'où mon idée de vider le cache de FF mais ne semble pas marcher. ...

Dernière modification par cyrille (21-12-2021 18:50:57)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#6 21-12-2021 19:08:20

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

je viens de tester avec
service nginx reload
pas mieux

Mon fichier hosts au complet

cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 valhalla.sid-local  valhalla

127.0.0.1   wp-local.local
127.0.0.1 php-local.local


# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters



Que je saisisse wp-local.local ou php-local.local je tombe sur le repertoire virtuel de php-local.local

Ai du mal à sasir ce qui cloche

Ai essayé avec plusieurs browsers pour être sur qu'il n' y avait rien en cache, mais nada, pas mieux

Dernière modification par cyrille (21-12-2021 19:10:44)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#7 21-12-2021 19:17:35

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

Après avoir cherché sur le net, ai redémarré / flsuhé tout ce qui pouvait l'être

 systemctl is-active systemd-resolved.service &&  systemd-resolve --flush-caches;  systemctl is-active dnsmasq.service &&  systemctl restart dnsmasq.service;  systemctl is-active nscd.service &&  systemctl restart nscd.service ;
inactive
inactive
inactive



Mais pas mieux, à court d'idées...


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#8 21-12-2021 19:33:05

raleur
Membre
Inscription : 03-10-2014

Re : Repertoires virtuels de nginx / /etc/hosts

Au pire, tu peux affecter une adresse IP différente à chaque serveur.

PS : en principe, le fichier hosts ne devrait contenir qu'une seule ligne pour une adresse IP donnée, avec le nom canonique et tous les alias.

Dernière modification par raleur (21-12-2021 19:45:01)


Il vaut mieux montrer que raconter.

En ligne

#9 21-12-2021 19:38:17

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

Merci pour l'astuce Raleur
Dommage car d'après les docs sur le Net ça devrait passer ainsi. M'enfin, j'essaie ta proposition asap wink
Merci

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#10 21-12-2021 21:53:55

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

@raleur
Pas mieux
192.168.0.29     wp-local.local
192.168.0.30    php-local.local

En 29, c'est lip de la machine, ça passe mais pas sur le wordpress sur file sur le second repertoire virtuel
en 30 c'est une ip "inventée" : Firefox ne peut établir de connexion avec le serveur à l’adresse 192.168.0.30.
--> ça me semble normal, l'ip 192.168.0.30 ne correspond rien dans mon réseau

ça semble assez normal
Si je met un 127.0.0.1 pour l'un ou l'autre, pas mieux

SInon je ne comprends pas trop

PS : en principe, le fichier hosts ne devrait contenir qu'une seule ligne pour une adresse IP donnée, avec le nom canonique et tous les alias.



car plein d'how to sur le net semble dire que ça passe

(et sous une autre machine et apache, j'ai pas de soucis)

Dernière modification par cyrille (21-12-2021 21:57:30)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#11 21-12-2021 22:43:02

raleur
Membre
Inscription : 03-10-2014

Re : Repertoires virtuels de nginx / /etc/hosts

Si tu déclares une adresse IP qui n'appartient pas à la machine, ça ne risque pas de marcher. Il y a plus de 16 millions d'adresses disponibles dans la plage de loopback 127.0.0.0/8, tu n'as qu'à te servir.
Et as-tu bien spécifié l'adresse dans la directive "listen" de chaque configuration de serveur ?

Dernière modification par raleur (21-12-2021 22:43:56)


Il vaut mieux montrer que raconter.

En ligne

#12 21-12-2021 23:41:15

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

raleur a écrit :

Si tu déclares une adresse IP qui n'appartient pas à la machine, ça ne risque pas de marcher. Il y a plus de 16 millions d'adresses disponibles dans la plage de loopback 127.0.0.0/8, tu n'as qu'à te servir.
Et as-tu bien spécifié l'adresse dans la directive "listen" de chaque configuration de serveur ?




En directive listen c'est là : https://debian-facile.org/viewtopic.php … 25#p372025

server {
        listen 80;
        listen [::]:80;
....




Et pas mieux avec ce hosts

127.0.0.5   wp-local.local
127.0.0.4 php-local.local




Bref, là ça me dépasse....


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#13 22-12-2021 00:06:14

raleur
Membre
Inscription : 03-10-2014

Re : Repertoires virtuels de nginx / /etc/hosts

cyrille a écrit :

En directive listen c'est là


Et je n'y vois pas de spécification de l'adresse IP à écouter, donc ce que tu mets dans le fichiers hosts ne risque pas d'avoir un effet.


Il vaut mieux montrer que raconter.

En ligne

#14 22-12-2021 00:51:00

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Repertoires virtuels de nginx / /etc/hosts

Bonjour

en boucle locale


server {
        listen 127.0.0.1:80;
 


ps: l' IPv6 tu n'a pas besoin en local

ou a partir du réseau local avec ton IP


server {
        listen 192.168.0.29:80;
 



ta machine a un hostname ?  (etc/hostname)

je le voit pas sur ton fichier "hosts"

Hors ligne

#15 22-12-2021 01:11:38

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : Repertoires virtuels de nginx / /etc/hosts

dans /etc/nsswitch.conf

tu a la ligne "hosts  files dns"
le système va lire en premier ton fichier hosts , puis un dns disponible

et je sais plus si ceci est valide (écouter n'importe quelle adresse ) avec "*"


server {
        listen     *:80;
 

Hors ligne

#16 22-12-2021 09:13:46

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

@robert2a
Alors voilà, j'ai apporté les modfications suivantes, mais rien de mieux



$ cat /etc/hostname
valhalla



 
$ cat /etc/nginx/sites-available/php.conf
server {
        listen 127.0.0.1:80;
        root /var/www/html/php;
        index  index.php index.html index.htm;
        server_name php-local.local;

        error_log /var/log/nginx/php-local.local_error.log;
        access_log /var/log/nginx/php-local.local_access.log;
       
        client_max_body_size 100M;
        location / {
                try_files $uri $uri/ /index.php?$args;
        }
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
}
 



cat /etc/nginx/sites-available/wordpress.conf
server {
        listen 127.0.0.1:80;
        root /var/www/html/wordpress;
        index  index.php index.html index.htm;
        server_name wp-local.local;

        error_log /var/log/nginx/wp-local.local_error.log;
        access_log /var/log/nginx/wp-local.local_access.log;
       
        client_max_body_size 100M;
        location / {
                try_files $uri $uri/ /index.php?$args;
        }
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
}
 





 
$ cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 valhalla.sid-local  valhalla

127.0.0.1   wp-local.local
127.0.0.1 php-local.local


# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
 




$ cat /etc/nsswitch.conf
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         files systemd
group:          files systemd
shadow:         files
gshadow:        files

hosts:          files mdns4_minimal [NOTFOUND=return] dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis
 




@raleur
si je mets
127.0.0.2 sur un site et 127.0.0.3 sur l'autre, ça ne change rien. ça redirige toujours sur php-local.local

En tout cas merci pour l'aide wink

Dernière modification par cyrille (22-12-2021 09:16:33)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#17 22-12-2021 09:39:45

Anonyme
Invité

Re : Repertoires virtuels de nginx / /etc/hosts

Salut,

Pour moi préfixer l'ip du serveur ne sert à rien (si ce n'est que tu ne pourras pas l'atteindre depuis une autre machine).

La syntaxe

listen 80;


est la bonne.


Peux-tu faire :

nginx -t



On dirait que peu importe les modifs que tu fais elles ne sont pas prises en compte.

Ha et…

"/etc/nginx/sites-available/wordpress.conf " tu veux dire "/etc/nginx/sites-enabled/wordpress.conf" non ?

avaible => conf dispo
enabled => conf actives

#18 22-12-2021 09:47:51

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

@Anonyme
Oui j'avais pas préfixer l'ip du serveur, mais on m'a dit qu'il fallait le faire (message de raleur)

root@valhalla:~# ls -l /etc/nginx/sites-available/
total 8
-rw-r--r-- 1 root root 642 22 déc.  08:07 php.conf
-rw-r--r-- 1 root root 645 22 déc.  08:07 wordpress.conf
root@valhalla:~# ls -l /etc/nginx/sites-enabled/
total 0
lrwxrwxrwx 1 root root 35 21 déc.  15:19 php.conf -> /etc/nginx/sites-available/php.conf
lrwxrwxrwx 1 root root 41 21 déc.  18:03 wordpress.conf -> /etc/nginx/sites-available/wordpress.conf
 


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#19 22-12-2021 09:58:08

Anonyme
Invité

Re : Repertoires virtuels de nginx / /etc/hosts

nginx -t donne quoi ?

#20 22-12-2021 10:13:22

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

 nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful


Tout roule pour lui


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#21 22-12-2021 12:41:06

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

Le pire c'est que si je crée un autre block server, ça fonctionne bien
J'ai simplement copier la conf de php.conf et créer un autre répetoire de publication web lui étant associé
Et là pas de soucis...

Par contre ça ne fonctionne toujours pas avec le wordpress.conf

cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 valhalla.sid-local  valhalla

127.0.0.1 php.local
127.0.0.1 php2.local

127.0.0.1 wp-local.local


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#22 22-12-2021 13:04:50

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

A n'y rien comprendre
Ai renomme le wordpress.conf en blog.conf et là ça marche ....

Pour informations j'ai donc ça comme conf

 ls /etc/nginx/sites-available/* | xargs cat
server {
        listen 127.0.0.1:80;
        root /var/www/html/blog;
        index index.php index.html index.htm;
        server_name blog.local;

        error_log /var/log/nginx/blog.local_error.log;
        access_log /var/log/nginx/blog.local_access.log;
       
        client_max_body_size 100M;
        location / {
                try_files $uri $uri/ /index.php?$args;
        }
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
}
server {
        listen 127.0.0.1:80;
        root /var/www/html/php2;
        index  index.php index.html index.htm;
        server_name php2.local;

        error_log /var/log/nginx/php2.local_error.log;
        access_log /var/log/nginx/php2.local_access.log;
       
        client_max_body_size 100M;
        location / {
                try_files $uri $uri/ /index.php?$args;
        }
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
}
server {
        listen 127.0.0.1:80;
        root /var/www/html/php;
        index  index.php index.html index.htm;
        server_name php.local;

        error_log /var/log/nginx/php.local_error.log;
        access_log /var/log/nginx/php.local_access.log;
       
        client_max_body_size 100M;
        location / {
                try_files $uri $uri/ /index.php?$args;
        }
        location ~ \.php$ {
                include snippets/fastcgi-php.conf;
                fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
        }
}




Et

cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 valhalla.sid-local  valhalla

127.0.0.1 php.local
127.0.0.1 php2.local
127.0.0.1 blog.local



# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
 



Merci pour l'aide de tous wink
(y a quand même un truc qui m'échappe...)

-PS passe aussi avec
        listen 80; à la place de listen 127.0.0.1:80;
-

Dernière modification par cyrille (22-12-2021 13:10:15)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#23 22-12-2021 14:00:53

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

cyrille a écrit :

Ai renomme le wordpress.conf en blog.conf et là ça marche ....



Je vois que tu as aussi changé le domaine de "wp-local.local" à "blog.local". Est-ce que tu n’aurais pas un autre bout de configuration qui traîne, peut-être directement dans /etc/nginx/nginx.conf, qui utiliserait le domaine "wp-local.local" et qui aurait pu entrer en conflit avec tes autres tentatives ?


Jouer sous Debian ? Facile !

En ligne

#24 22-12-2021 15:32:05

cyrille
CA Debian-Facile
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

A priori non j'ai tout fouillé.... ça restera un mystère.... Bon finalement ça roule....
ai renommer en me disant que le tiret était peut être en cause (mais dans ce cas pourquoi passait il avec les autres ?)
Enfin, ça marche

Dernière modification par cyrille (22-12-2021 15:33:23)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

En ligne

#25 22-12-2021 17:40:16

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.15 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : Repertoires virtuels de nginx / /etc/hosts

cyrille a écrit :

ai renommer en me disant que le tiret était peut être en cause (mais dans ce cas pourquoi passait il avec les autres ?)


J’y ai pensé un instant, puis j’ai relu le nom de domaine de ce forum tongue


Jouer sous Debian ? Facile !

En ligne

Pied de page des forums