Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-12-2021 16:43:15

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : Linux 5.19.0-1-amd64
(G)UI : Gnome 43.0
Inscription : 07-02-2018

Appariement difficile d'un casque audio [RÉSOLU]

Bonjour,
On m'a offert un casque audio (c'est la saison…), qui fonctionne parfaitement avec un un câble sur la sortie jack. Il est aussi sans-fil. Il apparaît dans les paramètres - Bluetooth. Mais il est impossible de le faire fonctionner : il est signalé comme "Déconnecté". Quand on clique sur son nom, on a bizarrement :

Connexion : off (c'est là qu'il est impossible de maintenir le bouton en position "on")
Appairé : Oui
Type : Casque audio
Adresse : A3:0E:CA:6B:46:1D

Supprimons-le de la liste des périphériques, puis rechargeons Bluetooth. Il revient avec la mention "Connecté" ; mais ce n'est l'affaire que d'une ou deux secondes, avant qu'il soit à nouveau déconnecté.

Passons au Terminal :

# bluetoothctl
Agent registered
[CHG] Device A3:0E:CA:6B:46:1D Connected: yes
[CHG] Device A3:0E:CA:6B:46:1D Connected: no



Puis saisissons : Controller A3:0E:CA:6B:46:1D Pairable: yes

[bluetooth]# Controller A3:0E:CA:6B:46:1D Pairable: yes
Invalid command in menu main: Controller

Use "help" for a list of available commands in a menu.
Use "menu <submenu>" if you want to enter any submenu.
Use "back" if you want to return to menu main.
[CHG] Controller A0:A8:CD:EF:6E:8C Discovering: yes
[CHG] Device A3:0E:CA:6B:46:1D RSSI: -51
 



Et on obtient alors une longue liste avec une variation dans les chiffres finaux : -54 ; -72, etc.

Eh bé…Help, alors…

Merci de vos suggestions

Dernière modification par fred02840 (19-08-2022 17:06:29)


Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#2 25-12-2021 19:02:19

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : Linux 5.19.0-1-amd64
(G)UI : Gnome 43.0
Inscription : 07-02-2018

Re : Appariement difficile d'un casque audio [RÉSOLU]

Je poursuis mes investigations en suivant la page d'Ubuntu consacrée au bluetooth.

D'abord avec rfkill (à installer)

rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
  Soft blocked: no
  Hard blocked: no
2: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
5: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no



On continue avec hcitools

hcitool dev
Devices:
  hci0  A0:A8:CD:EF:6E:8C
 



hcitool inq
Inquiring ...
  E0:51:63:CC:D1:E1 clock offset: 0x3d28  class: 0x380424
  22:22:D3:81:1D:1A clock offset: 0x5cc7  class: 0x280424
  A3:0E:CA:6B:46:1D clock offset: 0x1aa8  class: 0x340404
 


Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#3 25-12-2021 19:04:17

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : Linux 5.19.0-1-amd64
(G)UI : Gnome 43.0
Inscription : 07-02-2018

Re : Appariement difficile d'un casque audio [RÉSOLU]

Bon, toujours rien…

On continue

root@debian:~# killall pulseaudio
pulseaudio: aucun processus trouvé
root@Machin:~# pulseaudio --start
W: [pulseaudio] main.c: Le programme n’est pas conçu pour être lancé en tant que root (sauf si --system est renseigné).
root@Machin:~# exit
déconnexion
Truc@Machin:~$ pulseaudio --start
Truc@Machin:~$ su -
Mot de passe :
root@Machin:~# systemctl restart bluetooth
root@Machin:~#
 



Yes : la connexion est établie. Mais le son ne passe pas : pfff…


Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#4 26-12-2021 20:24:21

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Appariement difficile d'un casque audio [RÉSOLU]

peut être il te faut le paquet pulseaudio-module-bluetooth

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 27-12-2021 15:20:17

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : Linux 5.19.0-1-amd64
(G)UI : Gnome 43.0
Inscription : 07-02-2018

Re : Appariement difficile d'un casque audio [RÉSOLU]

Et pourtant, il est installé. Bizarre. Sur un PC Windows, le son passe par le casque : c'est pas rageant, ça ?
Mais bon, ça ne me dérange pas de refaire la manip', d'autant que je n'ai pas de son avec ce casque en bluetooth

Dernière modification par fred02840 (27-12-2021 15:22:05)


Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

#6 27-12-2021 16:53:28

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Appariement difficile d'un casque audio [RÉSOLU]

Je sais sous Gnome mais moi qui suis sous Mate le pulseaudio a rien a voir avec Xfce par exemple c'est un greffon qui est fourni par l'environnement de Bureau Mate
Y'a peut être un conflit qui vient de la
se que je ferais pour revenir au base c'est voir l'historique apt , purger se qui a été installé en rapport avec pulseaudio
puis relancer tasksel au cas ou un élément a été viré

tasksel


les déplacement se font au clavier , fleches touche tab et barre d'espace pour activer une option


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#7 15-08-2022 19:22:49

fred02840
Membre
Lieu : Aisne
Distrib. : Debian GNU/Linux bookworm/sid
Noyau : Linux 5.19.0-1-amd64
(G)UI : Gnome 43.0
Inscription : 07-02-2018

Re : Appariement difficile d'un casque audio [RÉSOLU]

[Des balises de commande ont disparu lors de la validation : bizarre. Je vais tâcher de les rétablir tout à l'heure…]

Encore le même (désolé…)

Toujours avec ce casque récalcitrant (donc affaire non résolue), qui ne veut pas fonctionner en bluetooth (il ne figure pas parmi les périphériques « son », dans les paramètres). Pas de problème cependant avec un câble ad hoc (double sortie jack) : le mode d'utilisation bluetooth échouant, j'utilise le casque en filaire (pas trop le choix, remarquez…). C'est un modèle de chez Zihnic : un WH-816 (un « Bluetooth Headphone », par dessus le marché…).

@Croutons. Tu m'avais conseillé de de regarder dans l'historique d'apt, mais je ne sais pas comment faire (je vais chercher sans attendre ta réponse). Mais je fais chaque jour une mise à jour complète avec purge systématique à la clé. Pas de problème de dépendances ou de paquets cassés (vérification faite avec Synaptic).

fred@debian:~# aptitude update && aptitude full-upgrade && apt autoremove && aptitude clean && aptitude autoclean && localepurge




`pulseaudio-module-bluetooth` est bien installé.



Pour rappel (et repartir sur de bonnes bases) :

  • je n'ai pas de code à entrer : rien n'était dans la boîte du casque

  • il apparaît bien dans les périphériques bluetooth (paramètres) : WH-816. Mais « déconnecté ».

  • si je clique sur la ligne `WH-816. Déconnecté` : une fenêtre s'ouvre, mais il est impossible d'activer le bouton de connexion. Indications :
         

    • Appairé : Oui
           

    • Type : Casque audio
           

    • Adresse : A3:0E:CA:6B:46:1D
         




Voici la série d'opérations faites à l'instant (au moins pour vérifier ce qui avait déjà été fait précédemment). Cela va être long : merci de votre patience…



Tiens : une adresse différente de celle qui apparaît dans la fenêtre des paramètres bluetooth…


Essayons  de voir les services disponibles



La 2e adresse trouvée ci-dessus correspond donc à autre chose.



On a exactement les mêmes résultats avec `systemctl status bluetooth`.
Dans la deuxième partie (août 15, etc.), il est à noter que ce qui suit les deux-points est en rouge à partir de la deuxième ligne (profiles/sap/server.c:sap_server_register() Sap driver initialization failed.), ce qui n'est pas bon signe. Je remarque aussi que l'adresse de mon casque (hci0    A0:A8:CD:EF:6E:8C) est absente, mais que celle qui a été trouvée avec `hcitool scan` (A3:0E:CA:6B:46:1D)  y est bien; il y aurait d'ailleurs un problème de protocole.
Mais le service bluetooth est actif : c'est déjà un bon point, confirmé par l'instruction suivante :



Ce qui ne m'avance guère, maintenant que je sais que hci0 n'est pas mon casque (c'est phy0 ou tpacpi_bluetooth_sw, alors ?).

Avec d'autres outils :



hci0 repéré (je ne sais toujours pas ce que c'est ), ainsi que la Freebox. On continue…



Eh bien voilà : hci0 est mon propre ordinateur… Tout ça pour ça.

Des informations sur le casque, à partir de son adresse :



Bon, ça fait toujours plaisir, une loquacité pareille… On retourne sur bluetoothctl : il y a des informations intéressantes



Le casque est reconnu, mais l'appariement n'est pas possible (oui : on dit bien « appariement » et non apairement, avec un ou deux « p ». Promis, je vous lâche avec mes réflexes de prof) …



Données de « Features » : là, je patauge… Bon, essayons de voir ce qui coince dans l'appariement : « Failed to pair: org.bluez.Error.AlreadyExists », si vous vous souvenez bien.
Je retrouve le problème avec pulseaudio que soulevait @Croutons : on tue le processus en cours et on relance (rappel : le paquet pulseaudio-module-bluetooth est installé)



Et on repasse en root pour un essai d'appariement :


fred@debian:~# bluetoothctl # info A3:0E:CA:6B:46:1D
Agent registered
[CHG] Controller A0:A8:CD:EF:6E:8C Pairable: yes
[bluetooth]# pair A3:0E:CA:6B:46:1D
Attempting to pair with A3:0E:CA:6B:46:1D
Failed to pair: org.bluez.Error.AlreadyExists
 




Damned… https://unix.stackexchange.com/questions/258074/error-when-trying-to-connect-to-bluetooth-speaker-org-bluez-error-failedIci, on conseille la manip' suivante si la relance de pulseaudio ne donne rien


@debian:~# pactl load-module module-bluetooth-discover
Échec lors de la connexion : Connexion refusée
Échec de pa_context_connect() : Connexion refusée
 



Allons bon… J'ouvre les paramètres bluetooth : le bouton de connexion fonctionne ! Alléluia et toutes ces sortes de choses. vérification :


@debian:~# bluetoothctl
Agent registered
[CHG] Controller A0:A8:CD:EF:6E:8C Pairable: yes
[WH-816]#
 



Ben c'est quoi, cette adresse ?? Mais la connexion se fait (toujours avec l'adresse A3:0E:CA:6B:46:1D).
Mais pas de son : le casque n'apparaît pas dans les périphériques de sortie (désappointement…). Vais-je renoncer ? Eh bé non…


fred@debian:~# pactl load-module module-bluetooth-policy module-bluez5-device module-bluez5-discover
Échec lors de la connexion : Connexion refusée
Échec de pa_context_connect() : Connexion refusée
 



J'ajoute (et enregistre) les deux modules qui manquent dans /etc/pulse/default.pa :


.ifexists module-bluez5-device.so
load-module module-bluez5-device
.endif

.ifexists module-bluez5-discover.so
load-module module-bluez5-discover
.endif
 



Je quitte et relance pulseaudio : toujours pas de son… Et si on ne relance pas pulseaudio ? Rien de mieux.

J'arrête : j'ai faim…

Merci de votre aide.

Dernière modification par fred02840 (22-10-2022 14:13:35)


Lenovo E540 (Intel Core i3) : Debian GNU/Linux bookworm/sid. Gnome 40.4

Très accessoirement : Debian 10 Buster sur un MacBook Pro 6,4 (mi-2010), 15'', mod. A1286 (ah mais...) et une Debian 9 sur une eMachines (Intel Atom N455, 1Go de Ram, et 250 Go. LXDE minimale).

Hors ligne

Pied de page des forums