Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-12-2021 19:42:59

chtr
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64
(G)UI : LXDE
Inscription : 30-06-2012
Site Web

Problème VPN

Bonjour à toutes et tous,

J'ai installé il y a un petit moment RiseupVPN sous Buster.
Je l'ai installé sous forme de snap de la façon suivante:

apt install snapd


snap install --classic riseup-vpn



Le VPN fonctionnait parfaitement après la migration vers Bullseye
jusqu'à une mise à jour du VPN. Aujourd’hui il ne se lance plus.

J'ai trouvé sur une page Riseup que cette commande pourrait identifier
le problème. C'est bien possible, mais je ne sais pas l'interpréter.

/snap/bin/riseup-vpn.launcher


No systray icon available.
qml: flavor: riseup-vpn
QSystemTrayIcon::setVisible: No Icon set
2021/12/30 18:21:37 Client expects anon auth
2021/12/30 18:21:37 Fetching MOTD for riseup.net
qml: delay...
2021/12/30 18:21:39 There are 1 pending messages
2021/12/30 18:21:39 firewall stop
2021/12/30 18:21:42 Getting certificate...
2021/12/30 18:21:42 Fetching certificate to /tmp/leap-458187953/openvpn.pem
2021/12/30 18:21:42 Fetching gateways...
2021/12/30 18:21:44 DEBUG We have a valid cert: /tmp/leap-458187953/openvpn.pem
2021/12/30 18:21:44 Got sorted gateways: [hirondelle.riseup.net hoatzin.riseup.net mouette.riseup.net fournier.riseup.net pie.riseup.net zarapito.riseup.net mockingjay.riseup.net hornero.riseup.net shag.riseup.net redshank.riseup.net yal.riseup.net gaei.riseup.net starling.riseup.net crane.riseup.net limpkin.riseup.net garza.riseup.net]
2021/12/30 18:21:44 Got sorted gateways: [hoatzin.riseup.net fournier.riseup.net pie.riseup.net hirondelle.riseup.net zarapito.riseup.net mouette.riseup.net hornero.riseup.net redshank.riseup.net shag.riseup.net mockingjay.riseup.net gaei.riseup.net yal.riseup.net starling.riseup.net limpkin.riseup.net crane.riseup.net garza.riseup.net]
2021/12/30 18:21:44 args passed to bitmask-root: [--cipher AES-128-CBC --keepalive 10 30 --tls-cipher DHE-RSA-AES128-SHA --tun-ipv6 --auth SHA1]
2021/12/30 18:21:44 firewall start
2021/12/30 18:21:46 openvpn start:  [--cipher AES-128-CBC --keepalive 10 30 --tls-cipher DHE-RSA-AES128-SHA --tun-ipv6 --auth SHA1 --remote 212.83.143.67 443 tcp4 --remote 212.129.4.124 443 tcp4 --remote 212.83.146.228 443 tcp4 --verb 3 --management-client --management 127.0.0.1 6061 --ca /tmp/leap-458187953/cacert.pem --cert /tmp/leap-458187953/openvpn.pem --key /tmp/leap-458187953/openvpn.pem --persist-tun --float]
qml: show motd
qml: configured locale: fr
qml: platform: linux
2021/12/30 18:21:47 New connection into the management
2021/12/30 18:21:47 Event: INFO: OpenVPN Management Interface Version 1 -- type 'help' for more info
2021/12/30 18:21:48 Event: WAIT
2021/12/30 18:21:48 Event: AUTH
2021/12/30 18:21:50 Event: GET_CONFIG
2021/12/30 18:21:50 Event: ASSIGN_IP: 10.41.0.96
2021/12/30 18:21:50 Event: CONNECTED: 212.83.143.67
2021/12/30 18:21:50 Connected to gateway: hoatzin.riseup.net
 



Une fois que cette commande est entrée, le terminal semble attendre quelque
chose et une interface graphique de Risuep s'ouvre avec un lien qui amène ici:
https://riseupstatus.net/
Bien que mon anglais soit médiocre il semble m’annoncer que les utilisateurs de
Windows doivent effectuer une mise à jour pour se connecter. Parfait, j'ai bien
essayé il y a quelque temps d'installer Wine. Ayant trouvé le moyen de faire ce
que je voulais faire sans ce logiciel, je l'ai supprimé.

Si vous avez une idée, je suis preneur. Merci à vous.
Bonne soirée.
chris


Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#2 31-12-2021 17:40:40

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problème VPN

Bonjour Chtr,
je n'ai pas de soucis particulier ces jours-ci avec ce logiciel. La page de ton lien indique, en ce moment, que le VPN  de Windows est en maintenance. Ça ne concerne pas Linux : Sur Bullseye, pas de soucis de connexion. Mais peut-être que cela ne marchait pas hier soir et que c'est rétabli maintenant.

Hors ligne

#3 31-12-2021 17:52:34

chtr
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64
(G)UI : LXDE
Inscription : 30-06-2012
Site Web

Re : Problème VPN

Bonjour à vous, bonjour potemkim,

Merci pour le coup de main.
Je pense que ça vient de mon ordi et pas de Riseup.
Je continu mes investigation.
Salutation
chris

Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#4 02-01-2022 21:57:34

chtr
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64
(G)UI : LXDE
Inscription : 30-06-2012
Site Web

Re : Problème VPN

Salut à vous,

Le vpn fonctionne et il est fort possible qu'il ait toujours fonctionné.
Le truc un peu chiant est qu'il n'y a plus d'interface graphique au
démarrage de l'ordi, pas d'icone non plus pour l'ouvrir. Le seul
moyen que j'ai trouvé pour y avoir accès est cette commande
qui oblige à laisser le terminal ouvert en attente de je ne sais quoi.
Si je ferme le terminal l'interface du vpn en fait de même.
Peut-être avez-vous une solution?

/snap/bin/riseup-vpn.launcher


No systray icon available.
qml: flavor: riseup-vpn
QSystemTrayIcon::setVisible: No Icon set
2022/01/02 22:00:55 Client expects anon auth
2022/01/02 22:00:55 Fetching MOTD for riseup.net
qml: delay...
2022/01/02 22:01:15 WARN Error fetching json from https://static.riseup.net/vpn/motd.json
2022/01/02 22:01:15 firewall stop
2022/01/02 22:01:17 Use transport Obfs4
2022/01/02 22:01:17 Setting transport to obfs4
2022/01/02 22:01:17 Fetching gateways...
qml: status off
2022/01/02 22:01:19 Got sorted gateways: [zarapito.riseup.net hoatzin.riseup.net mouette.riseup.net fournier.riseup.net pie.riseup.net hirondelle.riseup.net redshank.riseup.net mockingjay.riseup.net shag.riseup.net hornero.riseup.net starling.riseup.net yal.riseup.net gaei.riseup.net crane.riseup.net limpkin.riseup.net garza.riseup.net]
2022/01/02 22:01:23 Getting certificate...
2022/01/02 22:01:23 Fetching certificate to /tmp/leap-350521441/openvpn.pem
qml: status off
qml: status off
2022/01/02 22:01:24 DEBUG We have a valid cert: /tmp/leap-350521441/openvpn.pem
2022/01/02 22:01:24 Selected Gateway: yal.riseup.net 199.58.83.10
2022/01/02 22:01:24 Connected via obfs4 to 199.58.83.10 ( yal.riseup.net )
2022/01/02 22:01:24 firewall start
2022/01/02 22:01:25 openvpn start:  [--auth SHA1 --cipher AES-128-CBC --keepalive 10 30 --tls-cipher DHE-RSA-AES128-SHA --tun-ipv6 --float  --remote 127.0.0.1 4430 tcp4 --route 199.58.83.10 255.255.255.255 net_gateway --verb 3 --management-client --management 127.0.0.1 6061 --ca /tmp/leap-350521441/cacert.pem --cert /tmp/leap-350521441/openvpn.pem --key /tmp/leap-350521441/openvpn.pem --persist-tun --float]
2022/01/02 22:01:25 New connection into the management
2022/01/02 22:01:26 Event: INFO: OpenVPN Management Interface Version 1 -- type 'help' for more info
2022/01/02 22:01:26 Event: AUTH
2022/01/02 22:01:28 Event: GET_CONFIG
2022/01/02 22:01:28 Event: ASSIGN_IP: 10.41.0.126
2022/01/02 22:01:28 Event: ADD_ROUTES
2022/01/02 22:01:28 Event: CONNECTED: 127.0.0.1



Merci bien.
chris

Dernière modification par chtr (02-01-2022 23:02:16)


Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#5 03-01-2022 11:56:52

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème VPN

Hello
normalement c'est lxpanel qui affiche les icones dans la zone de notification
tu devrais avoir le petit icone vert en forme bouclier quand tu est connecté
le message semble indiqué qu'il n'y a pas d'icone de disponible et qu'il n'a pas été défini
la ligne qui lance le vpn

env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/riseup-vpn_riseup-vpn.desktop /snap/bin/riseup-vpn.launcher



Voici l'emplacement du lanceur ainsi que son contenu

cat /usr/share/applications/applications/riseup-vpn_riseup-vpn.desktop


[Desktop Entry]
X-SnapInstanceName=riseup-vpn
Version=1.0
Type=Application
Name=RiseupVPN
Comment=Anonymous VPN
Comment[es]=VPN Anonima
Comment[de]=Anonymous VPN
Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/riseup-vpn_riseup-vpn.desktop /snap/bin/riseup-vpn.launcher
Terminal=false
Icon=/snap/riseup-vpn/179/meta/gui/riseup-vpn.png
Categories=Network;Application;
StartupNotify=true
Keywords=VPN;Riseup;leap



ls -l /usr/share/applications/applications/riseup-vpn_riseup-vpn.desktop


-rwxr-xr-x 1 root root 432  3 janv. 10:35 /usr/share/applications/applications/riseup-vpn_riseup-vpn.desktop



l'icone apparait dans la catégorie internet (un bouclier bleu avec un oiseau noir)

Dernière modification par Croutons (03-01-2022 12:26:06)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#6 03-01-2022 12:34:14

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problème VPN

Bonjour Chtr,

Le truc un peu chiant est qu'il n'y a plus d'interface graphique


J'ai eu le même soucis de perte d'icône et j'ai remplacé le Snap par le paquet Debian pour résoudre le problème.
Quant à l'absence d'interface (celle de Bitmask ?) et la désactivation du vpn par le terminal, c'est pas nouveau chez moi ; c'est dommage mais bon...Je fais avec. En fait, Je n'ai cherché bien loin,  c'est suffisant pour mon usage.

Hors ligne

#7 03-01-2022 13:18:46

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème VPN

potemkine17 a écrit :

j'ai remplacé le Snap par le paquet Debian pour résoudre le problème


y'a rien après Buster apparemment


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#8 03-01-2022 13:24:25

potemkine17
Membre
Distrib. : Débian Bullseye
Noyau : amd64
(G)UI : Mate
Inscription : 17-09-2014

Re : Problème VPN

Bonjour Crouton,
J'ai contourné le problème en utilisant le depot Leap de Buster, justement. En attendant une hypothétique mise-à-niveau du paquet sur Bullseye.

Hors ligne

#9 05-01-2022 21:05:19

chtr
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64
(G)UI : LXDE
Inscription : 30-06-2012
Site Web

Re : Problème VPN

Bonjour à vous,

J'ai donc remplacé le Snap par le paquet Debian en faisant ceci:

apt install leap-archive-keyring
echo "deb https://deb.leap.se/client release buster" | tee -a /etc/apt/sources.list.d/leap.list
apt update
apt install riseup-vpn


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
leap-archive-keyring est déjà la version la plus récente (2017.11.24+nmu1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
deb https://deb.leap.se/client release buster
Atteint :1 http://deb.debian.org/debian bullseye InRelease
Atteint :2 http://deb.debian.org/debian-security bullseye-security InRelease  
Atteint :3 http://deb.debian.org/debian bullseye-updates InRelease            
Atteint :4 https://brave-browser-apt-release.s3.brave.com stable InRelease    
Réception de :5 https://deb.leap.se/client release InRelease [22,7 kB]        
Réception de :6 https://deb.leap.se/client release/buster amd64 Packages [8320 B]
Réception de :7 https://deb.leap.se/client release/buster i386 Packages [4651 B]
35,6 ko réceptionnés en 3s (13,4 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 riseup-vpn : Dépend: libappindicator3-1 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».



Il persiste visiblement un petit souci que je ne parvient pas régler.
Peut-être est-ce dû au fait que l'ordi fonctionne avec Bullseye.

J'avais longuement hésiter à passer sous Débian 11, tout simplement
parce que mon vieux coucou fonctionnait très bien et n'était pas trop lent.
Bullseye qui est probablement très bien me semble moins adapté a mon
vielle ordi. C'est pas grave, ça me permet de mettre les mains dans le cambouis.

Salutation
chris


Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#10 06-01-2022 12:38:28

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : Problème VPN

oui libappindicator3-1 n'existe plus sous Bullseye
je sais pas comment potemkin17 a contourné le problème
toujours est il que la version snap fonction bien chez moi en machine virtuel j'ai l’icône dans la barre des taches
D'ailleurs si riseup-vpn est pas lancé au démarrage y'a plus d'internet big_smile
Doit on vraiment faire confiance a se VPN?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 06-01-2022 19:17:42

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.4
Noyau : 5.10.0-16-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : Problème VPN

Pour  libappindicator3-1 normalement ça devrait le faire en installant
1- libindicator3-7_0.5.0-4_amd64.deb https://packages.debian.org/buster/libindicator3-7
2- libappindicator3-1_0.4.92-7_amd64.deb (Depends:libindicator3-7 ) https://packages.debian.org/oldstable/l … dicator3-1

--
Jc E

Hors ligne

#12 06-01-2022 21:34:04

chtr
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64
(G)UI : LXDE
Inscription : 30-06-2012
Site Web

Re : Problème VPN

Bonjour à toutes et tous,

Toujours pas de vpn mais voici la suite des événements,
j'ai d'abord ajouté une ligne au fichier /etc/apt/sources.list

cat /etc/apt/sources.list
 


deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib

deb http://ftp.de.debian.org/debian buster main
 



Ce qui m'a permis d'installer:

apt install libappindicator3-1


apt install libindicator3-7



Pour autant toujours rien.
Merci de votre coup de main.
chris


Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#13 06-01-2022 22:08:45

jce76350
Membre
Lieu : Rouen
Distrib. : Debian_Bullseye 11.4
Noyau : 5.10.0-16-amd64
(G)UI : XFCE
Inscription : 24-08-2016
Site Web

Re : Problème VPN

Pas obliger de modifier le sources.list il suffit de télécharger les 2 fichiers *.deb donnés par les liens wink

EDIT
lien direct amd64
libappindicator3-1
libindicator3-7

Dernière modification par jce76350 (08-01-2022 20:48:34)


--
Jc E

Hors ligne

#14 06-01-2022 22:54:41

chtr
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64
(G)UI : LXDE
Inscription : 30-06-2012
Site Web

Re : Problème VPN

Bon, j'ai supprimé les lignes qui s'étaient mises dans

/etc/apt/sources.list.d/leap.list


et supprimé la ligne dans

cat /etc/apt/sources.list


Par contre, il n'est pourtant pas très tard, mais je ne vois pas de fichiers .deb sur les liensscratchhead.gif

chris


Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

#15 07-01-2022 00:20:04

solar66
Membre
Distrib. : debian stable
Noyau : Linux 5.10.0-9-amd64
(G)UI : cinnamon
Inscription : 23-08-2016

Re : Problème VPN

tu déroules les pages indiquées et tu auras en bas les liens de téléchargement

Dernière modification par solar66 (07-01-2022 00:20:47)

Hors ligne

#16 08-01-2022 13:50:03

chtr
Membre
Distrib. : Bullseye 11.1
Noyau : Linux 5.10.0-9-amd64
(G)UI : LXDE
Inscription : 30-06-2012
Site Web

Re : Problème VPN

Salut à vous,

J’essaierai depuis un autre navigateur parce depuis Brave quand
je clic sur le lien un nouvel onglet s'ouvre mais une fraction de
seconde seulement. Affaire à suivre...

Merci bien.
chris

Ma patrie c'est le monde, ma famille c'est l'humanité.

Hors ligne

Pied de page des forums