Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-12-2021 11:39:02

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

[résolu]Erreur "warning: current package is openjdk-11"

Bonjour
mise a jour ce matin sur testing (bookworm)


Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 189220 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../0-openssh-client_1%3a8.7p1-4_amd64.deb ...
Dépaquetage de openssh-client (1:8.7p1-4) sur (1:8.7p1-2) ...
Préparation du dépaquetage de .../1-libpipeline1_1.5.4-2_amd64.deb ...
Dépaquetage de libpipeline1:amd64 (1.5.4-2) sur (1.5.4-1) ...
Préparation du dépaquetage de .../2-binfmt-support_2.2.1-2_amd64.deb ...
Dépaquetage de binfmt-support (2.2.1-2) sur (2.2.1-1) ...
Préparation du dépaquetage de .../3-libssh-gcrypt-4_0.9.6-2_amd64.deb ...
Dépaquetage de libssh-gcrypt-4:amd64 (0.9.6-2) sur (0.9.6-1) ...
Préparation du dépaquetage de .../4-python-six_1.16.0-3_all.deb ...
Dépaquetage de python-six (1.16.0-3) sur (1.16.0-2) ...
Préparation du dépaquetage de .../5-python3-six_1.16.0-3_all.deb ...
Dépaquetage de python3-six (1.16.0-3) sur (1.16.0-2) ...
Préparation du dépaquetage de .../6-usb.ids_2021.12.24-1_all.deb ...
Dépaquetage de usb.ids (2021.12.24-1) sur (2021.07.19-1) ...
Paramétrage de libssh-gcrypt-4:amd64 (0.9.6-2) ...
Paramétrage de libpipeline1:amd64 (1.5.4-2) ...
Paramétrage de openssh-client (1:8.7p1-4) ...
Paramétrage de python-six (1.16.0-3) ...
Paramétrage de python3-six (1.16.0-3) ...
Paramétrage de usb.ids (2021.12.24-1) ...
Paramétrage de binfmt-support (2.2.1-2) ...
update-binfmts: warning: current package is openjdk-11, but binary format already installed by openjdk-8
Traitement des actions différées (« triggers ») pour man-db (2.9.4-2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.33-1) ...
 



la description du paquet "binfmt-support"


Le module de noyau binfmt_misc, inclus dans les versions 2.1.43 et
suivantes du noyau Linux, permet aux administrateurs systèmes de recenser
les interpréteurs des différents formats binaires à partir d'un nombre
magique ou de leur extension et fait que l'interpréteur approprié est
appelé lorsqu'un fichier correspondant est exécuté. Considérez-le comme une
version plus flexible du mécanisme d'interpréteur exécutable #!.

Ce paquet fournit un script « update-binfmts » avec lequel les responsables
de paquet peuvent enregistrer les interpréteurs devant être utilisés dans
ce module sans se préoccuper de l'écriture de leurs propres scripts init.d
et que les administrateurs systèmes peuvent utiliser comme interface
d'assez haut niveau pour ce module.
 



je dois faire quoi ? ,  pour résoudre ceci "but binary format already installed by openjdk-8"
ps: j'ai un driver nvidia , mais le paquet du driver n'est pas installé


nvidia-openjdk-8 jre
 



apt policy nvidia-openjdk-8-jre
nvidia-openjdk-8-jre:
  Installé : (aucun)
  Candidat : 9.+8u312-b07-1~11.4.3-1+b1
 Table de version :
     9.+8u312-b07-1~11.4.3-1+b1 500
        500 https://deb.debian.org/debian bookworm/non-free amd64 Packages
 


je vois pas trop ou est le souci  roll , si quelqu'un a une idée

Dernière modification par robert2a (01-01-2022 00:39:41)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#2 31-12-2021 12:00:57

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.19 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : [résolu]Erreur "warning: current package is openjdk-11"

Tu as probablement les deux paquets openjdk-8-jre et openjdk-11-jre qui sont installés. Si c’est le cas la version 8 n’est plus d’actualité depuis longtemps.

Jouer sous Debian ? Facile !

En ligne

#3 31-12-2021 16:26:42

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu]Erreur "warning: current package is openjdk-11"

pas de "openjdk-8-jre" installé , suivi les liens que du "openjdk-11-jre" installé
commencer  a virer le  "openjdk-11-jre"
puis a coup de "rm" enlever ce que j'ai pu


update-binfmts --display
llvm-11-runtime.binfmt (enabled):
     package = llvm-11-runtime
        type = magic
      offset = 0
       magic = BC
        mask =
 interpreter = /usr/bin/lli-11
    detector =
llvm-13-runtime.binfmt (enabled):
     package = llvm-13-runtime
        type = magic
      offset = 0
       magic = BC
        mask =
 interpreter = /usr/bin/lli-13
    detector =
python2.7 (enabled):
     package = python2.7
        type = magic
      offset = 0
       magic = \x03\xf3\x0d\x0a
        mask =
 interpreter = /usr/bin/python2.7
    detector =
python3.9 (enabled):
     package = python3.9
        type = magic
      offset = 0
       magic = \x61\x0d\x0d\x0a
        mask =
 interpreter = /usr/bin/python3.9
    detector =
 


pour moi c'est un bug
ps: sur une installation récente pas de soucis , c'est sur des machines (plusieurs) qui ont migrer (peut être plusieurs fois )
a priori java n'est pas indispensable ?

remarque: il y a la commande "--remove" mais ne fonctionne pas , me demande le dossier qui n'existe pas (et ou le fichier) a supprimer
tous les liens correct , mais qui pointe sur la version "11"
pas très propre ce que j'ai fait , mais pas trouver la bonne méthode

Dernière modification par robert2a (31-12-2021 16:28:25)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#4 01-01-2022 00:41:11

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu]Erreur "warning: current package is openjdk-11"

suffit de supprimer le paquet "binfmt-support"

nota: il semblerai que ce soit (en autre ) une dépendance de wine (wine-binfmt)

Dernière modification par robert2a (01-01-2022 01:20:34)


Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

#5 02-01-2022 12:01:34

robert2a
Membre
Distrib. : Bookworm version 12
Noyau : kernel 6.x.x
(G)UI : Mate
Inscription : 15-11-2014

Re : [résolu]Erreur "warning: current package is openjdk-11"

Bonjour
j'ai installé  le minimum "jre" 11 , la ou libreoffice est installé , il a perdu des choses , je ne l'utilise pas beaucoup
je sais pas pourquoi ce bug , mais sur , aucune trace de la version 8  sur les machines

Machines : kabylake I7 7700 , AMD 1700(X) ,AMD threadripper gen1 , AMD Raven R3 2200G , AMD FX(tm)-8320

Hors ligne

Pied de page des forums