Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-01-2022 03:01:00

sarti
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Metacity (Gnome)
Inscription : 24-03-2020

[Résolu] Impossible de se connecter au Wi-Fi

Bonjour à tous, big_smile

Je vous contacte car je viens d'installer Debian 11 (kernel 5.10) et je n'arrive pas à me connecter au réseau wifi. J'ai une carte Intel AX210 : https://www.intel.fr/content/www/fr/fr/ … eless.html

Dans l'ordre croissant j'ai fait cela :

***** Installation de iwlwifi *****
- Ajout de "contrib non-free" en faisant

su -

nano /etc/apt/sources.list

apt update && apt install firmware-iwlwifi

modprobe -r iwlwifi ; modprobe iwlwifi

systemctl reboot



***** Pour les firmwares *****
- J'ai récupéré la dernière version de linux-firmware.git à https://git.kernel.org/pub/scm/linux/ke … rmware.git
- J'ai extrait l'archive
- J'ai ouvert un terminal dans le dossier avec tous les firmwares puis

sudo cp iwlwifi-ty-a0-gf-a0-59.ucode /lib/firmware/

sudo systemctl reboot



Au final, aucune trace du wifi....
o30q.png

Que faire ? sad
Je vous remercie par avance. smile

Dernière modification par sarti (08-01-2022 03:56:13)

Hors ligne

#2 06-01-2022 09:31:37

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Impossible de se connecter au Wi-Fi

Bonjour
Regarde cette doc https://debian-facile.org/doc:materiel:wifi:detecter et poste le retour des commandes dont elle parle.
ça permettra sans doute d'identifier le soucis
++

Dernière modification par cyrille (06-01-2022 09:31:55)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#3 06-01-2022 19:25:56

sarti
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Metacity (Gnome)
Inscription : 24-03-2020

Re : [Résolu] Impossible de se connecter au Wi-Fi

Justement, j'ai suivi cette page. Tous les firmwares étaient OK, rien ne manquait, aucune erreur. Mais la carte n'était toujours pas reconnue / utilisable par le système avec la commande "ip a". roll

Bien qu'Intel indique qu'elle est compatible dès le kernel 5.10, dans les faits il semblerait qu'il faille avoir le kernel 5.11 pour profiter du Wi-Fi 6E. Je me suis donc tourné vers Ubuntu 21.10 qui utilise le kernel 5.13, et là RAS carte Wi-Fi détectée / reconnue et utilisable.

Je vais patienter que Debian intègre ce kernel pour revenir. smile

Merci de ton aide !

Hors ligne

#4 06-01-2022 19:34:54

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Impossible de se connecter au Wi-Fi

Si tu actives les backports, tu pourras bénéficier d'un kernel 5.14

https://wiki.debian.org/fr/Backports

ragnarok@debian11Vbox:~$ uname -a
Linux debian11Vbox 5.14.0-0.bpo.2-amd64 #1 SMP Debian 5.14.9-2~bpo11+1 (2021-10-10) x86_64 GNU/Linux


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#5 06-01-2022 19:47:14

sarti
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Metacity (Gnome)
Inscription : 24-03-2020

Re : [Résolu] Impossible de se connecter au Wi-Fi

Je vais regarder. On peut repasser ensuite à une version stable sans mal ?

Hors ligne

#6 06-01-2022 19:54:26

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Impossible de se connecter au Wi-Fi

Les backports t'offrent des paquets plus récents. Ce n'est pas une version différente de la stable. ça reste une debian stable. Ce n'est pas du pinning
Au pire si le kernel pose soucis  (ce qui m'étonnerait), au boot, lors de l'invite du grub, tu pourras toujours booter sans un kernel de version précédente

"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#7 06-01-2022 20:07:03

sarti
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Metacity (Gnome)
Inscription : 24-03-2020

Re : [Résolu] Impossible de se connecter au Wi-Fi

OK merci je vais regarder ça. Car même si Ubuntu fait le taf, j'avoue avoir une préférence pour Debian.

Hors ligne

#8 06-01-2022 20:11:34

cyrille
CA Debian-Facile
Lieu : Nowhere
Distrib. : SID + FreeBSD. Stable sur serveurs.
(G)UI : Xfce/Openbox
Inscription : 21-06-2020
Site Web

Re : [Résolu] Impossible de se connecter au Wi-Fi

Tu m'étonnes wink
(niveau éthique, c'est légèrement différent ...)

Dernière modification par cyrille (06-01-2022 20:12:10)


"Ils ne me comprennent point, je ne suis pas la bouche qu’il faut à ces oreilles."

Association Debian-Facile | Les cahiers du débutant | ISO Debian-FacilePage perso. sur #df

Hors ligne

#9 06-01-2022 21:05:30

sarti
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Metacity (Gnome)
Inscription : 24-03-2020

Re : [Résolu] Impossible de se connecter au Wi-Fi

Tout à fait. smile

Bon on est bon je suis en kernel 5,14. Je touche au but. big_smile

Voilà ce que j'ai avec les différentes commandes :

ip a



Me donne :

6: wlp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 84:14:4d:07:15:39 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.100/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp4s0
       valid_lft 43sec preferred_lft 43sec
    inet6 fd54:9209:9147:7700:bed9:7cd2:d377:5407/64 scope global dynamic noprefixroute
       valid_lft 7142sec preferred_lft 3542sec
    inet6 fe80::2233:91c:2764:db8e/64 scope link noprefixroute
       valid_lft forever preferred_lft forever



Du coup j'enchaîne avec :

dmesg | grep firmware



Et là c'est le drame :

[  321.881564] iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-ty-a0-gf-a0-64.ucode (-2)
[  321.881571] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-64.ucode failed with error -2
[  321.881585] iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-ty-a0-gf-a0-63.ucode (-2)
[  321.881587] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-63.ucode failed with error -2
[  321.881976] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0-62.ucode
[  321.882366] iwlwifi 0000:04:00.0: loaded firmware version 62.49eeb572.0 ty-a0-gf-a0-62.ucode op_mode iwlmvm
[  321.882380] iwlwifi 0000:04:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
[  322.031319] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0.pnvm
[  323.170539] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  325.624024] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  326.077604] iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-ty-a0-gf-a0-64.ucode (-2)
[  326.077612] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-64.ucode failed with error -2
[  326.077625] iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-ty-a0-gf-a0-63.ucode (-2)
[  326.077628] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-63.ucode failed with error -2
[  326.077977] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0-62.ucode
[  326.078339] iwlwifi 0000:04:00.0: loaded firmware version 62.49eeb572.0 ty-a0-gf-a0-62.ucode op_mode iwlmvm
[  326.078353] iwlwifi 0000:04:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
[  326.227531] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0.pnvm
[  326.627674] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  327.846985] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  345.578975] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  351.624857] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  386.459720] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  387.394141] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  387.617833] iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-ty-a0-gf-a0-64.ucode (-2)
[  387.617841] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-64.ucode failed with error -2
[  387.617853] iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-ty-a0-gf-a0-63.ucode (-2)
[  387.617855] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-63.ucode failed with error -2
[  387.618186] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0-62.ucode
[  387.618555] iwlwifi 0000:04:00.0: loaded firmware version 62.49eeb572.0 ty-a0-gf-a0-62.ucode op_mode iwlmvm
[  387.618567] iwlwifi 0000:04:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
[  387.768854] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0.pnvm
[  388.928869] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode
[  405.822946] iwlwifi 0000:04:00.0: Loaded firmware version: 62.49eeb572.0 ty-a0-gf-a0-62.ucode



Concrètement il me manque les firmware : https://git.kernel.org/pub/scm/linux/ke … rmware.git

J'ai installé le paquet git. Comment faire pour récupérer le fichier et installer les firmwares ? Comme ça ?

git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git



Mais avec quelle ligne de commande copier ensuite les fichiers dans /lib/firmware ?

Encore merci.

Hors ligne

#10 07-01-2022 02:50:06

sarti
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Metacity (Gnome)
Inscription : 24-03-2020

Re : [Résolu] Impossible de se connecter au Wi-Fi

Bon ça semble marcher.

J'ai téléchargé la dernière version disponible : linux-firmware-20211216.tar.gz

Puis j'ai extrait le contenu dans un dossier "firmware". Et j'ai copié le tout par un :

cp -r /home/usr/firmware /lib/firmware


C'est peut-être un peu "bâtard" comme méthode, mais ça a marché.

Puis j'ai redémarré et j'avais toujours :

firmware: failed to load iwl-debug-yoyo.bin (-2)



J'ai donc fait ce qui a été recommandé là : https://forums.debian.net/viewtopic.php?t=149817

nano /etc/modprobe.d/iwlwifi.conf


Et y copier :

options iwlwifi enable_ini=N



De nouveau, redémarrage du système. Puis vérification :

dmesg | grep firmware


[    0.068440] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    1.995256] psmouse serio4: elantech: assuming hardware version 4 (with firmware version 0x381f00)
[    4.007210] platform regulatory.0: firmware: direct-loading firmware regulatory.db
[    4.007511] platform regulatory.0: firmware: direct-loading firmware regulatory.db.p7s
[    4.147125] iwlwifi 0000:04:00.0: firmware: failed to load iwlwifi-ty-a0-gf-a0-64.ucode (-2)
[    4.147130] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[    4.147131] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-ty-a0-gf-a0-64.ucode failed with error -2
[    4.151847] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0-63.ucode
[    4.152256] iwlwifi 0000:04:00.0: loaded firmware version 63.c04f3485.0 ty-a0-gf-a0-63.ucode op_mode iwlmvm
[    4.402698] iwlwifi 0000:04:00.0: Allocated 0x00400000 bytes for firmware monitor.
[    4.545752] iwlwifi 0000:04:00.0: firmware: direct-loading firmware iwlwifi-ty-a0-gf-a0.pnvm
[    4.595904] bluetooth hci0: firmware: direct-loading firmware intel/ibt-0041-0041.sfi
[    4.595910] Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi
[    4.738032] r8169 0000:05:00.1: firmware: direct-loading firmware rtl_nic/rtl8411-2.fw



Me reste plus qu'à trouver "iwlwifi-ty-a0-gf-a0-64.ucode", introuvable..... en attendant le débit semble bon. smile
o9c3.png

En espérant ne plus être embêté. Encore merci pour ton aide.

Hors ligne

#11 19-01-2022 14:17:31

sarti
Membre
Distrib. : Debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : Metacity (Gnome)
Inscription : 24-03-2020

Re : [Résolu] Impossible de se connecter au Wi-Fi

Bon ce fut de courte durée. Avec la MAJ vers le kernel 5.15, la carte Wi-Fi ne fonctionne plus. Obligé de rester avec 5.14.

Hors ligne

Pied de page des forums