Debian Debian-France Debian-Facile Debian-fr.org Debian-fr.xyz Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-01-2022 07:59:50

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : stretch Xfce et DFLinux
Noyau : Linux 4.18.0-0.bpo.3-rt-amd64
(G)UI : ??
Inscription : 11-02-2012

DFlinux Bullseye mise à jour

Bonjour tout le monde.

J’ai installé Dflinux Bullseye (debian-facile-11.2_amd64.iso) sur un pc fixe depuis quelques semaines maintenant et je ne vois pas de messages demandant des mises à jour.
Il me semble que cette version se met à jour automatiquement, mais rien n’indique que les mises à jour ce font effectivement.
Tant que ce pc est chez moi j’applique les lignes de commande suivantes :

sudo apt-get update


sudo apt-get upgrade


Avant de le donner (la personne qui s’en servira ne veut pas entendre parler de lignes de commande) je désirerais savoir si c’est bien le cas.
Merci à la personne qui voudra bien me répondre.


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#2 09-01-2022 09:25:29

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : DFlinux Bullseye mise à jour

Bonjour
normalement oui , un responsable du projet confirmera
tu peu vérifier la présence d'un icône en haut a droite du bureau
et vérifier la présence de ces paquets


apt policy unattended-upgrades
 


et ou


apt policy packagekit
 



tu a la documentation aussi fournit avec Dflinux Bullseye

Hors ligne

#3 09-01-2022 10:21:20

robert2a
Membre
Distrib. : Arch Linux
(G)UI : Mate
Inscription : 15-11-2014

Re : DFlinux Bullseye mise à jour

remarque :
aujourd'hui j'ai ceci sur bullseye


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
3 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
 



apt list --upgradable
En train de lister... Fait
ghostscript/stable-security 9.53.3~dfsg-7+deb11u2 amd64 [pouvant être mis à jour depuis : 9.53.3~dfsg-7+deb11u1]
libgs9-common/stable-security,stable-security 9.53.3~dfsg-7+deb11u2 all [pouvant être mis à jour depuis : 9.53.3~dfsg-7+deb11u1]
libgs9/stable-security 9.53.3~dfsg-7+deb11u2 amd64 [pouvant être mis à jour depuis : 9.53.3~dfsg-7+deb11u1]
 



il faut laisser faire la machine , si tu veut vérifier si cela fonctionne (pas immédiat lors du démarrage de la machine ).
et c'est peut être une mise a jour silencieuse , pour ne pas perturber l'utilisateur
je sais pas comment ils procèdent , le mieux est d'attendre la réponse du responsable de l'iso  wink

Dernière modification par robert2a (09-01-2022 10:27:29)

Hors ligne

#4 09-01-2022 11:47:18

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : DFlinux Bullseye mise à jour

Bonjour et bonne année 2022 nounours et robert2a ! smile

À inscrire dans vos notes : Pour vérifier si l'ordi se met à jour automatiquement, c'est à dire voir toutes les mises à jour déjà effectuées, que ce soit par l'intermédiaire d'apt, apt-get, aptitude, dpkg, synaptic ou en automatique avec unattended-upgrade, il faut regarder :

less /var/log/apt/history.log




Pour remonter plus loin dans le temps :

zcat /var/log/apt/history.log.1.gz

Dernière modification par --gilles-- (09-01-2022 16:55:37)


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#5 09-01-2022 12:21:39

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-10-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : DFlinux Bullseye mise à jour

Ou s'appuyer sur ce script :https://debian-facile.org/viewtopic.php?id=31213
pour une recherche plus approfondie dans l'historique d'apt wink

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#6 09-01-2022 12:33:52

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : stretch Xfce et DFLinux
Noyau : Linux 4.18.0-0.bpo.3-rt-amd64
(G)UI : ??
Inscription : 11-02-2012

Re : DFlinux Bullseye mise à jour

robert2a #2
Bonjour.

Je vais donc attendre.

A tout hasard voila le résultat des commandes :

apt policy unattended-upgrades


impossible de trouver le paquet unattended-upgrade


pt policy packagekit


packagekit:
  Installé : 1.2.2-2
  Candidat : 1.2.2-2
 Table de version :
 *** 1.2.2-2 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status



Je vous remercie tous.

Dernière modification par nounours (09-01-2022 13:24:12)


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#7 09-01-2022 13:08:31

Tawal
Membre
Distrib. : Debian 11 Bullseye
Noyau : Linux 5.10.0-10-amd64
(G)UI : Xfce
Inscription : 25-02-2021

Re : DFlinux Bullseye mise à jour

Es-tu sûr de n'avoir pas fait d'erreur de copier/coller ou de frappe ?
Car ce n'est pas normal de ne pas trouver le paquet unattended-updates ! Installé ou pas.

Comme la science n'est pas infuse, elle se diffuse.
Useless Use of Cat Award
Filenames and Pathnames in Shell: How to do it Correctly
À chaque problème sa solution, à chaque solution son moyen, si pas de moyen, toujours le problème !

Hors ligne

#8 09-01-2022 13:49:40

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : stretch Xfce et DFLinux
Noyau : Linux 4.18.0-0.bpo.3-rt-amd64
(G)UI : ??
Inscription : 11-02-2012

Re : DFlinux Bullseye mise à jour

@tawal
Effectivement il y avait une erreur (il manquait un "s" a upgrades) comme quoi il ne faut pas grand chose pour tout casser !!!.

utilisateur@debian:~$ apt policy unattended-upgrades


 unattended-upgrades:
  Installé : 2.8
  Candidat : 2.8
 Table de version :
 *** 2.8 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#9 09-01-2022 13:58:21

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : DFlinux Bullseye mise à jour

à nounours, tu peux voir si le paquet unattended-upgrades a agi ou non pour des mises à jour avec la commande :

less /var/log/apt/history.log




ou bien avec le script de Tawal : https://debian-facile.org/viewtopic.php?id=31213


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#10 09-01-2022 14:26:31

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : stretch Xfce et DFLinux
Noyau : Linux 4.18.0-0.bpo.3-rt-amd64
(G)UI : ??
Inscription : 11-02-2012

Re : DFlinux Bullseye mise à jour

@gilles

less /var/log/apt/history.log


 Start-Date: 2022-01-05  17:35:16
Commandline: /usr/sbin/synaptic
Requested-By: utilisateur (1000)
Install: pwgen:amd64 (2.08-2)
End-Date: 2022-01-05  17:35:19

Start-Date: 2022-01-07  18:15:05
Commandline: apt-get upgrade
Requested-By: utilisateur (1000)
Upgrade: thunderbird:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1), thunderbird-l10n-fr:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1)
End-Date: 2022-01-07  18:15:16

Start-Date: 2022-01-09  06:44:39
Commandline: /usr/bin/unattended-upgrade
Upgrade: libgs9-common:amd64 (9.53.3~dfsg-7+deb11u1, 9.53.3~dfsg-7+deb11u2), ghostscript:amd64 (9.53.3~dfsg-7+deb11u1, 9.53.3~dfsg-7+deb11u2), libgs9:amd64 (9.53.3~dfsg-7+deb11u1, 9.53.3~dfsg-7+deb11u2)
End-Date: 2022-01-09  06:44:46
/var/log/apt/history.log (END)



Je ne sais pas trop en conclure (?).


N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#11 09-01-2022 14:51:03

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : DFlinux Bullseye mise à jour

Eh, bien nounours, la situation est pédagogique ( apte à faire apprendre ).


Regarde :

Start-Date: 2022-01-05  17:35:16
Commandline: /usr/sbin/synaptic
Requested-By: utilisateur (1000)
Install: pwgen:amd64 (2.08-2)
End-Date: 2022-01-05  17:35:19
Explication : Tu as installé le paquet pwgen le 5 janvier 2022 avec synaptic.



Start-Date: 2022-01-07  18:15:05
Commandline: apt-get upgrade
Requested-By: utilisateur (1000)
Upgrade: thunderbird:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1), thunderbird-l10n-fr:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1)
End-Date: 2022-01-07  18:15:16
Explication : Tu as mis à jour thunderbird et thunderbird-l10n-fr avec apt-get upgrade le 7 janvier 2022.


Start-Date: 2022-01-09  06:44:39
Commandline: /usr/bin/unattended-upgrade
Upgrade: libgs9-common:amd64 (9.53.3~dfsg-7+deb11u1, 9.53.3~dfsg-7+deb11u2), ghostscript:amd64 (9.53.3~dfsg-7+deb11u1, 9.53.3~dfsg-7+deb11u2), libgs9:amd64 (9.53.3~dfsg-7+deb11u1, 9.53.3~dfsg-7+deb11u2)
End-Date: 2022-01-09  06:44:46
Explication : La mise à jour automatique fonctionne, elle s'est déclenchée pour la dernière fois le 9 janvier 2022 et a mis à jour libgs9-common, ghostscript, libgs9.


Tu pourrais remonter dans des logs plus anciens avec :

zcat /var/log/apt/history.log.1.gz



encore plus anciens avec :

zcat /var/log/apt/history.log.2.gz




ou utiliser le script de Tawal : https://debian-facile.org/viewtopic.php?id=31213

En résumé, la mise à jour fonctionne, pas de problème. smile

Dernière modification par --gilles-- (09-01-2022 16:54:48)


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

#12 09-01-2022 14:59:13

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : stretch Xfce et DFLinux
Noyau : Linux 4.18.0-0.bpo.3-rt-amd64
(G)UI : ??
Inscription : 11-02-2012

Re : DFlinux Bullseye mise à jour

Un grand merci à @gilles.
J'ai appris quelque chose.

N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#13 09-01-2022 15:31:09

Croutons
Membre
Distrib. : Debian10 Buster
Noyau : Linux 4.19.0-18-amd64
(G)UI : Mate
Inscription : 16-12-2016

Re : DFlinux Bullseye mise à jour

hello
penser a remettre Thunderbird en Français , suite au petit bug
https://debian-facile.org/viewtopic.php?id=31261
faudrait l'épingler cette affaire

Upgrade: thunderbird:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1), thunderbird-l10n-fr:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1)


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

En ligne

#14 09-01-2022 16:26:57

nounours
Adhérent(e)
Lieu : hourtin 33
Distrib. : stretch Xfce et DFLinux
Noyau : Linux 4.18.0-0.bpo.3-rt-amd64
(G)UI : ??
Inscription : 11-02-2012

Re : DFlinux Bullseye mise à jour

@gilles

Oui j'ai installé pwgen (générateur de mots de passe) avec synaptic.
Oui j'ai utilisé apt-get update et apt-get upgrade voir #1
Oui mais manuellement.

Non Je n'utilise pas thunderbird (client de messagerie) et je ne vois pas pourquoi j'aurai éprouvé le besoin de faire une mise à jour.
Peut-être que la mise à jour de thunderbird prouve que les mises à jours se font automatiquement (?).

N'achetez pas Windows !. Volez-le !. Au moins vous en aurez pour votre argent.

Hors ligne

#15 09-01-2022 16:57:14

--gilles--
Membre
Lieu : Orléans - La Source
Distrib. : debian 11
Noyau : Linux 5.10.0-10-amd64
(G)UI : mutter 3.38.6-2~deb11u1
Inscription : 15-02-2016

Re : DFlinux Bullseye mise à jour

à nounours : dans /var/log/apt/history.log, il y a un historique de toutes les installations, suppressions, purges, mises à jour par tous les moyens que Debian nous mets à disposition.

Tout ce qui est mis à jour automatiquement a la mention suivante dans le log :
Commandline: /usr/bin/unattended-upgrade
ou
Commandline: packagekit role='update-packages'





Toutes les autres mentions décrivent des installations, suppressions, purges, mises à jour manuelles, d'après ce que je vois moi dans mes logs et donc d'après les commandes que j'utilise :

Commandline: apt install

Commandline: apt upgrade

Commandline: apt purge

Commandline: apt autoremove --purge

Commandline: apt-get upgrade

Remove: ( aptitude )

Purge: ( aptitude )

Install: ( aptitude )

Commandline: /usr/sbin/synaptic





nounours a écrit :

Je n'utilise pas thunderbird (client de messagerie) et je ne vois pas pourquoi j'aurai éprouvé le besoin de faire une mise à jour.


Debian et les autres systèmes d'exploitation mettent à jour les logiciels installés. Même ceux que tu n'utilises pas ! Tu aurais du t'en apercevoir depuis le temps ! Cette mise à jour a eu lieu, même si tu n'utilises pas thunderbird, avec tes commandes sudo apt-get update et sudo apt-get upgrade que tu dis utiliser dans ton message 1. Le log le confirme :


Start-Date: 2022-01-07  18:15:05
Commandline: apt-get upgrade
Requested-By: utilisateur (1000)
Upgrade: thunderbird:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1), thunderbird-l10n-fr:amd64 (1:78.14.0-1~deb11u1, 1:91.4.1-1~deb11u1)
End-Date: 2022-01-07  18:15:16


Tu peux être tranquille, les mises à jour automatiques fonctionnent. Je ne sais pas si j'ai été assez clair dans mes explications, mais je ne vois pas comment je pourrais t'expliquer mieux. Bon courage pour la suite. smile


Je m'aperçois que j'ai merdouillé dans les commandes zcat que je t'ai donné ! yikes  Je vais les corriger dans les messages précédents !

zcat /var/log/apt/history.log.1.gz

Dernière modification par --gilles-- (09-01-2022 17:40:55)


« Quand la vérité n'est pas libre, la liberté n'est pas vraie. » Jacques Prévert

Hors ligne

Pied de page des forums