Debian Debian-France Debian-Facile Debian-fr.org Forum-Debian.fr Debian ? Communautés

Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-01-2022 15:20:40

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 11 Xfce
Inscription : 21-09-2016

(SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Bonjour à tous,
ce petit post pour ma culture perso. Hier lors de ma mise à jour de ma Debian Sid, j'ai eu le paquet wpasupplicant qui a été identifié par apt-listbugs comme buggé. J'ai choisis l'option (p) comme préconisé sur le wiki pour le placer en pinned dans /etc/apt/preferences.d/apt-listbugs.
Il est bien en statut pinned

Explanation: Pinned by apt-listbugs at 2022-01-19 18:50:19 +0100
Explanation:   #1003907: fails to successfully associate
Package: wpasupplicant
Pin: version 2:2.9.0-23
Pin-Priority: 30000


Ma question: lors d'une mise à jour n'ayant plus de bugg, ce paquet disparaîtra de ce dossier ? Si oui, ça sera transparent ou j'aurais droit à une alerte ?
Merci


Acer Aspire 5733 - Debian 11 Xfce

Hors ligne

#2 20-01-2022 15:34:03

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.19 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Avec la méthode d’étiquetage que tu as utilisé (touche "p" lors du choix présenté par apt-listbugs), le déblocage sera automatique une fois le bug corrigé. Tu n’as rien de particulier à faire de ton côté, sinon patienter wink

Jouer sous Debian ? Facile !

Hors ligne

#3 20-01-2022 16:33:17

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 11 Xfce
Inscription : 21-09-2016

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

vv222 a écrit :

Avec la méthode d’étiquetage que tu as utilisé (touche "p" lors du choix présenté par apt-listbugs), le déblocage sera automatique une fois le bug corrigé. Tu n’as rien de particulier à faire de ton côté, sinon patienter wink



ça je sais faire big_smile Merci vv222 merci.gif


Acer Aspire 5733 - Debian 11 Xfce

Hors ligne

#4 20-01-2022 17:29:54

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Bonjour,

Hier lors de ma mise à jour de ma Debian Sid, j'ai eu le paquet wpasupplicant qui a été identifié par apt-listbugs comme buggé


je m'en souviens pas l'avoir vu ... Après ce que je ne comprend pas c'est:

Package: wpasupplicant
Pin: version 2:2.9.0-23


en regardant par chez moi :

 apt policy wpasupplicant
wpasupplicant:
  Installé : 2:2.10-1
  Candidat : 2:2.10-1
 Table de version :
 *** 2:2.10-1 500
        500 https://deb.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status


J'en suis à la version 2:10 et toi t'es encore bloqué à la 2:9 qui est buggée en plus ...
moi pas comprendre ... d'ailleurs, sur la webpage debian de wpasupplicant pour sid, me semble que c'est la 2:10 dont ils parlent ....
https://packages.debian.org/unstable/net/wpasupplicant

après de souvenir, il n'y a pas d"alerte" quand un paquet buggé finit par être mis à jour, mais c'est signalé dans la partie « les paquets suivants seront mis à jour » de même que pour la partie paquets gardés en l'état ou non mis à jour, me souviens plus des termes exacts...

Hors ligne

#5 20-01-2022 17:45:23

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

après autant pour moi, je l'ai pas vu faut croire ..
Si tu reste bloqué sur 2:9 c'est pour ça:

Severity: grave

Hi,

during todays upgrade of wpasupplicant 2:2.9.0-23 to 2:2.10-1 my network
connection was killed (I'm using NetworkManager 1.34.0) and I wasn't
able to successfully connect again, even after a reboot.
Only a downgrade to 2:2.9.0-23 helped.



J'ai du faire ma mise à jour avant le signalement de bug .....

Hors ligne

#6 20-01-2022 18:15:31

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Moi non plus je ne me souviens pas l'avoir vu.

en regardant par chez moi :

apt policy wpasupplicant
wpasupplicant:
  Installé : 2:2.10-1
  Candidat : 2:2.10-1
Table de version :
*** 2:2.10-1 500
        500 https://deb.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status



J'ai donc la même chose que toi ubub

Dernière modification par Jean-Pierre Pinson (20-01-2022 18:16:59)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#7 20-01-2022 18:32:57

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.19 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

ubub a écrit :

J'en suis à la version 2:10 et toi t'es encore bloqué à la 2:9 qui est buggée en plus ...



La version 2.10 que tu utilises est concernée par un bug grave qui n’est pas présent dans la 2.9 sur laquelle Herve33 est resté : #1003907 - fails to successfully associate - Debian Bug report logs.


Jouer sous Debian ? Facile !

Hors ligne

#8 20-01-2022 18:40:25

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 11 Xfce
Inscription : 21-09-2016

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Je vois que je suis le plus patient lol
J'ai fait une màj hier soir, apt-listbugs me l'a bien signalé.

Acer Aspire 5733 - Debian 11 Xfce

Hors ligne

#9 20-01-2022 18:46:45

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Moi il ne me l'a pas signalé,
En revanche j'ai bien constaté que ma connexion réseau a été interrompue (j'utilise NetworkManager)

Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#10 20-01-2022 18:53:44

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Donc d'après ce que je comprends, je suis concerné par le bug de wpasuppliant #1003907 qui ne m'a pas été signalé par apt-listbugs vv221 ?

Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#11 20-01-2022 18:55:14

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

J'imagine qu'il a été signalé par aptlist-bug qu'une fois "rapporté" ...
En tout cas, ma machine ne semble pas touchée par ce bug:

my network connection was killed
and I wasn't able to successfully connect again, even after a reboot.


ou alors, vu que ma connection réseau est naze, lente et un peu aléatoire, je m'en suis pas apperçu.. en tout cas ca marche chez moi ...

++ oui Jean Pierre, comme moi ...

Dernière modification par ubub (20-01-2022 18:56:37)

Hors ligne

#12 20-01-2022 19:00:47

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 11 Xfce
Inscription : 21-09-2016

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Attendons la nouvelle version, vu que ça a été remonté, ça sera corrigé coffeecup.gif

Acer Aspire 5733 - Debian 11 Xfce

Hors ligne

#13 20-01-2022 22:11:10

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Moi en tout cas, j'ai rétrogradé ma version à la 2:2.9.0-23 smile

Et j'ai épinglé la version 2:2.10-1

Dernière modification par Jean-Pierre Pinson (21-01-2022 06:36:43)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#14 24-01-2022 20:55:30

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Jean-Pierre Pinson a écrit :

Moi en tout cas, j'ai rétrogradé ma version à la 2:2.9.0-23 smile

Et j'ai épinglé la version 2:2.10-1


Salut Jean Pierre,
.. et t'as fait comment ? (je préfère demander avant de faire nawak, j'ai pas l'habitude des rétrogradages...). Paske j'ai l'impression que ma connexion wifi capote, enfin, est kaput ...

Hors ligne

#15 25-01-2022 09:52:10

Herve33
Membre
Lieu : Mérignac 33
Distrib. : Debian 11 Xfce
Inscription : 21-09-2016

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs


Acer Aspire 5733 - Debian 11 Xfce

Hors ligne

#16 25-01-2022 18:41:35

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Bonjour,
merci pour le lien, mais... j'y ai rien compris...
enfin j'ai compris que sous debian et dérivées on installait avec apt install... Bon, je savais déjà...
Après ils disent


apt install <le_paquet> <la_version_voulue>


bon, je m'en doutais... Mais quoi pas de remove avant ? On installe une vieille version en écrasant la nouvelle ? comme ça, paf !??
Et puis, ce que j'aurai bien voulu savoir, c'est comment qu'on fait pour connaitre le nom:à:rallonge du paquet précédent.. Là, c'est simple, c'est écrit au début du post... mais sinon ...?
Bah je verrai quand ça refusera définitivement de marcher... pour l'instant ça marche un moment, puis ca perd sa connectivité ....
merci en tout cas de la réponse....

N.B:

Vous pouvez obtenir informations sur le paquet firefox (ou tout ce dont vous avez besoin, il vous suffit de changer le nom pour celui qui convient dans votre cas), comme les versions précédentes installées, etc., vous pouvez utiliser la commande suivante:
sudo apt-cache showpkg firefox
Une fois que tu connais bien la version précédente que vous souhaitez installer, vous pouvez utiliser la commande suivante pour installer le package souhaité


???


apt-cache showpkg wpasupplicant


Package: wpasupplicant
Versions:
2:2.10-1 (/var/lib/apt/lists/deb.debian.org_debian_dists_sid_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: etc etc
everse Depends:
  wpagui,wpasupplicant 0.7.3~
  wpasupplicant:i386,wpasupplicant
  ceni,wpasupplicant
  task-laptop,wpasupplicant
  network-manager,wpasupplicant
  netscript-2.4,wpasupplicant
  netplan.io,wpasupplicant
  netctl,wpasupplicant
  ifplugd,wpasupplicant
  geoclue-2.0,wpasupplicant
  connman,wpasupplicant
Dependencies:
2:2.10-1 - libc6 (2 2.33) libdbus-1-3 (2 1.9.14) libnl-3-200 (2 3.2.21) libnl-genl-3-200 (2 3.2.7) libnl-route-3-200 (2 3.4.0) libpcsclite1 (2 1.0.0) libreadline8 (2 6.0) libssl1.1 (2 1.1.1) lsb-base (0 (null)) adduser (0 (null)) initscripts (3 2.88dsf-13.3) wpagui (0 (null)) libengine-pkcs11-openssl (0 (null)) initscripts:i386 (3 2.88dsf-13.3) wpasupplicant:i386 (32 (null))
Provides:
2:2.10-1 - wpasupplicant:i386 (= 2:2.10-1)
Reverse Provides:
wpasupplicant:i386 2:2.10-1 (= 2:2.10-1)


bref, je vois rien dans cette commande qui renseigne sur les versions précédentes, sont bien gentils dans leur article ....

Dernière modification par ubub (25-01-2022 18:53:13)

Hors ligne

#17 25-01-2022 19:52:17

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Pour rétrograder, j'ai rajouté dans mon sources.list cette ligne --> deb http://deb.debian.org/debian/ testing main contrib non-free

Et ensuite, j'ai installé la bonne version du paquet, avec la commande:

apt install wpasuppliant=version



Après j'ai mis à jour avec la commande:

apt update

et

apt upgrade



Il m'a demandé  Êtes-vous certain(e) de vouloir installer/mettre à niveau les paquets ci-dessus ? [Y/n/?/...]

J'ai tapé Y puis entrée

Et ensuite j'ai tapé p pour épingler le paquet et j'ai tapé entrée

Il y a un tuto ici --> Que faire si un paquet bugué est détecté ? https://debian-facile.org/doc:systeme:apt:apt-listbugs


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#18 25-01-2022 20:22:35

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

ah beh ok, merci,
là, je comprend mieux la logique ...
J'y avais pensé, même si je doutai à rajouter la ligne de testing...
car je viens de regarder, testing est encore à la version précédente ...
https://packages.debian.org/bookworm/wpasupplicant
cela dit, au début, tu l'as effacé (remove) avant de le réinstaller, j'imagine
merci pour le lien

Hors ligne

#19 25-01-2022 21:06:40

Jean-Pierre Pinson
Membre
Lieu : Orléans
Distrib. : Debian Sid 64bits Ordi.: Thinkpad T400
Noyau : 5.10.40-1
(G)UI : xfce
Inscription : 04-03-2017

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

non je ne l'ai même pas désinstallé ! Il a compris tout seul qu'il fallait le désinstaller. smile

Dernière modification par Jean-Pierre Pinson (25-01-2022 21:15:56)


Debian sid
Bureau : xfce
Ordinateur : Thinkpad T400 libreboot

Hors ligne

#20 25-01-2022 21:28:08

ubub
Membre
Distrib. : Debian
(G)UI : xfce
Inscription : 14-05-2019

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Roh beh ça alors, j'en aurai pas parié ma wifi à couper, ok, merci de l'info,
je verrai ça si je décide de rétrograder,
merci ben
  xxx

+ cela dit, j'ai trouvé pour les anciennes versions,
suffit de regarder le journal des modifications, of course,
pour voir les anciens n° de paquet


wpa (2:2.9.0-23) unstable; urgency=medium

  * Implement driver fallback directly in wpa_supplicant.
    Thanks to Kees Cook.
  * Enable airtime policy support (Closes: #996742)

 -- Andrej Shadura <andrewsh@debian.org>  Tue, 19 Oct 2021 10:35:00 +0200

Dernière modification par ubub (25-01-2022 21:37:23)

Hors ligne

#21 26-01-2022 12:54:42

vv222
Administrateur
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : Linux ≥ 5.19 (amd64)
(G)UI : Openbox / xfwm4
Inscription : 18-11-2013
Site Web

Re : (SID) Mise à jour d'un paquet gelée suite à alerte apt-listbugs

Je confirme, aucun besoin de désinstaller la version courante avant de la rétrograder.

Tu peux par contre sans aucun souci oublier l’illisible commande apt-cache showpkg wpasupplicant au profit de apt policy wpasupplicant pour récupérer la liste des versions du paquet.

Jouer sous Debian ? Facile !

Hors ligne

Pied de page des forums